4x4cheesecake

Members
  • Content Count

    1,670
  • Joined

  • Last visited

Everything posted by 4x4cheesecake

  1. 4x4cheesecake

    [1.4.X] KS3P

    I assume you talk about the error.log which will be created on a game crash but I'm talking about the output_log, which will be written as soon as the game starts and since you got a screenshot which shows the issue, I guess that your game actually still launches and you can enter the game. Many mod issues are already logged during the loading screen, so a log would actually help
  2. 4x4cheesecake

    [1.4.X] KS3P

    Sounds unusual...do you use a custom config or the default one? What are the other 'very few' mods which are installed? You didn't saved a copy of your log so we can take a look at it, did you? Not sure if you actually want to recreate the issue for a log file since it sounds like a huge problem but it will probably help...
  3. 4x4cheesecake

    I need help here...

    I would suggest the same^^
  4. 4x4cheesecake

    [1.4.X] KS3P

    If you scroll up a bit, you'll notice that The White Guardian already works on a new version
  5. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    Cool I've changed it to cyan^^
  6. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    No. See my comments about the MIN and MAX Uhm...why not keep the highlighting (or set total different color) in the expandable mod list? As soon as you start to cover a range of versions instead of an explicit verson number, you may install a mod which doesn't work and without any hints in any directions, you may not notice if you have installed a wrong version. edit: just to be sure there are no misunderstandings (and it is easy to do^^), this is how it would look like: In this case, EVE is not listed in the compatibility issues window but still highlighted in the expandable mod list. Maybe switch it to a different color (blue-ish?) to have a separation from mods which have an update available but I actually like the idea edit2: little update What's working so far: Version override, respects version min/max Keep highlighting in expandable mod list (waiting for some feedback) .version file entry can disable version override for a specific mod ignore override for mod name (configurable in the avc.cfg) to do: override priority maybe some refractoring of the override code, I'm not very satisfied so far, even though it's working fine
  7. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    That's no problem, I'll change the behaviour to this
  8. What are Pwings? o_O But if I understood you correctly, this is just a single wing part? Not sure how KSP deals with it but if you think about it: The more parts you have, the merrier joints can carry a part of the load. A single wing element will carry the full load on a single joint, so this might be actually an issue on your shuttle. More struts to increase the number of joints or more (upscaled) wing elements may help
  9. Do they break during reentry or during the landing? In generall, moar struts are always a good idea Do you have some heavy parts connected to the wings? Could be worse^^ Horizon Zero Dawn is a lot of fun
  10. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    Thanks for testing That's correct and what I've tried to say: Sorry if this wasn't clear. It's easy to change this behaviour to cover a range of versions but I thought it would be better to check just the KSP_VERSION to keep a better control about different versions. But I have to admit, that it can be confusing. I'll try to implement both methods, to cover a range and/or a single version, depending on the config settings so the user can decide. Haven't checked this window during my tests, I'll take a look at it
  11. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    @Tonka Crash Would you mind to try my version of AVC to test the override functionallity? https://github.com/4x4cheesecake/KSPAddonVersionChecker/releases/tag/1.2.0.8_beta This AVC version compares KSP_VERSION from the .version file of a mod with the settings for COMPATIBLE_VERSION_OVERRIDE in the AVC.cfg. These version numbers need to match. In order to exclude mods from the version override, use IGNORE_OVERRIDE node, for example: KSP-AVC { IGNORE_OVERRIDE = Kopernicus IGNORE_OVERRIDE = Environmental Visual Enhancements } (The name is taken from the .version file) edit: I just noticed that I missed the entry "DISABLE_COMPATIBLE_VERSION_OVERRIDE" so this doesn't work yet...it's enabled everytime^^
  12. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    Well, if you don't mind, I would like to try to get it working and if I'm successfull, you'll get a PR
  13. 4x4cheesecake

    [1.5.x] KSP-AVC Add-on Version Checker Plugin - MiniAVC

    @Tonka Crash Oh, I didn''t even know this feature exists I took a look at it and so far I can tell, there is actually a NRE while this config node is read. I was able to fix the NRE, so AVC actually creates a dictionary which contains these values but this doesn't seem to be enough, I'm still getting the incompatible game version displayed on game launch. There is actually a comment which intrigues me, saying // need to add code to check the compatible list here maybe that's related, maybe it's for a different part, not sure yet^^ *grabs a shovel to dig deeper into the code*
  14. 4x4cheesecake

    MK3 cargo bay drag bug?

    Uhm...I'm confused now: the title says MK3, your description says MK2 There is a confirmed bug with drag on the MK2 cargo bays, but actually the other way around...less draggy while opened: It's also on the bug tracker: https://bugs.kerbalspaceprogram.com/issues/20997 Not sure if there is something similar with the MK3 cargo bays...I just know about a difference in buoyancy, depening on the state of the bay.
  15. 4x4cheesecake

    Space Shuttle Help

    The biggest "trick" for shuttles is to point the thrust through the CoM to prevent uncontrollable pitch during launch. I've used this picture recently during a discussion about the roll program of a shuttle but it may help you as well: Most important is the CoM and the direction of the thrust vector (extended with the orange line). As you can see, the vector points directly on the CoM which has two effects: 1) Your shuttle will not pitch uncontrollable during launch 2) Your shuttle will not ascent in a straight line but along the thrust vector. This is important to know, otherwise you may crash into the launch clamps Keep in mind, that the CoM will shift during the launch (roughly displayed by the orange and red bubble) so at some point, you may have to start to pitch slightly to reduce the effect.
  16. What a nice way to be proven wrong Thanks for the update
  17. 4x4cheesecake

    mod part finding mod

    Probably this one? It shows the internal partname and file path: Just found the release thread for the mod: Or Janitors Closet, it shows the mod name (need to be enabled in the mod settings) when hovering the cursor over a part:
  18. 4x4cheesecake

    [1.5.1+] Toolbar Controller (for modders)

    Probably related to the updated .version file without changing the version number. Pinging @HebaruSan for this one (On a sidenote: This error message is displayed in CKAN so it is CKAN related and should be reported in the CKAN thread instead of here For now, the ping will do the trick instead)
  19. A quick peek into the 'Relationships' tab of CKAN answers the question: Celestial Body Science Editor was added recently as a dependency for PbC but it is not updated to 1.6 yet and maybe, there will not be an update in the future since it works perfectly fine in 1.6. But don't worry, CKAN got your back here. All you have to do is to set KSP 1.5 as a compatible game version. To do so, click on 'Settings' -> 'Compatible KSP Versions' and mark 1.5 to be compatible in the shown list. Apply the changes and it should work just fine again
  20. 4x4cheesecake

    [1.5.1+] Toolbar Controller (for modders)

    Oh, I see what's going on there and it's actually quiet surprising that no one else came across this one before The version file of the latest version of ToolbarController is set to be compatible with 1.5.1 - 1.6.0 but ToolbarController 0.1.4.7 is set to be compatible with any KSP version so CKAN will install this one, instead of the latest release. The easiest way to fix that is to set KSP 1.6 as a compatible game version in CKAN. Click on 'Settings' -> 'Compatible KSP versions' and mark 1.6 as compatible (should be the very first entry in the list). Apply the changes and CKAN should install the correct mod version for you. On a sidenote: The location for the log file changed between KSP 1.3.1 and KSP 1.4.0, so th linked log is an old one from 1.3.1 Next time, take a look here instead (the mod version pointed to the issue in this case, you don't need to upload a new log this time ) %USERPROFILE%\AppData\LocalLow\Squad\Kerbal Space Program\output_log.txt @linuxgurugamer This issue might be interesting for you as well, even though it is quiet surprising that this is not a more common issue.
  21. 4x4cheesecake

    [1.6.x] Community Tech Tree (January 21)

    It's actually done the other way around: Mods need to support the Community TechTree (CTT) and in this case, MK4 Spaceplane Parts already got a config for this, which should be applied as soon as you install CTT
  22. 4x4cheesecake

    [1.0.5] Controllable Mastcam for Rovers

    HullCam VDS should work as well: But if you definitly want to use this mod: Some time ago, I wrote a tutorial on how to recompile this mod for 1.5.1 using the .NET framework commandline compiler. Should work for 1.6.1 in the same way: (The license doesn't allow do share a recompiled version directly)
  23. 4x4cheesecake

    [1.5.1+] Toolbar Controller (for modders)

    They are the same size for me (103.763 bytes). On which game version do you play and did you setup CKAN to be compatible with other game versions then the one you have installed? Please upload a full log, the snippets don't provide enough informations.
  24. 4x4cheesecake

    [1.5.1+] Malah's Quick Mods

    You will stay in IVA while undocking and docking and afaik, it is impossible to switch to the external camera at all if you set Quick IVA to disable the third person view (it is disabled by default). I would suggest to use some mods like part commander or ship manifest to keep controll over the PAW of all the parts on your vessel (and RPM + custom IVA internals for the cockpits of course^^).
  25. The log is not public available, it just prompt a window to send a request for the file via email and I would prefer not to send out my private email address. Please check the settings for the link/file