Brimarx

Members
  • Content Count

    38
  • Joined

  • Last visited

Everything posted by Brimarx

  1. LFOx, H2O and Ox working ok for me Did not test LCH4Ox as I don't have tanks and engines for that. I noted that H2O production is much slower than LOx. Is that because this process supposed to be more energy-demanding, all processes being capped at 0.4 EC/s ?
  2. I've been using your mod for testing and it's working great Next step: Duna!!! I did not check against other mods (KSPIE, Kerbalism) or real processes but it "feels" like it should use more EC.
  3. I'd be happy to help anyway I can
  4. Also, those legs tend to slide a bit. Which is bummer unless when combined with USI-MKS and it's nice tethers Kerbal Foundry legs are closer to the MD legs look, allow horizontal extension (extra stability!!!) and do not slide. But they require manual adjustment. Vertical-only deployment: Horizontal deployment:
  5. No worries at all Kerbal Foundry has adjustable legs, apparently based on KSPWheel. I tries modding the MD legs to use it based on the Kerbal Foundry part but could not figure out how to properly use it since the config attributes are very different from the stock ones. RO has MM files patching the stock legs into Kerbal Foundry legs. That could be used as an example how to convert the legs I guess, but I did have the time to look into properly. So for now I switched to Station Parts Expansion Redux which has auto-leveling legs in the form of a single part frame attached below the Hab. Here is how it looks: Before deployment After deployment; the mod auto-levels:
  6. I totally failed doing it myself So for now I'm using the largest adjustable base frame from Station Parts Expansion Redux. It's the right size, works great (inc with the heat shield) and looks good.
  7. Man, I was about to custom made the same out of desperation as for my latest save I want to stay away from KSPIE (which is amazing btw). I'm playing with RR (very rare Ore...) and JNSQ (much higher DeltaV requirement) which make such a process super important to keeping Duna mission viable interm of mass. Perfect timing I'll test it and report back! Some thoughts meanwhile: Calling it MOXIE was kind of confusing to me considering the NASA MOXIE experiment outputs O2 while your process is akin to a Sabatier process. But hey, that's your mod You may also consider adding H2O as an output as it would be both plausible and convenient on Duna, at least for guys like me playing with USI and RR.
  8. Thanks for that amazing mod! The one improvement I can think of is in-flight tweakables for landing legs for hab leveling after landing. I might try doing it myself but I've never done anything as complicated Would that be feasible with the BDAdjustableLandingGear module from BD Animation Modules? Is there any example I could use?
  9. Same issue here with KSP 1.8.1 and KSPWheel 0.16.14.33. Seems like it would be a great little rover if it worked I built the over in the SPH, when launched it's wheels are 50% below the surface and would not turn or rotate. When I stow them the rover snaps out of the ground, jumping quite high. but thne the stowed wheels can turn and rotate. if i re-deploy them it's leveled with the ground but neither turn nor rotate. (obviously a Stock rover works just fine)
  10. I have the same issues as @Michel Bartolone with the latest release and KSP 1.9.1. @allista I guess you should mark the 2.6.x releases as compatible with KSP 1.10 only and stop bothering with KSP 1.9.x
  11. Same here. That's actually hardcoded with support for Stock and RSS only. See the GIT issue I opened for more details: https://github.com/TriggerAu/AlternateResourcePanel/issues/97 @TriggerAu: Thx a lot for your amazing mods, KAC, TWP and ARP are all-times favorites of mine and I would not play without them. They are that good!!!
  12. I just tested again and the issue did not occur this time. Maybe the 1st install had some issue, maybe it's random. Should it happen again I'll report it back and upload the logs. Thanks again for your amazing job!
  13. While I've be able to edit/change tank contents with the proposed patch with an unmodded KSP (that is, except for CC and it's dependencies), as soon as I reinstalled all my other dependencies (quite a lot...) editing a tank with CC caused the whole part UI to totally disappear after the 1st tank edit... Unfortunately I've lost the Player.log by mistake. I'll try reproducing this issue this evening, checking it's still working with the previous version + the same other mods and uploading the logs. Stay tuned
  14. Adding the VolumeConfigs.user file fixed the issue on my side. Sorry for not sharing the full logs. I'll do next time. Thanks again for your amazing job Allista!!! And also to Linux
  15. Same issue here: clicking on the "Edit Tank"button has no effect. Fresh KSP 1.9.1 with all DLCs and Module Manager 4.1.4, AT Utils 19.5 Configurable Containers 2.6.0 Same issue if installed if CKAN or manually. Interesting entries in the logs: [ERR 07:43:15.481] The AssetBundle 'file://C:\UserData\Vincent\Documents\My Games\KSP-1.9.1-Kerbalism\GameData\000_AT_Utils\at_utils_ui.ksp' can't be loaded because another AssetBundle with the same files is already loaded. [ERR 07:43:15.481] Error while getting Asset Bundle: The AssetBundle 'file://C:\UserData\Vincent\Documents\My Games\KSP-1.9.1-Kerbalism\GameData\000_AT_Utils\at_utils_ui.ksp' can't be loaded because another AssetBundle with the same files is already loaded. [ERR 07:43:15.481] AssetLoader: Bundle is null and [EXC 07:44:39.831] ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index Actual value was 0. System.Collections.Generic.SortedList`2[TKey,TValue].GetKey (System.Int32 index) (at <376e8c39bbab4f1193a569c8dbe4305c>:0) System.Collections.Generic.SortedList`2+KeyList[TKey,TValue].get_Item (System.Int32 index) (at <376e8c39bbab4f1193a569c8dbe4305c>:0) CC.UI.TankConfigsControl.updateConfigsDropdownTooltip (System.Int32 index) (at <765007bdf7e74f409794393c67b5df08>:0) CC.UI.TankConfigsControl.updateConfigsDropdown () (at <765007bdf7e74f409794393c67b5df08>:0) CC.UI.TankConfigsControl.SetTankManager (CC.UI.ITankManager manager) (at <765007bdf7e74f409794393c67b5df08>:0) CC.UI.TankManagerUI.SetTankManager (CC.UI.ITankManager newTankManager) (at <765007bdf7e74f409794393c67b5df08>:0) AT_Utils.SwitchableTankManagerUI.init_controller () (at <324244d7a45147de909b23df5034a14d>:0) AT_Utils.UIWindowBase`1+<Show>d__22[T].MoveNext () (at <035d89da618a4ef3851a6436fc3029c5>:0) UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) [LOG 07:44:52.419] [UIApp] OnDestroy: Reverting to AT Utils 19.4 and CC 2.5.0.1 fixes the issue. I hope it helps Thanks for your amazing mods!
  16. First I'd like to thank Kerbalism author(s) and tester(s) for this amazingly deep and rich mod. It renewed my interest for KSP. You rock! I also have two questions (I'm using "Kerbalism - Default Config") First: what is the clean way to add the laboratory experiments to a mod/custom laboratory? Sampling analysis is added to any lab out of the box. But experiments are not and I can't figure out the right module manager code to add it. I tried with Stockalike Station Parts Expansion Redux (which has a patch, but not for the lab) and a custom made lab with all the same science modules as the stock one. Any hint? Second: in the Kerbalism Default Config module manager file I can see that a lab experiments can apparently be changed in-flight by any Level-5 Scientist. I tried it with a sandbox save and can't find how it works. Any hint?
  17. Yes I'm using both. I did disable Kerbalism's part failure.
  18. I'm facing an issue while using KSP 1.9.1 with both RealAntennas and BARIS: the built-in antenna of probes and of capsules don't show up neither in the VAB or in-flight contextual menu of the part, even though the antenna works. That's a serious issue as that's required for configuring the antennas' band and target. Antenna parts don't have that issue. I commented out the following section into the MM_BARIS.cfg file and the menus are back: //@PART[*]:HAS[@MODULE[ModuleDataTransmitter],!MODULE[ModuleBreakableTransmitter]]:FOR[BARIS] //{ // MODULE // { // name = ModuleBreakableTransmitter // qualityCheckSkill = ScienceSkill // } //} Would that happen to be some known or obvious issue? I also have a rather heavily-modded install, inc. Kerbalism (with disabled reliability feature), and I've not yet tested with a KSP+BARIS+RealAntenna only install. Would it make sense?
  19. A quick message to thank all the people involved in the making and support of this amazing mod!!! You are doing a fantastic work and I very much appreciate it
  20. If you don't want to wait the next release and don't mind manual-editing files, you can simply replace all the contents of [KSP-directory]\GameData\UmbraSpaceIndustries\MKS\Patches\KIS.config With the patched file from the PR here https://raw.githubusercontent.com/UmbraSpaceIndustries/MKS/3082e1aff5b5c754cccebed795742d603bb7e8a2/FOR_RELEASE/GameData/UmbraSpaceIndustries/MKS/Patches/KIS.cfg I had the same issue as yours and this fixed it for me.
  21. FYI: I tested the Scoop for a couple flights and I had no problem with it.
  22. I would think that even Kerbals are not crazy enough for using NSWR on their planet
  23. Clear. I've just upgraded my pebble-bed powered SSTO spaceplane with an Mk5 MTFR. And that's actually pretty decent. In-atmosphere thermal flight is inferior but still solid and VTOL is still possible. Vaccum flight is (surprisingly) significantly better with my ATTILA engines stabilizing at about +50% thrust. I'm guessing that's because heat management is easier than with a pebble-bed. Thanks again for the amazing support!!! That mod is amazing
  24. I just unlocked the 1st antimatter node and 3 things seem weird to me. First, an Mk2 anti-matter reactor combined with an ATTILA engine can single handedly SSTO a 40t spaceplane. It can even VTOL that spaceplane! I'm surprised this is even possible for an electric engine (I can't do the same with any other electric engine). Is that intentional? Second, I bough positrons in the VAB/SPH for essentially the same price as regular fuel. Is that normal? Isn't antimatter supposed to be the most expensive stuff ever? Third, at 4k science, antimatter looks very OP. How is that low cost justified? Except for the extra-heat (that was still very manageable; note: I've unlocked all heat-management nodes except the last one) it did not have any significant drawback when compared to fission or fusion. For SSTO spaceplanes anyway.