Amadou

New Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Amadou

  • Rank
    Newbie
  1. I have KSP 1.7.3 LMP cannot launch because its version is for KSP 1.8.x, I want LMP for KSP 1.7.x