Jump to content

TheSpaceVenturer

New Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About TheSpaceVenturer

  • Rank
    Newbie
  1. I'm a bit of a big noob when it comes to using mods so can anyone help me install Kopernicus? It is saying no matter what that it is not compatible with 1.10.1 and that means I cannot play with this mod because the actual planets will not load. Iv'e really been looking forward to playing it after watching Gameslinx's series for it and Carnasa's series on it as well. So can anyone help me with it? It would be much appreciated since i really don't know how to use it.
×
×
  • Create New...