Jump to content

Krydax

Members
  • Posts

    28
  • Joined

  • Last visited

Everything posted by Krydax

  1. Haha nice I'll definitely look into it! If anyone has "earned" donations... you're one of them. The work you do for the modding community has always amazed me. You're like the glue that holds everything together. I'm hopeful that the KSP2 modding community will have more vibrancy and popularity and thus more modders like you, so you won't need to carry such a heavy load.
  2. Just for what it's worth. Kronometer in JNSQ happened to be the issue I had, and LGG pointed me towards a more unofficial patch that seems to have fixed things.
  3. Holy cow you are a saint among men! Not only did that work, but now I also have the added benefit of station keeping, precise manuever, and docking port alignment indicator now all working (they weren't before)!!!!! Thank you thank you!
  4. Unfortunately... It didn't work. I manually deleted toolbar controller folder from gamedata, along with deleting all the toolbarcontroller downloads in the CKAN cache (in user/appdata/local), and used the reinstall button on toolbar controller in ckan (since it still thought it was installed), it went and downloaded the newest version and installed it. And I'm still getting unresponsive main menu buttons. KSP log: https://www.dropbox.com/s/cbl673yc4zvvdis/KSP.log?dl=0 Player Log: https://www.dropbox.com/s/xv64ce714zm47zh/Player.log?dl=0 Sorry to be such a hassle! Thank you for your wizard interpretation of these log files... It's 99.9% gibberish to me!
  5. Ohhh okay. Thanks for that clarification. There is a reinstall button in CKAN which I assumed is what you were getting at. I'll try that out later when I'm at my computer and report back
  6. Okay I rightclick + reinstalled zero mini avc, toolbar, toolbar controller, and ksp avc, just for good measure. Still got the same issues. Menu buttons do nothing. Have to force quit the game cause the quit button doesn't even work haha. Player.log https://www.dropbox.com/s/mbelb9cv9tqi7rs/Player.log?dl=0 ksp.log https://www.dropbox.com/s/p81lsxdlniqklqb/KSP.log?dl=0 Thanks!
  7. I'm having the same issue that Xt007 was (I think) where the main menu is completely unresponsive. I also don't have the huge popup anymore that shows how all my mods aren't designed to work with 1.12.2 But the game was working fine as of a few days back (not sure, maybe 5-7 days since I played last? Can't remember), but fired it up tonight and the main menu buttons just don't do anything. Tried clearing input locks via alt+f12 and no dice. All mods installed via CKAN with maaaaybe one or two exceptions. (and I forced a reinstall of toolbar controller via ckan as well). And all mods are fully updated Log file: https://www.dropbox.com/s/zn8kswri5wls8t7/KSP.log?dl=0 avc log: https://www.dropbox.com/s/zn8kswri5wls8t7/KSP.log?dl=0 Thanks in advance for any and all help and wisdom!
  8. Dang. No worries though. Just gotta settle for not having your mod for a while I guess Congrats on moving! Is this the kind of thing another player who has a bit of coding experience could look into (not me)? Or do you have certain licenses that would prevent that?
  9. Hello all, I was wondering if someone who knows a bit more about log files could help me with why PreciseManeuver is currently not working and throwing exceptions every frame of the game. Other players are apparently seeing success with this mod in 1.12, so it's not simply a 1.12 issue. Something about my particular set of mods or configs is causing PM to poop out. Thanks in advance! Log file: https://www.dropbox.com/s/zn8kswri5wls8t7/KSP.log?dl=0
  10. have you tried career evolution? It added a lot of helpful contracts for me (playing with unkerballed start as well) that got me enough funding to move forward!
  11. IDK it just won't appear. I have it installed via CKAN along with many other mods. Here's the log file. It throws an exception in the log file literally every frame from precisemaneuver. So clearly something has broken. Just not sure what. https://www.dropbox.com/s/zn8kswri5wls8t7/KSP.log?dl=0
  12. They really don't Being able to "snap to ap/pe" is a HUGE functionality, along with hitting the "circularize" button. Precise node lets you MANUALLY edit the node fairly well, but it doesn't have the quality of life buttons (like even the inclination turning buttons) that precise maneuver does.
  13. https://imgur.com/a/JjVq2ua It's just... not there....
  14. Yep. Installed via CKAN. And it's Blizzy's toolbar that gives the toolbar button visibility. Some mods use blizzy's and some use the stock toolbar. Toolbar controller is made by linuxgurugamer to be able to select where mods can go on which toolbar. It shouldn't be messing with preciemanuever.
  15. I do not have the button nor does the display pop up when I create a manuever node on 1.12 https://imgur.com/a/CP4hz3M
  16. I'll have to check tomorrow, won't be able to check today. Thanks for the heads up!
  17. IDK I didn't know what changed in 1.12 I've been away for quite a while now, I just thought I would report the bug! I think this isn't the mod I thought it was, as I was remembering one that simply reduced torque as you continued rotating in a single direction, and then it would slowly regenerate once you stopped rotating in that direction, and that was it. It didn't track all the axes and regenerate based on reverse direction or anything. Thanks for the response!
  18. Making Less History, at least for me, is causing the recurrence of a bug that's apparently been around since 1.11: I really like the making less history mod, but is there any way that it can be fixed so it doesn't cause the extra SAS modes bug? I'm planning on using it as-is, and just not letting myself use modes I shouldn't have, but it's definitely a bug! Thanks,
  19. Yep. That fixed it. Making Less History mod created this issue. Unfortunate. I actually like the mod enough that I'll continue playing with it, and just use self control to choose not to use any SAS modes that shouldn't be available to me.
  20. https://imgur.com/a/Pt6ZhTJ I got news for ya.... I already have it. Do you think, then, it could be the "making less history" mod? I really like that mod... It saves me loadtime and ram. But it disables some elements of making history and maybe that's why I'm seeing this bug? I'll test it out and get back to you.
  21. I'd have thought maybe so. But that still doesn't do any explaining on why sandbox DOESNT have the issue and Career does. If anything you think it would be the other way around. Unless somehow unlocking a tech node FIXES the problem, and that's what's happening in sandbox. And removing probes before core, which would be the most likely thing to mess with probes, didn't fix it. I also cheated some science in, unlocked command pods, and lvl 1 Jeb is even giving all the SAS controls, so it's not just a probe core thing
  22. https://imgur.com/a/r5Nxjzq Not sure how difficulty settings are relevant. The sandbox game i just left on default normal settings and the SAS control stuff worked correctly, but the career game left on default settings has all the sas options enabled. So the difficulty settings for both of those pictures were exactly the same.
  23. The RW window seems to be having a bug. https://imgur.com/a/ciIURyZ Not sure why it's just the tiny window with an x. Maybe has something to do with 1.12? Not sure. Also, my available torque isn't "regenerating" over time. I thought it was supposed to come back slowly? EDIT: Actually it seems like the whole thing is bugged. If I launch a probe into space and then just use roll in a single direction for a while, the available roll torque goes down, but if I then introduce a bit of pitch or yaw, all the numbers go haywire as the craft spins around crazily (no stability assist on). So like, it's regenerating torque not from actually applying reaction wheels, but from simply spinning, which I'm quite sure is not the intended behavior.
  24. Hello all, Playing a modded JNSQ w/ probes before crew save with plenty of parts mods and QOL mods. However, I can't seem to fix this one particular issue no matter what I do. Decouplers are missing from their regular hope in the "coupling" menu. Only the stack decouplers, however. Engine plates, radial decouplers, and other things that decouple are showing up normally. Even weirder, if I do the advanced sorting options in the top left of the VAB, and select "sort by module" and find decoupler, then they DO show up there! So they exist, but are somehow being hardcore hidden and don't show up in any of the "sort by function" menus. I thought it might be procedural parts, but removing that did nothing. I thought it might be Janitors Closet, but removing that did nothing. I though it might be probes before crew, but again, removing that did nothing. So regardless of what I try, I can't seem to figure out what is hiding these parts. I'm not crazy far into the career save, but so far, it's ONLY the regular stack decouplers & separators, the ones included via Squad or squad expansion. Any ideas would be much appreciated. Coupling menu missing regular td-06 and td-12 and the like: https://imgur.com/a/lSfCQkC Searing by module coupling, you can see that they are there: https://imgur.com/a/nIjeZIi I am happy to provide log files but not sure of an imgur-like service for easily uploading .txt files.
  25. As mentioned via title, I have full SAS controls available on any craft I've launched so far. I'm doing a modded JNSQ career with probes before crew and lots of various QOL and parts mods, but I can't really understand what might be causing this. When I googled/searched the issue, it sounds like it was an issue at some point in 1.11 but didn't really hear of any fixes or why it was happening so I'm not sure where to start. Here's a pic from my current career playthrough. Stayputnik has full controls with SAS: (i also tried starting a brand new career with default settings, and it still had full sas controls) https://imgur.com/a/QDt1IHq Here's a pic from a NEW sandbox save. Stayputnik does NOT have full controls with SAS: https://imgur.com/a/MHm5fRm What on earth? Why would it have full SAS hax on career but not sandbox? I'm happy to share log files but honestly not sure what site is easy to upload them to, like an imgur for txt files?
×
×
  • Create New...