Warringer

Members
  • Content Count

    408
  • Joined

  • Last visited

Community Reputation

6 Neutral

About Warringer

  • Rank
    Sr. Spacecraft Engineer

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Please for all that is good and holy in this world and for all the players of KSP... Do not sell out to Epic with KSP and do an exclusive after Epic throws money at you. PLEASE!!!
  2. Question on KSCSwitcher. Is it possible to turn a launch site by 180 degrees? It's very disconcerning of the sun raises on the other side of the launch complex. (I'm using SKY.)
  3. Okay, I've done a Launch with the KerbalX, using FAR. I had about 640 m/s left after burning into a 150x123 km orbit at 7° inclination. So I guess that you need about 5700 to 5800 m/s of delta-v for the ascent.
  4. I have encountered this bug for a while now and it does not matter whether the install is modded or not. Every one in a while I get a 'sticky decoupler' that simply doesn't decouple when I stage it or click 'Decouple' in the context menu. I thought that it might be a case of the acceleration wedging parts together (somehow), but a launch after revert always goes on without any problems and the decoupler decouples. I would be thankful for any help.
  5. *thanks for ckan* - AdvancedAnimator autodetected dll - AGExt autodetected dll - AntennaRange autodetected dll - AutoAction autodetected dll - BandwidthFix autodetected dll - BDAnimationModules autodetected dll - CommunityResourcePack 0.4.0 - ContractsWindowPlus 5.0 - ControlLock autodetected dll - DistantObject v1.5.3 - DistantObject-default v1.5.3 - EVAManager autodetected dll - FirespitterCore 7.0.5463.30802 - KDEX v1.04 - KerbalDebrisFix autodetected dll - KerbalEngineerRedux 1.0.16.3 - KerbalJointReinforcement v3.1.3 - KerbalMechanics v0.6.4.1 - kOSVoidAction autodetected dll - KSPAPIExtensions autodetected dll - KSP-AVC 1.1.5.0 - LifeSupport autodetected dll - MechJeb2 autodetected dll - MiniAVC autodetected dll - ModuleCargoBayFix autodetected dll - ModuleJettisonFix autodetected dll - ModuleManager 2.6.1 - ModuleParachuteFix autodetected dll - ModuleProceduralFairingFix autodetected dll - ModuleWheelFix autodetected dll - ProceduralFairings autodetected dll - ShipManifest 4.1.4.4 - StickyLaunchPadFix autodetected dll - SymmetryActionFix autodetected dll - ToadicusTools autodetected dll - Toolbar 1.7.8 - TweakableEverything - USI-FTT 0.4.0 - USITools 0.4.0 - VesselSimulator autodetected dll - VOID - WaypointManager 2.3.0
  6. I just had a pair of wired incidents, perhaps bugs, in the game. I renevouzed with my brand new station, when suddenly a Goog container on the outside of the Sojuz service module exploded. Apparently firing the main engine is massively heating up the service module. To make it worse, the Sojus capsule heated up to such a degree, the the ablator burned of nearly completely. EDIT: I found an explanation for this event. Squad has reduced the Heatproduction of all engines by one order of magnitude, most likely due to the new heat model. I would therefore suggest reducing the heat production. Example: LV-909@0.90 heatproduction = 300, LV-909@1.0 heatproduction = 20 The second inducent was trying to move Bob from the Sojus capsule to the Science module of the station, a Kwant module, where he was punted back into the Sojus and the video image began to flicker between 'not there at all' and 'Bob in fear'. An EVA to transfer Bob, lead the same result and when I EVAed him to mode into a Hitchhiker, he was dublicated, one in the Sojus and one in the Hitchhiker. Trying to transfer him from the Hitchhiker to the Kwant also didn't work...
  7. I still have the problem that 64k does not work correctly, even with 64k being the only mod installed and the RSS.dll replaced with the latest version. It gets stuck at resizing the second planet, Tylo IIRC. The log file tells me that its stuck at saving the resized mesh/texture. But space is there, and 32 Jumbo as well as stock RSS work... >_>
  8. For some time now I wish there was an economy career mode. A bit like the Science Career mode, but with the full tech tree avaiable, while you have to do contracts and secure funding.
  9. I've made you a log file. -> http://goo.gl/yF4pNb And I discovered that it might have something to do with the 'Start in Archive' setting in the configuration.
  10. I just came over a strange bug that sneaked up on me, while trying to optimize my RSS/FAR launch script. More or less suddenly either of the computer cores heats up without cause (Deadly Reenty), making the launch vehicle explode in mid flight. If I remove Deadly Reentry, FAR causes the structural links to break up and the rocket explodes. And even before that, the control core connected to the computer core just detaches and needs to be held in place by struts... I have no freaking idea what is going on...
  11. Well, Gentlemen. After having found a near perfect launch trajectory for RSS 6.4x with FAR and RealFuels, I've decided to try and write a launcher script that makes use of that trajectory and can be used with any rocket. It worked well enough to get the rocket above tehe atmosphere during development. Then I tried to add a maneuver node part to for orbital insertation and it suddenly didn't work anymore. Something, I don't know what, keeps the throttle to 0, even though its locked to a variable tVal and should be used to adjust the TWR of the first stage (with solid boosters of the test rocket). launchtest.ks SET oldTWR TO 0. SET tVal TO 1. SET combthrust TO 0. SET direction to HEADING(0,90). LIST ENGINES IN engs. LOCK THROTTLE TO tVal. LOCK STEERING TO direction. RUN launchdisplay("Prelaunch", 0, 0, tVal, 0, 0, "Launch in 3!"). Wait 1. RUN launchdisplay("Prelaunch", 0, 0, tVal, 0, 0, "Launch in 2!"). Wait 1. RUN launchdisplay("Prelaunch", 0, 0, tVal, 0, 0, "Launch in 1!"). print THROTTLE. wait 1. stage. wait 0.5. FOR eng IN engs { SET combthrust TO combthrust + eng:THRUST. }. SET TWR to combthrust / (MASS*9.81). print THROTTLE + ", " + tVal + ", " + TWR. until TWR <= 1.2 { SET tVal to (tVal - 0.02). SET combthrust TO 0. FOR eng IN engs { SET combthrust TO combthrust + eng:THRUST. }. SET TWR to combthrust / (MASS*9.81). print THROTTLE + ", " + tVal + ", " + TWR. wait 0.05. } SET oldTWR to 0. SET TWR to 0. RUN launchdisplay("First Stage + Boosters", combthrust, TWR, tVal, 0, 0, "Launch!"). wait 0.5. stage. wait 0.5. SET message to "Launch!". SET timer to TIME + 10. WHEN timer = TIME THEN { SET message TO "". }. UNTIL oldTWR > TWR { SET oldTWR to TWR. LIST ENGINES IN engs. SET combthrust TO 0. FOR eng IN engs { SET combthrust TO combthrust + eng:THRUST. }. SET TWR to combthrust / (MASS*9.81). IF VELOCITY:SURFACE:MAG > 75 { SET direction to HEADING(90,ARCCOS(SHIP:ALTITUDE/40000)). }. RUN launchdisplay("First Stage + Boosters", combthrust, TWR, tVal, 0, 0, message). wait 0.5. } SET message to "Booster Separation!". SET timer to TIME + 10. WHEN timer = TIME THEN { SET message TO "". }. SET oldTWR to 0. SET TWR to 0. IF TWR < 1.2 { SET tVal to 1. }. wait 0.25. stage. wait 0.25. WHEN SHIP:ALTITUDE > 30000 THEN { SET direction to SHIP:SRFPROGRADE. WHEN SHIP:ALTITUDE > 50000 THEN { SET direction to SHIP:PROGRADE. }. }. UNTIL oldTWR > TWR { SET diffTWR to (TWR - oldTWR). SET oldTWR to TWR. LIST ENGINES IN engs. SET combthrust TO 0. FOR eng IN engs { SET combthrust TO combthrust + eng:THRUST. }. SET TWR to combthrust / (MASS*9.81). IF SHIP:ALTITUDE < 30000 { SET direction to HEADING(90,ARCCOS(SHIP:ALTITUDE/40000)). }. RUN launchdisplay("First Stage Main Core", combthrust, TWR, tVal, 0, 0, message). wait 0.5. } SET message to "Main Engine cutoff!". SET timer to TIME + 10. WHEN timer = TIME THEN { SET message TO "". }. stage. wait 0.25. SET tVal to 0. wait 0.25. stage. wait 0.25. SET Kerbin to BODY("Kerbin"). SET apo to SHIP:APOAPSIS. SET apoVel to VELOCITYAT(SHIP, apo). SET circularVel to SQRT(Kerbin:MU / (apo + Kerbin:RADIUS)). SET circulNode to NODE(ETA:APOAPSIS, 0, 0, circularVel). ADD circulNode. Set DeltaV to circulNode:DETLAV:MAG. SET direction to circulNode. SET acc TO MAXTHRUST/MASS. SET burntime TO 0.5 * acc / DeltaV. SET save TO 5. LOCK Tminus to circulNode:ETA - burntime. WHEN circulNode:ETA < 120 THEN { AG1 ON. AG2 ON. } WHEN (TMinus + save > 300) THEN { SET WARP TO 4. WHEN (TMinus + save > 150) THEN { SET WARP TO 3. WHEN (TMinus + save > 30) THEN { SET WARP TO 2. WHEN (TMinus + save > 15) THEN { SET WARP TO 1. WHEN (TMinus + save > 5) THEN { SET WARP TO 0. }. }. }. }. }. UNTIL TMinus + save < 1 { RUN launchdisplay("Second Stage", 0, 0, 0, circulNode:DETLAV:MAG, circulNode:ETA, message). } SET message to "Second Stage Ignition!". SET timer to TIME + 10. WHEN timer = TIME THEN { SET message TO "". }. SET tVal to 1. WHEN (DeltaV < 50) THEN { SET tVal to 0.1. WHEN (DeltaV < 5) THEN { SET tVal to 0.025. }. }. UNTIL DeltaV < 0.5 { SET combthrust TO 0. FOR eng IN engs { SET combthrust TO combthrust + eng:THRUST. }. SET TWR to combthrust / (MASS*9.81). RUN launchdisplay("Second Stage", combthrust, TWR, tVal, circulNode:DETLAV:MAG, circulNode:ETA, message). wait 0.5. } SET message to "Orbital Insertion Complete!". SET timer to TIME + 10. WHEN timer = TIME THEN { SET message TO "". }. WAIT 15. launchdisplay.ks DECLARE PARAMETER title, thrust, twr, throttle, nodedv, eta, message. set seconds TO MOD(eta,60). set minutes to FLOOR(eta/60). CLEARSCREEN. print title at (14,2). print "Vehicle Data:" at (5,4). print "Orbital Velocity : " + ROUND(VELOCITY:ORBIT:MAG, 3) + "m/s" at (10,6). print "Surface Velocity : " + ROUND(VELOCITY:SURFACE:MAG, 3) + "m/s" at (10,7). print "Altitude : " + ROUND(SHIP:ALTITUDE, 3) + "m" at (10,8). print "Periapsis : " + ROUND(SHIP:APOAPSIS, 3) + "m" at (10,9). print "Apoapsis : " + ROUND(SHIP:PERIAPSIS, 3) + "m" at (10,10). print "Thrust : " + ROUND(thrust, 3) + "kN" at (10,11). print "TWR : " + ROUND(twr, 3) at (10,12). print "Throttle : " + ROUND(throttle * 100, 3) + "%" at (10,13). print "Node Data:" at (5,15). print "Delta-V : " + ROUND(nodedv, 3) + "m/s" at (10, 17). print "ETA : " + minutes + "m " + seconds + "s" at (10,18). print message at (5, 20). Can someone please tell me why it suddenly doesn't work as it should? And potential better ways of doing it. ;-)