Ezriilc

Members
  • Content Count

    1,391
  • Joined

  • Last visited

Everything posted by Ezriilc

  1. Questioning others' update habits while forgetting to check my own is a delicious form of failure - public and egregious.
  2. @sslaptnhablhat and @thelukeshow, I'm a complete doofus! I was still using KSP 1.4.5. I'm updating now and will re-test. Sorry!
  3. @sslaptnhablhat and @thelukeshow, I am so far unable to reproduce the issue of Planet Editor failing to reload changes on game start-up and when manually reloading the config files. Are you sure that you're using the latest HyperEdit (v1.5.8 as of this post)? If so, please try making some new changes and then saving them. We moved the config files a couple versions back, so I wonder if it's just reading the wrong file location. When in doubt, please try an entirely new install of the latest KSP and HyperEdit without any other mods. EDIT: I'm a complete doofus! I was still using KSP 1.4.5. I'm updating now and will re-test. EDIT EDIT: Even after updating, I still can't reproduce this problem.
  4. I would not have predicted that. I'm pretty sure that nothing about the Planet Editor was changed from KSP v1.4 to 1.5, so I'm stumped. Unless you've deleted the configuration file, I can't think of why that would happen. Sorry I can't be of any help.
  5. You can edit the orbit of any body on the list, which includes asteroids, and my tests do allow me to move them. However, the Lander only works on the current vessel, which cannot be switched to an asteroid, so it's not possible to bring one all the way to the ground. Keep in mind, my tests are only with the current versions of KSP (v1.5) and HyperEdit (v1.5.8). Sorry for the delay, and I hope this helps.
  6. I'm sorry, but I don't know what to make of that. I'd need someone with more KSP API experience than I have, and possibly with experience on RSS and other planet packs. Hopefully someone here will have more insight.
  7. As of today, Kerbaltek members' Ribbons have been served more than 6 million times since ~July of 2014! At one point, I was worried that my host may not like the bandwidth use, but I've never gotten any notices or slowdowns (that I know of), so I'm glad that I decided to host users' images in-house - it has worked out great. I'm pleased that users still like it after all these years, and I look forward to many more years to come. I've been thinking it's high time I got back into it and add to my own achievements. Getting all the devices and completing all my ribbons has been my goal from the beginning of the project. I encourage others to do the same, as KSP has only gotten better over time, and it's so much better a use of one's time than crushing candy or battling royals. Fly on, you magnificent, exploding krash-test dummies!
  8. To be honest, I just don't know. I don't actually use that feature of HyperEdit, and I'm no expert in that area. I've inherited the mod from The Creator, and I didn't write that part of it. Sorry I'm of no help. Hopefully, some of the real experts will chime in here and help - they usually do.
  9. Sorry, I'm not fully understanding. Are you saying that KSP v1.5 reports that HyperEdit v1.5.8 is not compatible?
  10. I've actually been meaning to post about a report I got saying that HyperEdit 1.5.8 (latest as of this post) works (at least partly) with KSP 1.5. So, my question is did you try it?
  11. Welcome to the forum! There is no way to tell what's happening without complete details of what you're doing and how. First, remove all mods except HyperEdit and try it again. If you still have the same problem, please provide more information. What versions of everything you are using? Tell us exactly, step-by-step what you're doing and in what order. Include anything necessary for anyone else to reproduce the problem.
  12. @Aeroboi, this is what I've found while testing my Windows 10 rig with 64-bit KSP 1.4.5, including the Making History expansion, and HyperEdit 1.5.8, in sandbox mode. EDIT: Oops! I had the issue numbers backwards, so I corrected them here and in the repo. I've confirmed this and commented created the issue on GitHub, with some detail. Please let me know if I'm off the mark (so to speak ), or if I've left anything out. https://github.com/Ezriilc/HyperEdit/issues/62 As for the "moving only East" problem with IJKL, I think that may be due to using the Lander to land on a different body. The user should orbit the body first with the Orbit Editor, then land on the body with the Lander. I noticed your screenie of the Lander has the warning: "Landing on a different body is not recommended.", which indicates this condition. This may be the work-around for the East-only problem. I've created commented the other issue for this. https://github.com/Ezriilc/HyperEdit/issues/44 Please also take a look at that and tell me if it feels right. I look forward to any and all input on this issue from anyone and everyone. Especially any code geniuses such as @Thunderous Echo, @linuxgurugamer, and @fronbow. But seriously, all input is welcome, from suggestions to pull requests. I hope this helps!
  13. @Aeroboi, thank you for the excellent report and details. It does appear you're on to an issue that we've had in the past, but that I thought was at least partly fixed. https://github.com/Ezriilc/HyperEdit/issues/44 I have updated that issue with regard to the fact that the problem still exists. I realize this doesn't help you at all, and I'm sorry for that. I'm not an expert with KSP modding, so I don't know if I can actually fix it, but perhaps we can figure out a way around it. Also, someone seeing this may be able to help with the programming. I have been saved by this community many times so far. I plan to do some more testing of the specifics, and I will report back here in the next day or two. Please feel free to add any more input you may have at any time, here and/or in the GitHub issue.
  14. Please try it without any other mods. You may need to install one mod at a time to determine which if any is the problem. Good luck and please let us know if you learn anything new.
  15. Thanks for the follow-up. I feel your pain, but I'm glad it's working again. By all means, if you learn anything new, feel free to contact us again here, or on my site. Good luck! @Nightside, I just realized that I failed to answer your other question. I'm sorry for that, I must have been moving too fast that day. Please know that I don't intend to ignore you. It sounds like you're doing things properly, but if the Lander does nothing, then something is up, as it does work for me and other testers. I would need to know some more specific information about your setup and what steps you've taken. It's probably too late now, but if you still need help and/or have any questions, please let me know. I'm happy to help.
  16. I've not heard anyone report this issue yet, and I cannot imagine how that could be related to HyperEdit, as it doesn't make any changes whatsoever to the terrain or buildings. That doesn't mean it's not happening, just that I can't see how. I recommend that you try a fresh install of KSP and HyperEdit, without any other mods. If you still have the same problem, I'd be happy to do some more testing, so please let us know what you find out.
  17. Good news, everyone! I've updated my Craft Fixer tool (on the Craft Kitchen page), so it will recognize new (KSP v1.4.5) .craft files, as well as old ones. If you got the "Unrecognized file content" error, then this fix may help you. Please try it again, and report any issues you may find. http://www.Kerbaltek.com/craftkitchen
  18. @Nightside: Yes! HyperEdit 1.5.8 works well with KSP 1.4.5. I've updated the note on the HyperEdit page.