Ezriilc

Members
  • Content Count

    1,383
  • Joined

  • Last visited

Posts posted by Ezriilc


  1. 1 minute ago, Supercheese said:

    For having mirror(s) available if one location is down due to network troubles, naturally.

    I'm sorry if you're having trouble, and I promise to do my best to fix it.  :)

    The error you've reported is not caused by network issues, and my hosting provider hasn't suffered any significant outage since I started the Kerbaltek site in 2013.

    If you continue to have problems, please contact me directly, so I can help.  You can PM me here, on my site, and in IRC via EsperNet (#KSPofficial & #KSPmodding) and FreeNode.


  2. 2 minutes ago, Supercheese said:

    When I attempt to download http://www.kerbaltek.com/_downloads/hyperedit/HyperEdit-1.5.8_for-KSP-1.4.4.zip  I get "403 Forbidden".  :huh:

    That means you're either trying to hotlink to my files (a no-no), or your browser is misbehaving due to plugins or some such.

    Please try it again with a different browser and/or with all plugins disabled.


  3. 5 hours ago, tonimark said:

    plz update for ksp 1.4.4

    Sadly, The Creator is no longer part of the project, so it is left to me to care for it.  Because I'm not fluent in C# enough to properly update the code, I'm somewhat stuck.  :blush:  Most times, someone in this great community saves me by volunteering new code, and/or testing.

    4 hours ago, OhioBob said:

    plz don't ask that.  The author of this mod is under no obligation to update and doesn't owe you anything.

    I don't mind anyone asking for an update - especially when you say "please".  It's fine.  :D  Just understand that there may be quite a long wait.

    I would ask that you try our latest BETA-3 version with KSP 1.4.4 to see if it works, and report back to us here if you can.  Your assessment could lead me to a fix that I can handle, or inspire someone to jump in here and help.

    Please, everyone, feel free to contact me any time.


  4. 1 minute ago, MikeO89 said:

    Program works the way it is in 1.4.3. I just put a couple of Mun bases up with it and it worked fine. My only complaint with it remains it using a different method of displaying coordinates. It's been explained here how to convert but my dumb butt still doesn't entirely get it and is it still a hassle to me to do it on the fly. I don't know why it chose to use a different method than what the game uses. Other than than, this mod definitely does have it's uses. I have some cool bases on the Mun that I would never have been able to put there otherwise.

    Thanks for the report.

    I've added the coords thing as an issue here:  https://github.com/Ezriilc/HyperEdit/issues/54


  5. 4 hours ago, The Minmus Derp said:

    Me likey. One thing I want is it to build a professional rocket that is easy to fly for a prebuilt payload that I can legitimately fly.

    Practice makes perfect, and HyperEdit definitely helps me with new craft designs and mission plans.

    My favorite craft builds are on my site (Craft Kitchen), please help yourself.  "Kolsys" is my best ship.


  6. Yes, eventually.  I'm having some IDE issues.

    In the meantime, you can use the BETA-3 we have up, as it seems to also work in KSP 1.4.2.

    EDIT:  I think I was conflating this thread with my other mod's.  I'm not currently aware of any problems with Graphotron on the latest version of KSP,  but then I haven't done any testing.  This doesn't mean I don't intend to, I simply overlooked it and didn't get any support requests.


  7. 8 hours ago, Gargamel said:

    I was having issues with a HE'd vessel being flagged as traveling over land, but this fixed part of my issue.

    I edited a vessel into orbit around kerbin, and then into rendezvous with a station around minmus (Forgot a part and I had ships waiting to dock that needed that part).    Now, when I time warp, it is jumping ahead in it's orbit at times.    Using 1.5.6 for 1.3.1. 

    I'm assuming this is a known bug, but my question is, will this persist if I switch to other ships, namely the ones waiting to dock?  Will I have a station jumping around all over the sky?

    Yes, that is a known issue.  I believe that changing scenes (like to Tracking Station) and back will fix it.

    EDIT:  Also, you can see that issue here:  https://github.com/Ezriilc/HyperEdit/issues/14


  8. 34 minutes ago, xjames said:

    Hyperedit 1.4.1 beta 3 on KSP 1.4.2 (mac)

    Hi there. 1st time using hyperedit. Great tool to test your ship before committing to a mission! Here's some feedback, hope its useful.

    If I hyperedit a single stage probe from Kerbin's launchpad to another planet's orbit (Duna in this case), everything works fine.

    If I do it with a ship with multiple stages everything works fine until I stage the ship. Then it starts glitching as described by mercaholic75, with the ship wiggling back and forth. I'm then also unable to set maneuver nodes, and if I burn the engine, the orbit on the map view doesn't seem to change. If I try to go to the space center at this point, it'll say that I can't exit with a ship moving on the ground. If I'm not mistaken, the staged part doesn't glitch. Just the main ship.

    Thanks for this awesome mod!

     

    We recommend that you don't go straight from the surface directly to orbit another body.  Edit your orbit to be around the body you're on, then edit it to orbit the other body.

    On 3/28/2018 at 5:09 PM, Wolf Baginski said:

    The procedure in the FAQ is not what I did with the release version download, which is a standard zipfile containing the same sort of filesystem everyone uses

    Gamedata/

                       Kerbaltek/

                                         Flags/

                                         HyperEdit/

                                         HyperEdit.dll

     

    So I just extracted the Kerbaltek subfolder into the live Gamedata in my KSP install, and it works.

    Some mods don't bother with including the Gamedata/ folder in the zipfile. I really think that if you're doing something different it would be worth having a ReadMe that mentions it in the zipfile.

    The current setup makes it easy to install and use, by simply extracting to the game's root folder.


  9. 31 minutes ago, Wolf Baginski said:

    Thanks, that's what I was doing. What I started me off wondering was the FAQ you have on the HyperEdit webpage which gives a different procedure, that looks rather odd for the release downloads.

    Yes, the procedure in the FAQ is for normal use, and the Experimental (BETA) versions have an additional set of instructions for using the BETA versions.

    I suppose I could improve the language of our mod pages.  I'm open to any input as to how it should read.


  10. 1 hour ago, Wolf Baginski said:

    I think I may be missing something.

    The old release version of Hyperedit uses a file named "HyperEdit.dll". and it works.

    The Beta download only includes a file  named "HyperEdit_BETA-3.dll" and it's not been working

    Is the filename difference significant? Or is it something else that hasn't been mentioned?

    The normal release is a zipfile with the usual ~Gamedata\ based content.

    @Jacke is correct (thanks for your help!).  Per the instructions on our site.

    Just make sure that whatever .DLL file you're using, that it's the only one, and that it's inside the GameData folder.


  11. 10 hours ago, mercaholic75 said:

    i had the mission for transferring Kerbals from one vessel to another around the Mun and I used the BETA version of HyperEdit to instantly place one of my vessels at 100000m orbit around the Mun and then had another vessel rendezvous with it at and they both started glitching out and skipping back and forth in the orbit. I was finally able to dock them but they started shaking violently and tried EVA with and it just started hitting my Kerbal and sending him off to god knows where. I can replicate it and record it and send it to you if you want.

    Thanks for your report!

    Most of that sounds like it may matche some of our known issues.  I wonder if you'd be willing to read through them to see if they describe what you've seen.  If so, please comment on the issue, or here.  https://github.com/Ezriilc/HyperEdit/issues

    All input is appreciated.  :)


  12. 23 minutes ago, mercaholic75 said:

    Just used the BETA version to get a mission done that id already had a chance to do but didnt click accept for it. By far the scariest most unstable thing ive ever used but it got the job done. Holy crap that BETA needs some work. I was sitting on the edge of my seat while my ships were flinging around in orbit after I had just set them up to rendezvous together. Im scarred for life. :(

    As much as I enjoyed your tale, if you were to provide more (any?) details, we could possibly nail that problem down.

    :D


  13. 12 minutes ago, Lindy said:

    If it's any help, the beta seems to be playing nice for me in 1.4.1.  I haven't been real crazy with it yet, but I can put things into orbit, and then modify the orbit. Great mod! Hyper-Edit has been at the core of my flight test program for a long time! :)

    Yes, that is helpful!  Thanks for the report.

    And on that note... Good news, everyone!  I've published a new BETA-3 version for KSP 1.4.1, with all the latest fixes and improvements that @fronbow has been working on.  If that version is good, then we'll make it a full release.

    http://www.Kerbaltek.com/hyperedit


  14. 1 hour ago, Fireheart318 said:

    I was able to get the beta so I Dropboxed the .ZIP - https://www.dropbox.com/s/aemq7g3ah5pryjl/HyperEdit_BETA-1.zip?dl=0

    @Ezriilc , if you have a problem with this, just tell me and I'll get rid of the link as soon as I can (probably within a few hours)

     

    Edit - It's not working. I did all the things the site told me to - copied the Kerbaltek folder and replaced the .dll. Do I need the flags folder?

    No.  You don't need the Flags folder.  Just make sure the Kerbaltek folder is inside your GameData folder.