Phenom Anon X

Members
  • Content Count

    46
  • Joined

  • Last visited

Community Reputation

16 Good

About Phenom Anon X

  • Rank
    Rocketeer

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I just wanted to jump in again and mention a couple things. When I updated to the latest version of this mod, I ran into the "java not recognised" issue again. I put it off for a few days but I did find a workaround. First I went to Java test page located at http://www.java.com/en/download/installed.jsp Ran the test and selected "Always allow" from the browser popup. (The first time, I only set it to run once). Ever since I set it to always, the test runs properly every time. I then appended ;C:\Program Files (x86)\Java\jre7\bin;C:\Program Files (x86)\Java\jre6\bin; (to make sure both JRE versions were added) to the Windows PATH variable. For those reading, please keep in mind that those variable Paths are for users running 64bit Windows 7. 32bit users might not get this error and won't need the workaround but I can't currently confirm that. 32bit users may need to add the full version path thusly (C:\Program Files\Java\jdk1.6.0_27\bin;) for example, without the parentheses and corresponding to your specific version of Java. Here's a quick guide for those running into Java troubles. You will use the Java compiler javac to compile your Java programs and the Java interpreter java to run them. You should skip the first step if Java is already installed on your machine. Download and install the latest version of the the Java Platform. Note the installation directory for laterâ€â€probably something like C:\Program Files\Java\jdk1.6.0_27\bin. To make sure that Windows can find the Java compiler and interpreter: Select Start -> Computer -> System Properties -> Advanced system settings -> Environment Variables -> System variables -> PATH. [ In Vista, select Start -> My Computer -> Properties -> Advanced -> Environment Variables -> System variables -> PATH. ] [ In Windows XP/7, Select Start -> Control Panel -> System -> Advanced -> Environment Variables -> System variables -> PATH. ] Prepend C:\Program Files\Java\jdk1.6.0_27\bin; to the beginning of the PATH variable. Click OK three times. For me, the path directory was a little different, so be sure to check your own directory names carefully. (\Program Files (x86) for example) Next, you will want to see if your changes work so do the following: You will type commands in an application called the Command Prompt. Launch the command prompt via All Programs -> Accessories -> Command Prompt. (If you already had a command prompt window open, close it and launch a new one.) You should see the command prompt; it will look something like:Microsoft Windows [Version 6.1.7600] (or whatever) Copyright © 2009 Microsoft Corporation. All rights reserved. To check that you have the right version of Java installed, type the text below. You should see something similar to the information printed below. (It's important that you see the number 1.7, 1.6 or 1.5 for the Java version number, but the rest is not critical.) C:\Users\username>java -version java version "1.7.0_51" Java SE Runtime Environment (build 1.7.0_51-b13) Java HotSpot Client VM (build 24.51-b03, mixed mode, sharing) If you see a Java version come up on screen then the .bat file will work properly. So to summarise, add the PATH variable to your existing variable in the Environment variables path, check the version in a new command window, if the version shows, eat cake. Enjoy.
  2. Now that I've seen it in action, I just have to that this tool is just "Phenomenal". Awesome, awesome, awesome job. I love this :-D
  3. Done and done. It boiled down to where I was running the command from. From what I can see (VNC from work), everything is up and running as intended. Thanks man, much appreciated!
  4. @jamis I'm at work right now, so I'll try a few things out when I get back home and report back. The command line I used was this: C:\Users\***>C:\Users\Admin\Desktop\real-solar-system-20140211-2\real-solar-sy stem-20140211-2\real-solar-system.bat As far as editing the batch file, I just tried successive edits to see what the results would have been. After those failed attempts, I did in fact overwrite the edited file with a backup and to be sure, I unpacked the archive to have a clean version, so no worries there. I suspected that notepad was messing up the view when I opened the file both with the native WinRar file viewer and in notepad++, both of which displayed the command code properly. As I mentioned, I'm at work right now, so I'll try when I get home or later tonight through VNC. *edit: An additional error in the command prompt window: 'java' is not recognized as an internal or external command, operable program or batch file.
  5. I'm wondering if I'm doing something wrong with this. I run the batch file and nothing seems to happen. It runs and closes and that's it. Here's what's in the batch file. @echo offset CLASSPATH=.\jars\zip4j_1.3.2.jar java -Xmx500m -jar .\jars\real-solar-system.jar It displays as one continuous line in notepad. I added a space after @echo off, removed the java command among other things. I've unsuccessfully edited the command line to avail and I'm still stumped. I've also tried to run the batch from various locations (desktop, and other folders both ind outside of the KSP directory. Am I doing something wrong? * Edit: (JRE 7 is installed)
  6. Love the work your doing with Tingle. Have any of the orbital bodies been done yet, or is it just the skybox for now?
  7. My god, it's full of planets. The LT Engine is coming a long way and I just can't wait to see more. This one is high on my anticipated games list, just thought I'd point out the new update for those interested.
  8. Well, I did it. I've never designed a plane (other than stock STS in the VAB). I used Procedural wings for this as it seems the most logical thing to do. I generally run stock parts until I've played them to death before I go with larger mods. This one is made up of 2 sections, the Glider and the Launcher. The Glider is about 10 parts (15 or so with struts and RTG) and the Launcher is 6 parts (10 with struts). The Launcher is just a mk part with an intake and basic jet engine and wheels. It litterally took off right away, so in accordance with the rules, I counted down from 10 and jettisoned the launcher at just over 500m. I maintained level flight as much as I could without gaining too much speed. at 80m/s, the stabilizers go a little nuts, so I had to keep the speed low in order to be able to land. I essentially lined up the flight path and let the rate of descent fall by about 1m/s, with the occasional maneuver to line up the glideslope and maintain altitude. I don't know what this infiniglide bug is, but I did notice and observe how it's possible. That would have defeated the purpose for this challenge. After a few test flights and landings, I had calculated an optimal altitude to maintain a proper descent for landing. Finding the right landing speed took some trial and error at the Space center and I managed to land without incident on the first attempt. Thanks for the challenge. It got me out of the VAB and into the SPH for the first time. Here are my results: http://imgur.com/a/LdclX#0
  9. Banned for attempting to inject civility into banning.
  10. and opening up Software Center....
  11. I had a big long post that got deleted because I got logged out. I'm tired of forum Nazi's. No really. I'm sick of it. Here's my clipboard, I'm tired and sick to death of losing edits because of getting logged out and not getting proper redirects to my posts. /rant ================== I skipped over a large portion of replies, but I've subscribed to the thread for later reading. I don't even know where to start with my reply to OP. According to my logs, I've spent the better part of 300 hours in game desiging a proper space shuttle with stock parts only. It's not easy. Period. I had to think outside the box on two different fronts. The main issue, as OP posted, is balance. The challenge to myself was to never use a mod until I get a stock shuttle running. .... I really should be blogging this... anyway, I'll briefly summerise. First was the basic lander, no lifter, no engines, no tanks, no rcs, nothing. Just a plain old plain, with no engines that would glide and land. That in itself took ages. But how do you test it without engines? Well, on phase 2 I added jet engines and launched it horizontally and flew it. Just to get a feel for it's flight characteristics. Landing was a matter of cutting the engines and coasting, not facing the runway and treating it like a glider. Turning the thing was a bitch, but I figured it out and eventually got it to land 90% of the time. No mods, all manual control. Ok done. Next came the external tanks and engines. That's what took me over 300 hours of game time to figure out and still need to tweak. We're talking 4 weeks straight, every hour I could spare. I got pictures on my Imgur account of these two phases I think. What I ended up with was logistically intensive and just flat out hard. For the External Tank, I added a 1/4 tank on top. This tanks fuel flow would be disabled on launch. What this does is keep some weight far from the CoM to maintain the off balance. Yes, I wanted the off balance to stay constant for as long as possible. The trick is watchin fuel flow during flight to re-enable fuel flow before flame out. I don't even want to discuss engines. What a nightmare. The angles and placement of each have to to be more precise than the game allows, but it's doable. In general, I had to add them to the end of and I-Beam, connect the I-beams (with clipping ON - no cheats) internally so that I could pitch the engines in 5, 10, 15 or 20 degrees increments (yes there's a mod for that, but I refused). The best I ever did was get to 165km suborbital. The engine pitch is incredibly important to counter balance. Your flight pitch will almost always be 10 degrees off your thrust vector and you get used to it. I keep messing up the flight path and haven't quite figured out when to disengage the main engines through action groups to conserve Dv. Anyway, to keep it short, I stupidly saved over a WORKING engine configuration before a launch and lost all my efforts. I spent 4 weeks of work, got to 95% of the way to a full orbit and messed it up. If I could get to 165km suborbital, I can damn well get to 80km with enough Dv left for orbital engines to circularise. I've wasted all that time refusing to install B9 and other mods and I just gave up. I want to enjoy the game, so I shelved my plans on a Stock Nasa Shuttle, for now and install a ton of mods with the same goal in mind. I consider what I achieved a success, in that I was able to get suborbital, reentry and land, every time. 100% perfect. I was just missing some manual maneuvers to make it to orbit. What I realised, is that's all I can do with stock is make it to orbit, reentry and land. I have no bays, no payload, no missions what so ever. It's impossible with the current version of the game to do anything with a stock shuttle beyond that. So I've chalked that up to be akin to the Enterprise tests. Yes, I even replicated weight tests without engines to land my Orbiter. I would like to to simulate getting my orbiter up on the back of a plane, but that will definitely take a mod. I've now installed B9 (Finally!) and have begun simulating the entire NASA program, starting with Mercury. Mercury in game is nowhere near as exciting as the real thing and barely worthy of a sidenote but Ive done it, I even made a flag for it, even though I technically have no where to plant it, since Mercury was just a proof of concept to get man in space to see if it was even possible. I've made flags for several Apollo missions that I have planed and have lots of mods ready to start for screenshots, blogging, Twitch and even Youtube. I haven't even started playing this game yet. *Editors note: I previously had mentions of future NASA missions, Apollo Flags and missions, STS Flags and missions, the orion project and more. I'm sorry if this post is long, full of errors and has no links for context. I have a ton of images on Imgur, some very mild footage on Twitch and the start of a blog here on the forums specifically related to this topic and a ton more on hand that's not posted yet. I apologize for the rant at the start, I just want forum moderators to see it and reconsider some of their practices and that's not a topic ITT. Anyway, i've subbed to this thread and will re-read every word multiple times over the coming weeks. This thread is exactly what these forums needed; a focus on the Shuttle.
  12. Sorry, I guess I should have pointed this out a few weeks ago. I noticed this myself and just cleaned things up myself. I just assumed everyone else would have figured that out for themselves, or you would have noticed sooner. Glad you got it fixed for everyone else though. It's amazing how many people depend on this mod for ambience. We love it man, keep up the good work!
  13. Not sure, but it's going to the ISS, so we might as well keep up with the news. I have a feeling we're going to see a lot more of this little guy in the weeks ahead. Turn Captions on to Translate from Japanese. Might have to watch on youtube itself if Captions option is not enabled in the forum embed.