Jump to content

Wheffle

Members
  • Content Count

    263
  • Joined

  • Last visited

Everything posted by Wheffle

  1. @Spricigo I try to check this thread periodically, although I guess it took me a month to notice your comment. Sorry about that. The option to view the biome overlay won't show up unless you have scanned at least a little bit of the planet, or the option for "biome overlay does not require scan" is checked. If one of those things is true and you still don't see it, then it may be a bug and let me know. Edit: Also make sure you have the planet focused in the map view, not the ship. I chose to have OSP follow the same rules as the stock overlay buttons, in that they won't show up unles
  2. Finally got around to running some quick tests with 1.8.1, everything seems to be working as expected. As always, PM me or post here if anyone finds bugs.
  3. Not a dumb question. OSP is lighter and more basic. No new parts, it simply hijacks the stock resource overlay system and changes the way the M700 works. It also adds a biome overlay toggle. SCANsat adds a plethora of features like different kinds of scans and parts to go along with them (altimetry, biome, anomaly detection, etc.), cool map projections, more complex scanning mechanics (optimal distance for different scanners, fields of view, etc.), and probably other stuff I'm forgetting or don't know about. I believe it's more loosely coupled with the stock insta-scan system and can
  4. Nothing has changed in stock KSP as far as using the orbital surveyor goes. You'll need a mod to get "lawnmower" style scanning, either the one you linked for basic functionality or SCANsat as a larger more feature-rich option. Relays are an entirely different subject having to do with science transmission and probe control.
  5. Tested and confirmed working for latest version of KSP (1.7.X). I attempted to investigate and fix the slider issue with the tweakable "scan autocomplete" parameter in the settings menu, but apparently it's been a bug in KSP since 1.2.2. If someone knows better, please correct me. I do have a fix in mind that I could implement, but it would probably break current saves in at least a small way. It seems like a very tiny issue and it has a workaround so I'll leave it be for now.
  6. It does not. OSP only interacts with overlays that already exist in the game (stock resource overlay and biome overlay).
  7. Glad you got it figured out. I wholeheartedly agree with you, the stock resource overlay UI is way too hidden.
  8. Aw shucks, it's sticking for me too. I'll have to take a look at that. In the meantime, you can edit that value manually in your persistent.sfs located in the saves directory in your KSP folder. Search for this section and change the relevant value to whatever you want (between 0 and 1): OSPParamsBasic { ExtendedSurvey = True BiomeMapRequiresScan = True OverlayRequiresTransmit = True ScanAutocompleteThreshold = 0.95 } As far as the resource overlay in the tracking station, make sure you are focusing the planet you want to view, and use the normal stock resource button to pull up
  9. A fairly quick test shows compatibility with KSP 1.6. Let me know if anyone discovers otherwise!
  10. After some testing it looks like OSP hasn't been broken by KSP 1.5. Seeing as how @Wyzard didn't seem to have any obvious problems either (thanks for taking a look and reporting back!) I feel comfortable pronouncing OSP as 1.5.1 compatible. As usual, feel free to post here or PM me if anyone finds any bugs or issues.
  11. The changes this mod brings haven't been added to the base game in any version yet, and I doubt they ever will. SQUAD's take on orbital scanning seems done and closed. Like @BlackHat said, check the OP for more details. I haven't tested yet in 1.5.1, mostly because I haven't moved up yet myself. I doubt that 1.5.1 broke OSP, but you can never be sure. I'll be sure to try to test within the next few days. I can never be sure how much interest there still is and so I end up updating at a pace that suits my own playing needs, but if that's ever too slow for anyone please feel free to post an
  12. Seeing as how OSP seemed to work fine with 1.4.3, I expect it will be fine with 1.4.4 as well. I'll test it when I have time, hopefully this evening, at which point I'll make sure it's marked correctly on Spacedock and CKAN (I apologize to CKAN users for never getting around to it for 1.4.3). Feel free to let me know if anyone encounters weird behavior. *Edit* Did some testing and it looks fine. I'll update the compatible version. *Edit 2* Seems to be working fine in 1.4.5, updated spaceport and thread to reflect that.
  13. Quick head's up: After some light testing it looks like the OSP was not broken on the KSP 1.4.2 patch, so the last release seems good to go without an update. If anyone has any problems please message me or post about it here and I'll try to take care of it ASAP.
  14. So am I! I managed to accidentally nuke the mod list for my long-time 1.3.0 save, don't have to the time or patience to re-construct the mod environment for it. Planning on starting from scratch with 1.4.1, just waiting for all my favorite mods to catch up.
  15. Even though the old version seemed to be working, I recompiled against KSP 1.4.1 and pushed a new release to be safe (should also cause OSP to show up on CKAN for KSP 1.4.1 as well). Did some code clean-up while I was in there, but no end-user-facing changes.
  16. Pushed a new version, tested it a bunch and it seemed to be working with KSP 1.3.1. Made a few small pending changes while I was at it. As usual, report any bugs here and I'll try to squash them quickly. Quick Links: Spacedock | Curse* * Curse is slow and stupid so use Spacedock instead
  17. I've just begun checking it out today and I'm getting the same result. I'll be investigating the cause. At least I know it's happening to someone else, which rules out something derpy going on with my install.
  18. Undocking seems to produce an exception every time. I'd be happy to do some testing.
  19. Snapped a few shots. Hopefully they are helpful. It's an asteroid miner morphed into a permanent base, basically. The issues arose when I docked the hab module (the one with all the hitch hikers and itinerant). I also undocked the claw and re-grabbed in an attempt to make my drills work again before I realized the asteroid had no more ore left. I also undocked and re-docked the hab module once to rotate it. All the parts are either stock, USI Life Support, Near Future, or DMagic's EVA struts. Also, a list of mods I'm running, in case that is helpful as well:
  20. Hey, I started getting some exceptions from DynamicBatteryStorage it looks like. I'm not showing any obvious symptoms in-game, although my asteroid ore drills aren't turning on correctly (seems reasonably unrelated). It's a ship saved in 1.2.2 as well, which is probably causing issues. Thought I'd post it here just in case though. Full Log Edit: my drills aren't turning on because the asteroid has been mined out, so ignore that part. mega-derp.
  21. This mod is great. I really wish this kind of thing was stock, it makes the game so beautiful and adds a ton of immersion, especially on Eve (what a coincidence!). I did a few searches and couldn't find anything about it, but last time I checked the clouds obscure resource overlays, especially on Eve. Is there a workaround for this?
  22. In the part module of the STOCK orbital surveyor, "SciBonus" is set to 10. IIRC you get 10 base science for scanning a body, multiplied by the "low orbit" multiplier value for that body (a table can be found here). OSP works the same, you get the "SciBonus" base science multiplied by the "low orbit" multiplier for a 100% scan of a planet. "SciBonus" is a value in the part module contained in the OrbitalSurveyPlus.cfg file, under the "Patches" folder in the mod directory. This value is by default 20, which is double the amount of science you get from the stock surveyor. My original line of
  23. @markal glad you got it figured out! toggling between views with that button is not a bad idea. i leave most of the stock stuff in-tact but i might look into that.
  24. @markal I see it on the bar on the right side of your screenshot. The little satellite icon over the colored globe: Edit: Just thought of this, not sure if this is it but I figured I'd say this just in case. You might have gotten the ore map and the biome map confused. The button shown above is the biome map. To get the ore/resource overlay, you use the same button you use for stock. To get that button to appear, you have to focus the camera on the planet first, and then the button with the icon of a globe with a slice cut out of it will appear. OSP integrates with t
  25. New Update I finally found time to track down and fix the slowdown that happens often when you have an overlay up for a planet. Hopefully it's fixed, at least mostly. Quick test results were good. Let me know if there are anymore problems. Spacedock | Curse Important Note: Seeing as how KSP 1.3 just came out and a lot of mods aren't compatible yet, I actually deployed two updates. The first update fixes the slowdown issue and stays compatible with KSP 1.2. The second update is the same update but is compatible with KSP 1.3. If most of your mods are still on KSP 1.2, stick w
×
×
  • Create New...