OrianCEV

Members
  • Content Count

    263
  • Joined

  • Last visited

Community Reputation

15 Good

About OrianCEV

  • Rank
    Space Enthusiast

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. robotics time! Now I'll be able to TERMINATE the competition!
  2. Thanks, however I'm still confused on one thing, how come so many different engines generate their effects differently? for instance, the LV909 doesn't even have a engineFX module.
  3. I've been working on an engine model along with some tutorials, and for the life of me I cannot get it to show flame nor smoke, while surface affects and the actual thrust itself work fine. Here's the config file, where the problem is. I can't seem to understand the FX configurations setup. PART { \\==General Parameters=== name = liquidEngineTE2 module = Part author = OrionKerman mesh = model.mu scale = 1 rescaleFactor = 1.0 category = Engine subcategory = 0 TechRequired = generalRocketry entryCost = 5000 cost = 3000 title = TE2 Test Engine 2 manufacturer = Arcanoid Aeronautics and Brass Instruments description = A lovely little number from the people who usually bring you brass instruments. runs on valve oil and air. stagingIcon = LIQUID_ENGINE bulkheadProfiles = size1 tags = ascent main propuls \\===Effect Parameters==== fx_exhaustFlame_blue = 0.0, -0.67, 0.0, 0.0, 1.0, 0.0, 1 running fx_exhaustLight_blue = 0.0, -0.67, 0.0, 0.0, 1.0, 0.0, 1 running fx_smokeTrail_light = 0.0, -2.68, 0.0, 0.0, 1.0, 0.0, 1 running fx_exhaustSparks_flameout = 0.0, 0.67, 0.0, 0.0, 1.0, 0.0, 1 flameout sound_vent_medium = engage sound_rocket_hard = running sound_vent_soft = disengage sound_explosion_low = flameout \\==Physical Parameters=== node_stack_top = 0.0, .017, 0.0, 0.0, 1.0, 0.0, 1 node_stack_bottom = 0.0, -.88, 0.0, 0.0, -1.0, 0.0, 1 attachRules = 1,0,1,1,0 mass = 0.35 heatConductivity = 0.06 // half default skinInternalConductionMult = 4.0 emissiveConstant = 0.8 // engine nozzles are good at radiating. dragModelType = default maximum_drag = 0.2 minimum_drag = 0.2 angularDrag = 2 crashTolerance = 7 maxTemp = 2000 // = 3600 \\========Modules========= MODULE { name = ModuleEngines thrustVectorTransformName = thrustTransform exhaustDamage = True ignitionThreshold = 0.1 minThrust = 0 maxThrust = 650 heatProduction = 192 fxOffset = 0, 0, 1.2 EngineType = LiquidFuel exhaustDamageDistanceOffset = 1.05 PROPELLANT { name = LiquidFuel ratio = 0.9 DrawGauge = True } PROPELLANT { name = Oxidizer ratio = 1.1 } atmosphereCurve { key = 0 320 key = 1 280 key = 6 0.001 } } MODULE { name = FXModuleAnimateThrottle animationName = HeatAnimationEmissive responseSpeed = 0.001 dependOnEngineState = True dependOnThrottle = True } MODULE { name = ModuleAlternator RESOURCE { name = ElectricCharge rate = 7 } } MODULE { name = ModuleSurfaceFX thrustProviderModuleIndex = 0 fxMax = 0.5 maxDistance = 30 falloff = 1.5 thrustTransformName = thrustTransform } } thanks.
  4. Hi, I'm just starting out with modding and i've gotten decently far, I already have a model that went in game with the proper textures and collision mesh, however, I cannot figure out how to make the stack nodes appear or how to get the rocket engine visual effects to display. I've looked on the forum and there are some guides, but many link to long-gone forum posts. Thanks for the help. here's some resources of my part. Here is my unity workspace. The coordinates on the right are for a plane I used to approximate where my attach node would have to go(it's on the top of the engine) Here's my config file PART { name = LiquidEngineTE1 module = Part author = Orion mesh = model.mu rescaleFactor = 1.0 node_stack_bottom = 0.0, -0.124, 0.00, 0.0, 0.0, 0.0, 0 node_stack_top = 0.0, 0.14, 0.00, 0.0, 0.0, 0.0, 0 TechRequired = precisionPropulsion entryCost = 1750 cost = 300 category = Engine subcategory = 0 title = Liquid Test Engine "TE1" manufacturer = ArCanoid Aeronautics And Brass Instruments description = 3ABI's first rocket engine. We are not responsible for any personal harm due to normal operation of engine. attachRules = 1,0,1,1,0 mass = 0.02 heatConductivity = 0.06 // half default skinInternalConductionMult = 4.0 emissiveConstant = 0.8 // engine nozzles are good at radiating. dragModelType = default maximum_drag = 0.2 minimum_drag = 0.2 angularDrag = 2 crashTolerance = 7 maxTemp = 2000 // = 3600 stagingIcon = LIQUID_ENGINE bulkheadProfiles = srf tags = probe propuls rocket (spider thruster vernier EFFECTS { running_thrust { AUDIO { channel = Ship clip = sound_rocket_mini volume = 0.0 0.0 volume = 1.0 0.3 pitch = 0.0 0.20 pitch = 1.0 1.5 loop = true } } engage { AUDIO { channel = Ship clip = sound_vent_soft volume = 1.0 pitch = 2.0 loop = false } } flameout { PREFAB_PARTICLE { prefabName = fx_exhaustSparks_flameout_2 transformName = thrustTransform oneShot = true } AUDIO { channel = Ship clip = sound_explosion_low volume = 1.0 pitch = 2.0 loop = false } } } MODULE { name = ModuleEnginesFX thrustVectorTransformName = thrustTransform exhaustDamage = true ignitionThreshold = 0.1 minThrust = 0 maxThrust = 20 heatProduction = 30 //fxOffset = 0, 0 , 0 EngineType = LiquidFuel exhaustDamageDistanceOffset = 0.05 runningEffectName = running_thrust PROPELLANT { name = LiquidFuel ratio = 0.9 DrawGauge = True } PROPELLANT { name = Oxidizer ratio = 1.1 } atmosphereCurve { key = 0 290 key = 1 260 key = 8 0.001 } } Thanks for the help! EDIT: I have now gotten particle affects and attach nodes, but the attach node only attaches in the wrong direction and is off center. In addition the flame seems to be instant, it doesn't go bigger or smaller with throttle changes. Picture:
  5. I've got a model and texture in the correct config-but It just won't load. .cfg PART { name = fuelTank.25 module = Part author = OrianCEV mesh = Model.mu scale = 1 rescaleFactor = 1 node_stack_top = 0.0, 0.2853027, 0.0, 0.0, 1.0, 0.0 node_stack_bottom = 0.0, -0.2853027, 0.0, 0.0, -1.0, 0.0 TechRequired = advFuelSystems entryCost = 2400 cost = 600 category = FuelTank subcategory = 0 title = FuelTank.25 manufacturer = Altair Planetary description = This tank is a salveged piece of some kids model rocket kit that we-*ahem*-borrowed. attachRules = 1,0,1,1,0 mass = 0.15 dragModelType = default maximum_drag = 0.2 minimum_drag = 0.2 angularDrag = 2 crashTolerance = 12 maxTemp = 2000 // = 2900 bulkheadProfiles = size1 RESOURCE { name = Monopropellant amount = 2500 maxAmount = 2500 } } file layout: Altair Planetary --Parts ----FuelTank ------FuelTank.25[all below files are within FuelTank.25] -------Fueltank.25.cfg[.cfg] -------Model.mu[model] -------model000.dds[texture]
  6. That's great-but what are the four lines-pointing up, down, left, and right- in the Squad parts?
  7. Many thanks, this modding community is great! - - - Updated - - - Could you give me a hand with putting this into blender?
  8. I really want to get into KSP modding-but I just can't find a 1.0 compatible modding guide, anyone know any? I've been able to get a model into the game, but my collision mesh and my main are colliding and the spec. map is where the actual texture should be. I'm using blender. Help!
  9. Nope. No KSP 1.0 on the promised day...not even an excuse for its delay..nor the server migrations...
  10. I feel sorry for you having to fix all these bugs, helldiver.
  11. Having some issues here... It seems the MFD's are being replaced by randomized textures, as seen here, the kerbal EVA suit and the textures for the KSO parts.. Is there an existing fix for this? I sure can't find it.