Voidi

Members
  • Content Count

    76
  • Joined

  • Last visited

Community Reputation

15 Good

About Voidi

  • Rank
    Rocketeer

Profile Information

  • Location Array

Recent Profile Visitors

620 profile views
  1. I have the same problem, tested with a fresh install with only Making History, Filter Extensions and this mod. My Logs and ConfigCache are here
  2. 1: It seems the Celestial Objects from Extrasolar are missing their lozalisations for ResearchBody Integration. https://imgur.com/a/9Keew5R 2: What antenna configuration a vessel needs to communicate from Valentin back to Kerbin? have the Stock antennas enough range?
  3. At the end of the post in the full changelog, under section parts
  4. Why this was added? The stock parts in question have 'category=none' on purpose, as they were deprecated and hidden with 1.4.
  5. Physics TimeWarp+ = only works if physics time warp is already started This is what it should doing with standart keyboardcontrols. But if using only a Joystick how we are supposed to start Physics TimeWarp? If fixed this in my version and use it as following with Joystick: my Throttle has a 4-way knob, 2 of them controll non-physical timewarp, the other 2 physical timewarp.
  6. What is needed to build your version on Linux? Trying right after cloning from github, i get PreBuildEvent: set textTemplatingPath="%ProgramFiles(x86)%/Microsoft Visual Studio/2017/Community/Common7/IDE/texttransform.exe" %textTemplatingPath% "/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/AssemblyVersion.tt" /bin/sh: 7: /tmp/tmp71438b2a73ee4353b7bed4f4cddb60b6.exec.cmd: %textTemplatingPath%: not found /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: The command " [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: set textTemplatingPath="%ProgramFiles(x86)%/Microsoft Visual Studio/2017/Community/Common7/IDE/texttransform.exe" [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: %textTemplatingPath% "/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/AssemblyVersion.tt" [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] /usr/lib/mono/msbuild/15.0/bin/Microsoft.Common.CurrentVersion.targets(1292,5): error MSB3073: " exited with code 127. [/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj] Done Building Project "/home/tobias/workspace/KSP/ksp-advanced-flybywire/AFBW/ksp-advanced-flybywire-linux.csproj" (default targets) -- FAILED.
  7. I didn't pushed my changes to github as i am was unsure, if invest time in this mod. Have you already fixed some bugs? I willing to provide some fixes as pull requests.
  8. Although this question is quite old, i found the problem and a solution which may be useful for others: If a key in ModuleManagerPatch is annotated with '@' this means edit but only if the key is already present. The parts in question didn't have a tags key so the above patch doesn't work. So if you want to make sure your patch work with as much parts as possible use the '%' annotation, meaning edit-or-create @PART[*handle*]:AFTER[KIS] { @category = none %tags ^= :^: cck-eva-items } @PART[*handrail*] { @category = none %tags ^= :^: cck-eva-items }
  9. Is there a option to select the KSP instance at Startup (via a commandline parameter) ?
  10. I want to reduce the amount of Toolbar Buttons in the game. With the last update there comes this config window which looks like i can configure this, right?. In my installation (no Blizzy Toolbar installed) the only entry is the toolbar controller itself.
  11. I uploaded my for KSP 1.4.2 updated Version https://github.com/Voidi/ksp-advanced-flybywire-legacy/releases/tag/1.7.1
  12. It seems i am blind, because i can't find any documentation on how to use these mods. Where is the documentation?
  13. The problem coming up with 1.4 has nothing to do with Xinput or similar, as this is a Windows-only Part. The problem is very good described here https://www.reddit.com/r/linux_gaming/comments/5xics8/a_big_problem_with_joysticks_in_linux_right_now/ (although there answering a different question) TL, DR: with some update of the unity engine they moved from doing the input stuff for linux in Unity itself to a (crossplatform) libary named SDL2, but use only the higher-level, more abstract part of it (GameController API). Which requires that there is mapping specific for used joystick modell. I suppose only Unity can solving this problem. EDIT: Somewhere the i read the GameController API have problems with Joysticks with a lot of buttons. This makes this part of Unity even more problematic for KSP
  14. Hi Voidi,

    may i ask if you are the "owner" of the linux ksp_installer (https://github.com/Voidi/proprietary_installer)

    And if you are, if you please could update that script if this scipt is still valid/neccessary.

    I tried on an fresh 1.1 install and it feeds back "This seems to be not a vanilla KSP executable".

    Thanks for your Informations.

    Alex

  15. If you refer to my script: Should work partial. As I don't play KSP actively at the moment i only check this thread now and then for News. My Script has Problem downloading the latest version from the Kerbalspaceprogram website, as a workaround download the zipfile manual and place it in the same directory as the script. At all: The problem: There is maybe something broken with the SSL Certificate of the KSP Website. If you download something via wget, it aborts and you get the following error message: ERROR: cannot verify kerbalspaceprogram.com's certificate, issued by '/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certs.godaddy.com/repository//CN=Go Daddy Secure Certificate Authority - G2': Unable to locally verify the issuer's authority. To connect to kerbalspaceprogram.com insecurely, use `--no-check-certificate'. Has anybody a idea what this error really means or has a proper workaround (No diasableling '--no-check-certificate' is not a proper workaround). Also thiy problem may be know: http://forum.kerbalspaceprogram.com/threads/117966-trouble-accessing-kerbalspaceprogram-com-on-Firefox