Kalloran

Members
  • Content Count

    56
  • Joined

  • Last visited

Community Reputation

12 Good

About Kalloran

  • Rank
    Rocketry Enthusiast

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Standard answers are fine! I feel like I'm missing something simple, so I'm hoping for something as simple as "hey dumba**, do this". Also, I suspect it is/was a mod or a mod conflict....just can't isolate which one from the output log. To answer your question. No, I had never tried CTRL Z, and I'm not yet at the "remove everything" point...ref update below. UPDATE: After closing the game, verifying that all my mods were up to date (a couple needed updating), and restarting the game (stupid me hadn't tried THAT yet. I have the attention span of a goldfish sometimes).....and changing the batteries on my mouse, the problem seems to have disappeared. That being said, the fact that it cropped up after a week of playing the game off and on without issue, I can't imagine that mods started magically conflicting. This leaves only that I did something to irritate the game (*cough* Kraken *cough*). At this point I'm just wondering if someone has seen this before. Thanks for the help. If it crops up again, I shall see if CTRL Z does anything and will start removing mods one by one. I'm wondering if one of my mods conflicted when I researched the new batch of probes and somehow didn't implement properly when I went into build mode.
  2. Hey. Just started having a recent issue...incidentally, it did not appear after installing/uninstalling a mod, but rather after researching a new batch of probe cores: When I attach parts to a probe core in build mode, I can no longer remove them. They are selectable, and I can right click. I merely cannot remove them from the probe. I have tried all of the googles, and cannot find anything. Relevant information: KSP: 1.2.2 64bit // Windows 10 Problem: Cannot un-attach part from probe core in build mode. Cause/mod unknown Mods Installed: I try my very best to keep them all up to date USI (most) B9 Deadly Reentry Distant Object EVE KAS/KIS Kerbal Engineer KW Rocketry Redux PlanetShine Remote Tech SCANsat Scatterer SmokeScreen Stock Bug Fix Controller Plus SVE Texture Replacer Trajectories Kerbal Alarm Clock / Transfer Window Planner TweakScale VenStockRevamp Reproduction Steps: Begin a build with a OCTO or HEXA probe core. Attach anything. Cannot unattach Log: I can post the full log if you need it. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) UIList: RemoveItem didn't find any item to remove.
  3. ................................................................. no.
  4. I just updated KIS to 1.1.5 and all of a sudden my loading screen is halting at KAS/parts/cPort1/part/KAS_Cport1. Anyone else having this issue? Thoughts? The only other thing I updated since last playing is Mk2 Stock-a-like expansion, and I don't think there's a conflict there. UPDATE: From my output.txt PartLoader: Compiling Part 'KAS/Parts/cPort1/part/KAS_CPort1' (Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56) FileNotFoundException: Could not load file or assembly 'KIS, Version=1.1.1.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. UnityEngine.GameObject:Internal_AddComponentWithType(Type) UnityEngine.GameObject:AddComponent(Type) Part:AddModule(String) Part:AddModule(ConfigNode) PartLoader:ParsePart(UrlConfig, ConfigNode) :MoveNext() (Filename: Line: -1) Error looking up signature for method KASModulePort.OnKISAction (Filename: Line: 243) FileNotFoundException: Could not load file or assembly 'KIS, Version=1.1.1.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. UnityEngine.GameObject:Internal_AddComponentWithType(Type) UnityEngine.GameObject:AddComponent(Type) Part:AddModule(String) Part:AddModule(ConfigNode) PartLoader:ParsePart(UrlConfig, ConfigNode) :MoveNext() (Filename: Line: -1) FileNotFoundException: Could not load file or assembly 'KIS, Version=1.1.1.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. at (wrapper managed-to-native) System.Reflection.MonoMethodInfo:get_method_info (intptr,System.Reflection.MonoMethodInfo&) at System.Reflection.MonoMethodInfo.GetMethodInfo (IntPtr handle) [0x00000] in <filename unknown>:0 at System.Reflection.MonoMethod.GetPseudoCustomAttributes () [0x00000] in <filename unknown>:0 at System.MonoCustomAttrs.GetPseudoCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType) [0x00000] in <filename unknown>:0 at System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType) [0x00000] in <filename unknown>:0 at System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit) [0x00000] in <filename unknown>:0 at System.Reflection.MonoMethod.GetCustomAttributes (System.Type attributeType, Boolean inherit) [0x00000] in <filename unknown>:0 at BaseEventList.ReflectActions (System.Object part) [0x00000] in <filename unknown>:0 at BaseEventList..ctor (.Part part, .PartModule module) [0x00000] in <filename unknown>:0 at PartModule.ModularSetup () [0x00000] in <filename unknown>:0 at PartModule.Awake () [0x00000] in <filename unknown>:0 UnityEngine.GameObject:Internal_AddComponentWithType(Type) UnityEngine.GameObject:AddComponent(Type) Part:AddModule(String) Part:AddModule(ConfigNode) PartLoader:ParsePart(UrlConfig, ConfigNode) :MoveNext() (Filename: Line: -1) NullReferenceException: Object reference not set to an instance of an object at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0 at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0 at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0 at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0 (Filename: Line: -1) NullReferenceException: Object reference not set to an instance of an object at PartLoader.GetDatabaseConfig (.Part p) [0x00000] in <filename unknown>:0 at PartLoader.GetDatabaseConfig (.Part p, System.String nodeName) [0x00000] in <filename unknown>:0 at DragCubeSystem.LoadDragCubes (.Part p) [0x00000] in <filename unknown>:0 at Part+.MoveNext () [0x00000] in <filename unknown>:0 (Filename: Line: -1)
  5. ooooooohhhhhhhh. That explains alot........ *toddles off to go launch more rockets*
  6. Ladies, Gents, and fellow Kerbal Engineers: So..I recently installed FAR , and B9, (after not being able to for so long...different story). Much to my chagrin, building an aircraft generates no Lift! The little blue Center of Pressure ball has no arrow. Initially I thought this was just a fact that FAR doesn't use the stock lift model, so I checked FAR. My stability coefficients are all good to go and greened up, and an AoA sweep shows good values...but the Mach sweep shows nothing and when I attempt to take off, the aircraft stays diligently on the ground. I'm sure I'm not the only one who has or has had this problem. Does anybody have any ideas? My modlist is fairly extensive, but if necessary I can gen-up a list. Thanks folks!
  7. BLUF: A part I have created is displaying in KSP as a white component with no texture, despite a .png texture being available. Alright, so I've been working on my Jasper Aerospace Technologies mod, creating an ISRU for converting CO2 to fuel, and I'm upgrading the parts. However, textures are no longer assigning themselves to the models. Let me explain. I've been following a couple of tutorials on using Unity, namely Nifty255 on Youtube. I followed these tutorials when first generating the mod, and it worked fine...but now, not so much. Here is my process.... Create part and collider in Blender Paint .png texture in photoshop (based on Blender UV map) Export part as .fbx Import .23 part tools into Unity (4.6.3f1) Import model and texture into Unity Assign texture to material Assign PartTools to new GameObject Migrate the model to the GameObject Assign Collision Mesh to Collider Write GameObject as "model.mu" I then move the model.mu to the Gamedata folder as well as the .png texture. I rename the texture as model000.png. Thus my file structure is as such: GameData > JAT > Converter > model.mu GameData > JAT > Converter > model000.png GameData > JAT > Converter > part.cfg I have tried many model declarations in my .cfg, and currently it reads: PART { // --- general parameters --- name = JAT_Converter_25 module = Part author = Kalloran // --- asset parameters --- mesh = model.mu // --- node definitions --- node_stack_top = 0.0, 0.275, 0.0, 0.0, 1.0, 0.0,2 node_stack_bottom = 0.0, -0.2576, 0.0, 0.0, -1.0, 0.0,2 I have also tried // -- asset parameters --- MODEL{ model = JAT/Converter/model texture = Diffuse, JAT/Converter/model000 } In either case, the model shows up in KSP as a white part with no texture. Help! - - - Updated - - - Ok figured it out.....apparently renaming the texture .png is a BAD idea......
  8. Must've missed that. Thanks! The resource definition will be deleted in the next version.
  9. Wasml: Thanks for the notes: 1. I'll look at the stack configurations. I was changing a LOT in the config in the early design process and maybe I got some things mixed up which made me think that I needed the fuel line. 2. That's the idea! 3. I was basing this off of just CRP and Regolith, which did not appear to have CO2 configs. I'll dig around and see if I can't find some conflicts. 4. Noted. Researching.
  10. Interesting. Standby one. Troubleshooting. UPDATE: Stupid me...I forgot to publish the mod. Fixed that, logged out of Kerbal Stuff, navigated to the mod page, and re-copied the link. Try it again.
  11. Jasper Aerospace Technologies V0.1 Overview So after going through both Kim Stanley Robinson's Red/Green/Blue Mars series and Andy Weir's The Martian, I started getting the idea to design an ISRU to facilitate turning the planetary resources of Duna (specifically) into something useable, namely fuel. After some Wikipedia learning and, more extensively, Blender/Unity learning, I began building this ISRU. Currently it is useable on Kerbin, Laythe, and Duna. I am looking for feedback! Concept of Operations Using the Sabatier Process, this ISRU uses electricity and a catalyst to convert CO2 into CH4, which for the purposes of KSP, is Liquid Fuel. 4H2 + CO2 => CH4 + 2H2O The module also offers the capability to convert the H2O back into molecular Hydrogen and Oxygen via electrolysis. For the purposes of KSP, the Oxygen is Oxidizer and the Hydrogen may be re-used in the Sabatier Process. The core part is a 2.5m device (TweakScale compatable) and is internally capable of refilling the 1/4 size 2.5m Rockomax tanks. You need a fuel pipe going from the ISRU to the tank! Requirements CommunityResourcePack, by RoverDude Regolith, by RoverDude Built-in Compatibilities TweakScale Deadly Reentry ATM Way Forward - Finishing touches (fine-tune price, tech required, weight...add description) - Custom H2 Tanks - Oxidizer to Oxygen conversion module (so Oxidizer can be used for Life Support) - Radially-attach-able converter - Possible issues with CO2 resource configs.... Acknowledgements A HUGE thanks to all the people who posted Blender and Unity tutorials. Also a big thanks to RoverDude for the development and maintenance of Regolith and the CommunityResourcePack, without which, this part pack would not be possible. Link https://kerbalstuff.com/mod/652/Jasper%20Aerospace%20Technologies License Jasper Aerospace Technologies is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License
  12. *dwooop dwooop* Too Low. Gear. *dwooop dwooop* Too Low. Flllllllaps.
  13. Potential Bug Report: So I'm trying to update my mod list so that everything I have that is CKAN compatible is managed through CKAN. In other words, I'm deleting mods out of my GameData, hitting "refresh" on CKAN, and then reinstalling them with CKAN so that I don't see the "AD." (I realize that this is silly, but there's a little bit of mod-managing OCD.....quit judging me =D) So I did this with ModManager -- deleted it, then hit "refresh" on CKAN -- and CKAN threw the following Unhandled Exception: "Exception of type 'CKAN.InconsistentKraken' was thrown." See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box. ************** Exception Text ************** The following inconsistecies were found: KAS requires ModuleManager but nothing provides it * TweakScale requires ModuleManager but nothing provides it * Karbonite requires ModuleManager but nothing provides it * USI-ART requires ModuleManager but nothing provides it * USI-EXP requires ModuleManager but nothing provides it * USI-FTT requires ModuleManager but nothing provides it * Trajectories requires ModuleManager but nothing provides it * VenStockRevamp requires ModuleManager but nothing provides it at CKAN.SanityChecker.EnforceConsistency(IEnumerable`1 modules, IEnumerable`1 dlls) at CKAN.RegistryManager.Save(Boolean enforceConsistency) at CKAN.KSP.ScanGameData() at CKAN.Main.UpdateRepo() at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e) at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e) at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e) at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ToolStrip.WndProc(Message& m) at System.Windows.Forms.MenuStrip.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) ************** Loaded Assemblies ************** mscorlib Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll ---------------------------------------- ckan Assembly Version: 0.0.0.0 Win32 Version: 0.0.0.0 CodeBase: file:///C:/Users/James/Documents/My%20Games/KSP%20Full/ckan.exe ---------------------------------------- System.Windows.Forms Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll ---------------------------------------- System.Drawing Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll ---------------------------------------- System Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll ---------------------------------------- System.Configuration Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll ---------------------------------------- System.Xml Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll ---------------------------------------- System.Core Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll ---------------------------------------- Microsoft.GeneratedCode Assembly Version: 1.0.0.0 Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll ---------------------------------------- System.Transactions Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll ---------------------------------------- System.Numerics Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll ---------------------------------------- System.ComponentModel.DataAnnotations Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ComponentModel.DataAnnotations/v4.0_4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll ---------------------------------------- System.Runtime.Serialization Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll ---------------------------------------- System.Xml.Linq Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll ---------------------------------------- System.Data Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll ---------------------------------------- Accessibility Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll ---------------------------------------- System.EnterpriseServices Assembly Version: 4.0.0.0 Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll ---------------------------------------- ************** JIT Debugging ************** To enable just-in-time (JIT) debugging, the .config file for this application or computer (machine.config) must have the jitDebugging value set in the system.windows.forms section. The application must also be compiled with debugging enabled. For example: <configuration> <system.windows.forms jitDebugging="true" /> </configuration> When JIT debugging is enabled, any unhandled exception will be sent to the JIT debugger registered on the computer rather than be handled by this dialog box. It appears that, essentially, I cannot reinstall ModManager because I deleted it, everything else needs it, and CKAN knows this. At the same time, I'm trying to use CKAN to reinstall it because I deleted it and everything else needs it, and CKAN knows this as well. So CKAN won't refresh because I need that mod, but I need CKAN to refresh so I can install the mod that CKAN won't refresh because I need. That's some catch, that catch 22. Now, I'm assuming that there is something super simple that I'm not doing that I should be...so any help would be appreciated.
  14. Awesome! I didn't know! As a long time traditional-mod-installation-person, it's not a big deal. But I'm trying to jump on the bandwagon with all my favorite mods. I shall wait patiently. *refreshes CKAN incessantly*
  15. Taranis, thanks for the update for 0.90! What are your thoughts on making the 0.90 TACLS official release CKAN compatible?