MaxP

Members
  • Content Count

    133
  • Joined

  • Last visited

Everything posted by MaxP

  1. The problem exists only for the first stage (?). Right after launch the MJ fails with reaching the adjusted inclination (i.e. 300 degrees = 60 degrees = -60 degrees, etc.). When the first stage decouples, it is enough to enter correct value in the MJ inclination field, and it starts to works fine.
  2. KSP: 1.2.2 Windows 64bit Dx11 MJ: 2.6.0 and Dev #698 Main mods: RSS + RO + FAR + RealChute + RealFuels + RealHeat + KSCSwitcher + StationKeeping + BetterBurnTime + LandingHeight + many part mods 1. I'm trying to launch the rocket to Moon via MechJeb Ascent guidance autopilot. This is the stable result (yellow is the Moon's orbit): https://yadi.sk/i/3aQR8D563McioV Log. Several times it worked (in 2.6.0), and a couple of launch was succesfull. Where to look for? 2. Trying circularize at Ap through maneuver planner. After Pe (413 km) I create circularize task with Time Warp. The vessel starts to turn retrograde, but instead of warping to Ap the engines activates immediately, decreasing the Ap height. P.S. Also I had strange behavior of Smart A.S.S. prograde\retrograde functions orbiting the Moon. Suddenly, after a couple of turns, I've got such a problem as in video above, but I haven't any save.
  3. For Remote tech users: v.1.8.6. (for RSS\RO\1.2.2) has the error in syntax in FASA antennas config: after @PART[FASAMercruyCap2] first bracket is not closed, so none of FASA antennas works.
  4. Thanks for correcting. But the antenna still not linked with probe deploy animation. Maybe I have to use name = BDFSanimateGeneric module?
  5. With many mods, and without forcing Dx11 the game become almost unplayable, unfortunately - it eats additional memory (~1000 MB), that is not particularly important , but the game lags alot, so there is sufficient reason to use it. Yes, I have enough memory. Maybe, maybe this is the wrong way, and I have to cut half of my mods and use Dx9 mode, but it's too late )) Yes, there is a problem with one of the mods. I've just rolled back to RC3, and the problem with clouds still remains, while it works not so long ago. Something changed )) P.S. I really aprreciate your work. P.P.S. Can you tell me, how to find the source of the error: Full log. I've made fresh install, all works fine, but this error appears constantly in console (always after [UIApp]). Or I can forgot about it?
  6. KSP 1.2.2 + RSSVE v1.2.2-RC4 + Scatterer v0.0320 + EVE 1.2.2-1 "-force-d3d11 -popupwindow" = https://yadi.sk/i/Y22EPUxo3Ma4GP https://yadi.sk/i/mh1m9I7p3Ma4JG Log. KSP 1.2.2 + RSSVE v1.2.2-RC4 + Scatterer v0.0320 + EVE 1.2.2-1 + "-force-d3d11 -popupwindow" + Scatterer PlanetFix patch = the same error + https://yadi.sk/i/P6NEr75g3Ma5Es - no clouds KSP 1.2.2 + RSSVE v1.2.2-RC4 + Scatterer v0.0300 + EVE 1.2.2-1 + "-force-d3d11 -popupwindow" = the same error + https://yadi.sk/i/_TNq_-9h3Ma4fF Log. P.S. I've only removed City lights\textures.
  7. Can somebody help me with integrating RT module to the existing animated parts? I'm trying to put RTAntenna to RaiderNick's soviet probes (i.e. Luna 9/13), which has antenna animation, linking it - so the "Activate" button could activate antenna and the animations trigger at once. The problem is the probes has another animations too, so I'm stuck with it, beign not familiar enough with the module system. Luna-13 config: PART { name = luna13_als module = Part author = Raidernick MODEL { model = RN_Soviet_Probes/luna9-10/luna13_als scale = 0.80, 0.80, 0.80 } scale = 0.80 rescaleFactor = 1 node_stack_bottom = 0.0, -0.27, 0.0, 0.0, -1.0, 0.0, 0 node_stack_ab1 = 0.0, 0.15099, 0.0, 0.0, 1.0, 0.0, 0 TechRequired = generalRocketry entryCost = 500 cost = 1100 category = Pods subcategory = 0 title = Luna 13 ALS manufacturer = RN Industries description = Soviet Luna 13 ALS module. Self righting once unfolded! Airbag is now included in this module, do not use the old separate airbag part. attachRules = 1,0,1,1,1 mass = 0.073 dragModelType = default maximum_drag = 0.1 minimum_drag = 0.05 angularDrag = 2 crashTolerance = 80 maxTemp = 2000 breakingForce = 2000 breakingTorque = 2000 stackSymmetry = 1 CrewCapacity = 0 breakingForce = 2000000 breakingTorque = 50000000 linearStrength = 22000000 angularStrength = 22000000 vesselType = Probe MODULE { name = ModuleCommand minimumCrew = 0 RESOURCE { name = ElectricCharge rate = 0.0006 } hasHibernation = True } MODULE { name = ModuleReactionWheel PitchTorque = 0.5 YawTorque = 0.5 RollTorque = 0.5 RESOURCE { name = ElectricCharge rate = 0.001 } } MODULE { name = ModuleSAS SASServiceLevel = 2 } // --- Electric parameters --- RESOURCE { name = ElectricCharge amount = 250 maxAmount = 250 } MODULE { name = TankPriorityModule Priority = 10 } // --- Science --- MODULE { name = ModuleScienceContainer reviewActionName = Review Data storeActionName = Store Experiments collectActionName = Take Data evaOnlyStorage = False storageRange = 2 allowRepeatedSubjects = True } MODULE { name = ModuleScienceExperiment experimentID = crewReport experimentActionName = Probe Report resetActionName = Discard Probe Report reviewActionName = Review Report useStaging = False useActionGroups = True hideUIwhenUnavailable = True rerunnable = True xmitDataScalar = 1.0 } // --- Antenna parameters --- MODULE { name = ModuleDataTransmitter antennaType = DIRECT packetInterval = 0.18 packetSize = 2 packetResourceCost = 0.1 requiredResource = ElectricCharge antennaPower = 500000 } MODULE { name = MuMechModuleHullCameraZoom cameraName = Luna 9 ALS Phototelegraph cameraForward = 1, 0, 0 cameraUp = 0, 0, 0 cameraPosition = 0.0, 0.4, 0.0 cameraFoVMax = 60 cameraFoVMin = 20 } MODULE { name = HullCamera cameraName = Luna 9 ALS Phototelegraph cameraForward = 1, 0, 0 cameraUp = 0, 0, 0 cameraPosition = 0.0, 0.4, 0.0 cameraFoVMax = 60 cameraFoVMin = 20 //This camera uses film resource to get science usesfilm = false specialExperimentName = photo- specialExperimentTitle = #Anon# Picture experimentID = hullcampicture experimentActionName = Snap Picture resetActionName = Delete Picture collectActionName = Take Photo useStaging = False useActionGroups = True hideUIwhenUnavailable = True xmitDataScalar = 0.8 dataIsCollectable = True interactionRange = 1.2 rerunnable = True } RESOURCE { name = Resolution amount = 1 maxAmount = 15 } MODULE { name = BDFSanimateGeneric animationName = Deploy startEventGUIName = Open Panels endEventGUIName = Close Panels toggleActionName = Toggle Panels startDeployed = False layer = 1 playAnimationOnEditorSpawn = False useActionEditorPopup = True moduleID = 0 } MODULE { name = BDFSanimateGeneric animationName = Deploy1 startEventGUIName = Deploy Antennae endEventGUIName = Close Antennae toggleActionName = Toggle Antennae startDeployed = False layer = 2 playAnimationOnEditorSpawn = False useActionEditorPopup = True moduleID = 1 } MODULE { name = ModuleScienceExperiment experimentID = surfaceSample experimentActionName = Analyse Surface Sample resetActionName = Discard Surface Sample useStaging = False useActionGroups = True hideUIwhenUnavailable = True resettable = True resettableOnEVA = True rerunnable = True xmitDataScalar = 0.5 FxModules = 0 // Play animation collectActionName = Take Data dataIsCollectable = True interactionRange = 3 } MODULE { name=ModuleAsteroidAnalysis } MODULE { name=ModuleAnalysisResource resourceName = Ore } MODULE { name = ModuleResourceScanner ScannerType = 0 ResourceName = Ore MaxAbundanceAltitude = 1000 RequiresUnlock = false } MODULE { name = BDFSanimateGeneric animationName = Inflate startEventGUIName = Inflate Airbag endEventGUIName = Deflate Airbag toggleActionName = Toggle Airbag startDeployed = False layer = 3 playAnimationOnEditorSpawn = False useActionEditorPopup = True moduleID = 2 } MODULE { name = ReflectiveShaderModule CubeMapSize = 16 FarClipPlane = 500000000 NearClipPlane = .1 OneFacePerFrame = true ShaderName = Reflective/Bumped Diffuse realTimeReflection = False ParallaxHeight = 0.01 ReflectionStrength = 0.50 MeshesToChange = cube01,cube02,cube05,cube06,cube09,cube10,cube13,cube14,cylinder01 Shininess = 1.0 updateRate = 130 SpecColorR = 0.8 SpecColorG = 0.8 SpecColorB = 0.8 SpecColorA = 0.8 rimFalloff = 5.0 rimColor = 0.8242, 0.6445, 0.1914, 1.0 ReflectionColor = 0.6242, 0.6445, 0.69, 1.0 } } The example of RTAntenna module I'm trying to add (replacing the RO one): @PART[luna13_als]:FOR[RealismOverhaul]:NEEDS[RemoteTech] { %RSSROConfig = True @MODEL { @scale = 1.0, 1.0, 1.0 } @scale = 1 @rescaleFactor = 1 @maxTemp = 773.15 %skinMaxTemp = 873.15 @mass = 0.092 !MODULE[ModuleReactionWheel] {} !MODULE[ModuleDataTransmitter]{} %MODULE[ModuleAnimateGeneric],* { %allowManualControl = false } %MODULE[ModuleRTAntenna] { %Mode0DishRange = 0 %Mode1DishRange = 75e7 %EnergyCost = 0.035 %MaxQ = 6000 %DishAngle = 15 %DeployFxModules = 0 %TRANSMITTER { PacketInterval = 0.1 PacketSize = 1.0 PacketResourceCost = 0.01 } } MODULE { name = ModuleSPU IsRTCommandStation = False } } I'm using RSS+RO+RT for 1.2.2
  8. Have some problems: https://yadi.sk/i/fZf4UtMr3MQSZB https://yadi.sk/i/Q-DvuQzL3MQWhK The same happens with fresh install (only Squad folder + mod) I suppose there is a problem with the clouds: I've tried to combine RSSVE and some of new textures, and when I install the clouds (modified cfg + cloud dds texture) the Earth looks the same. But even with EarthColor.dds and lower cloud layer only it looks fantastic without significant impact on perfomance, like th RSSVE clouds, thank you https://yadi.sk/i/GYxFX0Rm3MRqY8 https://yadi.sk/i/Og9Xwh9_3MRqiA
  9. May be )) What about average fps, compared to Win version?
  10. there is an error under the @PART[soyuz_Main_Parachute]:FOR[RealChute] ... cutAlt = -1[incorrect symbol]
  11. I think Danny's models is the best ones, and I use it all the time too. First of all, the game is in beta stage, unfortunately - and so its popularity is low, till it's not presented in "release" chapters/topics. But it will be released. And people not prefer kerbal stock style, they just still do not know about other mods, which is located on main, english-speaking, forum. I began with NovaPunch, which I've found on our local tracker. So we must have a patience ))
  12. Thanks, but I don't want to spend your time for this, till I'm new to KoS and depths of KSP, and my game slowly turns into an extremly unstable combine with over 9000 mods - anything, but not a game. So for this time I prefer to use MechJeb, although it doesn't supports RT2. But if someone would be interested in described bug, I can provide full log and the list of mods.
  13. Changed, so VERTICALSPEED to SHIP:VERTICALSPEED, no changes. Works fine even without it, but fix it, just in case. Is there need to unlock throttle before locking it to 1? P.S. As the game cannot warp time when the engines throttled up, I've add a "wait 2." command before "set warp to 4.". Now it crashes "into terrain" just after the printing command )) print "Warping to apoapsis". wait 2. set warp to 4. wait until SHIP:ALTITUDE > 620000. set warp to 0. lock throttle to 1. wait until SHIP:APOAPSIS > 650000.
  14. Thanks, I'll try. LIST ENGINES IN l_eng. - can you bring an example of setting l_eng variable? And about the previous problem - here is my new script for ascending. lock throttle to 1. declare parameter MyDIR. declare parameter ANGL. declare parameter Y. declare parameter VYSOTA. lock VYSOTA to SHIP:ALTITUDE. lock ANGL to (1.2*(VYSOTA/1000)-(VYSOTA/1500)). lock Y to (90-ANGL). lock MyDIR to HEADING(90,Y). stage. print "Launch". lock steering to up + R(0,0,270). wait until VERTICALSPEED > 100. lock steering to MyDIR. print "Beginning gravity turn". wait until (1.2*(VYSOTA/1000)-(VYSOTA/1500)) > 80. unlock MyDIR. set MyDIR to HEADING (90,Y). //adjusting angle to ~10 deg. wait until APOAPSIS > 640000. lock throttle to 0. lock MyDIR to HEADING(90,0). clearscreen. print "Warping to apoapsis". set warp to 4. wait until SHIP:ALTITUDE > 620000. set warp to 0. lock throttle to 1. wait until SHIP:APOAPSIS > 650000. unlock throttle. set throttle to 0. unlock steering. break. I'm getting the same error, as on picture above, but the string is "set warp to 0", with pointer on the first letter. The error appears before 640 km. All works except warp, and program not ending. Any ideas?
  15. The FAR module causes game crash on craft load fo me. Says that is "no FARBasicDragModel module found on part definition. Skipping..." P.S. Using FAR, DR, RSS, RO, RF, KoS, MechJeb v.319 and 335. Solved by deleting both of plugins.
  16. Thanks, I forgot to activate stage before )) Please consider on you script: - what is efo? - what s PRESERVE? Didn't find anything on it.
  17. The same, the only difference is the pointer on the "S" )) [LOG 20:49:32.010] 1Test2 Debris Unloaded [LOG 20:49:32.011] RemoteTech: AntennaManager: RegisterProtos(1Test2 Debris, a6a36b8f-9763-4266-bc74-2bcaa3136735) [LOG 20:49:32.013] RemoteTech: SatelliteManager: RegisterProto(1Test2 Debris, a6a36b8f-9763-4266-bc74-2bcaa3136735) [LOG 20:49:32.013] RemoteTech: GetSignalProcessor(1Test2 Debris): Check [LOG 20:49:32.013] Packing 1Test2 Debris for orbit [LOG 20:49:39.908] 1Test2 Debris Unloaded [LOG 20:49:39.909] RemoteTech: AntennaManager: RegisterProtos(1Test2 Debris, 98a00f9d-8bee-4809-90c7-a3b9e0dbe6b9) [LOG 20:49:39.910] RemoteTech: SatelliteManager: RegisterProto(1Test2 Debris, 98a00f9d-8bee-4809-90c7-a3b9e0dbe6b9) [LOG 20:49:39.910] RemoteTech: GetSignalProcessor(1Test2 Debris): Check [LOG 20:49:39.910] Packing 1Test2 Debris for orbit [LOG 20:49:42.620] RemoteTech: ModuleRTAntennaPassive: Remove TRANSMITTER success. [LOG 20:49:49.094] At launch on 1, line 52 until PERIAPSIS > 640000 { ^ [LOG 20:49:49.094] System.NullReferenceException: Object reference not set to an instance of an object at kOS.Execution.CPU.OnSave (.ConfigNode node) [0x00000] in <filename unknown>:0 [LOG 20:49:49.095] Code Fragment File Line:Col IP opcode operand ---- ----:--- ---- --------------------- 1/launch 47:1 0363 push 76 1/launch 47:1 0364 addtrigger false 1/launch 47:1 0365 push steering 1/launch 47:1 0366 push True 1/launch 47:1 0367 call toggleflybywire() 1/launch 48:1 0368 push $throttle* 1/launch 48:1 0369 push 11 1/launch 48:1 0370 store 1/launch 48:1 0371 push 72 1/launch 48:1 0372 addtrigger false 1/launch 48:1 0373 push throttle 1/launch 48:1 0374 push True 1/launch 48:1 0375 call toggleflybywire() 1/launch 49:1 0376 call clearscreen() 1/launch 50:1 0377 push 80 1/launch 50:1 0378 addtrigger true 1/launch 52:7 0379 push $periapsis <<--INSTRUCTION POINTER-- 1/launch 52:19 0380 push 640000 1/launch 52:17 0381 gt 1/launch 52:17 0382 not 1/launch 52:17 0383 br.false 21 1/launch 53:1 0384 push $throttle* 1/launch 53:1 0385 push 3 1/launch 53:1 0386 store 1/launch 53:1 0387 push 72 1/launch 53:1 0388 addtrigger false 1/launch 53:1 0389 push throttle 1/launch 53:1 0390 push True 1/launch 53:1 0391 call toggleflybywire() 1/launch 54:1 0392 push $mydir* 1/launch 54:1 0393 push 68 1/launch 54:1 0394 store 1/launch 55:1 0395 push $steering* Ok, I'll try to use only one "lock" command. ____ The same... The error appears near wait until ETA:APOAPSIS < 60. string, anyway. And another question. Does anyone knows, how to stage with RealFuels engines? The stage:liquidfuels doesn't work for it. I've tried to use ENGINE:THRUST parameter, but it said that engine parameter is not declared...
  18. I've got a small problem: Here is the script: lock throttle to 1. lock VYSOTA to SHIP:ALTITUDE. declare parameter ANGL. until VERTICALSPEED > 100 {lock steering to up + R(0,0,270).}. unlock steering. print "Beginning gravity turn". until (1.2*(VYSOTA/1000)-(VYSOTA/1500)) > 80 { lock ANGL to (1.2*(VYSOTA/1000)-(VYSOTA/1500)). lock Y to (90-ANGL). set MyDIR to HEADING (90,Y). lock throttle to 1. lock steering to MyDIR. print "Current angle = " + CEILING(ANGL) + " degrees." at(0,2). print "Altitude =" + CEILING(VYSOTA) + " m." at(0,1). }. unlock ANGL. set ANGL to (1.2*(VYSOTA/1000)-(VYSOTA/1500)). until APOAPSIS > 645000 { set FANGL to (90-ANGL). print "Final angle = " + CEILING(FANGL) + " degrees." at(0,2). lock MyDIR to HEADING (90,FANGL). lock throttle to 1. lock steering to MyDIR. }. lock steering to HEADING(90,0). lock throttle to 0. clearscreen. wait until eta:apoapsis < 100. [B]until PERIAPSIS > 640000 {[/B] lock throttle to 1. lock MyDIR to HEADING (90,0). lock steering to MyDIR. }. unlock throttle. unlock steering. break. What I'm doing wrong? And is there a spoiler tag? ))
  19. Exactly I thought that you might already have real values in days - it would be easier. But if so, it will not be a problem to do it by myself, just need to search web a bit longer. Thanks
  20. Stavell, thanks for mod. Can you make a config for RSS-pods with real-like LS values?
  21. I think IFILifeSupport mod is th best LS to make a game a bit more realistic. Does it matter, what kind of micromanagement is going aboard? Water, oxygen, CO2, food, waste... There is an precisely estimated time of life support in every program, so anyway there is a specified time of life support - and the mod doing the same. Yes, it can be fun to toggle sitches and pushing buttons, watching as carbon dioxide growing or converting, but only if there is nothing to do else on KSP.
  22. I'm playing 64-bit version, so it seems it is a only way to avoid errors and freezes, and with it the ground straight under the vessel looks very odd. Anyway, it looks beautiful even without clouds May be there is another way, but I can't find. Overvhaul version works alike, but looks worse.
  23. And you can write it in the very first answer, not spending your and my time with two pages of comments. Let me explain, how I see it. OLDD's and FASA configs are in the pack, so not hard to tell "FASA and OLDD are not fully suported at this time" - with just eight caps, not thirty six. If it was another bugs in OLDD, I would not have asked, it works well. And I've asked - you know, it can be bug with the specific config, isn't it? So calm down. Thanks anyway.
  24. And it works well? Did you tried it?