Jump to content

Search the Community

Showing results for tags 'eva construction'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Welcome Aboard
  • Kerbal Space Program 2
    • KSP 2 Discussion
    • KSP 2 Suggestions & Development Discussion
    • KSP 2 Dev Diaries
    • Show and Tell
  • Kerbal Space Program
    • The Daily Kerbal
    • KSP Discussion
    • KSP Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Community
    • Player Spotlight
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (Console)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Making History Expansion
    • Making History Missions
    • Making History Discussion
    • Making History Support
  • Breaking Ground Expansion
    • Breaking Ground Discussion
    • Breaking Ground Support
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Twitter


About me


Location


Interests

Found 2 results

  1. Hello, I've found an issue where I can reliably produce a NullReferenceException that results in an unresponsive clone of a Kerbal stuck on a ladder. I'd like to find out if this is a well known issue since the bug reporting process seems to be pretty involved, and I am pretty lazy. To produce the bug: 1) Have two craft with docking ports near each other in space, one with an engineer on board. This can be accomplished by decoupling a craft from your space station, for example 2) With the craft carrying the engineer, target the docking port of the second craft (So that the pink markers appear on your nav-ball). 3) EVA your engineer and use the EVA construction mode to remove the docking port of the second craft that you targeted in step (2). 4) Board the engineer onto his/her original craft. The engineer should now be present inside the craft, but a clone will be stuck on the ladder outside. I have the base game installed, no mods, version 1.12.2.3167 (WindowsPlayer x64) en-us. From the log: [LOG 03:43:34.572] [FLIGHT GLOBALS]: Switching To Vessel Bill Kerman ---------------------- [LOG 03:43:34.575] [PlanetariumCamera]: Focus: Bill Kerman [LOG 03:43:34.601] [ApplicationLauncher] SetVisible: [LOG 03:43:34.602] [ApplicationLauncher] SetHidden: [LOG 03:43:40.479] Event Weld Started not assigned to state Ladder (Idle) [LOG 03:43:46.196] Event Weld Started not assigned to state Ladder (Idle) [LOG 03:43:50.277] Event Weld Started not assigned to state Ladder (Idle) [LOG 03:44:04.682] [FLIGHT GLOBALS]: Switching To Vessel Station Beta ---------------------- [LOG 03:44:04.683] [PlanetariumCamera]: Focus: Station Beta [LOG 03:44:04.697] Camera Mode: AUTO [EXC 03:44:04.723] NullReferenceException: Object reference not set to an instance of an object ProtoTargetInfo..ctor (ITargetable tgt) (at <cd473063d3a2482f8d93d388d0c95035>:0) Vessel.ResumeTarget () (at <cd473063d3a2482f8d93d388d0c95035>:0) Vessel.MakeActive () (at <cd473063d3a2482f8d93d388d0c95035>:0) FlightGlobals.setActiveVessel (Vessel v, System.Boolean force, System.Boolean clearDeadVessels) (at <cd473063d3a2482f8d93d388d0c95035>:0) FlightGlobals.ForceSetActiveVessel (Vessel v) (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalEVA.proceedAndBoard (Part p) (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalEVA.BoardPart (Part p) (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalEVA.<SetupFSM>b__424_53 () (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalFSM.RunEvent (KFSMEvent evt) (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalFSM.updateFSM (KFSMUpdateMode mode) (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalFSM.UpdateFSM () (at <cd473063d3a2482f8d93d388d0c95035>:0) KerbalEVA.Update () (at <cd473063d3a2482f8d93d388d0c95035>:0)
  2. prpretty self explanatory from the video, any idea what could be causing this and solutions to the issue? https://cdn.discordapp.com/attachments/295199794102796288/794310947475947560/Kerbal_Space_Program_2020-12-30_14-05-57_Trim.mp4 (video of issue)
×
×
  • Create New...