Jump to content

Search the Community

Showing results for tags 'mac'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • The Daily Kerbal
  • Kerbal Space Program 2
    • KSP 2 Discussion
    • KSP 2 Dev Diaries
  • General KSP
    • KSP Discussion
    • Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Community
    • Welcome Aboard
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (PlayStation 4, XBox One)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Making History Expansion
    • Making History Missions
    • Making History Discussion
    • Making History Support
  • Breaking Ground Expansion
    • Breaking Ground Discussion
    • Breaking Ground Support
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Twitter


Location


Interests

  1. This one is so obvious that I'm a bit ashamed of myself for just noticing it now. That's the history: my loading times are getting terrible as KSP evolves. New hires textures and maar parts are imposing a toll on my rig. Of course, using a SSD is a nice compromise, but these things are still expensive around here - and I since I have every single KSP version released on a test bed on my development rig, I would need a really expensive one. So, while researching the new APFS deduplication facilities (ie, "Copy on Write"), I realised that APFS (and HPFS+ too!!) have transparent
  2. Launch Pad is a CKAN Client written for macOS. It allows you to download and install mods for Kerbal Space Program, including dependencies. If you play KSP on a Mac, and find it hard to use the official CKAN application using monodevelop, give Launch Pad a try! The app is still being developed, so while you can install most mods with it, you can't upgrade them right now. The app uses the original CKAN Metadata Repository, so all mods that are available on CKAN are also available in here. I'd LOVE for some adventurous Mac users to try it out and leave feedback though. Mo
  3. Hi, so I'm on macOS Mojave version 10.14.6, I got this game yesterday, it was working fine but then i logged out, when back in and the buttons don't work Let me explain, everything on my mouse works, zoom, click, adjust parachutes, etc. but when i press any button like M to open map or something it makes that mac error noise. Here's my ksp.log Please help me
  4. When I try to install 1.7 on my macbook pro, and click past the intro screen, the readme screen loads but freezes, and I cannot hit continue. Force Quit Menu says installer is not responding.
  5. Hello All, I have a lightly modded (10-12 mods) OSX KSP 1.3.1, that I want to convert to a Win KSP 1.3.1, before I then let it update to 1.6.1. However, this is the first time I am performing this kind of Wizardry.... Can someone please point me at a thread that advises what to do/not do, or provide a reply with instructions? I think i just need to change the environment Info from OSX *** to the Windows *** version? e.g. envInfo = - Environment Info - Unix 7FFFFFFFFFFFFFFF Args: KSP - versionFull = 1.3.1.1891 (OSXPlayer) versionCreated = 1.3.0.1804
  6. Does the Scatterer addon have an adverse effect on the performance of KSP when it is running on a Mac? Does it slow the game down?
  7. I have installed KSP 1.5.1 on a Mac (Sierra 10.12.6, MBP). No language package nor mods. When running from an administrator account KSP works fine. When running KSP from an account without admin privileges it stalls during loading. "Loading Asset Bundle Definitions" is displayed and loading does not proceed any further. (To be precise: In the admin account loading pauses for about three seconds at that stage, too, but then goes on; in the non-admin account loading stalls for minutes until I quit the program.) I have searched the forum and found the suggestion to move the KSP.app to t
  8. I am installing KSP for the first time on a Mac running El Capitain. The program has been loading now for over 5 hours. It’s not hung, so I am reluctant to shut it down, but this can’t be right. The progress bar looks about 45% complete and it says “Loading Asset Bundle Definitions.” Every few seconds, the screen image changes and I see an encouraging new message (Flying Sage, Adding More Stuts, Terminating Debris, etc). What should I do?
  9. Well... The last few days I got somewhat overwhelmed by a series of crashes on my MacOS box that I didn't diagnosed correctly, and found myself chasing ghosts. =/ Not one of my brightest times. =P This thread is my attempt to gather together a knowledge base of MacOS specific issues and, with luck, minimize the time spent on crashing KSP and maximize the time spent crashing crafts on KSP. :-) The proposed "rules" are simple: a post per 'problem x solution'. I don't plan to use this as a generic support thread - I think that help for unknown problems should be get in dedicated th
  10. I am dependent on an external DLL to perform some functionality for my plugin. To do this I use P/Invoke's DllImport and it works all fine on Windows. When on Linux/OSX, however, a DllNotFoundException is thrown. (I am using dedicated mac/linux libs when appropriate) [EXC 13:45:27.864] DllNotFoundException: osx/discord-rpc.bin DiscordRP.Discord.OSXInvoker.Initialize (System.String applicationId, .EventHandlers& handlers, Boolean autoRegister, System.String optionalSteamId) DiscordRpc.Initialize (System.String applicationId, .EventHandlers& handlers, Boolean autoRegister, System.S
  11. When i loaded it the first time, it worked, but then i went into the VAB, everything was looking simple, the color was blue, nothing was visible except the structure of the VAB, then i tried to press the invisible "Exit from the VAB" button, everything went right, but when i got of the VAB, i saw KER`s UI, the screen was black, then it turned into something like https://imgur.com/gallery/lNtPQ, but the screen was black except the curvature of kerbin which was orange (the edges). Mods: https://imgur.com/4Zq7StG Information about my Mac: https://imgur.com/gallery/LR9iF, if you
  12. Since the update to 1.4, the icons for the parts in the first rows in each category are not showing the top half. MacOS: 10.13.3 KSP: 1.4.0.2077 (Steam) Screenshots: https://imgur.com/a/ATXLa Starting a new career or sandbox does not fix the issue. I have removed all mods to test, it still happens. Does anyone else have this issue?
  13. What the title says. Is there a way to make KSP work without having to right click on the icon in the folder and trudge through the files every single time?
  14. I have tried all the recommended workarounds, running from the root directory, with the -opengl flag, etc, etc. None of them work for me. Running macOS 10.13.3, and Kerbal ver 1.3.1 It might run for 10 minutes, or it might hang during loading. but it always dies--just totally stops responding--with a blank screen. Are Macs actually a supported platform anymore?
  15. I've crashed my game every single time i've gone into fullscreen mode on Kerbal Space Program 1.3. I'm trying to figure out if it's a problem with my computer or the game and if there is an easy solution
  16. Greetings, I have a new MacBook Air with an up to date version of OS X on it, and I haven't been able to run CKAN. I installed it through Mono as it says in the read me, but i just get a window that pops up for a split second. Any my help would be truly appreciated, thanks.
  17. I tried following the instructions for installing CKAN on my Mac (using terminal mono), but I can't get it to work. I am using a MacBook pro (Touch-bar) with OS High Sierra. Has anyone solved this issue? My goal is to get RSS up and running.
  18. So I just updated KSP to 1.3.1 (after about 3 years of not updating!) I'm currently on OSX Yosemite 10.10.5. The issue I'm having is the game gets to the "Loading Asset Bundle Definitions" point and then stops loading. I downloaded the update and the KSP_osx folder is in the Applications folder. I have tried moving the KSP and Launcher apps to the desktop and back again, that hasn't worked. I also tried the method of right clicking and going through "Show Package Contents" to open the exe. I would upload the log, but can't seem to find that either! Any help would be much apprecia
  19. Backstory: Trying to dock a science pod to a space station/making a space station. RSC controls stuck in rotation mode and I can't really use ROT controls for docking. Before this the frames were jittering and basically going back and forth in time. Adjusted display settings, helped a little, then when docking it happened again. Don't know If this is important, but just recently updated to MacOS High Sierra, jittering happened a day before and stuck in ROT controls happened after. I'm really irritated that I cannot finish my space station, I had it in a low orbit. It was perfect. I launc
  20. My first experience of Kerbal Space Program was on PS4. I put a lot of hours into it. As I discovered later it's behind the current release and it's tendency to corrupt save files is now legendary. So, I figured, let me try it on my Mac book pro. Mouse usage has been great. Flight controls leave a lot to be desired. When I connected up my ps4 controller, I couldn't help but notice that the controls are behaving like the keyboard. Yaw and pitch are just on and off, despite having full analog control on the ps4 version of the game. My basic question is, does anyone know what the best ps
  21. Please Help. I haven't been able to play KSP since the newest update! Here is an explanation of the problem: So, I launched KSP on steam, like I always have, without updating my computer or anything different. Just a normal day. I notice the new loading pictures, wich i think are pretty cool, and then at around 75% or so of loading the game, It stops. It just stops. It stops on the asset: Squad/Parts/Wheel/roverWheelXL3/roverWheel3. I tried again, and it didn't work. So I turned off steam and opened it again and tried. Didn't work. I turned off my computer and left it for an hour or so an
  22. Yo guys, I have a problem. When I start my KSP up it won't load. It stuck always at "Loading Asset Bundle Definitions." I'm playing on Mac so i checked every folder like "parts" and "sounds" but there is nothing at all in it. So yeah idk what to do. I downloaded it a couple of times again, but every time I have the same problem. Does anyone know what to do? Thanks!
  23. how to model my mods i dont know how and i use mac so which software should i use
  24. I recently installed the game on my 13" Macbook Pro early 2015, and whenever I run the game it seems to load fine. It gets to the end – says "Squad/Spaces/mk2InlineInternal/Internal/mk2InlineInternal" – and remains stuck there. I am running the latest version of macOS Sierra, and I could not find any solutions to this problem, although there does seem to be a similar one where it got stuck on assets earlier in the loading sequence.
  25. I am running KSP 1.2.0 on my Mac (OS Sierra 10.12.3). It got stuck at the Accessing Bundle Definition procedure when loading. Please help!!! Not being able to play is killing me. I am not using Steam. [LOG 14:15:42.656] ******* Log Initiated for Kerbal Space Program - 1.2.0.1509 (OSXPlayer)-pre ******* Kerbal Space Program - 1.2.0.1509 (OSXPlayer)-pre OS: Mac OS X 10.12.0 CPU: Intel(R) Core(TM) i5-5257U CPU @ 2.70GHz (4) RAM: 8192 GPU: Intel(R) Iris(TM) Graphics 6100 (1536MB) SM: 41 (OpenGL 4.1 INTEL-10.18.65) RT Formats: ARGB32, Depth, ARGBHalf, Shadowmap, RGB565, ARGB4444, ARGB15
×
×
  • Create New...