Search the Community

Showing results for tags 'cfg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • The Daily Kerbal
  • General KSP
    • KSP Discussion
    • Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (PlayStation 4, XBox One)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Community
    • Welcome Aboard
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website

Categories

  • Developer Articles

Found 13 results

  1. Making a small parts mod and for whatever reason KSP keeps looking for the IVA Model sub-directory that is not referenced in the IVA Cfg anywhere Cfg - Logs -
  2. Firespitter CFG

    Need some help, comrades! But first, sorry for my ugly english I making aircraft and my fuel tanks contains 6 units of L. fuel (30 kg) Wanna use this 6 units for 45 minutes flying at 100% thr. I copy-pasted this module from Firespitter engine and changed a bit. MODULE { name = FSengine thrustTransformName = thrustTransform maxThrust = 0.55 powerProduction = 40 engineBrake = 15 powerDrain = 10 velocityLimit = 0,1; 20,0.95; 25,0 fuelConsumption = 0,0.00001;1,0.002 atmosphericThrust = 0,0;0.9,1;1,1 resources = LiquidFuel,0.0025;IntakeAir,0.375 } But now fuel wasting too fast - enough only for 3-4 minutes. How can i fix it? What values i should use?
  3. I'm trying to get the ModuleResourceHarvester working for atmospheric CO2, but it doesn't show up on the part menu. Here's the cfg: PART { name = CO2Compressor module = Part author = Chirality mesh = compressor.mu scale = 1 rescaleFactor = 2.1 node_attach = 0.03, 0.0, 0.0, 1.0, 0.0, 0.0, 1 TechRequired = precisionEngineering entryCost = 6400 cost = 20 category = Utility subcategory = 0 title = Surface Mount CO2 Compressor manufacturer = Chirality Technologies description = Filters CO2 out of the atmosphere and compresses it. Fuels CO2 thrusters! attachRules = 0,1,0,0,0 mass = 0.01 dragModelType = default maximum_drag = 0.2 minimum_drag = 0.2 angularDrag = 2 crashTolerance = 7 maxTemp = 2000 bulkheadProfiles = srf MODULE { name = ModuleResourceHarvester HarvestorType = 2 Efficiency = 0.15 ResourceName = CarbonDioxide ConverterName = CO2 Filtration StartActionName = Start Filtering CO2 StopActionName = StopFilteringCO2 AutoShutdown = true UseSpecialistBonus = false INPUT_RESOURCE { ResourceName = ElectricCharge Ratio = 10 } } MODULE { name = ModuleResourceConverter ConverterName = CO2 Compressor StartActionName = Start Compressor StopActionName = Stop Compressor AutoShutdown = true GeneratesHeat = false UseSpecialistBonus = false INPUT_RESOURCE { ResourceName = CarbonDioxide Ratio = 1.0 FlowMode = ALL_VESSEL } INPUT_RESOURCE { ResourceName = ElectricCharge Ratio = 20 } OUTPUT_RESOURCE { ResourceName = LqdCO2 Ratio = 0.1 DumpExcess = true FlowMode = ALL_VESSEL } } } The converter function works (or at least, it shows up). Any ideas?
  4. Hey all, i seriously need a second set of eyes to help me see where i'm going wrong here, or if what im doing is even possible (im assuming it is, it's just that im more of a modeller than programmer and i'm missing something utterly obvious.) To the quick! The problem. I'm trying to create a "Spacebus" a small 6 man shuttlepod to ferry kerbals around Kerbin/Mun/Minmus stations. Everything was going fine until i tried adding the engines and RCS. Now, i've done a good bit of modding before so i know the pitfalls here, and i tried to cover most of my bases. =I tried adding in RCS, and it worked fine. I tried adding the engines, and it all bust. =I tried adding in the engines, and it worked fine. I tried adding the RCS, and it all bust. =I tried using both sets of engines in one cfg without any effects at all included. Both work --perfectly-- without any effects being added. To make the point easy, here's a video. As i say, this isnt my first rodeo. I've made sure both RCS and the engines have different sets of transforms each, and none overlap or are incorrectly named (as the video proves). The problem boils down to the sodding EFFECTS module, or so i think. I first copy/pasted seperate effects modules, and that just breaks everything. I then tried to merge the two effects modules into one "EFFECTS" in the cfg, and it still buggers up. It's like the game is saying "You can have one set of effects on this part, but not two." Below ive included the main starting section of the CFG (incase ive overlooked something bloody obvious) here. And here are the two separate Effects modules that i cant seem to get to play nice together. Main Engines : And the RCS part I've tried using just fx_whatevers at the start of the cfg, but unless im adding them in wrong, they dont play nice with the RCS Effects module. Thanks for taking the time to read this, and if you've any helpful advice or can see where i've gone wrong i'll be so SO grateful (and make sure to mention you when i release my main mod, of course!)
  5. Notepad++ language for CFG files

    I've been working on this for a while, so I thought that I would share, This is a notepad++ configuration file to add a new ksp language into the program Steps to use: download the file locally go to language in notepad++ click user defined import and point to the file load a config file and select ksp as language. --- EDIT: Dropbox stopped sharing, here's another link New Link : https://1drv.ms/u/s!Au_FusKqvwUWguRcaLxW9iAFa5veaA It formats cfg files so you can find errors easier. Let me know if you find it useful Ge.
  6. I did some searching around regarding AnimationCurve's, and found some good things. However, what I did not find, was anywhere that explains the easiest way to come from the keys in the cfg file someModule { someAnimationCurve { key = 0 320 key = 1 280 key = 6 0.001 } } reading that in C# (plugin) into an AnimationCurve object FloatCurve curve = new FloatCurve(); curve.add(0,320); curve.add(1,280) curve.add(6,0.001); So what is the most efficient way to populate AnimationCurve from the cfg file format we know in KSP? other related question reference: for answer see and
  7. Hello, I am developing a mod with Kopernicus. Everything seems to be in order...Except it isn't showing up. I Checked the logs with minimal Errors found. The only Errors were: (Body Log) (KSP Log): Note that these are the errors from the log, and I didn't put the entire log into the Spoiler as I saw it was unnecessary. Any Help?
  8. Crewed modules have an INTERNAL section like the following: INTERNAL { name = landerCabinInternals } Is it possible to offset the entire internal space? Failing that, can anyone direct me to the stock CFG for landerCabinInternals so that I can manually create an offset version? I'm welding a pod with other parts and need to correct the location where the internal cabin "part" gets attached to.
  9. So this is a really simple error: Somebody forgot to add the LIFTING_SURFACE module to this tank. Other adapters have the same mass as a fuel tank of their capacity does, and other Mk2 spaceplane parts have the same mass as a tank of their capacity + a wing of that lift rating would (1 lift per 0.1t), but the Mk2 - 2.5m adapter has the mass of the latter with no lift. I assume, therefore, it was intended to have a lift rating of 0.7.
  10. Hi, I'm a new poster but have been (trying to) play KSP for a long time now. After a lengthy break, I've picked it up again at v1.1.2 to discover quite a lot has changed. I had a program back in the day for modelling ascents of various ships into orbit and have been trying to update the code to model the new drag cube system. However, when opening my GameData\Squad\Parts folder, none of the .cfg files for any of the parts seem to have the DRAG_CUBE { cube= } parameters as described in numerous discussions on the new aerodynamics system (see link) Am I missing the most recent files, or am I simply looking in the wrong place? Any help is much appreciated, Cheers
  11. Hi everyone, I am wondering how to correctly edit the orientation of a node within the cfg I under stand that the first 3 values 0.0, 0.0, 0.0 are for entering location of the node and that the second 0.0, 0.0, 0.0 are for entering orientation. What I don't understand is what the units in these values are equal to? is 1.0 = to 360 degrees? and 0.0 equal to 0 degrees? or does 1.0 represent something else? I am trying to get the connections for the part in the video below to work correctly. The angle at the ends is 22.5 degrees from the centre of the circle the 8 parts form. However entering this as a value of 0.225 in the cfg does not work. Thanks for your help
  12. Sorry. Figured it out. @DuoDex please delete this thread.
  13. Is it possible to edit the cfg file for the stock resource converters so they create things like argon gas? I haven't looked into it but I was going to try somehow copying the section of code that defines the ore to xenon or the ore to liquid fuel module and paste it in only making it an ore to argon gas converter. Would this work? Or will that just give me errors? thanks.