Search the Community

Showing results for tags 'ram'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • General
    • Announcements
    • The Daily Kerbal
  • General KSP
    • KSP Discussion
    • Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (PlayStation 4, XBox One)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Community
    • Welcome Aboard
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • Making History Expansion
    • Making History Missions
    • Making History Discussion
    • Making History Support
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website


  • Developer Articles

Found 12 results

  1. Low Ram Clouds

    I want to use cloud mods such as EVE but I don't have a lot of RAM to spare. I looked into the files and found a bunch of rather large files. However, a cloud addon that simply adds a cloud texture layer onto is all I need. Is there a way to do this? Or somehow drastically reduce RAM usage of EVE? And yes, I do have texture settings all the way down.
  2. So, after some tedious searching, I’ve narrowed down the cause to my game’s crashing issue to it’s overuse of RAM. I’ve noticed that as soon as my KSP starts using more than 3.4 GB of RAM it crashes. How do people run so many mods without the profuse crashing issue? (I understand that KSP has a ram usage limit)
  3. Hello, i have a gamebreaking problem in my 70+ modded game. I dont use scatter and VE-Mods cause i thought they might fix it, but actually do nothing. Like the title suggests I have mini freezes after like 20min of gameplay and my memory also increases over time untill it crashes or freezes every 5sec. I have win10, 1070, i5 5XXX, and 16gb of ram. I reinstalled the game a few times and verified game by the steam option daily. I also use the 64bit version with force opengl start option. I can upload the "output_log" if someone tells me how. EDIT: Dropbox Link to normal and _x64 output_log Pls help me.
  4. Hey guys! I'm running an, i would say moderatly modded install of KSP ver 1.3.0. The issue i'm having is a stutter which appears periodically in uncomfortably short intervals. My question is if the problem is simply my lack of RAM to run all these mods or perhaps something else? Also if it were the sooner do you guys have any recommendations on which mods to exclude form the list, which ones are considered RAM heavy? Modlist: Here is a screenshot of my performance monitor during the run: Here is a video recording the issue: (excuse the low frame rate i recorded it full HD @60 fps it was a bit demanding for my rig) My specs.: Acer Aspire v3 772G Laptop with an i7-4702MQ @2.2GHz (3.2GHz turbo), 8GB of DDR3 RAM and an NVIDIA GeForce GT 750M. The game runs from a Samsung SSD.
  5. So, I just installed A LOT of mods: BDArmory CameraTools Chatterer Stock Visual Enhancements Pack Kerbal Engineer KerbalX PhysicsRangeExtender Targetron TweakScale And Vessel Mover Quite the shopping list, eh? So that means that it'll take a big hit on my FPS, but that's kinda unfair, since I have 8GB of RAM. So how do I give KSP more RAM?
  6. Hello, I'm aware of the fact that there already are plenty of threads with the exact same topic, but none of them acctually answered my question. Most of them are like "You dont need to allocate more RAM, all you need is better CPU". However, I know why they say these things as I am quite versed in Hardware questions. Still, I read the crash reports of my game and by how and when the game crashes I am confident that know what is to do. All i need to know is how I can allocate more RAM. I'm happy about anybody trying to help!
  7. My computer is 64bit and 4GB ram , use 10 mod but when play 20min i get Blue screen or game crash . Any way to fix this?? Mod for memory or something else.
  8. So, the game works fine. It loads at around ~3GB of RAM, and in game it's 3.5 GB. Totally normal, even in 32 bit that would be the case. I'm using 64 bit, and over time of playing KSP, the memory usage slowly but surely creeps up, 4GB, 5GB, up to 6GB before I had to terminate and relaunch KSP as it would either crash the game or my system. (8GB of RAM). No idea what is causing it, I'm using SVE... Mod list: KSP: 1.2.2 (Win64) - Unity: 5.4.0p4 - OS: Windows 7 Service Pack 1 (6.1.7601) 64bit Filter Extensions - Toolbar - 1.7.13 USI Tools - 0.8.6 B9 Part Switch - 1.5.3 Bon Voyage - 0.11.1 Community Category Kit - 1.2.1 Community Resource Pack - 0.6.3 CommunityTechTree - 3.0.2 Contract Configurator - 1.21 CustomBarnKit - 1.1.10 DistantObjectEnhancement - 1.8.1 Firespitter - 7.4.2 Flexible Docking - 1.0.4 Interstellar Fuel Switch - 2.3 Kerbal Attachment System - 0.6.1 Kerbal Engineer Redux - Kerbal Joint Reinforcement - 3.3.1 KerbNet Controller - 1.0.2 Kerbal Inventory System - 1.4 KSP-AVC Plugin - ModularFlightIntegrator - 1.2.2 NearFutureConstruction - 0.7.2 NearFutureElectrical - 0.8.2 NearFuturePropulsion - 0.8.2 NearFutureSolar - 0.7.1 NearFutureSpacecraft - 0.5.4 Play Your Way - 1.0.1 Science Relay - 1.0.3 SSTULabs - StageRecovery - 1.6.5 Stock Visual Enhancements - 1.1.4 Strategia - 1.5 TweakScale - 2.3.2 USI Core - 0.3.4 Karbonite - 0.8.3 Karbonite Plus - 0.7.3 Konstruction - 0.1.2 USI-LS - 0.5.13 Malemute Rover - 0.2.3 UKS - 0.50.7 KSP Interstellar Extended - 1.11.7 Here is KSP.log and output_log. (not sure how to do attachments on the forum, too used to the old vbulletin
  9. More RAM?

    I have been having issues with "compatible" mod-related crashes. I know it won't speed up my game, but I need more mods. I've read a question similar to this, and no one gave any answers, so lets get some things out of the way. 1: I am playing the x64 bit version. 2: My computer runs on Windows 10. 3: I do have excess RAM. Now, with those out of the way, bring on the answers!
  10. Hi All, I realise an accurate answer is impossible due to the vast variety of mods and other factors, but here it is: How much of an impact on RAM, CPU or other limiting resources does the average non-part/texture plugin take? If Im on 90-95% RAM usage, and have already made my peace with the fact that more parts will likely cause much more frequent crashes, is it worth contemplating mods like "CraftHistory", "Ship Manifest", "Persistant Rotation" etc.? Or should i just forget it until I can increase my RAM? I don't need to know the properties of those exact mods, just wondering in general, because there are one or two that have caught my eye, but I have just reached a point of stability with my build and dont want to rock the boat too much Thanks! Pete
  11. Hello there, I've been running 65 mods now on KSP 1.1.2 x64, and I got random crashes while on flight. When I see the debug toolbar, it shows "Unused Reserved Size: 141 MB". Been trying to use dx11, no improvements. And it seems that KSP allocates 1.5 GB of RAM (heapsize?), and coupled with 65 mods, will crash when launching, flying, or even entering a facility. This does NOT happen in KSP 1.0.5 x86 before and it has more than 80 mods. Windows 10 x64, Intel Core i3-3217U, Intel HD Graphics 4000, 4 GB (4x1) RAM, 500 GB 5400 RPM HDD. GameData folder : CKAN Modlist (1) : CKAN Modlist (2) : CKAN Modlist (3) : Debug toolbar : output_log.txt are too big to upload to Dropbox. If you want me to upload, please suggest a website that lets you upload codes and texts bigger than 5 MB. This is my first thread, if this is placed in a wrong section, I apologize for that kind of mistake. If these report less information of the usage, please tell me.
  12. KSP Mac OS X 64 bit

    DISCLAIMER: I did not came up with this method. I found it on Reddit (see this topic). I just want to share it here. Thanks to Reddit user sq10 for sharing. So, you are playing on Mac OS X and you can't use many mods because there's no OpenGL trick and the game crashes around 2,7 GB of RAM usage? You have to turn down your texture resolution? That's the fix for you! Original post from user q10 on Reddit: MAKE SURE TO BACKUP YOUR CURRENT INSTALL OF KSP FIRST! First, get the Mac version of Unity 4.6.4, download it from After downloading and installing it, right click the Unity app and 'Show Package Contents' - the first file you will need to get is in Contents/Playback Engines/MacStandaloneSupport/Variations/macosx64_nondevelopment_mono, click 'Show Package Contents' again and go to Contents/MacOS. Copy 'UnityPlayer' from the UnityPlayer app and go to Contents/MacOS/ in the KSP app, remove the 'KSP' file inside the folder and copy the file you copied from the UnityPlayer application and rename it to 'KSP'. Then, go back to Contents/ in the KSP app and go to the 'Frameworks' folder and delete 'MonoEmbedRuntime', replacing it by the 'MonoEmbedRuntime' from Contents/Frameworks in the UnityPlayer application. Next, go to Contents/Data/Managed in the UnityPlayer application and copy UnityEngine.dll to Contents/Data/Managed in the KSP application, replacing the previous dll. Finally, go to Contents/Data/Managed/etc/ in the KSP app and delete the mono folder, and copy the mono folder from /Contents/Data/Managed/etc/ in the UnityPlayer application to /Contents/Data/Managed/etc/ in the KSP application. I hope the instructions weren't too unclear and please let me know if I did something wrong somewhere! With this 64 bit modification, I am able to run EVE and Astronomer's Visual Pack with no problem and 64 bit vanilla KSP just feels much smoother. Also from my personal observation, FAR, DRE and Kerbal Joint Reinforcement seem to work fine and I do no get any error messages for using a 64 bit version of KSP. Thanks for reading! Keep launching those rockets! ~sq10 And the best think is that it works! I've tried it with around 60 mods installed on KSP 1.0.5 and with loaded 700+ parts vessel. This is the result. Played for about 1hr and no crashes. As the forum user said, I used Unity 4.6.4 and not other 4.6.x version. Nothing more to say. Hope you enjoy!