pellinor

[1.4.x] TweakScale v2.3.12(Apr-16)

Recommended Posts

So far, no luck.

With this config:

//Shooting Star Pod

@PART[Super100] // Super 100 Shooting Star
{

%MODULE[TweakScale]
{
type = stack
defaultScale = 3.75
}
}

The pod starts spewing mono prop in the VAB, then runs the game out of memory shortly after. I tried adding the ending module, and that didn't change anything. I don't think I've ever scaled a pod with RCS built in. I tried it with and without the engine module. Anyone else want to take a crack at this?

Share this post


Link to post
Share on other sites

Thank you both for your patince and time, i really like this Capsule :D

/ if you dont mind , can i post the working one as file in the Shootingstar Capsule topic?

I think the author want to add it too when its done :D

So far, no luck.

With this config:

//Shooting Star Pod

@PART[Super100] // Super 100 Shooting Star
{

%MODULE[TweakScale]
{
type = stack
defaultScale = 3.75
}
}

The pod starts spewing mono prop in the VAB, then runs the game out of memory shortly after. I tried adding the ending module, and that didn't change anything. I don't think I've ever scaled a pod with RCS built in. I tried it with and without the engine module. Anyone else want to take a crack at this?

Ouuu :S sound like it breaks alot

Edited by fatjoe2015

Share this post


Link to post
Share on other sites
Thank you both for your patince and time, i really like this Capsule :D

/ if you dont mind , can i post the working one as file in the Shootingstar Capsule topic?

I think the author want to add it too when its done :D

Ouuu :S sound like it breaks alot

Doesn't happen for me (TweakScale dev version with the above MM patch and few other mods installed).

Once you confirmed it working, feel free to distribute the patch with the part. It would be good to add a ":NEEDS[TweakScale]" in this case.

- - - Updated - - -

I wonder if anyone else is experiencing this... I've got a set of wheels (the KF wheels, in which I implemented the original TweakScale options for, which worked fine with the same scale type setup a while back) and at least from the launch of 1.0.2 of kSP and onward I am getting not only no option to scale them, but the place where the scale would be is replaced by a blank entry. What I mean is the context menu has a blank spot in it where I believe it is trying to render the scale slider and failing. In addition to this, the log is spammed with: "ItemPrefab for control type 'UI_ChooseOption' not found." Now I did some digging of my own and 'UI_ChooseOption' is a KSPAPIExtensions thing which, when browsing that DLL, in the version specified by the references for TweakScale's DLL, the item does in fact exist. What's even more irritating is that the same scale type options for another part type (the KF repulsors) works perfectly fine. I'm about ready to pull my hair out trying to fix this. Has some form of game-changing modification been done to how the scale type has to be defined in order for this mod to continue working as it has in the past?

Just checked the KF wheels, everything scales fine for me.

Share this post


Link to post
Share on other sites

Got it working :D

Go to "GameData > TweakScale > ScaleExponents.cfg

Search for "noScaledCrewPods = 1" and change it to "noScaledCrewPods = 0"

Save

Go to "GameData > TweakScale > patches" and create a new Textfile

Paste This Code into it:

//Shooting Star Pod

@PART[Super100] // Super 100 Shooting Star
{

%MODULE[TweakScale]
{
type = stack
defaultScale = 3.75
}
}

Click "Save as.." and name it "RaptorAerospacial_TweakScale.cfg"

Save

// It should now be freely Scaleable

Pic:

iUaDrLe.jpg

Edited by fatjoe2015

Share this post


Link to post
Share on other sites
Go to "GameData > TweakScale > patches" and create a new Textfile

...

Click "Save as.." and name it "RaptorAerospacial_TweakScale.cfg"

It does not matter how the .cfg file is named, or where in GameData it is located. When distributing such a patch with another mod you should place it in that mod's directory. The clean way to update a mod is to completely delete it and then install the new version. Files from other mods or manual changes tend to get lost in this process. This is also why it is advisable to put your personal tweaks as ModuleManager patches in a separate folder instead of directly editing .cfg files.

Share this post


Link to post
Share on other sites

Hey all,

I'm trying to get TweakScale to only work for Infernal Robotics parts. I am quite unsuccessful...

for some reason the following MM patch strips all parts of TS functionality. Anyone have an idea?

// Module Manager Config to make only IR parts have TweakScale

@PART[*]:HAS[!#manufacturer[Magic?Smoke?Industries]]:FINAL
{
!MODULE[TweakScale] {} // Remove TweakScale from all non IR parts.
}

Share this post


Link to post
Share on other sites
// Module Manager Config to make only IR parts have TweakScale

@PART
[*]:HAS[[COLOR=#ff0000]~[/COLOR]manufacturer[Magic?Smoke?Industries]]:FINAL
{
!MODULE[TweakScale] {} // Remove TweakScale from all non IR parts.
}

Share this post


Link to post
Share on other sites
// Module Manager Config to make only IR parts have TweakScale

@PART
[*]:HAS[[COLOR=#ff0000]~[/COLOR]manufacturer[Magic?Smoke?Industries]]:FINAL
{
!MODULE[TweakScale] {} // Remove TweakScale from all non IR parts.
}

Excellent, thanks so much!

Share this post


Link to post
Share on other sites
question, why doesn't tweakscale scale heatConductivity, emissiveConstant and heatConvectiveConstant?

My guess would be that they're dimensionless values.

Share this post


Link to post
Share on other sites
I want to report a bug

It appears tweakscale doesn't scale heatConvectiveConstant with surface area, this means rescaled object disproportionately exchange less heat when you increase them is size. This is a problem for rescaled radiators or cryostat tanks. For now I will implement it myself

There is a simple explanation for that, the tweakscae dev does not know how exactly these new systems work.

I only find heatConvectiveConstant in one stock part (the shock cone intake). The fact that it is the same for stock parts of different scale strongly suggests that it does not need scaling. Furthermore I'd expect large parts to exchange heat less efficiently because mass usually scales with the cube and surface area with the square of the scale.

Of course there might be a problem similar to drag (KSP not taking into account the scaled 3D-model) that can be worked around by scaling this constant, but I'd like to understand that before hacking in something that does not look right.

Share this post


Link to post
Share on other sites

I did some tests for the drag, and I'm hitting a wall there.

* I can reproduce a 1.25m mammoth engine having insane amounts of drag.

* When trying to scale maximum_drag, minimum_drag and angularDrag, nothing changes. Those values are still in the part.cfg files, though I could imagine they are no longer needed, and will only have an effect when the old drag model is used. Also tried lowering them with a MM patch, no change.

Can someone confirm these values do not scale drag? Any more insights in how this new drag system can be manipulated?

Edit: solid advice here. Will try that when I find the time to do some more coding.

Edited by pellinor

Share this post


Link to post
Share on other sites
There is a simple explanation for that, the tweakscae dev does not know how exactly these new systems work.

I only find heatConvectiveConstant in one stock part (the shock cone intake). The fact that it is the same for stock parts of different scale strongly suggests that it does not need scaling. Furthermore I'd expect large parts to exchange heat less efficiently because mass usually scales with the cube and surface area with the square of the scale.

Of course there might be a problem similar to drag (KSP not taking into account the scaled 3D-model) that can be worked around by scaling this constant, but I'd like to understand that before hacking in something that does not look right.

I did some further test, and heat does seem to work correctly with scaling, but it can give highly confusing results depnding on what you have attached and resources used. The problem is that all custom resources in CRP are missing specific heat, which is leading to weird heating behavior causing parts heat up too fast or lose heat too fast. But once you have compensated for that, the stock heating framework seems to function quite well

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Hi again,

I just wanted to know how the development of the Chain scaling for a whole subassembly is going? I need to scale all parts at once. Please add it, when you have the time.

Share this post


Link to post
Share on other sites

Prerelease v2.2 is up!

I'll publish this as a release in a few days, or after some feedback that it works for you. Please help me and your fellow players by giving this version a try.

Changelog since v2.1:

* KSP 1.0 support: scaling of part drag

* exponent -0.5 for heatProduction

* support for HX parts from B9-Aerospace

* support for firespitter modules: FSEngine, FSPropellerTweak, FSAlternator

* remove support for KAS connector port so it stays stackable in KIS

* a few missing part patches

* update NF-Solar patches (some parts were renamed)

* catch exceptions on rescale

* survive duplicate part configs

Share this post


Link to post
Share on other sites

* update NF-Solar patches (some parts were renamed)

Some NF-Propulsion tanks have changed name too

here some i have find


@PART[hydrogen-25-1] // HI-49 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 2.5
}
}
@PART[hydrogen-25-2] // HI-49 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 2.5
}
}
@PART[hydrogen-25-3] // HI-49 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 2.5
}
}
@PART[hydrogen-125-1] // HI-30 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 1.25
}
}
@PART[hydrogen-125-2] // HI-30 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 1.25
}
}
@PART[hydrogen-375-1] // HI-80 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 3.75
}
}
@PART[hydrogen-375-2] // HI-80 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 3.75
}
}
@PART[hydrogen-375-3] // HI-80 Hydrogen Tank
{
%MODULE[TweakScale]
{
type = stack
defaultScale = 3.75
}
}
@PART[hydrogen-rad-25-1] // HB-45 Radial Hydrogen Tank
{
%MODULE[TweakScale]
{
type = free
}
}
@PART[hydrogen-rad-125-1] // HI-4 Radial Hydrogen Tank
{
%MODULE[TweakScale]
{
type = free
}
}
@PART[hydrogen-rad-375-1] // HI-4 Radial Hydrogen Tank
{
%MODULE[TweakScale]
{
type = free
}
}
@PART[hydrogen-rad-375] // HB-140 Radial Hydrogen Tank
{
%MODULE[TweakScale]
{
type = free
}
}

Share this post


Link to post
Share on other sites

I'll have a look at the new KSP version tomorrow, havent even tested 1.0.3 yet.

TweakScale depends on KspApiExtensions, so a clean build needs a KAE update. Often the old dlls still work, has anyone tested TweakScale yet?

- - - Updated - - -

Hi again,

I just wanted to know how the development of the Chain scaling for a whole subassembly is going? I need to scale all parts at once. Please add it, when you have the time.

I'll eventually do it, just don't have much time for tweakScale at the moment, and bugfixing comes first.

Share this post


Link to post
Share on other sites

Sitrep: It appears to work on 1.0.4 even though it complains about incompatibility. I didn't do any extensive testing, but it did scale my spaceplane's landing gear correctly so I guess it's working.

Share this post


Link to post
Share on other sites

Hi, pellinor!

I'd like to offer a suggestion (or add a second voice if someone else already suggested it). Could we see a new feature/control for scaling just one axis for a part? I'm thinking specifically of the ability to rescale just the longitudinal axis of a part without adjusting the diameter.

Share this post


Link to post
Share on other sites

Hi

I'm currently trying to recompile TweakScale for 1.0.4 locally. I downloaded the latest files from github.

However when I compile the Scale_Editor project it complains about missing definition for MinValue and MaxValue in the TweakScale.ScaleType class at line 125 and 126 in file: https://github.com/pellinor0/TweakScale/blob/master/Scale_Editor/Editor.cs

And actually these types are not defined in the ScaleType.cs of the Scale Project.

Did I something wrong?

Best regards,

GrafZahl

Share this post


Link to post
Share on other sites

Recompile is up (dev version), release is on the way.

- - - Updated - - -

However when I compile the Scale_Editor project it complains about missing definition for MinValue and MaxValue in the TweakScale.ScaleType class at line 125 and 126 in file: https://github.com/pellinor0/TweakScale/blob/master/Scale_Editor/Editor.cs

Scale_editor is unused code from my predecessors, I still need to clean that up. You can ignore it for now. Scale.dll is all you need to recompile. (Scale_redist has no dependencies so no recompile necessary).

Share this post


Link to post
Share on other sites
I'd like to offer a suggestion (or add a second voice if someone else already suggested it). Could we see a new feature/control for scaling just one axis for a part? I'm thinking specifically of the ability to rescale just the longitudinal axis of a part without adjusting the diameter.

The problem is, it would add interface clutter and look ugly for pretty much all parts. What we need here is a procedural parts mod with a stretchy (or tiled) middle and separate end caps.

- - - Updated - - -

Release is up: v2.2.1 for KSP 1.0.4

Share this post


Link to post
Share on other sites
The problem is, it would add interface clutter and look ugly for pretty much all parts. What we need here is a procedural parts mod with a stretchy (or tiled) middle and separate end caps.

- - - Updated - - -

Release is up: v2.2.1 for KSP 1.0.4

This doesn't work for me. I've installed it, didn't work

Uninstalled and Installed it again, cause the Game to crash

Uninstalled and Installed it again - game loads but there is apparently no sign of tweakscale. If I right click on the item no scale bar is appearing

Help?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.