pellinor

[1.4.x] TweakScale v2.3.12(Apr-16)

Recommended Posts

So if I want to make a patch that lets a part be tweakscaled to .3125m and and .35m how would I do it? How far off is this?

@PART[mypart]:NEEDS[TweakScale] 
{ 
	%MODULE[TweakScale] 
	{ 
		%type = scale 
		%defaultScale = 0.3125 
	} 
	%MODULE[SCALETYPE] 
	{ 
		%name = scale 
		%freeScale = false 
		%scaleFactors = .3125, .35
	}
}

What does incrementSlide do and do I need to include it?

Share this post


Link to post
Share on other sites
8 hours ago, pellinor said:

So far it is hardcoded, but I plan to make it configurable with an exponent like everything else. A workaround would be a MM patch to define a scaled copy of the MPL.

Thank you, this is what I ended up doing. <3
Looking forward to future updates, great mod, thanks!

Share this post


Link to post
Share on other sites

@pellinor I noticed an issue with Tweakscale that I haven't seen discussed yet. 

I've noticed that when launching a vehicle from the runway or launchpad directly, the IVA is flipped upside down (example) and the IVA window in the lower right is blacked out (example). Launching from the SPH or VAB with the same craft does not cause the issue.

Tested in 1.1.3 with only MM and the latest version of Tweakscale installed. 

Here is a copy of my log.

Thanks for all your hard work! Let me know if you need anything else from me.

Share this post


Link to post
Share on other sites

I can't seem to get tweak scale to work. Are there dependencies that I'm missing? I'm in 1.1 because I don't feel like updating all my mods.

Share this post


Link to post
Share on other sites
11 hours ago, JDarksword said:

I can't seem to get tweak scale to work. Are there dependencies that I'm missing?

An easy question to answer with your detailed description of how you installed it.

Share this post


Link to post
Share on other sites
1 hour ago, damerell said:

An easy question to answer with your detailed description of how you installed it.

I took the .zip and opened it up, went into the gamedata folder inside and put tweakscale folder into my KSP gamedata folder. I also installed module manager. Not the one from the Tweakscale .zip as it is identical to my existing version.

Share this post


Link to post
Share on other sites
17 hours ago, JDarksword said:

I can't seem to get tweak scale to work. Are there dependencies that I'm missing? I'm in 1.1 because I don't feel like updating all my mods.

Then maybe you shouldn't update TweakScale. Each version is compiled against a specific KSP version and might not work with others. The last version for ksp1.1.0  should be v2.2.7.2:

https://github.com/pellinor0/TweakScale/releases

Share this post


Link to post
Share on other sites
3 minutes ago, pellinor said:

Then maybe you shouldn't update TweakScale. Each version is compiled against a specific KSP version and might not work with others. The last version for ksp1.1.0  should be v2.2.7.2:

https://github.com/pellinor0/TweakScale/releases

That's the version I'm using. v2.2.7.2 is installed. Doesn't work though.

Share this post


Link to post
Share on other sites

What happens if there are like 5 different versions of this .cfg in various different mod directories? Are assets in directories without a copy of TweakScale.cfg the reason some of them cannot be tweaked? I suppose that those assets need to be configured to allow Tweaking functionality to affect them?

Can one file in root GameData directory make the functionality apply to assets from all mods?

 

Share this post


Link to post
Share on other sites

pellinor, can u make it so tweakscale can be use to rescale the most recent decal mod by AncientGammoner, or make an option were we can make those said mods able to be resized? i would like that, especially since it is hard to make 1,000's or millions of parts to move cuz +80% of it is decals....

 

ty! :)

 

Edited by Komander Faul
saying thank you

Share this post


Link to post
Share on other sites
On 18.7.2016 at 5:04 AM, Diche Bach said:

What happens if there are like 5 different versions of this .cfg in various different mod directories? Are assets in directories without a copy of TweakScale.cfg the reason some of them cannot be tweaked? I suppose that those assets need to be configured to allow Tweaking functionality to affect them?

Can one file in root GameData directory make the functionality apply to assets from all mods?

Names and folders don't matter as all of these are moduleManager patches (and those files probably do not have the same content). Tweakscale is a partModule (i.e. a piece of code/data) that you need to explicitely add to a part if you want to make it scaleable. This is usually done with a MM patch (that can be placed anywhere in a .cfg file under GameData). The simplest way to write your own patches is to look at the existing files (for example in TweakScale/patches/Squad) and copy from there.

8 hours ago, Komander Faul said:

pellinor, can u make it so tweakscale can be use to rescale the most recent decal mod by AncientGammoner, or make an option were we can make those said mods able to be resized? i would like that, especially since it is hard to make 1,000's or millions of parts to move cuz +80% of it is decals....

ty! :)

I'll have a look. In the meantime you can also experiment with making your own patches, see my above comment.

On 17.7.2016 at 0:28 AM, andreasblom said:

How do I disable the feature that blocks cockpits from being used if tweakscaled?

Currently hardcoded, sorry (should only affect downscaled parts). I plan to make a config exponent for this like for the other part properties. 

Edited by pellinor

Share this post


Link to post
Share on other sites
On 14.7.2016 at 9:05 PM, JDarksword said:

That's the version I'm using. v2.2.7.2 is installed. Doesn't work though.

Then it should work. Maybe something helpful in your log (like the .dll refuses to load for some reason)? Do the TweakScale modules appear in a saved craft file (if not the moduleManager patches are not applied correctly)?

Share this post


Link to post
Share on other sites

would the below be correct, or would i need to add a few definitions? (all of this below is .cfg file....)

 

PART

{

name = decalsCamo

module = Part

author = Kommander Faul

mesh = camo.png

 

MODEL

{

model = Decals/letters texture = A, Decals/Camo

}

scale = 1

rescaleFactor = 1

node_attach = 0.0, 0.0, 0.045, 0.0, 0.0, -1.0, 1

cost = 200

category = Utility

subcategory = 0

title = Camo

description = a piace of camo from an eairlier war.....

attachRules = 0,1,0,0,0

 PhysicsSignificance = 1

mass = 0.001

dragModelType = default

maximum_drag = 0.2

minimum_drag = 0.2

angularDrag = 0.5

crashTolerance = 10

maxTemp = 3400 }

MODULE     

{   

 name = TweakScale   

 type = free   

 }

}

 
Edited by Komander Faul
needed to add moar words

Share this post


Link to post
Share on other sites

That should work. Just make sure it also works if TweakScale is not present (it might throw errors/warnings). The clean way would be to add the TweakScale module via MM with :NEEDS[TweakScale].

Share this post


Link to post
Share on other sites
On 7/24/2016 at 6:11 AM, pellinor said:

 

Currently hardcoded, sorry (should only affect downscaled parts). I plan to make a config exponent for this like for the other part properties. 

thank you for responding, I asked this because I remember downscaled parts having crew capacity

Share this post


Link to post
Share on other sites
On 7/24/2016 at 6:22 AM, pellinor said:

Then it should work. Maybe something helpful in your log (like the .dll refuses to load for some reason)? Do the TweakScale modules appear in a saved craft file (if not the moduleManager patches are not applied correctly)?

[LOG 13:18:18.922] AssemblyLoader: Loading assembly at C:\Users\Joshua\Documents\Kerbal Space Program 1.1\GameData\TweakScale\plugins\Scale.dll
[LOG 13:18:18.925] Load(Assembly): TweakScale/plugins/scale_redist
[LOG 13:18:18.926] AssemblyLoader: Loading assembly at C:\Users\Joshua\Documents\Kerbal Space Program 1.1\GameData\TweakScale\plugins\scale_redist.dll
 

That is there, then this 

[ERR 13:18:19.101] AssemblyLoader: Exception loading 'Scale': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'TweakScale.GoodspeedTweakScale' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TweakScale.TSGenericUpdater' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TweakScale.EmitterUpdater' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TweakScale.TweakScale' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'EmitterData' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<UpdateByWidth>c__AnonStorey0' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<GetRelativeScaling>c__AnonStorey1' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 

I couldn't find any text related to Tweak or TweakScale in my most recent saved ship so id assume that the patches aren't being applied.

Share this post


Link to post
Share on other sites
On 3/8/2015 at 6:31 PM, pellinor said:

scaled wheels are still wonky [workaround: define scaled copies using rescaleFactor]

After changing

WHEEL_CLIP_OFFSET = 0
WHEEL_CLIP_RANGE = 0
WHEEL_CLIP_MULTIPLIER = 0

in settings.cfg i was able to rescale wheels and drive around without problems and wheels braking but it jumped once when i first spawned.

But wheels are floating above the ground so it looks like thats why they are breaking and jumping around in the first place

Spoiler

screenshot14.png

 

Share this post


Link to post
Share on other sites

I've got a problem with 5m rockets.  (I'm using the SpaceY big parts.)  My booster is a 5m tank with a TweakScaled Mammoth under it.  MechJeb says TWR = 1.29.  I put it on the pad and it just roars--now MechJeb says it has only half the TWR.  While I haven't done an exact comparison it looks like what I see in the VAB with the engines at their normal 3.75m size.

While I have tweaked engines before it's always been downsizing space engines rather than upsizing launch engines, if they were actually producing their original thrust I wouldn't have been likely to notice it.

Share this post


Link to post
Share on other sites

Todays has been a really bad day for me. It's a private matter so I won't explain but on top of it all I was really excited to play some ksp and try out this mod. I downloaded the newest version and dragged the gamedata into ksp folder. I launched the game and it worked. I was happy but when I tried to scale the whole craft from the craft root part only the root part got scaled. I have been tryong for hours and hours reinstalliung the game 3 times and searching on google for different topics for like 2 hours now. And im left with nothing but rage. I'm literally raging while writing this ... Since it didn't work for me. It's not the mods fault or the creators or anything like that this is just a very bad day for me. I hope someone can help me fix this. When I try to scale the whole craft it only scales the part im on even if I choose the root part. I have tried to change the rioot part aswell as I have searched for random stuff like hotkeys to see if that's whats needed but I cant find anything similar on the web. Pleas help I would really appreciate it.

Share this post


Link to post
Share on other sites

HI all,

Somewhere lost in the mists of time and forum I'm sure i saw a  scale exponent that only allowed scaling in two axis.  I'd like to scale x and Y while leaving z untouched, If my memory isn't just making stuff up, can you point me in the right direction? If I am suffering mod hallucinations, is the scaling of only two axis possible? I'm hoping it is as I'd rather not go down the procedural route if i can help it. (tried it already didn't like it much, for my purposes at least)

Cheers

22 hours ago, 5tyresyhrtsyrtsyrts said:

Todays has been a really bad day for me. ( snipperoony)  I. Pleas help I would really appreciate it.

Hi if your issue still persists and you have tried checking for known issues etc, a copy of your log file for one of you game sessions will be needed. With a log file it's usually a quick fix and you'll be away, without a log nobody can help, apart from offering anecdotal advice and commiserations. So do yourself a favor, save yourself some pain, zip up your games log files and make them available via a link,,

Share this post


Link to post
Share on other sites

Hi! I have an issue with tweakscale that is quite confusing. I've just installed the TweakScale folder as well as the modulemanager. When I enter the game, nothing is scalable, why?

Share this post


Link to post
Share on other sites
On 27.7.2016 at 11:12 PM, JDarksword said:

 System.TypeLoadException: Could not load type 'TweakScale.GoodspeedTweakScale' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TweakScale.TSGenericUpdater' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TweakScale.EmitterUpdater' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TweakScale.TweakScale' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'EmitterData' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<UpdateByWidth>c__AnonStorey0' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<GetRelativeScaling>c__AnonStorey1' from assembly 'Scale, Version=2.2.7.2, Culture=neutral, PublicKeyToken=null'.

So for some reason it refuses to load the dll. No real idea how to continue from here. The missing modules are a consequence of this, there is nothing to apply if KSP does not know the partModule.

On 8.8.2016 at 9:08 PM, 5tyresyhrtsyrtsyrts said:

when I tried to scale the whole craft from the craft root part only the root part got scaled.

Actually this is what most people expect when they scale a part. What you are looking for is called chain-scaling (toggled with leftCtrl+K). Had to look this up in the code because it is a feature I never used. This propagates a scale change to child parts (recursively so scaling the root part will try to scale the whole vessel).

Share this post


Link to post
Share on other sites
On 9.8.2016 at 7:15 PM, SpannerMonkey(smce) said:

Somewhere lost in the mists of time and forum I'm sure i saw a  scale exponent that only allowed scaling in two axis.  I'd like to scale x and Y while leaving z untouched, If my memory isn't just making stuff up, can you point me in the right direction? If I am suffering mod hallucinations, is the scaling of only two axis possible? I'm hoping it is as I'd rather not go down the procedural route if i can help it. (tried it already didn't like it much, for my purposes at least)

Sorry, TweakScale has always treated all dimensions equally. I think the model transform of a part allows non-isotropic scaling. However, including it in TweakScale would introduce a lot of complications (starting with UI and ending with an unknown amount of connections to other mods). Also there are very few models that look reasonable when distorted that way.

3 hours ago, NightshineRecorralis said:

Hi! I have an issue with tweakscale that is quite confusing. I've just installed the TweakScale folder as well as the modulemanager. When I enter the game, nothing is scalable, why?

Anything interesting in your log? First look for "exception" and then for "tweakscale".

Share this post


Link to post
Share on other sites
6 minutes ago, pellinor said:

Sorry, TweakScale has always treated all dimensions equally. I think the model transform of a part allows non-isotropic scaling. However, including it in TweakScale would introduce a lot of complications (starting with UI and ending with an unknown amount of connections to other mods). Also there are very few models that look reasonable when distorted that way.

Yeah, the only thing I can think of that reasonably would tweak in two dimensions are things which are basically flat by nature.  Those panels for probe building & the flat solar cells

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.