pellinor

[1.4.x] TweakScale v2.3.12(Apr-16)

Recommended Posts

14 hours ago, pellinor said:

Sorry, TweakScale has always treated all dimensions equally. I think the model transform of a part allows non-isotropic scaling. However, including it in TweakScale would introduce a lot of complications (starting with UI and ending with an unknown amount of connections to other mods). Also there are very few models that look reasonable when distorted that way.

14 hours ago, Loren Pechtel said:

Yeah, the only thing I can think of that reasonably would tweak in two dimensions are things which are basically flat by nature.  Those panels for probe building & the flat solar cells

 

HI, i carried out a little experiment and am in complete agreement that it's not worth pursuing,  I hadn't taken into account the nasty things that would happen to the texture. It was flat panel application i was thing of but even that when scaled oddly is not nice. So scrap that thought, there is another option to pursue

Share this post


Link to post
Share on other sites

I've made research for hours upon hours but couldn't find any help so i'll ask here: how do we chainscale? there doesn't seem to be a key and if i rescale the first part, it only rescale that one. Could someone answer me quickly

Share this post


Link to post
Share on other sites
On 13/08/2016 at 9:47 PM, david2084 said:

I've made research for hours upon hours but couldn't find any help so i'll ask here: how do we chainscale?

Discussed in the previous page in this thread. I realise one can't read back indefinitely but "hours and hours" might have allowed going back one page, no?

Share this post


Link to post
Share on other sites
On 8/10/2016 at 3:06 PM, pellinor said:

So for some reason it refuses to load the dll. No real idea how to continue from here. The missing modules are a consequence of this, there is nothing to apply if KSP does not know the partModule.

Actually this is what most people expect when they scale a part. What you are looking for is called chain-scaling (toggled with leftCtrl+K). Had to look this up in the code because it is a feature I never used. This propagates a scale change to child parts (recursively so scaling the root part will try to scale the whole vessel).

Thanks!!!! :)

Share this post


Link to post
Share on other sites

Hi, pellinor.

I'm not sure if this issue has been brought up before, but I'm having a problem with scaled tanks on one my crafts.

Whenever I launch a craft with scaled parts, it either breaks apart on the runway or begins to float upward as if I had hacked the gravity. In the case of the latter, if I try to activate the engines and apply thrust the craft will simply float in the air as if nothing happened.

I thought the first time it happened that I had simply installed the mod incorrectly, but after a fresh install I noticed the problem kept occurring.

For me, this mod is essential for the type of craft that I create, so any help would be greatly appreciated.

I've added logs and screenshots to make things easier.

Sorry for the trouble.

Screens:

https://gyazo.com/8e20aeda94f7a30f9a0ec80c60d27db4

https://gyazo.com/7b8434e375eff1345ff7be0e3b05840f

https://gyazo.com/4be75ee64b67f11a23d053a98a8aefd9

Log:

https://www.dropbox.com/s/afx764c1ugsap89/output_log.rar?dl=0

Share this post


Link to post
Share on other sites

Please can you tell me what configs to edit to stop  "scaling of crew capacity" from taking place, i really want to build a micro jet like Enter Elysium did in his video

Share this post


Link to post
Share on other sites

It seems like this mod doesn't properly support scaling MFT tanks.

MFT dev said its Tweak Scale bug.

There is bug with levitating precoler (stock) part - if you downscale it to 0.625m and remove all fuel from it, it will levitate (negative mass bug):

http://imgur.com/a/haHwO

Down-scaling precoler part below 1 meter sets its mass below 0.

This is critical bug - I have to exit game, or if I try launch unrelated craft game crashes.

 

Share this post


Link to post
Share on other sites
10 hours ago, raxo2222 said:

It seems like this mod doesn't properly support scaling MFT tanks.

MFT dev said its Tweak Scale bug.

There is bug with levitating precoler (stock) part - if you downscale it to 0.625m and remove all fuel from it, it will levitate (negative mass bug):

http://imgur.com/a/haHwO

Down-scaling precoler part below 1 meter sets its mass below 0.

This is critical bug - I have to exit game, or if I try launch unrelated craft game crashes.

 

Could you narrow that down a bit, i.e. check if you can reproduce it with less mods (ideally that would be only TweakScale + one other)? The last time that sort of bug appeared it was a bad interaction with FAR (and should have been fixed some time ago in FAR). Not sure how you know it needs MFT tanks at all.

21 hours ago, PandaWoo said:

Please can you tell me what configs to edit to stop  "scaling of crew capacity" from taking place, i really want to build a micro jet like Enter Elysium did in his video

Not possible yet, I still have to do a config interface for that.

Share this post


Link to post
Share on other sites
1 minute ago, pellinor said:

Could you narrow that down a bit, i.e. check if you can reproduce it with less mods (ideally that would be only TweakScale + one other)? The last time that sort of bug appeared it was a bad interaction with FAR (and should have been fixed some time ago in FAR). Not sure how you know it needs MFT tanks at all.

Not possible yet, I still have to do a config interface for that.

You could make it so players can choose in the config how much each size change effects crew capacity, also if i resize a pod, then put in more then its original crew capacity, my game freezes in the SPH/VAB

Share this post


Link to post
Share on other sites
On 17.8.2016 at 3:02 PM, Johnny#5 said:

Hi, pellinor.

I'm not sure if this issue has been brought up before, but I'm having a problem with scaled tanks on one my crafts.

Whenever I launch a craft with scaled parts, it either breaks apart on the runway or begins to float upward as if I had hacked the gravity. In the case of the latter, if I try to activate the engines and apply thrust the craft will simply float in the air as if nothing happened.

I thought the first time it happened that I had simply installed the mod incorrectly, but after a fresh install I noticed the problem kept occurring.

For me, this mod is essential for the type of craft that I create, so any help would be greatly appreciated.

I've added logs and screenshots to make things easier.

Sorry for the trouble.

Screens:

https://gyazo.com/8e20aeda94f7a30f9a0ec80c60d27db4

https://gyazo.com/7b8434e375eff1345ff7be0e3b05840f

https://gyazo.com/4be75ee64b67f11a23d053a98a8aefd9

Log:

https://www.dropbox.com/s/afx764c1ugsap89/output_log.rar?dl=0

Seems I can't properly extract that .rar file, will check on a windows system later.

Looks like you and @raxo2222 have the same problem, any chance it appeared after updating or adding some mod? It is very likely an interaction issue of at least two mods who manipulate part mass.

Edited by pellinor

Share this post


Link to post
Share on other sites
10 hours ago, raxo2222 said:

It seems like this mod doesn't properly support scaling MFT tanks.

MFT dev said its Tweak Scale bug.

There is bug with levitating precoler (stock) part - if you downscale it to 0.625m and remove all fuel from it, it will levitate (negative mass bug):

http://imgur.com/a/haHwO

Down-scaling precoler part below 1 meter sets its mass below 0.

This is critical bug - I have to exit game, or if I try launch unrelated craft game crashes.

 

Are you actually Boskone, playing with a Bergenholm mod? <G>

Share this post


Link to post
Share on other sites
8 minutes ago, Loren Pechtel said:

Are you actually Boskone, playing with a Bergenholm mod? <G>

Nope, but I have SMURFF mod, that makes masses of parts and fuel ratios realistic.

26 minutes ago, pellinor said:

Seems I can't properly extract that .rar file, will check on a windows system later.

Looks like you and @raxo2222 have the same problem, any chance it appeared after updating or adding some mod? It is very likely an interaction issue of at least two mods who manipulate part mass.

So looks like MFT + TweakScale + Smurff = Disaster.

Edited by raxo2222

Share this post


Link to post
Share on other sites
11 minutes ago, raxo2222 said:

Nope, but I have SMURFF mod, that makes masses of parts and fuel ratios realistic.

 

I guess you didn't get the reference, then.

Share this post


Link to post
Share on other sites
15 minutes ago, raxo2222 said:

Nope, but I have SMURFF mod, that makes masses of parts and fuel ratios realistic.

So looks like MFT + TweakScale + Smurff = Disaster.

Is that speculation or did you test it? SMURFF sounds very unlikely because it just changes config values. I should have said "two mods which manipulate mass at runtime". The configured mass (after MM is done with it) should make no difference as long as it is positive.

Edited by pellinor

Share this post


Link to post
Share on other sites
3 minutes ago, pellinor said:

Is that speculation or did you test it? SMURFF sounds very unlikely because it just changes config values. I should have said "two mods which manipulate mass at runtime". The configured mass (after MM is done with it) should make no difference as long as it is positive.

Ah then SMURFF isn't culprit then.

7 minutes ago, Loren Pechtel said:

I guess you didn't get the reference, then.

what reference?

 

Edited by raxo2222

Share this post


Link to post
Share on other sites

I've been having issues with the tweakscale + Realfuels combo that might be related with the MFT issues people above me described.

So far I've narrowed it down to a small tank (Oscar B tank) rescaled to 0.4m going NaN when drained to about 50%. Before draining to that point everything works just fine. Tested on an install containing RSS (Shouldn't affect stuff), Engineer (shouldn't affect stuff), Procedural fairings (again, no influence), Ven's stock revamp (for the eyecandy) and of course Realfuels + tweakscale.

Here's a copy of my log in which I discovered said bug. The relevant bit is this stuff here:

Spoiler

[F: 154145]: [02:46:59]: [00:46:59] <color=orange>[LV-1 "Ant" Liquid Fuel Engine]: vapor in feedlines, shut down!</color>
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

RCS lock/unlock
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

[ModularFlightIntegrator] MFI Start
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

[ModularFlightIntegrator] Start. VesselModule on vessel : 
  ModularFlightIntegrator
  UllageModule
  SolverFlightSys

 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

recalculating orbit for fuelTankSmallFlat: the Moon ( Update mode TRACK_Phys )
rPos: [NaN, NaN, NaN]   rVel: [NaN, NaN, NaN] |NaN|
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

recalculated orbit for fuelTankSmallFlat: the Sun ( UT: 2197517.37348446 )
rPos: [NaN, NaN, NaN]   rVel: [NaN, NaN, NaN] |NaN|
Delta: [NaN, NaN, NaN] / [NaN, NaN, NaN]
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

[F: 154641]: RCSBlock collided into fuelTankSmallFlat - relative velocity: NaN - impact momentum: NaN
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

RCSBlock Exploded!! - blast awesomeness: 0.5
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)
 

After that first mention of a NaN everything predictably goes to excrements as the NaN spreads throughout the ship and demolishes everything. Considering that the bug only occurs when the tanks start to empty means it's probably something with the mass going to 0.

Looking at the offending tank in the VAB with engineer you can see this is indeed the case

In fact, testing it with several other tanks shows that many of the smaller tanks go negative mass when scaled down. Definitely something not working correctly here.

 

Edit: Just tested with a completely barebones install. Only tweakscale as it comes out of the box, Realfuels as it comes out of the box (no engine configs) and Engineer to see masses. Negative mass problem persists when downscaling tanks.

Edited by Ralathon

Share this post


Link to post
Share on other sites

By the way, while we're on the subject of tweakscale bugs:

I think you have some boundary condition error for the scaling. If you scale a fuel tank the indicator goes 7.5 --> 10 (full green bar) --> 10(full green bar) --> 20 while the actual size goes 7.5 --> 10 --> 20 --> 20. If you set freescale to false in the DefaultScales.cfg it works as expected, so it's probably something in the freescale code.

Share this post


Link to post
Share on other sites
2 hours ago, Ralathon said:

By the way, while we're on the subject of tweakscale bugs:

I think you have some boundary condition error for the scaling. If you scale a fuel tank the indicator goes 7.5 --> 10 (full green bar) --> 10(full green bar) --> 20 while the actual size goes 7.5 --> 10 --> 20 --> 20. If you set freescale to false in the DefaultScales.cfg it works as expected, so it's probably something in the freescale code.

Known issue: http://bugs.kerbalspaceprogram.com/issues/9743, doesn't look like it has gotten any attention yet.

Share this post


Link to post
Share on other sites

I can confirm that TweakScale+MFT can mess up part mass. MFT seems to mirror the behavior of the TweakScale module, so any mass change due to scaling is applied twice. So shrinked parts go below zero and enlarged ones get heavier than they should.

Edit: it looks like I can work around this by not reporting my moduleMass if an MFT module is present. Not the cleanest way but it should work.

Edited by pellinor

Share this post


Link to post
Share on other sites

Hello, I just wanted to point out a couple bugs/incompatibilities with other mods that I have found.

It looks like theres some discussion going on about other fuel part mods and crafts becoming stuck at spawn, so heres what Ive found:

 

Running KSPx64 1.1.3 on Windows 7 with all most recent drivers/updates/etc (SLI Nvidia GT750M, 16gb RAM, i7 4700MQ 2.4gHz)

  1. Fuel Wings 3.0 and Tweakscale 2.2.13 (all other mods removed)

    I have found a bug that others previously stated with the planes/rockets getting stuck at spawn position. 

    So, I spent a few minutes investigating and specifically, with the advanced canard scaled below 85% my plane gets stuck. Anything above 85% seems to work just fine.

    I tried a few other parts and heres what I found:

    Tail Fin gets stuck below 89%

    Structural Wing A gets stuck below 65%

    Swept Wings get stuck below 90%

    I couldnt discern a commonality among the breaking points, but maybe someone else can!

  2. Raster Prop 0.27.0 for 1.1.3 (6/22/16) and Tweakscale 2.2.13 (all other mods removed)

    When trying to go to cockpit IVA, my view is a Kerbal's forehead, and display is upside down and mirrored... So it appears the camera becomes inverted on all axes - ie, front is back, left is right,  so on.

    Im guessing that RPM has some configuration settings for camera position that get tweaked somehow or perhaps are not loaded properly with Tweakscale installed

 

Thanks for the great mod! I hope these problems are easy to fix!

Edited by dubdubak
added "(all other mods removed)"

Share this post


Link to post
Share on other sites
5 hours ago, pellinor said:

I can confirm that TweakScale+MFT can mess up part mass. MFT seems to mirror the behavior of the TweakScale module, so any mass change due to scaling is applied twice. So shrinked parts go below zero and enlarged ones get heavier than they should.

Edit: it looks like I can work around this by not reporting my moduleMass if an MFT module is present. Not the cleanest way but it should work.

If you're going to blacklist MFT configured tanks you'll also have to exclude engines and RCS configured by Realfuels. Testing tweakscale + Realfuels some more shows that rescaled engines (RCS counts as engines) also go negative mass if downscaled. So I'm guessing the mass change gets applied twice in that case as well.

Share this post


Link to post
Share on other sites
7 hours ago, dubdubak said:

1. Fuel Wings 3.0 and Tweakscale 2.2.13 (all other mods removed)

Fuel Wings bundles MFT, so this is the same bug as already discussed.

Edited by pellinor

Share this post


Link to post
Share on other sites

Could someone confirm this feedback issue:
http://bugs.kerbalspaceprogram.com/issues/9330

UI_ScaleEdit is the tweakable used in continuous scaling ("freeScale=true"). When checking with the current TweakScale version, you can only test the lower end because of the other stock issue (#9743). The official process says that feedback issues should be set to "confirmed" by a second person to show that there is more than one guy interested.

Edited by pellinor

Share this post


Link to post
Share on other sites

SmartParts has two new parts which aren't listed in the file KH_SSE_TweakScale.cfg file.  You can fix this by adding the following to that file:

@PART[km_smart_speed] 
{
    %MODULE[TweakScale]
    {
        type = free
    }
}

@PART[km_prox_sensor] 
{
    %MODULE[TweakScale]
    {
        type = free
    }
}

 

Share this post


Link to post
Share on other sites

Bug Report: Tweaking any un-manned probe core (i.e. Probodobodyne HECS) scales the cost in the opposite direction than it should. Normal scale HECS costs 650. 2x scale costs 230.

Using TweakScale v2.2.13 on KSP v1.1.3.

Edited by KerbalExplorer

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.