Jump to content

[1.4.x] TweakScale v2.3.12(Apr-16)


Recommended Posts

On ‎10‎/‎15‎/‎2016 at 9:28 AM, tempes156 said:

Good to see an update out. Any chance you know when it will kick over into CKAN? Thanks.

The mod authors have nothing to do with CKAN - it is a separate project. (I wish there was  a way to post this a the top of every forum page in the mod section).  This is like asking Boeing when your flight will get here.  So please stop asking "when will CKAN have this" in any thread other than CKAN.  Sheesh.  I have seen dozens of this post this week cluttering up the forums.  No wonder the mod authors get a bit angry about CKAN - this kind of post generate frustration against CKAN from the mod authors.

Guys, I helped a little bit on CKAN a long time ago.  It is automated, it runs a bot that scans the sites periodically every few hours, and it generates the data automatically based on the metadata they have, then every few hours it updates their repository, which your CKAN client then accesses. It can sometime take 2 or more days before CKAN catches up to a mod being updated, especially if its a new app, or the metadata changes considerably. And don't forget, that just like the mods, it is not an official part of the game, and it is being run by people volunteering their own free time, which means sometimes you simply will have to wait.

/end-rant

Edited by Murdabenne
typos as usual
Link to post
Share on other sites
13 minutes ago, Murdabenne said:

The mod authors have nothing to do with CKAN - it is a separate project. (I wish there was  a way to post this a the top of every forum page in the mod section).  This is like asking Boeing when your flight will get here.  So please stop asking "when will CKAN have this" in any thread other than CKAN.  Sheesh.  I have seen dozens of this post this week cluttering up the forums.  No wonder the mod authors get a bit angry about CKAN - this kind of post generate frustration against CKAN from the mod authors.

Guys, I helped a little bit on CKAN a long time ago.  It is automated, it runs a bot that scans the sites periodically every few hours, and it generates the data automatically based on the metadata they have, then every few hours it updates their repository, which your CKAN client then accesses. It can sometime take 2 or more days before CKAN catches up to a mod being updated, especially if its a new app, or the metadata changes considerably.

/end-rant

Umm...have to disagree with you. Unless the author of a MOD creates the CKAN file and then submits it over to the CKAN guys, it won't show on CKAN. It is NOT an auto scan thing, not all mods end up in CKAN as it's up the the MOD author.

For your edification: https://github.com/KSP-CKAN/CKAN/wiki/Adding-a-mod-to-the-CKAN

Edited by tempes156
Link to post
Share on other sites

Wrong.  Sometimes the metadata is created by a fan or a volunteer - I know because I created several of the metadata sets after asking their author if it was OK.  This is especially the case for certain mods where CKAN and the author have had a "rocky" relationship. Other authors simply don't want to deal with it, but do allow members of the CKAN community to do the metadata, so long as the mod author is not bothered by requests about it. For instance look at the first page for the widely used CTT (Community Tech Tree) by Nertea.

And in any event, the author has no control over when CKAN processes the new metadata, does its data scan, rebuilds the database they have, then publishes the new database to where the clients can see it.  Those are all cron job or similar, or triggered by Jenkins and other automated processes in their build engine, then pushed out to their servers.  None of which the mod authoers have any control over, nor input into, and especially, no visibility into what stage and where the processors are in publishing the updated data.  So in all cases, its useless to ask an author when CKAN will show the mod/app.  And counterproductive.

Sorry but this is a pet peeve - I was there for the big dust-up between Ferram and others with CKAN over issues being cause by users and CKAN that was out of the authors control but was taking up their development time (which was grinding on everyone)

 

 

Edited by Murdabenne
Link to post
Share on other sites
49 minutes ago, lekkimsm2500 said:

There's a chance it could just be because of my mods, but if i try scaling the Twin-Boar engine down, things get really screwed up.

Can anyone else confirm this for me?

I think you are experiencing this issue right?

22 hours ago, jrodriguez said:

Thanks @pellinor for the update to KSP 1.2. 

I just reported an issue on github with a detailed report to reproduce it. Issue 47 . Please let me know if you need any other information.

Regards
 

 

Link to post
Share on other sites
13 minutes ago, jrodriguez said:

I think you are experiencing this issue right?

 

It doesn't look like it.

If i downscale it, all of the Δv on default i had on the default size, turns into 0, and provides some crazy 75 TWR. This is at least what MJ reports.

And if i go to launch it, the camera gets extremely screwy and starts to gain altitude, the velocity goes up and down just as screwily.

Link to post
Share on other sites

looks like the OPT folks removed the opt_ from their part names so here is a new OPT_TweakScale.cfg

Spoiler

// == Engines ==
@PART[engine_darkDrive] // OPT Dark Drive
{
    #@TWEAKSCALEBEHAVIOR[Engine]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = stack
        defaultScale = 3.75
    }
}

@PART[AAengine] // OPT "ARIE" Engine
{
    #@TWEAKSCALEBEHAVIOR[Engine]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = stack
        defaultScale = 1.25
    }
}

@PART[nebula_engine] // OPT J-92 Advanced Shcramjet
{
    #@TWEAKSCALEBEHAVIOR[Engine]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = stack
        defaultScale = 2.5
    }
}

// 2 engines not part of OPT test release 1.8
@PART[mk2_engine] // OPT J-61 Advanced TurboRamjet
{
    #@TWEAKSCALEBEHAVIOR[Engine]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = stack
        defaultScale = 1.25
    }
}
@PART[turboRamJet] // OPT J-59 Turboramjet
{
    #@TWEAKSCALEBEHAVIOR[Engine]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = stack
        defaultScale = 1.25
    }
}

@PART[OPTdropTank] // OPT DropTank
{
    %MODULE[TweakScale]
    {
        type = free
    }
}

// Gears: removed in test release
@PART[gears_l] // OPT Landing Gears (L)
{
    %MODULE[TweakScale]
    {
        type = free
    }
}
@PART[gears_m] // OPT Landing Gears (M)
{
    %MODULE[TweakScale]
    {
        type = free
    }
}
@PART[gears_s] // OPT Landing Gears (S)
{
    %MODULE[TweakScale]
    {
        type = free
    }
}

@PART[mk2_ramIntake] // Mk2 Ram Air Intake
{
    %MODULE[TweakScale]
    {
        type = stack_square
        defaultScale = 1.25
    }
}

//
// == Wings ==
//
@PART[stabilizer_a] // OPT Stabilizer Type A
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[stabilizer_b] // OPT Stabilizer Type B
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}

@PART[pylon_a] // OPT Huge Pylon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[pylon_b] // OPT Large Pylon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}

@PART[wing_a] // OPT Main Wing Type A
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[wing_b] // OPT Main Wing Type B
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[wing_c] // OPT Main Wing Type C
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}

@PART[wing_a_elevon] // OPT Main Wing Type A Main Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[wing_b_elevon] // OPT Main Wing Type B Main Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[wing_c_elevon1] // OPT Main Wing Type C Main Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[wing_c_elevon2] // OPT Main Wing Type C Secondary Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}

@PART[winglet_a] // OPT Winglet Type A
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[winglet_b] // OPT Winglet Type B
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[winglet_c] // OPT Winglet Type C
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}

@PART[winglet_a_elevon] // OPT Winglet Type A Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[winglet_b_elevon] // OPT Winglet Type B Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
@PART[winglet_c_elevon] // OPT Winglet Type C Elevon
{
    %MODULE[TweakScale]
    {
        type = free_square
    }
}
 

 

Link to post
Share on other sites
6 hours ago, COL.R.Neville said:

looks like the OPT folks removed the opt_ from their part names so here is a new OPT_TweakScale.cfg

So is this for the main or the legacy pack? I'd prefer to follow the main pack with the bundles configs and keep the legacy support separate somehow, not sure how to organize that yet.

Link to post
Share on other sites

Regarding the update to KSP 1.2, I do not believe the aerodynamic effects are scaling when changing the size of a fin/canard/ control surface. The mass of the part scales properly and you can see the center of gravity move, but the center of lift doesn't change and there is no effect in flight no matter how big I make the part. 

For some reason, fixed wings are aerodynamically scaling well along with their mass, the problem seems to apply only to moving control surfaces like fins and canards.

Other than that, I love the mod and I appreciate you updating it. I couldn't play KSP again after the 1.2 update until I could scale things again.

Link to post
Share on other sites

Do Im trying to launch a craft with tweakscaled landing gear on it, and it cant survive the physics bump, which usually results in a craft with no wings at the very least. The craft(s) in question:

 

http://i.imgur.com/uAdLd9R.png

and

http://i.imgur.com/pk5Oq2P.png

 

On each craft the rear landing gear are scaled up to 130%, and the nose gear are left at 100%. When they spawn on the runway the rear gear spawns in the ground and the the physics bump causes a very violent disconnection of one or both wings. Previously both craft had normal sized gear with no issues.

Link to post
Share on other sites
11 hours ago, pareseux9 said:

Regarding the update to KSP 1.2, I do not believe the aerodynamic effects are scaling when changing the size of a fin/canard/ control surface. The mass of the part scales properly and you can see the center of gravity move, but the center of lift doesn't change and there is no effect in flight no matter how big I make the part. 

For some reason, fixed wings are aerodynamically scaling well along with their mass, the problem seems to apply only to moving control surfaces like fins and canards.

Makes sense, wings and control surfaces use different modules so it is totally plausible that one of them broke. I'll have a look.

Link to post
Share on other sites

@pellinor thanks for this great mod, I use it since what seems forever and I am glad you push it to KSP 1.2 but I have a pretty big issue with it : every part with an attachment node who's scaled gets its node back to non-scaled position when I reload the craft in the VAB, and when I duplicate a part already scaled.

Here some screenshot describing the issue better than my english :

Spoiler

On the left three girder at default scale, on the right : they were down-scaled to 50% but you can see the attachment node are still at 100%.

pIJSKeK.png

 

Radial-only attached part are fine, and part with attachment node which are radially attached seem too but their node is still displace : jA36ENY.png

The one left of the hatch as been down-scaled but the craft hasn't been reload so it's fine and the one on the right is a duplicate of the previous : it is in good position but the node are at the original size.

 

Finally every things seem to be good in flight, I'm not sure which size is used to calculate aerodynamics but it flies :) , even with hole in it :aCqpErb.png

 

I did all the test on a clean install of KSP 1.2 x64 on Windows 10 with TweakScale 2.3 and ModuleManager 2.7.1
Here is a log where I build and fly a rocket with this bug : https://mega.nz/#!Nw9FGL5D!bXmooaDvlfmsXEgMtyQQcWH-JEslD-RPJrkcs69rJIk

Link to post
Share on other sites
7 hours ago, Li0n said:

every part with an attachment node who's scaled gets its node back to non-scaled position when I reload the craft in the VAB, and when I duplicate a part already scaled.

should be fixed in the dev version (https://github.com/pellinor0/TweakScale/issues/47)

20 hours ago, pareseux9 said:

Regarding the update to KSP 1.2, I do not believe the aerodynamic effects are scaling when changing the size of a fin/canard/ control surface. The mass of the part scales properly and you can see the center of gravity move, but the center of lift doesn't change and there is no effect in flight no matter how big I make the part. 

I just did a quick test in the SPH, and I'm seeing both the CoM and the CoL move as expected when I scale control surfaces (tested with the dev version v2.3.0.2 and an AV-R8 Winglet). Does that version fix it for you?

Link to post
Share on other sites
13 hours ago, Avalon304 said:

Do Im trying to launch a craft with tweakscaled landing gear on it, and it cant survive the physics bump, which usually results in a craft with no wings at the very least. The craft(s) in question:

On each craft the rear landing gear are scaled up to 130%, and the nose gear are left at 100%. When they spawn on the runway the rear gear spawns in the ground and the the physics bump causes a very violent disconnection of one or both wings. Previously both craft had normal sized gear with no issues.

Thanks, raised a github issue: https://github.com/pellinor0/TweakScale/issues/48

Link to post
Share on other sites

@pellinor: Unfortunately it is still an issue for me. I downloaded the dev version and it still didn't help.

Here are some screenshots of the issue:
This first one shows the base plane with the center of gravity and lift
http://imgur.com/a/zwOwf

This second one shows the front winglets scaled up to 400%, the cog moves forward but the col doesn't change
http://imgur.com/a/Ne0oN

And the last one shows the delta wings scaled up, the cog and col both shift back as expected.
http://imgur.com/a/mNTRg

Link to post
Share on other sites
22 hours ago, pareseux9 said:

Unfortunately it is still an issue for me. I downloaded the dev version and it still didn't help.

Here are some screenshots of the issue:
This first one shows the base plane with the center of gravity and lift
This second one shows the front winglets scaled up to 400%, the cog moves forward but the col doesn't change
And the last one shows the delta wings scaled up, the cog and col both shift back as expected.

Anyone else seeing this? Building the exact plane from the screenshot, it doesn't happen for me.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...