pellinor

[1.4.x] TweakScale v2.3.12(Apr-16)

Recommended Posts

I know this is a known bug already but with the release of 1.0 has there been anymore looking into the camera bug and the size revert bug that occurs upon reloading? Just curious, it can be very annoying.

Share this post


Link to post
Share on other sites
I know this is a known bug already but with the release of 1.0 has there been anymore looking into the camera bug and the size revert bug that occurs upon reloading? Just curious, it can be very annoying.

No idea, but my hopes are pretty low. Since I'm not part of the QA/experimental team I can't even see if the issue (that biotronic reported last year) ever made it to the internal bug tracker.

Share this post


Link to post
Share on other sites
No idea, but my hopes are pretty low. Since I'm not part of the QA/experimental team I can't even see if the issue (that biotronic reported last year) ever made it to the internal bug tracker.

Dang :( I hope they get around to it :/

Share this post


Link to post
Share on other sites

I just downloaded and installed v2.0.1 and I'm playing it in KSP v1.0.2.842. It seems that at Day0 of a hardcore career, I can scale up a Flea booster to 10x, which would weight 260t on the pad with a single Mk1 Pod. Two questions -- did I mistakenly throw a setting somewhere such that I have access to scaling things that large without first unlocking the tech tree? And second, if I didn't make a mistake, are there plans to integrate tweakscale abilities into the tech tree?

Otherwise, awesome mod, sandbox wouldn't be as fun without it!

Share this post


Link to post
Share on other sites

thanks, whey usefull mode, use it very long! Idk thy ksp devs dont add this function in 1.0.

Share this post


Link to post
Share on other sites

Update: v2.1

* recompile for KSP 1.0.2

* patch for new stock part

Neither KerbalStuff nor Curse know the KSP 1.0.1 or 1.0.2 versions. So it is labeled with 1.0 there.

- - - Updated - - -

Two questions -- did I mistakenly throw a setting somewhere such that I have access to scaling things that large without first unlocking the tech tree? And second, if I didn't make a mistake, are there plans to integrate tweakscale abilities into the tech tree?

There is a way for tech tree integration but it is not widely used and not very comfortable. You can set a techRequired list for a scaletype or a part, so that the scaleFactors are unlocked at specific techs. The problem with this is (for stack parts) that you can easily end up in situations where the default scale of a part is not unlocked yet.

Personally, my approach is to just apply a generous portion of common sense in early career.

Share this post


Link to post
Share on other sites

I'm getting this but with tanks, where I scale up this 1.25m tank, and it has somewhere around 2000-3000 fuel in the editor. Upon launch, the fuel reverts to the 1.25m state, but scale stays the same.

3EdG53i.png?1

Share this post


Link to post
Share on other sites

Loving the new Tweakscale! Thanks for everything pellinor. Great work. Biotronic needs to update the .90 thread to point here. The free-scaling is delicious.

Share this post


Link to post
Share on other sites
I'm getting this but with tanks, where I scale up this 1.25m tank, and it has somewhere around 2000-3000 fuel in the editor. Upon launch, the fuel reverts to the 1.25m state, but scale stays the same.

http://i.imgur.com/3EdG53i.png?1

you gotta stop scaling root parts

Share this post


Link to post
Share on other sites
I'm getting this but with tanks, where I scale up this 1.25m tank, and it has somewhere around 2000-3000 fuel in the editor. Upon launch, the fuel reverts to the 1.25m state, but scale stays the same.

http://i.imgur.com/3EdG53i.png?1

Wow, I haven't seen this yet. Which one is the root part of the vessel? Any other mods which mess with RESOURCE nodes / tank contents, like fuel switches, MFT etc?

@enceos: The replicated revert bug with the root part is the other way round. It has the correct stats but the visual model reverted.

Edited by pellinor0

Share this post


Link to post
Share on other sites

I have an inkling feeling that this is the doing of Nertea's latest CryoEngines release, which is bundled with "InterstellarFuelSwitch"

the command pod is the root

Share this post


Link to post
Share on other sites

Hi

I get the same as

pellinor0

After revert to VAB fuel vanishes out of the tanks!

I have also installed the CryoEngines and InterstellarFuelSwitch (also needed by other mods)

Root is a rescalled fuel tank. But it also happend before where the root part was not scaled and not a fuel tank.

Please fix!

Thanks a lot!

Edited by ManuxKerb

Share this post


Link to post
Share on other sites

Testing the new build, 2.1...

... aside from the strange behaviour about the mk.3 Shuttle cockpit, disabled on Squad MM cfg, ANY manned pod does not allow to be rescaled.

NOT stock ones, NOT any manned part from any mod.

It was disabled someway on the new patch?

Share this post


Link to post
Share on other sites
Testing the new build, 2.1...

... aside from the strange behaviour about the mk.3 Shuttle cockpit, disabled on Squad MM cfg, ANY manned pod does not allow to be rescaled.

NOT stock ones, NOT any manned part from any mod.

It was disabled someway on the new patch?

Yes there is a switch now (see the end of scaleExponents.cfg). Seems like I missed that in the change log of v2.0.

- - - Updated - - -

After revert to VAB fuel vanishes out of the tanks!

I have also installed the CryoEngines and InterstellarFuelSwitch (also needed by other mods)

Root is a rescalled fuel tank. But it also happend before where the root part was not scaled and not a fuel tank.

Please fix!

Thanks a lot!

I'll look into it tomorrow. My guess is that the fuel switch is overwriting what tweakScale does. Did the old firespitter fuelswitch work with tweakScale?

Share this post


Link to post
Share on other sites

the old firespitter switch did indeed work with tweakscale

Share this post


Link to post
Share on other sites

Hey I was about to report that bug in the VAB: the stock "engineer" shows up wrong weight after loading up a craft, which sometimes prevents launch due to launchpad limit.

But it seems you already know about it, what that workaround though? it doesn't seems to work for me. Tweaking it back to original and then again seems to work though.

Share this post


Link to post
Share on other sites

Would anyone kindly help me out with trying to get tweakscale to work with the newer USI-LS mod.

There's a shiney new recycler/greenhouse that just pokes out the top of the 2.5m service bay and it's driving me absolutely nuts.

Would be most useful to be able to squidge it down into four smaller greenhouses and maintain a sleek aerodynamic craft.

Edit: nevermind, using

MODULE

{

name = TweakScale

type = surface

}

does the job

Edited by Galactic Hitchiker

Share this post


Link to post
Share on other sites

@pellinor Thank you for keeping up and working this awesome mod. It means so much to the community! And devs as well :)

I've been reading reddit today, and I'm bringing in some love from there.

KasperVld: Of the ones I currently have installed I’d have to pick between AntennaRange and Tweakscale. Both are great mods for very different reasons.

Share this post


Link to post
Share on other sites
@pellinor Thank you for keeping up and working this awesome mod. It means so much to the community! And devs as well :)

I've been reading reddit today, and I'm bringing in some love from there.

Nice to hear! Still I hope they know that TweakScale is suffering from a stock bug that is already 3 versions old.

Share this post


Link to post
Share on other sites

Bugreport!

Decuplers and separatons have incorrect values of Ejection Force after resizing:

TRriRvj.jpg

Share this post


Link to post
Share on other sites

2 times smaller engine, should be 4 times weaker, but it is like 8 times weaker, so it's tied to the size exponent/mass. I thought the engine power was connected to the surface area of the engine inlet, and compression ratio, but i was wrong apparently.

Edited by DeepOdyssey

Share this post


Link to post
Share on other sites

Ah nice to know, and i though this was caused by TeakEverything :-)

@pellinor

Many thanks for Tweakscale i cant play without it :-D REALLY

Did you get a chance to look at my "node not attach" bugreport ?

Thanks

Edited by ManuxKerb

Share this post


Link to post
Share on other sites
Bugreport!

Decuplers and separatons have incorrect values of Ejection Force after resizing:

First, Sepratrons are engines and do not have an ejectionForce value. The slider looks like TweakableEverything, which currently does not work together with TweakScale (support is planned). For stock+TweakScale I tested decouplers, I'd be surprised if they broke during the last few days.

- - - Updated - - -

2 times smaller engine, should be 4 times weaker, but it is like 8 times weaker, so it's tied to the size exponent/mass. I thought the engine power was connected to the surface area of the engine inlet, and compression ratio, but i was wrong apparently.

I set the thrust (and mass) exponent to 2.5 because downscaled engines seemed too strong/heavy and upscaled ones to weak to be really useful.

- - - Updated - - -

Hi

Please see my bugreport (parts do not node attach) here, this is caused by Tweakscale: http://forum.kerbalspaceprogram.com/threads/119437-RCS-Wheel-Large-%28stock%29-no-Node-attach?p=1905379#post1905379

Logs and pics are in the support Thread:-)

Thanks!

I can't reproduce it, neither with reaction wheels nor with decouplers. Any mods that manipulate attachment nodes maybe?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.