KospY

[1.1.2] Kerbal Inventory System (KIS) 1.2.12

Recommended Posts

There's no detach option. Sorry, but thios needs someone who definitely knows how to use the anchor properly to respond; thanks for trying to help though!

The anchor uses drag to stay in place. The only way to get it back is to reel it in or detach the anchor, reel in the cable then reattach the anchor.

Share this post


Link to post
Share on other sites

Thanks for the great mod. I'm currently struggling with the issue that I cannot add items to an inventory window in the VAB. When I open an inventory window and try to drag an item into it, the item just appears behind the window as if the window is being totally ignored. I read about this click through problem in previous posts, but apparently it's not as bad for others. In my case I cannot place an item in the inventory, regardless of where the window is placed.

I tried it with a clean install. Fresh version of KSP 1.0.4 with just two mods: KIS v1.2.1 and KAS v0.5.4. Same problem even then.

Why am i the only one with this issue? Running it on Windows 7 ..

Share this post


Link to post
Share on other sites
Thanks for the great mod. I'm currently struggling with the issue that I cannot add items to an inventory window in the VAB. When I open an inventory window and try to drag an item into it, the item just appears behind the window as if the window is being totally ignored. I read about this click through problem in previous posts, but apparently it's not as bad for others. In my case I cannot place an item in the inventory, regardless of where the window is placed.

I tried it with a clean install. Fresh version of KSP 1.0.4 with just two mods: KIS v1.2.1 and KAS v0.5.4. Same problem even then.

Why am i the only one with this issue? Running it on Windows 7 ..

You have to click and hold, then drag to the window. If you are doing it right, you will have a small icon attached to the pointer.

Share this post


Link to post
Share on other sites
The anchor uses drag to stay in place. The only way to get it back is to reel it in or detach the anchor, reel in the cable then reattach the anchor.
Thank you, Klatt; well, I haven;'tbeen able to find a way to dislodge teh anchor from the ground without detaching it from the cable, so I'll have to go with the second option. It'll do! :-)

Share this post


Link to post
Share on other sites

Has anyone come across an issue where you inadvertently attach a part - in this case, a container mount - to a kerbal on EVA (in orbit). I just had this happen, and it was not recoverable - I could not grab, drop, detach or otherwise remove the mount from the kerbal (stuck to her feet!) and the game burned all their EVA propellant constantly rotating them while I desperately tried to get them back in the ship.

Gave up and reloaded in the end, but seems odd to be able to attach parts to a kerbal; I had a container mounted on my back when I did it, then dropped the container - maybe it was attached to the container first, then "glued" to the kerbal once I dropped the container (from the menu).

Share this post


Link to post
Share on other sites

Hello I am getting this error in my log upon trying to board my capsule. It leads to the kerbal boarding and being on EVA duplicating the kerbal and breaking all sorts of other stuff after. This was the first error upon trying to board with nothing else relevent in the log, but I will get them if you like. It was on a heavy modded install and may be an interaction, but I wanted to post first to see. Latest KIS and KAS. Thanks!


NullReferenceException: Object reference not set to an instance of an object
at KIS.KIS_Item.Drop (.Part fromPart) [0x00000] in <filename unknown>:0


at KIS.ModuleKISInventory.OnCrewTransferred (HostedFromToAction`2 fromToAction) [0x00000] in <filename unknown>:0


at EventData`1[GameEvents+HostedFromToAction`2[ProtoCrewMember,Part]].Fire (HostedFromToAction`2 data) [0x00000] in <filename unknown>:0


at KerbalEVA.proceedAndBoard (.Part p) [0x00000] in <filename unknown>:0


at KerbalEVA.BoardPart (.Part p) [0x00000] in <filename unknown>:0


at KerbalEVA.<SetupFSM>m__92 () [0x00000] in <filename unknown>:0


at KerbalFSM.RunEvent (.KFSMEvent evt) [0x00000] in <filename unknown>:0


at KerbalFSM.updateFSM (KFSMUpdateMode mode) [0x00000] in <filename unknown>:0


at KerbalFSM.UpdateFSM () [0x00000] in <filename unknown>:0


at KerbalEVA.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Share this post


Link to post
Share on other sites
Hello I am getting this error in my log upon trying to board my capsule. It leads to the kerbal boarding and being on EVA duplicating the kerbal and breaking all sorts of other stuff after. This was the first error upon trying to board with nothing else relevent in the log, but I will get them if you like. It was on a heavy modded install and may be an interaction, but I wanted to post first to see. Latest KIS and KAS. Thanks!

I've seen these same symptoms reported previously for several mods, including this one. It may be a stock bug.

Share this post


Link to post
Share on other sites

Actually, anything that causes an exception while boarding will cause such a symptom, so no, there is no stock bug in this one: the fault is squarely on KIS's shoulders.

Share this post


Link to post
Share on other sites

Why are the textures for new container in MBM format? I thought it is obsolete, and DDS should be used wherever possible.

Share this post


Link to post
Share on other sites

KIS 1.2.2 released!

Here is the changelog:

1.2.2 (13 August 2015)

  • [Fix] Fixed kerbal items not transfering to pod without internal model
  • [Fix] Fixed missing command seat icon (thx to mongoose)
  • [Fix] Fixed node attach not working for some radial part
  • [Fix] Prevent playing static attach sound after load/warp
  • [Fix] Removed old ILC-18k container .mbm textures
  • [Fix] Converted ISC-6K container textures to DDS
  • [Fix] Fixed minor typo in sound error message (thx to Amorymeltzer)

Hopefully there will be no more issues when transfering kerbal to a pod without internal (mods).

Also a workaround has been found for the command seat icon, big thanks to mongoose!

Edited by KospY

Share this post


Link to post
Share on other sites

I had, as some may recall, problems with KAS and KIS upgrades appearing at different times. I am downloading this version, but I am going to hold off on installing until there is either a matching KAS upgrade, or some confirmation that I can safely go ahead with just this.

Share this post


Link to post
Share on other sites
I had, as some may recall, problems with KAS and KIS upgrades appearing at different times. I am downloading this version, but I am going to hold off on installing until there is either a matching KAS upgrade, or some confirmation that I can safely go ahead with just this.

KAS no longer has a hard dependency on KIS, so it should be safe to update

Share this post


Link to post
Share on other sites

Does this update mean placeholder Iva's are no longer nessasry for pods without a Iva made for them?

Share this post


Link to post
Share on other sites
Does this update mean placeholder Iva's are no longer nessasry for pods without a Iva made for them?

Probably not, but only one way to find out for sure.

Share this post


Link to post
Share on other sites
Probably not, but only one way to find out for sure.

I thought that first fix in the changelog sounded pretty definitive towards this issue. If you guys were using placeholder IVAs to work around the issue, a fix wouldn't cause you to have to keep the workaround (in case there was confusion, internal model == IVA)

Share this post


Link to post
Share on other sites
Does this update mean placeholder Iva's are no longer nessasry for pods without a Iva made for them?

Yes, placeholder iva is no more needed.

Share this post


Link to post
Share on other sites

Hello,

Thank you for your awesome mod, and for updating it. Anyway CKAN don't have the latest version (yet). I suppose it's to be expected as there's just a few hours you released the update but just wanted to let you know about it.

Kind regards.

Edited by FrancoisH
Adding my signature

Share this post


Link to post
Share on other sites

Thanks Kospy! great mod, after a couple of weeks using it, it feels like stock! Lots and lots of gameplay added with this.

Share this post


Link to post
Share on other sites

Utterly essential mod, IMO. Perfect just as it is.

...but, if you happen to get a minute or 5 to update the version on CKAN to 1.2.2...

Share this post


Link to post
Share on other sites
Utterly essential mod, IMO. Perfect just as it is.

...but, if you happen to get a minute or 5 to update the version on CKAN to 1.2.2...

Hahaha! You see!

I'm not the only one who's lazy and rely on CKAN and don't want to manually update! ;)

Share this post


Link to post
Share on other sites

I still have been unable to get this to work. I cant open the cans in the hangar. It keeps telling me the sound files are missing. I don't know what i have done wrong.

Share this post


Link to post
Share on other sites

Hi!

I saw that it is possible to *detach* parts, that have other parts attached to them.

Is it somehow possible to *attach* two parts with other parts attached to them?

I want to manipulate the stack in space, and for example insert a part without having to rebuild an entire half of the ship.

Is this feasible now? If not, is it theoretically feasible to implement? If yes, will it be implemented in the future?

Share this post


Link to post
Share on other sites
Hahaha! You see!

I'm not the only one who's lazy and rely on CKAN and don't want to manually update! ;)

HAHA, there is a CKAN thread for questions/issues. In many cases the modders themselves had nothing to do with their mod being on CKAN. And these posts only tend to make modders more annoyed with CKAN.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.