Jump to content

[1.2.1] Spacetux - Contract Pack: Unmanned Contracts, Rover Contracts, Grand Tours and Sprite Missions


Recommended Posts

Hello, as is probably well known now there is no more kerbalstuff. Spacedock is up and running as a replacement with apparently a lot of the same functionality.

Are there plans to update things/upload to spacedock so this mod works with CKAN again?

Link to post
Share on other sites
4 hours ago, John FX said:

Hello, as is probably well known now there is no more kerbalstuff. Spacedock is up and running as a replacement with apparently a lot of the same functionality.

Are there plans to update things/upload to spacedock so this mod works with CKAN again?

Already uploaded to spacedock, waiting for CKAN to get their act together

Link to post
Share on other sites
  • 4 weeks later...

[LOG 19:20:34.736] [INFO] ContractConfigurator.ContractConfigurator: Loading CONTRACT_GROUP: 'SpaceTuxGroup'
[ERR 19:20:34.748] ContractConfigurator.ContractConfigurator: Couldn't load CONTRACT_TYPE 'STS-30' due to a duplicate name.
 

I think Unmanned and GAP is fighting with each other and I guess GAP won, as I don't like GAP's STS-30 (I think it's some submarine mission), can't you rename yourself to anmanned. Just kidding.

 

[LOG 19:20:34.948] [INFO] ContractConfigurator.ContractType: Loading CONTRACT_TYPE: 'FirstPlanetProbe'
[ERR 19:20:34.958] ContractConfigurator.ReachStateFactory: CONTRACT_TYPE 'FirstPlanetProbe', PARAMETER 'ReachState6001' of type 'ReachState': targetBody for ContractConfigurator.ReachStateFactory must be specified.
 

[LOG 19:20:35.055] [INFO] ContractConfigurator.ContractType: Loading CONTRACT_TYPE: 'FirstPlanetFlyby'
[ERR 19:20:35.064] ContractConfigurator.ReachStateFactory: CONTRACT_TYPE 'FirstPlanetFlyby', PARAMETER 'ReachState11001' of type 'ReachState': targetBody for ContractConfigurator.ReachStateFactory must be specified.
 

Is this also unmanned? 

 

Link to post
Share on other sites
18 minutes ago, Miravlix said:

[LOG 19:20:34.736] [INFO] ContractConfigurator.ContractConfigurator: Loading CONTRACT_GROUP: 'SpaceTuxGroup'
[ERR 19:20:34.748] ContractConfigurator.ContractConfigurator: Couldn't load CONTRACT_TYPE 'STS-30' due to a duplicate name.
 

I think Unmanned and GAP is fighting with each other and I guess GAP won, as I don't like GAP's STS-30 (I think it's some submarine mission), can't you rename yourself to anmanned. Just kidding.

 

[LOG 19:20:34.948] [INFO] ContractConfigurator.ContractType: Loading CONTRACT_TYPE: 'FirstPlanetProbe'
[ERR 19:20:34.958] ContractConfigurator.ReachStateFactory: CONTRACT_TYPE 'FirstPlanetProbe', PARAMETER 'ReachState6001' of type 'ReachState': targetBody for ContractConfigurator.ReachStateFactory must be specified.
 

[LOG 19:20:35.055] [INFO] ContractConfigurator.ContractType: Loading CONTRACT_TYPE: 'FirstPlanetFlyby'
[ERR 19:20:35.064] ContractConfigurator.ReachStateFactory: CONTRACT_TYPE 'FirstPlanetFlyby', PARAMETER 'ReachState11001' of type 'ReachState': targetBody for ContractConfigurator.ReachStateFactory must be specified.
 

Is this also unmanned? 

 

What is GAP?

 

Link to post
Share on other sites

@linuxgurugamer, @inigma - I've long meant to implement logic to have the contract group treated as a sort of namespace (but never trackered it, raised #493).  I'll see if I can get that in (but wont' be any sooner than the KSP 1.1 release).  In the meantime the only way to fix would be for one of you to rename the conflicting contract (that's actually the reason all my contract packs have a prefix to the contract type names).

Link to post
Share on other sites
29 minutes ago, nightingale said:

@linuxgurugamer, @inigma - I've long meant to implement logic to have the contract group treated as a sort of namespace (but never trackered it, raised #493).  I'll see if I can get that in (but wont' be any sooner than the KSP 1.1 release).  In the meantime the only way to fix would be for one of you to rename the conflicting contract (that's actually the reason all my contract packs have a prefix to the contract type names).

I can rename the contract. Would be cool to have conflicts fixed via a namespace though. Would save me a ton of re-write. Adding to my tracker.

Link to post
Share on other sites
31 minutes ago, nightingale said:

@linuxgurugamer, @inigma - I've long meant to implement logic to have the contract group treated as a sort of namespace (but never trackered it, raised #493).  I'll see if I can get that in (but wont' be any sooner than the KSP 1.1 release).  In the meantime the only way to fix would be for one of you to rename the conflicting contract (that's actually the reason all my contract packs have a prefix to the contract type names).

Inigma and I discussed this, it will be easier for me to make a change rather than him, so I'll do this in the next day or so

 

LGG

Link to post
Share on other sites
15 hours ago, Enceos said:

@linuxgurugamer Are RemoteTech antennas hardcoded? I have RemoteTech, but I deleted the parts in favor of the Stock RT patch from Malah and Origami Antennas.

P.S. The OP still needs its download links updated from Kerbalstuff to Spacedock.

I've updated the links, thanks.

Now sure what you mean by RT antennas hardcoded?

Link to post
Share on other sites
7 hours ago, linuxgurugamer said:

I've updated the links, thanks.

Now sure what you mean by RT antennas hardcoded?

Your OP reads:

Spoiler

Also, if RemoteTech is installed, the contracts will only become available when specific types of antennas are available

Does that change anything if I have RemoreTech but use antennas from other mods?

Link to post
Share on other sites

Hm, the first two Grand Tours I got offered (tour of the outer planets/of all planets) both had an apparent requirement of landing on Jool (Vessel State: Destination: Jool; State: Landed)

Is there any kind of fix for that?

Link to post
Share on other sites

I'm getting 404's from your pack on SpaceDock. What's going on?

Sorry, CDN issues on the website. Nothing to do with the modder. My bad!

Edited by Volt
Link to post
Share on other sites
  • 4 weeks later...
5 hours ago, SpaceBadger007 said:

So for the contracts, you dont need contract configerator for them to work?

No, you DO need Contract Configurator... Hard to see, but this is in the OP: " Requires: Contract Configurator, Version 0.7.0 or higher, CoherentContracts, Module Manager"

Link to post
Share on other sites
5 hours ago, Stone Blue said:

No, you DO need Contract Configurator... Hard to see, but this is in the OP: " Requires: Contract Configurator, Version 0.7.0 or higher, CoherentContracts, Module Manager"

Right so contract configurator, coherent contracts and module manager, got it thank you

Link to post
Share on other sites

Your spacetuxSA.version seems to say it's for KSP 1.0.5, which I think is just an omission, right? I believe it was a new version that was downloaded when I got your new 1.1 Grand Tours contract pack, so I believe it to be a mistake, and not an out of date dependency...is this correct? KSP-AVC keeps bugging me that it is out of date, so I was just curious. Also trying to eliminate possible reasons for some bugs that I'm experiencing.

Link to post
Share on other sites
On ‎2016‎-‎04‎-‎30 at 10:51 PM, PortableGoogle said:

I installed via ckan but none of the rover or unmanned missions are showing up. I disabled other contracts and I get nothing.

Are you sure you're running the correct version?  Updating to KSP v1.1.2 (which is usually an auto-update if you're on Steam) will mess with CKAN.  CKAN will continue to see your installed mods as "visible" despite them not being updated in the CKAN index.  To verify: uninstall and attempt to reinstall with CKAN.  It'll end up suppressed because the most recent version of these mods are indexed according to CKAN as being v1.1.0.

@linuxgurugamer speaking of, not an update progress request but just wanted to make sure you were aware, CKAN doesn't show these mods as v1.1.2 compatible.  Is this something you're already aware of?  I don't see any discussion on this thread about it, hence my question.

Link to post
Share on other sites
1 minute ago, MisterFister said:

Are you sure you're running the correct version?  Updating to KSP v1.1.2 (which is usually an auto-update if you're on Steam) will mess with CKAN.  CKAN will continue to see your installed mods as "visible" despite them not being updated in the CKAN index.  To verify: uninstall and attempt to reinstall with CKAN.  It'll end up suppressed because the most recent version of these mods are indexed according to CKAN as being v1.1.0.
 

I actually do not have steam on auto update and run it outside of steam. Both show up as contract types i can disable in another mod, i forget what it is called but lets you disable contract types.  They show up on avc as well, space tux and unmanned showed up green and rover said it was for 1.0.5 instead of 1.1

Link to post
Share on other sites
5 minutes ago, MisterFister said:

Are you sure you're running the correct version?  Updating to KSP v1.1.2 (which is usually an auto-update if you're on Steam) will mess with CKAN.  CKAN will continue to see your installed mods as "visible" despite them not being updated in the CKAN index.  To verify: uninstall and attempt to reinstall with CKAN.  It'll end up suppressed because the most recent version of these mods are indexed according to CKAN as being v1.1.0.

@linuxgurugamer speaking of, not an update progress request but just wanted to make sure you were aware, CKAN doesn't show these mods as v1.1.2 compatible.  Is this something you're already aware of?  I don't see any discussion on this thread about it, hence my question.

I wasn't, thanks.  I'll look into it this evening

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...