Jump to content

[1.2.2] Contract Pack: Bases and Stations 3.6.1 (30/04/2017) (formerly Kerbin Space Station)


severedsolo
 Share

Recommended Posts

Oh you don't need to fix a specific panel, just send an engineer on EVA (from the KSS) - wait about 2 minutes (I think... the contract parameters should tell you) - and it will be fixed.

Ah, then I might've stumbled on a bug, as I've been outside at least for 10 minutes moving from panel to panel. It did detect the Engineer and the EVA, but not the 2 minute timer. I'll do some more checking and report back here.

Link to comment
Share on other sites

Try this: https://www.dropbox.com/s/8a5qjyfyh0a0hvm/KerbinRepairFaultyModuleHOTFIX.zip?dl=0 (just replace KerbinRepairModule.cfg in the Kerbin folder).

Totally untested, you'll need to reject your current contract to get the new one to regenerate (you may need to cancel Tier3 missions a few times to get it to show up), and will only work around Kerbin. If it works, I'll roll it out for the other bodies.

BACK UP YOUR SAVE!

Link to comment
Share on other sites

Try this: https://www.dropbox.com/s/8a5qjyfyh0a0hvm/KerbinRepairFaultyModuleHOTFIX.zip?dl=0 (just replace KerbinRepairModule.cfg in the Kerbin folder).

Totally untested, you'll need to reject your current contract to get the new one to regenerate (you may need to cancel Tier3 missions a few times to get it to show up), and will only work around Kerbin. If it works, I'll roll it out for the other bodies.

BACK UP YOUR SAVE!

Unfortunately this doesn't solve it.

Backup up my save, replaced KerbinRepairFaultyModule.cfg, loaded the game, cancelled the contract, picked it up again.

The mission shows:

Vessel: KSS 1: Kerbal must be an engineer and on board the KSS (checked).

Complete ALL of the following: (not checked).

Vessel type: EVA (checked).

Crew (not checked).

Trait: Engineer (checked)

Count: At least 1 (checked).

This is with an Engineer flying around the KSS 1.

Ready to give it another try?

Link to comment
Share on other sites

Dropbox is down, so I'll have to go about this another way:

Overwrite the file with the contents of this - (use notepad ++ or something not windows notepad):

https://github.com/severedsolo/KerbinSpaceStation/blob/master/KerbinRepairFaultyModule.cfg

I've removed the ALL parameter, I think thats the problem.

Edit: It's pretty late here, if this doesn't fix it I'll take another look in the morning)

Link to comment
Share on other sites

Dropbox is down, so I'll have to go about this another way:

Overwrite the file with the contents of this - (use notepad ++ or something not windows notepad):

https://github.com/severedsolo/KerbinSpaceStation/blob/master/KerbinRepairFaultyModule.cfg

I've removed the ALL parameter, I think thats the problem.

Edit: It's pretty late here, if this doesn't fix it I'll take another look in the morning)

Unfortunately this doesn't solve it either.

Changed KerbinRepairFaultyModule.cfg

Cancelled the Contract

Accepted a new contract (of this type).

The mission shows:

Vessel: KSS 1: Kerbal must be an engineer and on board the KSS (checked).

Complete ALL of the following: (not checked).

Vessel type: EVA (checked).

Crew (not checked).

Trait: Engineer (checked)

Count: At least 1 (checked).

Waiting for an Engineer 02:00 (unchecked)

This is with an Engineer flying around the KSS 1.

I'll be online again probably late tomorrow evening or otherwise the evening after. Anyway, no rush :)

Link to comment
Share on other sites

severedsolo - It's sort of a bug/limitation with the completeInSequence - basically when the parameter above is completed, it doesn't force the one below to re-check. In this case, I'd recommend adding the ALL back (otherwise the sequence doesn't make sense), but removing the completeInSequence off all but the timer parameter - that's the only one where you really need it.

Link to comment
Share on other sites

As nightingale has now pushed 1.0 version of CC, I'm declaring this ready for 1.0. I've also updated CKAN (although my PR failed for some reason, guess I'll have to wait to see what Daz says about that)

This is still listed as incompatible by CKAN as is nightingale's CC mod. Is there a thread for CKAN on here to see whats up with it? CKAN is almost more trouble than its worth lately what with having to DL mods that say they are updated here but CKAN doesn't recognize or DL's older versions.

Link to comment
Share on other sites

This is still listed as incompatible by CKAN as is nightingale's CC mod. Is there a thread for CKAN on here to see whats up with it? CKAN is almost more trouble than its worth lately what with having to DL mods that say they are updated here but CKAN doesn't recognize or DL's older versions.

The problem is that CKAN hasn't picked up the new Contract Configurator version. I'll raise it with the CKAN folk.

- - - Updated - - -

Alright, raised [#413] against CKAN-meta - we'll see how quickly they get it through.

Link to comment
Share on other sites

Any chance on getting a bonus feature for the resupply to use Roverdude's new "supplies" LS mod, instead of TACLS?

I don't see why not. Can you provide a link please, so I can take a look?

On the Repair issue: new file available: https://www.dropbox.com/s/lnzojtkds0y74yt/KerbinRepairFaultyModule.cfg?dl=0

Edited by severedsolo
Link to comment
Share on other sites

KCAN is picking up the mod fine, but the AVC version metadata still says 0.9:

{
"NAME":"Contract Pack: Kerbal Space Station",
"URL": "https://github.com/severedsolo/KerbinSpaceStation/blob/master/KerbinSpaceStation.version",
"DOWNLOAD":"https://github.com/severedsolo/KerbinSpaceStation/releases",
"GITHUB":
{
"USERNAME":severedsolo,
"REPOSITORY":KerbinSpaceStation
"ALLOW_PRE_RELEASE":false,
},
"VERSION":
{
"MAJOR":1,
"MINOR":2,
"PATCH":1,
"BUILD":0
},
"KSP_VERSION":
{
"MAJOR":0,
"MINOR":90,
"PATCH":0
},
"KSP_VERSION_MIN":
{
"MAJOR":0,
"MINOR":90,
"PATCH":0
},
"KSP_VERSION_MAX":
{
"MAJOR":0,
"MINOR":90,
"PATCH":0
}
}

Link to comment
Share on other sites

Is there a way of getting this to work in the meantime?

I tried changing the KerbinSpaceStation.version file to read:


"KSP_VERSION":
{
"MAJOR":1,
"MINOR":0,
"PATCH":0
},
"KSP_VERSION_MIN":
{
"MAJOR":1,
"MINOR":0,
"PATCH":0
},
"KSP_VERSION_MAX":
{
"MAJOR":1,
"MINOR":0,
"PATCH":0
}

... but it still complained that it needed 0.9

I dunno if the mod actually works, at what point do you get space station missions?

Link to comment
Share on other sites

It will unlock when you get Specialist Construction unlocked (which reminds me... I need to check that is still the docking port node).

On the AVC thing - I think it's checking my online .version file and reporting 0.90. So, I've updated my github repo to say 1.0 - if you update your version file as evilC has above, that will make the message go away.

Link to comment
Share on other sites

Confirmed, I am no longer receiving the warning.

The docking ports are still in Specialized Construction, but there is now a Jr docking port available in a lower tier as part of Miniaturization.

Link to comment
Share on other sites

I'm having an issue with the "orbit" part of the Launch A Kerbin Station contract. All of the criteria is met, but it's not completing the orbit part. My station is at 250km, is that too high? I've tried completing it with the debug menu, but the same contract just keeps popping up.

Edit: I also have the Minmus and Mun station contracts. They show altitudes, but the Kerbin station isn't showing one for me.

Edit #2: So after reading the config, I see the max is 249km. I was so close!

Edited by bsimms606
Link to comment
Share on other sites

Yeah the contract will regenerate if you don't complete it properly because there is a failsafe built in -

when you complete the contract, the vessel is given an internal name - which the other contracts rely on, if it can't find a vessel with that name, the contract assumes that something went wrong and offers it again

Link to comment
Share on other sites

Any chance of adding support for IFI life support?

USI? Yes sure, if you can tell me what the LS resource(s) are called in game, I had a quick look yesterday, I think it's just "supplies"?

Edit ; if this is another ls mod I'm not aware of, can I have a link please

Edited by severedsolo
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...