tomf

[1.4.x] Impact! - impact science and contracts -v1.6.5

Recommended Posts

I update to the new version and found that the Bangometer is new missing it's texture. 

error in log file is:
[LOG 00:16:18.138] Load(Model): Impact/Parts/Seismometer/seismometer
[ERR 00:16:18.143] Texture 'Impact/Parts/Seismometer/texture or' not found!

Share this post


Link to post
Share on other sites

just completed a bangometer mission on minmus on a craft "permanently" stationed on minmus.  I then collected the data and transferred to my vessel but when I recover, the mission does not complete.  It does say that the data has been recorded, just  not recovered, any suggestions?

Share this post


Link to post
Share on other sites
3 hours ago, gsamelon said:

just completed a bangometer mission on minmus on a craft "permanently" stationed on minmus.  I then collected the data and transferred to my vessel but when I recover, the mission does not complete.  It does say that the data has been recorded, just  not recovered, any suggestions?

Why don't you transmit it by radio? It works for me.

Share this post


Link to post
Share on other sites
3 hours ago, gsamelon said:

just completed a bangometer mission on minmus on a craft "permanently" stationed on minmus.  I then collected the data and transferred to my vessel but when I recover, the mission does not complete.  It does say that the data has been recorded, just  not recovered, any suggestions?

I haven't tested it recently, but it certainly used to work. I'll give it a try myself.

Share this post


Link to post
Share on other sites
On 28/09/2017 at 12:44 AM, wile1411 said:

I update to the new version and found that the Bangometer is new missing it's texture. 

error in log file is:
[LOG 00:16:18.138] Load(Model): Impact/Parts/Seismometer/seismometer
[ERR 00:16:18.143] Texture 'Impact/Parts/Seismometer/texture or' not found!

Is noone else missing the texture after this update? Or should I  be redownloading / reinstalling

Share this post


Link to post
Share on other sites
31 minutes ago, wile1411 said:

Is noone else missing the texture after this update? Or should I  be redownloading / reinstalling

version 1.6.2.2 on github should fix that

  • Like 2

Share this post


Link to post
Share on other sites
16 hours ago, tomf said:

And updated for 1.4

Hi, I noticed there's no main folder in the latest download, so the user would have to create one, which might confuse some folks:

$ unzip -l Impact-v1.6.3.0.zip 
Archive:  Impact-v1.6.3.0.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
      919  2017-10-18 06:47   biomedifficulty.cfg
     8410  2018-03-07 22:17   english.cfg
      687  2018-03-08 07:17   Impact.version
    36352  2018-03-07 22:17   kerbal-impact.dll
     1102  2017-10-18 06:47   LICENSE
    37376  2017-10-18 06:47   MiniAVC.dll
       74  2017-10-18 06:47   README.md
     1183  2017-10-18 06:47   Parts/Seismometer/seismometer.cfg
    56918  2017-10-18 06:47   Parts/Seismometer/seismometer.mu
   924670  2017-10-18 06:47   Parts/Seismometer/texture or.png
   924670  2017-10-18 06:47   Parts/Seismometer/texture-or.png
   389183  2017-10-18 06:47   Parts/Spectrometer/Shader 3.png
      911  2017-10-18 06:47   Parts/Spectrometer/spectrometer.cfg
   486731  2017-10-18 06:47   Parts/Spectrometer/Spectrometer.mu
     2561  2017-10-18 06:47   Resources/ScienceDefs.cfg
---------                     -------
  2871747                     15 files

 

Share this post


Link to post
Share on other sites

I'm playing with RSS and saw there weren't any science defs for any RSS bodies. Are you planning on making some? And if not, how would I go about to throw some random ones in myself? Love the mod quite a lot

Share this post


Link to post
Share on other sites
6 hours ago, Corts said:

I'm playing with RSS and saw there weren't any science defs for any RSS bodies. Are you planning on making some? And if not, how would I go about to throw some random ones in myself? Love the mod quite a lot

You are going to need to edit two files. In impact/resources/ScienceDefs you should add new entries for the RSS atmosphere-less bodies copying the existing format. Then in Impact/english.cfg add your phrases with the appropriate keys.

If your happy with the results send them over and I'll consider them for the next version.

  • Like 1

Share this post


Link to post
Share on other sites

The newest release on Github (1.6.3.1) is a zip inside a zip ...

The only difference is the version file.

Spoiler

 

Reminds me of a friend back in the 1990's who also made that again and again ... :wink:

I asked him for a 700 MB CD and after unfiddling the multiple zip in zip chaos I got 200 MB left.

 

 

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
29 minutes ago, Gordon Dry said:

The newest release on Github (1.6.3.1) is a zip inside a zip ...

The only difference is the version file.

  Reveal hidden contents

 

Reminds me of a friend back in the 1990's who also made that again and again ... :wink:

I asked him for a 700 MB CD and after unfiddling the multiple zip in zip chaos I got 200 MB left.

 

 

It doesn't only contain the zip, it also contains the files for the mod in the correct directory which the previous one didn't. The zip shouldn't be in there though.

Share this post


Link to post
Share on other sites

Love the mod! I wish there was a bit more autonomy to the impactor though for an Apollo style seismic experiment using an expended booster. Switching between the science package, and the booster while trying to get the CM in munar orbit can be a handful :P This would be a nice mission for the upcoming expansion pack

  • Like 1

Share this post


Link to post
Share on other sites

The flashometer isn't working in my current game. I *suspect* it might be due to sigma dimensions on a 6.4x scale (out of the many mods I run, the rescale seems most 'likely' to interfere with this).

Is anyone else having trouble (or success) with the flashometer in an up-scaled system?

FWIV, the bangometer works fine.

Share this post


Link to post
Share on other sites
11 hours ago, TheOrqwithVagrant said:

The flashometer isn't working in my current game. I *suspect* it might be due to sigma dimensions on a 6.4x scale (out of the many mods I run, the rescale seems most 'likely' to interfere with this).

Is anyone else having trouble (or success) with the flashometer in an up-scaled system?

FWIV, the bangometer works fine.

There are a couple of things that might stop you getting results. The first is the position of the flashometer. It needs to be located above the virtual horizon of the impactor i.e. it needs to be visible in the sky ignoring any mountains that get in the way. The flashometer also needs to be less than 500km away.

The second thing I've seen is a very weird bug that seems to occur when multiple craft have the same name. I haven't reliably been able to reproduce it though.

Share this post


Link to post
Share on other sites
7 hours ago, tomf said:

There are a couple of things that might stop you getting results. The first is the position of the flashometer. It needs to be located above the virtual horizon of the impactor i.e. it needs to be visible in the sky ignoring any mountains that get in the way. The flashometer also needs to be less than 500km away.

The second thing I've seen is a very weird bug that seems to occur when multiple craft have the same name. I haven't reliably been able to reproduce it though.

The virtual horizon calculation is what I was wondering if Sigma Dimensions might be screwing up - flashometer craft was definitely in view; I was looking backwards at it from the impactor all the way to impact. Distance was less than 50k. One thing pointing against this sigma/rescale is that I also can't get the flashometer to work on asteroids, where I usually just have the flashometer 'trailing' the impactor by slowing it down relative to the target once the impactor has been released. Again, distance was well under 500k, and the flashometer right behind the impact.

The thing about multiple craft having the same name IS interesting - nothing shares the name of the impactors or probes, but I do have other craft with identical names in flight. I'll try fixing this to see if that makes a difference.

Share this post


Link to post
Share on other sites

How can I make the mod stop spamming the log with "Trying to generate an impact contract" in early career?

Share this post


Link to post
Share on other sites
3 minutes ago, Gordon Dry said:

How can I make the mod stop spamming the log with "Trying to generate an impact contract" in early career?

Um download the source, comment out that line and recompile it? :rolleyes: Ok, new version coming.

  • Like 1

Share this post


Link to post
Share on other sites

I should have read how this mod works in the first place. I just crashed a probe with bangometer on it at 950m/s and waited for results.

Share this post


Link to post
Share on other sites

Anyone else notice issues with installing via CKAN? I tried installing via CKAN and the parts wouldn't do anything (impacts wouldn't register), but then I installed manually and everything works.

Share this post


Link to post
Share on other sites

@tomf

I submitted a PR to fix a KeyNotFound exception, as well as an issue about it not working outside of standard KSP

Share this post


Link to post
Share on other sites

Hi. I've got this installed through CKAN, but the Bangometer part doesn't register any data from crashes. I'm following your guide and I've tried several times. Am I missing something? Do I need anything other than the bangometer on the ship to record the data? Thanks!

Share this post


Link to post
Share on other sites
5 hours ago, Zander451 said:

Hi. I've got this installed through CKAN, but the Bangometer part doesn't register any data from crashes. I'm following your guide and I've tried several times. Am I missing something? Do I need anything other than the bangometer on the ship to record the data? Thanks!

The bangometer is on a ship on the surface of the airless body?  Not on the impactor crashing into the surface.  You fly the impactor all the way into the crash?  I'm not using a current version of KSP, but I found that switching to the bangometer probe and then back to the impactor, before crashing it into the surface, reduced or eliminated my impacts failing to register.

Share this post


Link to post
Share on other sites
1 hour ago, overkill13 said:

The bangometer is on a ship on the surface of the airless body?  Not on the impactor crashing into the surface.  You fly the impactor all the way into the crash?  I'm not using a current version of KSP, but I found that switching to the bangometer probe and then back to the impactor, before crashing it into the surface, reduced or eliminated my impacts failing to register.

Ah.... Somehow I missed that it needed an airless body. I was testing my rig on kerbin to make sure I had it working. Now I'll try it the right way! Thanks! 

Share this post


Link to post
Share on other sites
On 7/3/2018 at 4:34 PM, linuxgurugamer said:

@tomf

I submitted a PR to fix a KeyNotFound exception, as well as an issue about it not working outside of standard KSP

New release!

I've finally got round to fixing the things found by linuxgurugamer

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now