KillAshley

[1.3] [Kopernicus] New Horizons v2.0.1 [2JUN17] - It's Back!

Recommended Posts

I don't know if this falls under the known issue listed in the OP but I feel its different enough to log here.. when loaded with konstructs the view from the KSC is not just out of sync but is in fact spinning (sort of) wildly. Sonnah covers the width of the sky in about 4 seconds http://recordit.co/PLRFvGARtc

easy reproducible steps..
Load game with latest Konstructs, Kopernicus, and new_horizons, start game>save and enter tracking center, exit  to ksc view and look east (not strictly necessary but facilitates viewing)

 

output_log = https://drive.google.com/file/d/0B1BNaGWVQPr8eFphTWlqQkQ5dFU/view?usp=sharing
 

is different to when Konstructs is not present more dynamic :wink:

Share this post


Link to post
Share on other sites

Greetings all,

 

Just doing a little bit of troubleshooting. Have been having some issues with MechJeb (yeah, I know) landings on Eli. Have approach the team behind that mod as well, but just looking to see if anyone else has been having issues. Primarily have had issues with Eli, which is a pain because I'm building a fueling depot there.

 

If you've had similar issues, I'd appreciate it if you could share any workarounds. Specifically, if you're using a particular version of MJ, I'd appreciate the number. It's just that in terms of my storyline, I'm needing to complete the fueling base in order to allow my Kerbals to travel beyond Sonnah.

 

Cheers,

Share this post


Link to post
Share on other sites
On ‎2017‎-‎11‎-‎07 at 6:33 PM, Messernacht said:

Greetings all,

 

Just doing a little bit of troubleshooting. Have been having some issues with MechJeb (yeah, I know) landings on Eli. Have approach the team behind that mod as well, but just looking to see if anyone else has been having issues. Primarily have had issues with Eli, which is a pain because I'm building a fueling depot there.

 

If you've had similar issues, I'd appreciate it if you could share any workarounds. Specifically, if you're using a particular version of MJ, I'd appreciate the number. It's just that in terms of my storyline, I'm needing to complete the fueling base in order to allow my Kerbals to travel beyond Sonnah.

 

Cheers,

Your description of the issue you're experiencing is rather generic.  Answering blindly, I'd suggest that one of the few ways that a MJ issue can be caused by a specific planet in a planetpak mod is if the terrain collider were somehow not matching the visual texture.  Perhaps some elaboration would help?  Or even a link to your comment in the MJ thread?

Share this post


Link to post
Share on other sites
On 11/12/2017 at 6:09 PM, MisterFister said:

Your description of the issue you're experiencing is rather generic.  Answering blindly, I'd suggest that one of the few ways that a MJ issue can be caused by a specific planet in a planetpak mod is if the terrain collider were somehow not matching the visual texture.  Perhaps some elaboration would help?  Or even a link to your comment in the MJ thread?

Looking back at it, it is quite generic. I'll try again.

 

I'm finding that landings using MJ to land on Eli are consistently trailing to the east of the targets I've selected. Never north or south; always east. I can see it trying to make it to the target coordinates, but it never seems to quite get there. I've mostly been using a specific engine that I know has a little bit of throttle delay, so I'm not sure if this is a factor, so will be using that as a troubleshooting tactic later today. It may be an issue of the engine struggling to keep up with the spin.

 

I've run the same query by the MJ community, and while I've seen some others that have had the problem with landings, I was not able to get specific feedback regarding MJ performance in NH. I'm using the most updated version of MJ's dev versions, as they are working on the formal release of 1.3.1's fully compliant version. Whether it's a problem between the interaction of the updated Dev version of MJ and the 1.3 version of NH, I cannot say. I do know that it's pulling off landings reasonably on-point on the Mun, which does lead me to agree that it may be a terrain collider and texture issue. I'm aware that there is work being done on the updates for both mods, and I fully understand that these things take time.

 

I've hammered together a further troubleshooting list that I'm going to work through, to see if the problem occurs elsewhere in the NH system of planets and will report back. If the problem is purely with Eli, then I'll channel my inner Monolith and tell my Kerbals that all of these worlds are theirs, but they are not to set foot on Eli (I could also channel my inner Mufasa, with a similar comment). If I can replicate the issues on other planets, it may be a further issue to be looked in to.

 

Cheers,

Share this post


Link to post
Share on other sites
8 hours ago, Messernacht said:

Never north or south; always east.

Always east by the same magnitude?  Is the differential scalable to landing orbital altitude, or by body?

Try differing your decay orbit.  If you were orbiting equatorial retrograde, inclination 180, would this cause your target-drift to be westward?  (I predict: westward by a different margin).  Would inclining to a 45 or -45 orbit alter the drift?

Share this post


Link to post
Share on other sites

What can I do to fix Sonnah's rings? They show up as black and shaky in the title screen/map view.

Share this post


Link to post
Share on other sites
On 11/14/2017 at 11:17 AM, MisterFister said:

Always east by the same magnitude?  Is the differential scalable to landing orbital altitude, or by body?

Try differing your decay orbit.  If you were orbiting equatorial retrograde, inclination 180, would this cause your target-drift to be westward?  (I predict: westward by a different margin).  Would inclining to a 45 or -45 orbit alter the drift?

My apologies for the delay in response. Woke up and found there were headcrabs everywhere. A crowbar, a crowbar; my kingdom for a crowbar.

I've run through my troubleshooting and liaised with the MJ guys, and it's turned out that the problem was not with the MJ or New Horizons mods, but with the fleshy bag of goo behind the keyboard. I've added more powerful engines to my landers now and have let MJ do its thing rather than mollycoddling it. I've now managed to hammer together my fueling base.

 

Many thanks.

 

 

Share this post


Link to post
Share on other sites
On ‎2017‎-‎11‎-‎28 at 4:32 PM, Messernacht said:

A crowbar, a crowbar; my kingdom for a crowbar.

-snip-

I've added more powerful engines to my landers now and have let MJ do its thing rather than mollycoddling it.

Not sure what the crowbar expression refers to, as I've never heard it before.

And what does TWR have to do with MJ autoland?

Share this post


Link to post
Share on other sites
On 12/3/2017 at 4:29 AM, MisterFister said:

Not sure what the crowbar expression refers to, as I've never heard it before.

@Messernacht was crossing a line from Shakespeare's Richard III with a Half-Life reference. Headcrabs are the first enemy you come across in the game; the crowbar is the first weapon you come across (a few rooms later).

I got it, anyway...

Edited by capi3101
  • Like 1

Share this post


Link to post
Share on other sites

@KillAshley What color is Sonah's rings supposed to be? On mine, they are a translucent black. I reinstalled KSP with only New Horizons, the latest Kopernicus, and Module Manager 3.0.1, and it was still like that.

Not sure if any of this has to do with it, but I opened the console when I started the game, and when it got to the menu, there was a message saying "ERROR: [Kopernicus] Could not find built-in texture 05-NORMAL." It also said "Warning: Cannot find preset "Default" for pqs [planet/moon name]." for all of the bodies, and there was a NullReferenceException immediately after the message saying how long Module Manager took to load everything.

Here are the logs: https://drive.google.com/open?id=1NiqRBGqkKpcXdj09AIcXovrIVquMDWFh

EDIT: I found the issue. In Sonnah's config file (New_Horizons\KopernicusFiles\Sonnah) the rings color is "colour = RGBA(0.100, 1.000, 1.000, 1.000)" while Arin and Titanus have "color = 0.700, 0.500, 0.300, 1.000". I changed Sonnah's ring color to "color = 0.100, 1.000, 1.000, 1.000" and it looked closer to normal, but it still didn't look quite right. I lowered the green value to 0.800, and now it looks much better.

I could've sworn they were blue at some point before, so is this change a mistake or on purpose?

Edited by Micro753
  • Like 1

Share this post


Link to post
Share on other sites
On 11/12/2017 at 4:55 PM, Micro753 said:

@Nansuchao Are you still working on/planing to work on the Scatterer and E.V.E. configs?

Yes, and I'm doing it, but in a really slow pace. I'm not so good with Photoshop and I have a lack of motivation in going on right now.

  • Like 1

Share this post


Link to post
Share on other sites

I just installed New Horizons and there seems to be something wrong with Kerbin. In Kerbal Alarm Clock Kerbin appears as its own planet, not as a moon to Sonnah, Scansat scans of Kerbin yield science but don't show up in Scansat itself, and Asteroid detection missions put the target orbit really close to the sun. I've read about a reparenting bug in this topic, is this it?

Edited by Black-Two-

Share this post


Link to post
Share on other sites
On 13/12/2017 at 1:31 AM, Micro753 said:

@KillAshley What color is Sonah's rings supposed to be? On mine, they are a translucent black. I reinstalled KSP with only New Horizons, the latest Kopernicus, and Module Manager 3.0.1, and it was still like that.

Not sure if any of this has to do with it, but I opened the console when I started the game, and when it got to the menu, there was a message saying "ERROR: [Kopernicus] Could not find built-in texture 05-NORMAL." It also said "Warning: Cannot find preset "Default" for pqs [planet/moon name]." for all of the bodies, and there was a NullReferenceException immediately after the message saying how long Module Manager took to load everything.

Here are the logs: https://drive.google.com/open?id=1NiqRBGqkKpcXdj09AIcXovrIVquMDWFh

EDIT: I found the issue. In Sonnah's config file (New_Horizons\KopernicusFiles\Sonnah) the rings color is "colour = RGBA(0.100, 1.000, 1.000, 1.000)" while Arin and Titanus have "color = 0.700, 0.500, 0.300, 1.000". I changed Sonnah's ring color to "color = 0.100, 1.000, 1.000, 1.000" and it looked closer to normal, but it still didn't look quite right. I lowered the green value to 0.800, and now it looks much better.

I could've sworn they were blue at some point before, so is this change a mistake or on purpose?

probably a change in kopernicus to actually start using those values properly, originally it didn't do anything. I'll fix it very soon.

On 16/12/2017 at 8:47 PM, Black-Two- said:

I just installed New Horizons and there seems to be something wrong with Kerbin. In Kerbal Alarm Clock Kerbin appears as its own planet, not as a moon to Sonnah, Scansat scans of Kerbin yield science but don't show up in Scansat itself, and Asteroid detection missions put the target orbit really close to the sun. I've read about a reparenting bug in this topic, is this it?

possibly, however i think I'll have to check it out soon to make sure, KAC was sometimes weird with the reparenting, same with TWP....some people get issues, others don't.

Share this post


Link to post
Share on other sites
18 hours ago, KillAshley said:

probably a change in kopernicus to actually start using those values properly, originally it didn't do anything. I'll fix it very soon.

Thats because Kopernicus isn't british :wink:

Quote

colour = RGBA(0.100, 1.000, 1.000, 1.000)

It just never parsed that and used the default instead.

Share this post


Link to post
Share on other sites

just an FYI everybody, I'm back and have begun to update NH once again. Sorting through like 15 pages on the thread was a pain, but hopefully i should be able to get everything done up soon. I'm hoping to have a crack at finishing Derso (the planet which has been a placeholder up to this point) too. If you want to keep up to date you can follow the github for NH, or you can join the Kopernicus discord if you have any other issues or questions.

Edited by KillAshley
  • Like 3

Share this post


Link to post
Share on other sites
3 hours ago, KillAshley said:

just an FYI everybody, I'm back and have begun to update NH once again.

THE LEGEND HAS RETURNED!!! :D

  • Like 1

Share this post


Link to post
Share on other sites

A very cool mod overall!

 

The only thing that bugs me is that Sonnah seems to be lit well past the terminator, and the true "dark side" is quite small, covering 20% or so of the giant at best. This could be a graphical problem on my side however.

 

Also, for the OPM integration, how about this: Sarnus replaces Eeloo, just like in the mod, and Minmus becomes another moon (Mimas analogue?). Urlum, Neidon and Plock are pushed further than Vanor.

Edited by MinimalMinmus

Share this post


Link to post
Share on other sites

Quick question, has the geostationary orbital period been changed at all due to making Kerbin a moon of Sonnah? I've been having a lot of trouble creating geostationary orbits for RemoteTech satellites, and am wondering if Kerbin's position is why. I go into it more in depth in this post on reddit. Thanks

Share this post


Link to post
Share on other sites

I was cleaning up unneeded files from my backup drives when I found this. I think it's from 1.0.5.

Spoiler

HNdGh9D.jpg

 

Edited by Micro753
  • Like 2

Share this post


Link to post
Share on other sites

do kopernicus mods like this conflict with mods like scatterer?  just wondering because i have scatterer and this installed and new horizons isn't working also i cant seem to get this mod working even WITHOUT scatterer... does patch manager interfere or something? i just have a feeling one of my mods is breaking this one

Edited by mindseyemodels

Share this post


Link to post
Share on other sites

i just realized that this mod is not compatible with 1.3.1 so could we please have an update to rectify that? i REALLY love this mod and would like to enjoy it again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now