Jump to content

[1.3] [Kopernicus] New Horizons v2.0.1 [2JUN17] - It's Back!


Recommended Posts

46 minutes ago, Rob K said:

Well, for me the Mun orbit  bug isn't exactly rare.

I started a new game after a few months absence and I found that even in 1.0.5 anything I put in orbit of the Mun will eventually either crash into it or be flung out of its orbit.

As far as I can see the problem is caused by time warp when the vessel isn't loaded. I tried it in sandbox mode, put a satellite in a 250km 0degree orbit, ran the timewarp as high as it would go and watched. It ran without problems with the vessel loaded for about 5 years. Then I returned to KSC and ran time forward and within 10 days got the SOI warning for the vessel and when I checked it, it was on its way to Jool.

I put in a new satellite and tried again from the tracking station, First with the vessel selected, no problems. Unselected vessel, and within a few orbits I see the orbit shift around the Mun and it crashes after about 10 days.

I then had a little brainfart and put 2 sattelites in orbit, one as active vessel, the other as it's target and both stay in their orbits in high timewarp. Unselect the target at 100000X timewarp and Titanus, here we come !!!!

I don't suppose this little testing session will help a whole lot, I guess you would have tested the hell out of this bug yourself by now.

Mostly it stops me from doing contracts around the mun that require any orbital work. It's not a hoge hit but there are some very profitable StationScience contracts I have to pass on. And it stops me from doing a refueling operation on the mun.

I checked the forum posts and there seem to be no more reports of this issue coming in the last few months, so are there any other people still seeing this happening?

Modlist:

-New Horizons                 -KW rocketry

-KSP Interstellar E           -Infernal robotics

-KCT                                -tweakscale

-KAS/KIS                         -KAC

-TAC LS/FB                     -Station science

-Orbital science               -Mechjeb

-Scansat                         -and a lot of dependencies coming with these mods

 

Anyhow, I absolutely love this mod and the challenges it adds, so KillAshley keep up the good work and thanks for still staying on this project. I can only hope you will continue when 1.1 hits because this mod deserves 64bits KSP.

 

thanks

 

 

 

 

 

I tried to reproduce this bug a gazillion times and never got it to show up

Since you seem to get it consistently, could you try out with only

Modulemanager

Kopernicus

Newhorizons

Hyperedit

?

If you still get it consistently could you pm me about the entire process so I can try reproduce it on my pc? Thanks :)

 

Also, if you use hyperedit to put a ship in orbit, make sure you save and then reload ksp. Sometimes just hyperediting and using timewarp can give rise to weird issues

Edited by Sigma88
Link to post
Share on other sites

i was wondering what the synchronous orbits were for all the planets. i need to set up some long-range RemoteTech comsats that are hard to launch, and i can't just put them in LKO.

Link to post
Share on other sites
39 minutes ago, Plecy75 said:

i was wondering what the synchronous orbits were for all the planets. i need to set up some long-range RemoteTech comsats that are hard to launch, and i can't just put them in LKO.

you just need the rotation period and the mass of a planet, then you can go to wolfram alpha and get the SMA of the stationary orbit :)

just search for   "orbital period xxxx kg yyyyy s"

 

you can get the mass (in kg) from the tracking station. and for the rotation period you can use math.

so let's say you go to the tracking station and see that the planet has

mass = 5e18 kg
rotation period = 1day 2hrs 5minutes 20 seconds

 

just go to wolfram alpha and search for:

orbital period 5e18 kg  (1*6*3600+2*3600+5*60+20)s

 

Edited by Sigma88
Link to post
Share on other sites
14 hours ago, Sigma88 said:

*snip*

ive never been able to reliably recreate this bug tbh. Adding in extra mods could possibly cause it to appear more often, however with just NH + kopernicus I've never actually been able to find a way to reliably replicate it, it's always just been a super rare thing that happened only when loading the game, and thus I have no idea whats causing the issue. As sigma said, try and recreate it without any additional mods, because unless i can find a trigger as to whats happening i won't ever know if it's fixable or not :confused:

I havent actually thought about this bug in a LONG time, as you said noone seems to be reporting it anymore, which is both good and bad as it stops me going crazy trying to find out whats causing it and bad as it might not be fixable

Link to post
Share on other sites

Just found an hour to do some tests, made a new game folder with just Cop/NH/MM/HE as you suggested Sigma88.

And bingo, no escaping during the 30 mins or so I tried testing it.

Its just, I cant think of any mods I am currently running that can affect orbits or would be out of the ordinary for any install.

Complete list:

-Active txt mngt                  -Planetshine

-chatterer                           -Scansat

-orbital science                  -Sciencealert

-DPA                                 -Stage recovery

-Infernal robotics               -Station science

-KAS/KIS                           -TAC FB/LS

-KAC                                  -Taurus HCV

-KCT                                  -Tweakscale

-Copernicus                       +auto installed depandancies like raster etc.

-KSPI extended

-KW rocketry

-Mechjeb

-New Horizons

-NH CRP recources

So not exactly a crazy 50 mod install or anything, and as I said, nothing that should affect orbits a.f.a.i.k.

So if you see anything that could cause the problem, let me know.

 

Link to post
Share on other sites
25 minutes ago, Rob K said:

Just found an hour to do some tests, made a new game folder with just Cop/NH/MM/HE as you suggested Sigma88.

And bingo, no escaping during the 30 mins or so I tried testing it.

Its just, I cant think of any mods I am currently running that can affect orbits or would be out of the ordinary for any install.

Complete list:

-Active txt mngt                  -Planetshine

-chatterer                           -Scansat

-orbital science                  -Sciencealert

-DPA                                 -Stage recovery

-Infernal robotics               -Station science

-KAS/KIS                           -TAC FB/LS

-KAC                                  -Taurus HCV

-KCT                                  -Tweakscale

-Copernicus                       +auto installed depandancies like raster etc.

-KSPI extended

-KW rocketry

-Mechjeb

-New Horizons

-NH CRP recources

So not exactly a crazy 50 mod install or anything, and as I said, nothing that should affect orbits a.f.a.i.k.

So if you see anything that could cause the problem, let me know.

 

The best way of proceding as far as I know is this one:

Divide the extra mods you are using in two groups of the same size

Install "group A" and see if you get any bug.

If you don't get bugs install "group B"

 

Once you find the bug (either in group A or group B) divide that group in two halves and start the process again

 

If at some point, you can't find the bug anymore in any of the two groups, it means that the bug needs at least 2 mods to occur. Try to scramble the groups untill you can find the 2 (or more) mods that cause the issue

Link to post
Share on other sites

So it would seem that the 64 bit workaround (renaming the unity.exe) conflicts with this mod, causing the facilities to reset in career mode to max upgrades.  Old news I know.   There is a workaround mod that adds a button to reset them, but that mod doesn't work with Kerbal Construction Time, which I want to use.   I tried searching this thread for mentions of 64bit or facility reset, but did not find anything relevant.  I was hoping there was a patched version of Kopernicus that worked with 64 bit.  I'm using the Jool Biomes and Extrasolar planets mods and I don't want to loose them if I switch my game to 64 bit to take on more part mods.  Anyone able to offer advice?

Link to post
Share on other sites
12 hours ago, eberkain said:

Anyone able to offer advice?

At the space center create a new save and then load that save, will fix the status of the facilities the majority of the time. If not just load it again. The max facilities don't actually give you the higher benefits and is only an issue if you need to upgrade a lower facility to a higher one (which you can't do because they are max) so you can ignore the visuals if that is not the case and only save/reload when you need to upgrade.

Link to post
Share on other sites
4 hours ago, KillAshley said:

No plans for it atm, its happily hosted on both curse and github, but i could possibly be swayed in the future as long as spacedock works properly.

Fair 'nuff.  Just wanted to cast my vote for "please post it there"... NH has long been one of my favorite mods, and I'd love to be able to "follow" it on SpaceDock.

The site's up and running pretty well at this point, it's already got a few hundred mods on it and growing fast.  I've hosted all my mods there, and their download rates are rapidly climbing up to KerbalStuff levels, so the site seems to have caught on with the player base.  My impression from the SpaceDock thread is that it's got pretty good community support from a lot of dedicated people, so it ought to be reasonably stable.

Edited by Snark
Link to post
Share on other sites

Sorry if this has been discussed already but, I'm having an issue with New Horizons mod where whenever I get into the VAB the save, load, new craft and even the quit button aren't clickable.

I can build ships and all of that but the rest of the stuff (kerbal crew and subassemblies and saves and loads) is just impossible to click on.

I know it's new horizons because I tried without it and it worked, and the installed it and it didn't work anymore.

Thank you for any help.

Link to post
Share on other sites
On 27/2/2016 at 4:50 AM, Dombi said:

Sorry if this has been discussed already but, I'm having an issue with New Horizons mod where whenever I get into the VAB the save, load, new craft and even the quit button aren't clickable.

I can build ships and all of that but the rest of the stuff (kerbal crew and subassemblies and saves and loads) is just impossible to click on.

I know it's new horizons because I tried without it and it worked, and the installed it and it didn't work anymore.

Thank you for any help.

very odd, what other mods are you running?

Link to post
Share on other sites

Ajustable Landing Gear
Asclepius
Asteroid Day
B9 Aerospace Parts Pack

B9 Aerospace Procedural Parts - Fork

B9 Aerospace Propos
B9 Animation Modules

B9 Part Switch
BahamutoD Animation Modules
Better TimeWarp
Community Resource Pack
Community Tech Tree
Contract Configurator
10 contract packs which probably aren't the issue
Extrasolar Planet: Byond Kerbol - Stock
Firespitter Core
Graphic Memory Monitor

Interstellar Fuel Switch
Kerbal Alarm Clock
Kerbal Engineer Redux
Kerbol Plus Remade
Klockheed Martian General Plugin Functions - Gimbal Module
Kopernicues Planetary System Modifier
Kronkus Planet Pack
KSP Interstellar Extended
Mission COntroller 2
Module Manager
Other Worlds Star Pack
Outer Planets Mod
RasterProp Monitor COre
RemoteTech
S.A.V.E.
Saru Planet Pack
Scansat
SmokeScreen - Extended FX Plugin
SpacetuxSA
Spud
Toolbar
Trajectories
Transfer Window Planner
TweakScale
USI Core
USI Exploration Pack
USI Kolonization Core
USI Kolonization Systems
USI Tools



That was long... I use CKAN so all of them should be compatible. I'm also a sucker for planet mods... That's probably the issue I guess.

Link to post
Share on other sites
On 1/3/2016 at 5:37 PM, Dombi said:

That was long... I use CKAN so all of them should be compatible. I'm also a sucker for planet mods... That's probably the issue I guess.

could be an issue with another planet pack tbh, its probably the most likely as I've never had this bug with NH in the past.

Try removing other planet packs one at a time and loading the game and seeing if there are any issues. If the issue is still there after its only NH and the part mods, then I'll start digging deep into finding out whats causing it all. :wink:

Edited by KillAshley
Link to post
Share on other sites
On 1-3-2016 at 10:37 AM, Dombi said:

That was long... I use CKAN so all of them should be compatible. I'm also a sucker for planet mods... That's probably the issue I guess.

All the planet packs I can see are:

  • Asclepius
  • Extrasolar Planet: Beyond Kerbol - Stock
  • Kerbol Plus Remade
  • Kronkus Planet Pack
  • Other Worlds Star Pack
  • Outer Planets Mod
  • Saru Planet Pack
  • Spud - Adds a moon to Dres but Dres is already a moon of Jool in NH

Green are compatible packs, orange are unknown and red are incompatible. I'm still working on the planet packs conflicts for CKAN, but it's takes A LOT of time.

Edited by Olympic1
Link to post
Share on other sites

Is there any chance that you could make more stock-alike textures for the added planets in this mod. For example, objects like Ernus, Lave, And Titanus have too detailed texture maps, and not only is it annoying for my eyes, but my game can't run the textures well near these bodies. Just wondering if you have the time to work on this this, please take your time.

Link to post
Share on other sites
8 hours ago, AlexTheNotSoGreat said:

Is there any chance that you could make more stock-alike textures for the added planets in this mod. For example, objects like Ernus, Lave, And Titanus have too detailed texture maps, and not only is it annoying for my eyes, but my game can't run the textures well near these bodies. Just wondering if you have the time to work on this this, please take your time.

I have plans for this, however they keep getting put off due to my general attitude to this pack. Unfortunately NH has undergone so many alterations due to the introduction of Kopernicus i still view this pack as "held together by tape" pretty much. Actually this might be a good time to rectify that (after i finish my work with RSS)...let me type up a post for everyone to give their opinion on.

Link to post
Share on other sites

Attention!

New Horizons has been an active pack for (almost) a year now. HOWEVER many issues cause it to be held in contempt by myself. These issues drain my motivation to work on it and leave me with a general hate for the pack these days. I'd like your opinion on how best to deal with these issues. There are a couple options, and ill go over them below.

 

Option 1

Leave the pack how it stands now. Although this is the pack you all know and love, it frustrates me a lot and my motivation to improve it is at an all-time low. Don't get me wrong though, support is still there, and planets are pretty much scope-complete.

Option 2

Rework the bodies visuals to be better in line with stock & my other packs. If you have a look at my other packs, such as UL, or KASE  you can see how much detail i can get onto these planets while staying in the realms of stock (compared to the hyper-realism NH has). Bringing in these changes will take time certainly, however they will add a better visual to the pack, and fit in better with my other packs and also other people's packs too. With this option i would also throw a lot of better changes to the planets, such as terrain variation, improved surface textures, lighting, etc.

Option 3

Rework EVERYTHING. There's plenty about the terrain that annoys me also, however the pack has been going on for so long that I'm extremely hesitant to touch it as it can be game-breaking. This would involve remaking everything from the ground up, so theres no guarantee how it would turn out or how long it would take.

 

Please feel free to voice your opinions here, as I'd love to hear them, just please don't argue with each other about the outcome/their opinions. Everyone's voice is relevant at this point, so don't discourage other people from contributing. I'll leave this open for a while, as I'm in the middle of another project atm, so this would happen (hopefully) once it's complete.

Link to post
Share on other sites

First, thank you for making this pack: I have a blast playing it in 64x career mode.

I would say either 2 or 3 would be good choices; in anything, intentionally building hate and contempt seems daft, especially so here in a recreational activity of all places. The pack as it exists will still continue to if someone is neck deep in a career, but I don't see why progress shouldn't be made, with special note that I think you should do what gives you the best feeling: It's your pack after all, we're just lucky enough to tag along for the ride! Timewise, again, the existing pack would continue to exist, so if an overhaul, major or minor, took some time, I'd be fine with that.

In light of 1.1 as well, it might be the perfect time to ponder art assets, as a funny feeling tells me kopernicus won't be ready on launch day. (Not to be cynical, but i'd be floored if KSP was ready launch day, such an update as it is.)

Link to post
Share on other sites

IMVHO, this is one of the most amazing and intriguing planet pack ever seen and it would be really sad to see it disappears. Only you can choose the right option for the future of NH, what for you is the best way to proceed. 

I hope to have again the pleasure to use it in 1.1, anyway thanks for this wonderful masterpiece.

Link to post
Share on other sites

I love this planet pack, and I'm sure it's the same with others. I don't mind a complete re-work if you're up to it, I can start a new save. But it's totally your choice dude. Personally I wish the ground textures were better. I thought everything was perfect until I got too close to the surface of Serran and it all blobbed together horribly.

Made an account just to tell you that. Good luck!

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...