krh42

[1.0.2] FTL Drive (Updates on development)

Recommended Posts

I have hyperedit but I didn't use it in this save game yet. When you say first stage you mean any stage or stage with the FTL drive on it? When I tested I had it in a rocket with about 3 stages and the FTL unit was at the top stage. I tried it with 2 stages left and 1 stage left at around 4.5million KM, but no luck.

Edited by mcbmaestro

Share this post


Link to post
Share on other sites
I have hyperedit but I didn't use it in this save game yet. When you say first stage you mean any stage or stage with the FTL drive on it? When I tested I had it in a rocket with about 3 stages and the FTL unit was at the top stage. I tried it with 2 stages left and 1 stage left at around 4.5million KM, but no luck.

Thanks for the feedback.

Hmm, I hoped there was an easy answer. Guess there is not.

Any stage will do, as the physics loop won't run without having activated a first stage. Launch clamps should also do.

Could you try to run it with a debug build I'm using.

https://www.dropbox.com/s/biz5qusf6jfxddc/FTLDrive-WithDebugUpdatesIncluded.zip?dl=0

This one has an updates field on the UI. If it gets incremented then the OnFixedUpdate() is runnning. If this is the case and it still won't jump then it starts to get really strange.

Another thought. With these early releases the old mod directory needs to be completely deleted. It will go wrong if the new release is just copied over.

Share this post


Link to post
Share on other sites

Ok I'll try that build and report back. This is first time installing this mod so didn't overrite anything. I might try cleaning out all my mods I have a few others maybe the issues with one of those.

.. so I tried that debug build and it says updates 0 after I activate the FTL. That what you expected?

I should also mention Generated Force always reads 0.

Edited by mcbmaestro

Share this post


Link to post
Share on other sites
Ok I'll try that build and report back. This is first time installing this mod so didn't overrite anything. I might try cleaning out all my mods I have a few others maybe the issues with one of those.

.. so I tried that debug build and it says updates 0 after I activate the FTL. That what you expected?

I should also mention Generated Force always reads 0.

Well at least it is Bohr bug, and there is a good reason why it won't jump.

Could you tell, where your ship is when you try to jump, and how you got there.

Generated Force gets incremented in OnFixedUpdate() so if its not running then it will always be zero.

Share this post


Link to post
Share on other sites
Ok I'll try that build and report back. This is first time installing this mod so didn't overrite anything. I might try cleaning out all my mods I have a few others maybe the issues with one of those.

.. so I tried that debug build and it says updates 0 after I activate the FTL. That what you expected?

I should also mention Generated Force always reads 0.

I created a release candidate:

https://www.dropbox.com/s/67czckqom0oj2dx/FTLDrive-Rev4rc1.zip?dl=0

That should solve the problem.

I hope you would like to test it and see if it solves your problem. If it does I will put it up on kerbalstuff.

Share this post


Link to post
Share on other sites

Great mod! Just throwing in my opinion here, I love the way it's set up now without having to complete massive momentum changes or wait for launch windows. It's something different from everything out there in that aspect, if you wanted something that didn't change your momentum you could just use one of the many warp drive mods that function that way. I think it adds a great gameplay mechanic with having to manually set up your entire network at appropriate altitudes for transfers. If you do change the mechanics to increase force to account for momentum changes then you should also add the ability to use the drives additively through action groups. But IMHO I like it the way it is now, since lower mass ships have lower gravitational forces applied at all altitudes thus requiring a good bit of thinking to get a network set up especially if you're doing resupply missions and have to optimize multiple variables (ship mass, cargo mass, fuel, beacon altitude, etc.)

Share this post


Link to post
Share on other sites

Oh my, oh my, oh my. KSP 1.0 is out!

This is so cool.

I re-linked the MOD to the new libs in KSP 1.0. Fixed the tech tree, and tested the mod. It a pretty rushed release of the MOD for KSP 1.0, but it seams to work.

If please let me know and I will try to fix it ASAP.

Share this post


Link to post
Share on other sites

By the way, did anyone notice that your mod is number 666 on KerbalStuff? Congrats on getting that spot!

Share this post


Link to post
Share on other sites

Hey guys!

First let me say that although I haven't had success yet I still think this is a great mod from what I've read.

I used the 'Search Thread' function and apparently the word "debris" hasn't been used once in this thread....don't know if that's true or if I'm just searching wrong but debris is my problem.

I launched a satellite to Duna last night. I quicksave regularly and ALWAYS before stages. I adjust my orbit to about 25000k, turned on my beacon, and decoupled it. It floated out and away and I thought I was set until I realized it was debris.

Is that supposed to happen? If so is there a way to change a particular piece of debris so it doesn't disappear as time goes on? I like to keep my debris counts low because of my lackluster specs.

I used the search before posting this to try to save time and am sorry if this has been answered and I've just been unable to find it.

Regardless I'm going to try redoing that mission tonight with a probe core and photovoltaic panel attached to see if that makes the difference. I should've added that I decoupled just a plain beacon, not sure if I should've attached something else....I will say it felt VERY odd just releasing a single piece of equipment without a power supply so I'm hoping that's my error.

Thanks in advance and sorry again if this has been addressed or if I just lacked the common sense.

Timmy T.

Share this post


Link to post
Share on other sites
Hey guys!

First let me say that although I haven't had success yet I still think this is a great mod from what I've read.

I used the 'Search Thread' function and apparently the word "debris" hasn't been used once in this thread....don't know if that's true or if I'm just searching wrong but debris is my problem.

I launched a satellite to Duna last night. I quicksave regularly and ALWAYS before stages. I adjust my orbit to about 25000k, turned on my beacon, and decoupled it. It floated out and away and I thought I was set until I realized it was debris.

Is that supposed to happen? If so is there a way to change a particular piece of debris so it doesn't disappear as time goes on? I like to keep my debris counts low because of my lackluster specs.

I used the search before posting this to try to save time and am sorry if this has been answered and I've just been unable to find it.

Regardless I'm going to try redoing that mission tonight with a probe core and photovoltaic panel attached to see if that makes the difference. I should've added that I decoupled just a plain beacon, not sure if I should've attached something else....I will say it felt VERY odd just releasing a single piece of equipment without a power supply so I'm hoping that's my error.

Thanks in advance and sorry again if this has been addressed or if I just lacked the common sense.

Timmy T.

Hi Timmy

The idea is that the probe is connected to a fully functioning ship/space station. I have to admit that I have never tested the MOD, when the beacon was not attached to a ship or probe core.

Please let me know if you still have problems after the beacon is attached to a probe core.

Share this post


Link to post
Share on other sites

OK, my first time trying the ftl drive and beacon.

So I have put a FTL beacon about 7500km orbit around kerbin (90 degree inclination, so it will rarely be affected by minmus or mun), I have a ship orbiting Eve, and checked the stats, and it would take about 55000 oin to make a successful jump.

So how far should I put the beacon, and does my initial starting point also affect the oin requirement? Not sure how it goes (I think I have the beacon sufficiently far enough from kerbin).

Any tips would be great....methinks I should get my ship out of eve orbit in order to reduce the gravity on that side of the equation?

Cheers.

EDIT* Found out - as you go further from the gravity well (i.e. your space ship moves away from the planet or moon, and the SOI, your OIN decreases, and inherently, you chance for success (as %) increases.

Cheers, and man this is a nice one!

Edited by Gaultesian

Share this post


Link to post
Share on other sites

Gaultesian, I am having some difficulty using the ft. drive. whenever I am at an appropriate altitude, the beacon is on and I have sufficient energy, the force generated in the right click window sometimes stops or goes over and nothing happens.

Share this post


Link to post
Share on other sites

does a heavier ship need more energy to jump ? if so, then can we use more than 1 drive on a ship ?

Share this post


Link to post
Share on other sites

I would have preferred if instead of beacons, you had to punch in specific coordinates as to where you wanted to go. like type in the desired X,Y,Z orientation, as well as the desired distance you wanted to travel, something like that.

Share this post


Link to post
Share on other sites

Anyone else having difficulty with this mod since 1.0.5? My beacons are active, but the jump drives won't detect any to jump to.

Share this post


Link to post
Share on other sites

Hi Krh42,

This is an excellent mod but it does not work on the latest version of ksp. Any chance you could update it? Pretty please?! 

Share this post


Link to post
Share on other sites
On 01/12/2015 at 4:39 PM, Benjikerbal said:

I would have preferred if instead of beacons, you had to punch in specific coordinates as to where you wanted to go. like type in the desired X,Y,Z orientation, as well as the desired distance you wanted to travel, something like that.

If you type in X,Y,Z you wouldn't need to enter distance travelled, or you would end up short or over... or nowhere close to the target.

At any rate, how about you tell me the exact coordinates Duna is currently at, and we'll get you there. Oh, sorry! Duna moved tens-of-thousands of metres since you entered the coordinates. Try aga-oh, sorry! Too slow! Go on, give it another go. Ah, you want to go there? Oh, so sorry... you're now trapped in Eve's core.

Yeah, I think beacons are the best way to go about it.

Edited by Melfice

Share this post


Link to post
Share on other sites

Hey man - just gotta say I'm a huge fan of this mod.  Any plans to update for 1.1?  I kept trying to use it in 1.0.5, and not having it was a bummer.  I love making the beacon network!  I was having such a blast with it!

Share this post


Link to post
Share on other sites

I sure hope you will update for the KSP 1.1 version. I just had a look. I think it can be updated be replacing the references with the new one, and the fixing the SoundManager. I think, according to Athlonic, that "panLevel" needs to be replaced by spatialBlend, which he did for Chatterer.

After this the plugin compiles. Haven't tested if it behaves though.

Share this post


Link to post
Share on other sites

This this mod sounds great, but the KerbalStuff site has shut down (:()  and i now have no way of downloading it! Please fix that so I can download it!!

Share this post


Link to post
Share on other sites
1 hour ago, Wilm said:

This this mod sounds great, but the KerbalStuff site has shut down (:()  and i now have no way of downloading it! Please fix that so I can download it!!

I have made a quick fix on the FTL Driver MOD, for KSP 1.1. I just tested, and found that it seems to work as the original, just on KSP 1.1. Don't expect it to work on prior KSP versions.

Changes:

  • Fixed soundmanager.
  • Fixed DLL references
  • Recompiled

FTL Driver for KSP 1.1

I hope krh42 will return and maintain and develop his mod eventually. But until then feel free to use the above link.

All credit goes to krh42, and licence is as he stated.

Enjoy

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.