blackrack

[WIP][1.10.x] Scatterer-atmospheric scattering (v0.0632 - 26/08/2020)

Recommended Posts

24 minutes ago, blackrack said:

I would just disable the ocean shader, once that's done, you can run the mod on anything that already runs KSP.

Also, depending on your specs, forcing the game to run in directx 11 might give you a performance boost. Which GPU and CPU do you have?

Thanks! I'll try that. I do use the dx11 switch; seems to lessen the memory impact, as advertised. I have (get ready :D) an AMD Athlon II X2 250 @ 3 GHz and an AMD Radeon HD 5570 with 1 GB video memory; running KSP @ 1600 by 900 rez.

Share this post


Link to post
Share on other sites

Are the steps to modify scatterer to function with RSS in 1.2 the same as they were in older versions? I seem to be having problems getting atmospheres to show up on the RSS bodies using the same process described on the OP.

Share this post


Link to post
Share on other sites

Scatterer seems to act on the particles produced by SmokeScreen (under RealPlume), which possibly isn't intended (it certainly makes them look super-bright/blobby if your point of view places them above the atmosphere, especially transecting the horizon)

Is there a way to get Scatterer to not effect the thrust/exhaust particles, would SmokeScreen need to generate those particles on another layer for this?

Share this post


Link to post
Share on other sites

I disabled the ocean shader as blackrack suggested; the performance is quite acceptable (if it lags too bad during a critical time, I just look up :) life is full of compromises) and it's still gorgeous, even with low res clouds (from SVE). Thanks very much blackrack.

hm6agT9.png

Q7n74Mw.png

 

R5hHH7J.png

Share this post


Link to post
Share on other sites
7 minutes ago, Moggiog said:

Yep that's the one.  If you are using force opengl in your command line,  delete it and try the mod again

Also,  your module manager is not up to date.  It won't make a difference,  I just happened to notice. 

Edited by Galileo

Share this post


Link to post
Share on other sites

@blackrack have you ever thought about adding a subtle,  dynamic depth of field?  Is that even possible?  

Edited by Galileo

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

@blackrack have you ever thought about adding a subtle,  dynamic depth of field?  Is that even possible?  

YESYESYESYES! please!

Share this post


Link to post
Share on other sites
6 hours ago, Galileo said:

@blackrack have you ever thought about adding a subtle,  dynamic depth of field?  Is that even possible?  

Yes, and yes it's possible. I have an approach in mind but I have a few things I want to do before.

Ahh if I could have infinite time...

24 minutes ago, mulfucer said:

How to install only lensflare?

Delete all planet entries in the planetsList file.

6 hours ago, Moggiog said:

I will look at this when I can.

20 hours ago, NoMrBond said:

Scatterer seems to act on the particles produced by SmokeScreen (under RealPlume), which possibly isn't intended (it certainly makes them look super-bright/blobby if your point of view places them above the atmosphere, especially transecting the horizon)

Is there a way to get Scatterer to not effect the thrust/exhaust particles, would SmokeScreen need to generate those particles on another layer for this?

Screens?

23 hours ago, VonFrank said:

Are the steps to modify scatterer to function with RSS in 1.2 the same as they were in older versions? I seem to be having problems getting atmospheres to show up on the RSS bodies using the same process described on the OP.

I frankly don't know, I haven't tried with RSS in ages. Try the Kerbin/Earth aproach otherwise try Earth/Earth.

Share this post


Link to post
Share on other sites
9 minutes ago, blackrack said:

Yes, and yes it's possible. I have an approach in mind but I have a few things I want to do before.

Ahh if I could have infinite time...

I wish you had infinite time as well!

Share this post


Link to post
Share on other sites
On 9/26/2016 at 0:51 AM, blackrack said:

I knew about the dark bar for a while but it didn't bother me much, I will fix it soon. Effects aren't supported to work in main menu so ignore it and get in flight.

Sorry for bumping old question, is there any fix for "dark bar" issue? I'm talking about thing like this, when there is transition line clearly visible at some angles:

c2e24eddcc9ad0c5414156d1be83ec88.jpeg

Edited by Mystique

Share this post


Link to post
Share on other sites
2 hours ago, blackrack said:

Screens?

Sorry, I've taken a few shots here (imgur isn't saving the order for some reason, I may just record a video)

imgur.com/a/6mEWA

The plumes seem normal until ~14000m altitude or so and then start getting bright/white/blobby

Perhaps this is when the plume expansion is kicking in

Edited by NoMrBond

Share this post


Link to post
Share on other sites
6 minutes ago, NoMrBond said:

Sorry, I've taken a few shots here

imgur.com/a/6mEWA

The plumes seem normal until ~14000m altitude or so and then start getting bright/white/blobby

Perhaps this is when the plume expansion is kicking in

As far as I can tell that has been the way it has looked since forever.  have you tried it without scatterer? 

Share this post


Link to post
Share on other sites

Fair point, I should have tested it correctly before skipping straight on to musing

Will sort out a clean KSP install and do Scatterer-only/RealPlume-only/Scatterer+RealPlume

Share this post


Link to post
Share on other sites
Just now, Program Kerbal Space said:

How do i install plz!

Drop the scatterer folder into your gamedata folder 

Share this post


Link to post
Share on other sites
12 minutes ago, Galileo said:

Drop the scatterer folder into your gamedata folder 

do i extract?

nvm u dont

Edited by Program Kerbal Space

Share this post


Link to post
Share on other sites

I installed KSP on the Win 10 partition (before I used it under MacOS) and I installed the same mods I had before the update.

After some troubleshooting I found that the problem I was experiencing was caused by Scatterer. I removed all the mods and installed them back one at a time, until I found the one that was causing the issue.

Basically, the games loads correctly but when I start a scenario (any kind) data starts to increase in RAM at a rate of 250-300MB per second, until it reaches 32 GB (16GB RAM + 16GB virtual memory). The task manager graph indicates a steady rate throughout.
Upon filling up the memory, KSP crashes because of an access violation error (I guess no more addresses are available).

I can replicate the problem each and every time with scatterer installed (alone, no other mods that use it). If I remove scatterer, the game is perfectly playable.

What can I do? I would like to have those awesome graphics back!

--------------------------

Edit: I seem to have found a possible cause. There was a png file missing in the "config" folder (in the log there is a series of "IsolatedStorageException: Could not find file" errors). Maybe the code could be changed in order to make sure that if a file is not found scatterer doesn't start an endless loop.

Edited by Falco251
Added info

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.