blackrack

[WIP][1.10.x] Scatterer-atmospheric scattering (v0.0632 - 26/08/2020)

Recommended Posts

Strange bug going on:

 

Scatterer seems to have broken for me, as the atmospheric effects have...taken their bags and left.

 

There's no atmosphere to be seen, and every single planet is black.

 

Has this occured before, and is there a fix?

Share this post


Link to post
Share on other sites
12 hours ago, theaveragepxtseryu said:

Strange bug going on:

 

Scatterer seems to have broken for me, as the atmospheric effects have...taken their bags and left.

 

There's no atmosphere to be seen, and every single planet is black.

 

Has this occured before, and is there a fix?

Install SVE manually. CKAN's version is busted

Share this post


Link to post
Share on other sites

@skandervr/@blackrack I think I've pinned down some of what's been causing the abrupt orbital line in Spectra/Scatterer - All .raw files that I export from the config tool have an abrupt line at the edge of the atmosphere, and a second faded line some distance away.

 

Default Scatterer configs in a Stock+Scatterer install:

Spoiler

8F8Es7m.png

Jh4rGLr.png

IJjWAMN.png

uxshjyT.png

Ot2C2dq.png

Custom Scatterer configs in Spectra:

Spoiler

yVzRRBq.png

6F4UmcD.png

FruDjKS.png

BQiyfGo.png

pEK2tXc.png

 

Strangely enough the only planet that actually looks good is Eve, which is using some custom .raw files that @Stratzenblitz75 sent me. For Kod knows why they're the only ones that don't have a dreadful line. I tried recreating them using the config tool, but everything I output has that line down the center and the bad fade. Curious if you might know a setting I don't that's causing this Blackrack? The only setting in my configs that does anything visible is changing the filepath to the .raw files used, I.E. making kerbin use Eve's files and vice versa.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
25 minutes ago, Avera9eJoe said:

@skandervr/@blackrack I think I've pinned down some of what's been causing the abrupt orbital line in Spectra/Scatterer - All .raw files that I export from the config tool have an abrupt line at the edge of the atmosphere, and a second faded line some distance away.

 

Default Scatterer configs in a Stock+Scatterer install:

  Hide contents

8F8Es7m.png

Jh4rGLr.png

IJjWAMN.png

uxshjyT.png

Ot2C2dq.png

Custom Scatterer configs in Spectra:

  Hide contents

yVzRRBq.png

6F4UmcD.png

FruDjKS.png

BQiyfGo.png

pEK2tXc.png

 

Strangely enough the only planet that actually looks good is Eve, which is using some custom .raw files that @Stratzenblitz75 sent me. For Kod knows why they're the only ones that don't have a dreadful line. I tried recreating them using the config tool, but everything I output has that line down the center and the bad fade. Curious if you might know a setting I don't that's causing this Blackrack? The only setting in my configs that does anything visible is changing the filepath to the .raw files used, I.E. making kerbin use Eve's files and vice versa.

What I notice is the skybox. It seems the only time the hard line is noticeable in those screenshots is when you have a lighter section of the stock skybox. In the second set, it seems like you are using either a custom skybox, or just viewing a section of it that doesn’t have lighter areas. This is something I noticed with the stock skybox, but with a darker custom one via TR or Sigma Replacements, the hard lines are hardly noticeable.

Edited by Galileo

Share this post


Link to post
Share on other sites
37 minutes ago, Galileo said:

What I notice is the skybox. It seems the only time the hard line is noticeable in those screenshots is when you have a lighter section of the stock skybox. In the second set, it seems like you are using either a custom skybox, or just viewing a section of it that doesn’t have lighter areas. This is something I noticed with the stock skybox, but with a darker custom one via TR or Sigma Replacements, the hard lines are hardly noticeable.

 

Stock skybox with Spectra's configs:

Spoiler

hUteFat.png

4tOe9BQ.png

hVFPKtR.png

mKg3I8b.png

zLUjQQP.png

Eve still is the only good looking planet and all the rest still have a bad fade and visible line farther out. The line is less visible when in front of another planet or the stock galaxy, but that's more the fact that it's blending with the brighter color. It's the same issue regardless of the skybox. The skybox definitely isn't the root of the problem though; must be something in the .raw files I'm outputting. Don't know what it is though. On a second note, do you know if this is an issue inside of SVE too?

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
2 hours ago, Avera9eJoe said:

 

Stock skybox with Spectra's configs:

  Reveal hidden contents

hUteFat.png

4tOe9BQ.png

hVFPKtR.png

mKg3I8b.png

zLUjQQP.png

Eve still is the only good looking planet and all the rest still have a bad fade and visible line farther out. The line is less visible when in front of another planet or the stock galaxy, but that's more the fact that it's blending with the brighter color. It's the same issue regardless of the skybox. The skybox definitely isn't the root of the problem though; must be something in the .raw files I'm outputting. Don't know what it is though. On a second note, do you know if this is an issue inside of SVE too?

I don’t think you quite understood what I was getting at. 

The stock skybox is pretty bright and has an even brighter galaxy band running through it, enhancing the line at the end of the atmosphere. 

A darker custom skybox does a better job of hiding the line. 

To summarize, you are more likely to see the line with the stock skybox and less likely with a custom dark one. 

Adding distant object enhancements hides it even more.

This is probably something that has been there all along and has just been noticed by a couple users. 

Yes, SVE also has hard lines. It has since I can remember. 

Try a darker skybox and see the difference 

Share this post


Link to post
Share on other sites
4 hours ago, Galileo said:

I don’t think you quite understood what I was getting at. 

The stock skybox is pretty bright and has an even brighter galaxy band running through it, enhancing the line at the end of the atmosphere. 

A darker custom skybox does a better job of hiding the line. 

To summarize, you are more likely to see the line with the stock skybox and less likely with a custom dark one. 

Adding distant object enhancements hides it even more.

This is probably something that has been there all along and has just been noticed by a couple users. 

Yes, SVE also has hard lines. It has since I can remember. 

Try a darker skybox and see the difference 

I tried a lot of skyboxes and i still see the line just as clear with all of them. My current one from the screen shots on the Spectra thread is Galenmacil_Skybox if it matters.

However, I.m definitely not seeing that line in SVE. I have a separate install with SVE/SVT and there is no atmosphere hard edge and no line visible

Comparison (normal and contrast enhanced) i know they're not the best screenshots to compare but i was in a hurry...

nYyRFNB.gif

OyyR3Q7.gif

Edited by skandervr

Share this post


Link to post
Share on other sites

Hey Hey! So I was just casually searching for mods and found this. installed, ran the game, turned the ocean option off for more fps, and when I went to play and got inside the tracking station, my game crashed. And when I go to play EVERYTIME the game crashes. Why? I'm on 1.3.1 btw. And I'm Brazillian so I killed grammar.

Edited by Rex2.0

Share this post


Link to post
Share on other sites
1 minute ago, Rex2.0 said:

Hey Hey! So I was just casually searching for mods and found this. installed, ran the game, turned the ocan option off for more fps, and when I went to play and got inside the tracking station, my game crashed. And when I go to play EVERYTIME the game crashes. Why? I'm on 1.3.1 btw. And I'm Brazillian so I killed grammar.

Make sure you are running the x64 bit exe. If you think you already are, see the “how to get support” button in my signature below my post.

ps your grammar was superb

Edited by Galileo

Share this post


Link to post
Share on other sites

Galileo! I'm the guy that had problems with instalation on sve! You helped me but my pc was a potato. Now I have a notebook and it looks beautiful! Was trying to get scatterer as well. It works! got KSP from steam now... Sorry..... I was Pirating.... But now I bought it because now I can properly run it!!! Forgot to say thanks!

Edited by Rex2.0

Share this post


Link to post
Share on other sites

843e22d7ly1fmyq0wtwuwj22yo1o0qv8.jpg

Saw the fan art in the first page and thought that I could make one too. Then I've got this...

p.s. thx for making such a nice mod

---

* some ideas in this pic come from the game Monument Valley.

Edited by 01010101lzy

Share this post


Link to post
Share on other sites
On 30/12/2017 at 3:18 AM, 01010101lzy said:

843e22d7ly1fmyq0wtwuwj22yo1o0qv8.jpg

Saw the fan art in the first page and thought that I could make one too. Then I've got this...

p.s. thx for making such a nice mod

---

* some ideas in this pic come from the game Monument Valley.

Beautiful...

Share this post


Link to post
Share on other sites

Happy New Year all. 

So over the holidays I had the chance to reinstall my OS to Win 10 on a shiny new SDD and this prompted me to move my KSP install. This has caused a number of issues I won't get into that eventually dove me to just reinstall it from Steam and rebuild my mod list. 

I started with the game engine modifying mods and SVE. After installing it and the requisite supporting mods from CKAN and nothing else I tested my install and got a NullReferenceException in red on the Space center screen, Tracking station screen and while in flight. 

Checking above I saw that @Galileo mentioned that the CKAN version of SVE might be borked, I scrubbed the CKAN installation and manually reinstalled. The problem has persisted. Log below.

The error appears to be at line 4066 when a volumetric cloud reference is called. I'm not sure if this is a Scatterer issue, EVE issue, SVE issue or what, but the error seems to be in Scatterer so that's why I'm posting this here. 

Thanks in advance for any help or advice. 

Share this post


Link to post
Share on other sites
On 26.11.2017 at 11:16 PM, blackrack said:

Got it, I'm on it, managed to reproduce.

Edited: @maja I believe I fixed it, please test: https://github.com/LGhassen/Scatterer/blob/d119b3cd5b53ac012f0ae0bc5c68a0623cf6644a/scatterer/bin/Release/scatterer.dll?raw=true

Ehh, log?

All problems gone now! This was because I was using the config files from my old version where I could disable the Halo with your latest .dll. Once I changed to the configuration files from the latest stable release, all is well now.

But performance is much worse now. There is a micro-lag spike every second or so, where it briefly freezes.

The log contains lots of entries like this:

[LOG 17:06:43.069] [Scatterer] Added eclipse caster Laythe for Jool
[LOG 17:06:43.069] [Scatterer] Added eclipse caster Vall for Jool
[LOG 17:06:43.069] [Scatterer] Added eclipse caster Tylo for Jool
[LOG 17:06:43.069] [Scatterer] Added eclipse caster Bop for Jool
[LOG 17:06:43.069] [Scatterer] Added eclipse caster Pol for Jool
[LOG 17:06:43.073] [Scatterer] Atmosphere config found for: Jool
[EXC 17:06:43.084] NullReferenceException: Object reference not set to an instance of an object
    scatterer.SkyNode.Start ()
    scatterer.Manager.Awake ()
    scatterer.Core.Update ()

Edited by Epoxid

Share this post


Link to post
Share on other sites

Having some trouble with Scatterer on KSP on the MAC. The halo around the planets is still present, even with the fix in the config.

also, the mod seems to drastically reduce framerate to the point where the game is unplayable. Is there any way to minimize the lagging? I've already tried to turn off the ocean shaders to try and reduce it but no dice.

Not sure if the halo problem got a fix before but would really appreciate the help :)

 

Share this post


Link to post
Share on other sites
4 hours ago, Poisonchocolate said:

Yeah, I am absolutely slammed with lag. GTX 1050Ti and I have 6 fps flying around on Kerbin. Unplayable, anyone have a solution?

KSP is does not care what GPU you have, the CPU is what is necessary here. If you have a ton of mods, particularly part mods and you install scatterer, unless you have a good CPU, you can expect awful FPS, even with a 1080ti. While the 1050ti is an ok GPU, it will definitely struggle with a game like KSP, which is not well optimized, and visual mods, on top of the demanding physics of KSP.

if you have EVE installed, it’s particle system is also pretty taxing. Not much you can do there except disable the volumetric clouds.

you need to provide us with more information:

computer specs (besides the GPU), output log, screenshot of your gamedata folder. You can find a link in my signature that says “how to get support” click that and come back with the necessary files. 

If you want to try other things, turn off the ocean shaders and the water refraction in the main menu window. Other than that, there isn’t much you can do in reference to scatterer and it’s probably a hardware issue if that doesn’t help out.

Edited by Galileo

Share this post


Link to post
Share on other sites
2 minutes ago, Voodoo8648 said:

The ALT + F10/F11 doesn't seem to work anymore. I need to disable eclipses. How do I do that?

ctrl+alt+F10/F11 works too, but thats not how you disable eclipses regardless.

That is done in the main menu.

Share this post


Link to post
Share on other sites
31 minutes ago, Galileo said:

ctrl+alt+F10/F11 works too, but thats not how you disable eclipses regardless.

That is done in the main menu.

I have looked everywhere in the main menu, but I don't see an option to disable eclipses... I also looked in the scatterer configuration UI and I no longer see the option in there like I used to. How do I disable Eclipse?

Share this post


Link to post
Share on other sites
19 minutes ago, Voodoo8648 said:

I have looked everywhere in the main menu, but I don't see an option to disable eclipses... I also looked in the scatterer configuration UI and I no longer see the option in there like I used to. How do I disable Eclipse?

Capture.PNG

Its has never been in the in game UI.

Edited by Galileo

Share this post


Link to post
Share on other sites
On 1/12/2018 at 6:17 PM, Galileo said:

Not much you can do there except disable the volumetric clouds.

Just reading through because I can, and i know this is a thing that can be done but im not sure how. Can you offer some help?

D'oh, did more reading and found it in your SVE post. Thanks anyways.

Edited by Not Sure

Share this post


Link to post
Share on other sites

Logically thinking here...if I'm using ssrss which uses rss..I need to do the rss configuration changes? So rename the folders and update the config file via the instructions in the op....?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.