Jump to content

[WIP][1.10.x] Scatterer-atmospheric scattering (v0.0632 - 26/08/2020)


Recommended Posts

37 minutes ago, Cpt.Wuurd said:

Can someone explain to me how this worked

 

He's using one of the workarounds posted that hurts performance (either -force-dx12 or -force-opengl)

They hurt performance massively though.  He must have a heck of a beefy system.

Link to post
Share on other sites
5 minutes ago, R-T-B said:

He's using one of the workarounds posted that hurts performance (either -force-dx12 or -force-opengl)

They hurt performance massively though.  He must have a heck of a beefy system.

Thanks for Clarifying.

Link to post
Share on other sites
1 hour ago, Cpt.Wuurd said:

Can someone explain to me how this worked

 

They probably used the temporary fix listed in the OP.

Link to post
Share on other sites

On a ship that size my system didn't lag that bad.  The problem is that it didn't look ANYTHING as gorgeous as this.  I had my settings on max for launch, and it was no where this beautiful on a 1440p monitor.... even in screenshots.  In a bit I'll try to load up and show you what I mean.  I get everything scatterer gives using force-dx12 but it's just nothing quite as nice as this video...... maybe it's the tons of other mods and something not playing well so i'll wipe all of it except eve, scatterer and SVE before showing you. lol  I don't play on 1.9.1 yet, except to goof off until the official releases hit.  1.8.1 looks much nicer in my opinion compared to my 1.9.1 on ultra simply because I have Kopernicus and OuterPlanets installed. :P

Link to post
Share on other sites
35 minutes ago, StoneWolfPC said:

The problem is that it didn't look ANYTHING as gorgeous as this.

The author of that video is using at least a post-processing mod + customized scatterer settings.  You are definitely not going to get those visuals 'out-of-the-box'.

Link to post
Share on other sites

Well I had to verify file integrity on KSP, something borked.  Anyway I got it back up and running, then found out part of my problem is SVE mod is being goofy.  So I went with Spectra.  HOLY VISUAL YUMM!!!  But um....... what system slow down?  What are you guys doing, I want to try to repeat it for myself, because.......... mine was running really really smooth.  The only issue I ran into is that I can't load a kerbal as crew or it crashes unity.  Not a mod issue so not posting about that here.......... here's the screens........... I'm going to tinker more and see if building a vessel bigger causes as big of lag....... but minimizing my mods from over 100 to 5 really makes a difference lmfao.  I'm running:

I7-7700k stock

MSI gaming gtx1080 8gb

ASROCK z270 gaming mobo

16 gigs DDR3 3200 Gskill Ripjaws V ram

Corsair 500gb sata ssd

4g lte internet connection because I can't get anything else in this building. >.<

It's not showing the image, so here's the gallery for all of the current uploads

Link to post
Share on other sites
On 3/11/2020 at 12:56 AM, Shadowmage said:

The author of that video is using at least a post-processing mod + customized scatterer settings.  You are definitely not going to get those visuals 'out-of-the-box'.

A little excessive bloom effect too, if you ask me. :D

Link to post
Share on other sites

If you play around, having the sun at the right position for the reflections, you get nice effects.

But not gonna happen when you focus on getting your mission done.

Most of the effects can be done with ReShade but it also works on the UI and it makes it almost unusable and/or annoying.

So this is possible but not fun to play :)

Edited by Animasola
Link to post
Share on other sites
16 hours ago, Animasola said:

If you play around, having the sun at the right position for the reflections, you get nice effects.

But not gonna happen when you focus on getting your mission done.

Most of the effects can be done with ReShade but it also works on the UI and it makes it almost unusable and/or annoying.

So this is possible but not fun to play :)

KS3P works great, so I don't use ReShade on ksp personally

Link to post
Share on other sites
1 hour ago, NielsGx said:

KS3P works great, so I don't use ReShade on ksp personally

KS3P, a custom sunflare, scatterer, EVE, and I believe that's AVP or Spectra.  Oh btw........ my frame rate does drop sorry, I found out I lied................. I compared it to my modded 1.8.1 with scatterer and no custom configs and EVE on 1.9.1............... 20 fps.......... with AVP 20 fps.  My 1.8.1 fully loaded with over 150 mods............ 32 fps........................ no mods on 1.8.1 stable at roughly 80 fps with a lot of change too rapidly to get an average.  1.9.1 is slower but appears to be less jerky and laggy so runs smoother.  Exiting time warp on 1.8.1 will freeze the game for a little while, a minute, or sometimes a second.  But noticeable.  1.9.1 doesn't slow down more than a few seconds and didn't freeze at all.  Unfortunately, I am having a random bug that keeps randomly booting me in 1.9.1 and it's rather irritating.  No log showing exactly what caused it, so I do a fresh clean no mod install of 1.9.1, then it still does happens on a new save............ must be a new windows update or something not sure.  lol

Link to post
Share on other sites
5 hours ago, Capt. Hunt said:

there is a workaround, but I'm sure he'll release it when it's ready.

Wait, so there'll be a 1.9.1 update? I thought that nothing would be put out due to the DX12 workaround.

Link to post
Share on other sites
1 minute ago, alberro+ said:

Wait, so there'll be a 1.9.1 update?

I truly hope so, personally, having Scatterer working, for me is much more important than to upgrade to 1.9.1 just for the sake of it :) 

Link to post
Share on other sites
11 hours ago, alberro+ said:

Wait, so there'll be a 1.9.1 update? I thought that nothing would be put out due to the DX12 workaround.

I haven't read anything that suggests he's not working on it.

Link to post
Share on other sites
13 hours ago, alberro+ said:

Wait, so there'll be a 1.9.1 update? I thought that nothing would be put out due to the DX12 workaround.

The "workaround" barely works for most people. KSP runs like garbage on DX12, even on computers that can run any other DX12 game just fine.

Link to post
Share on other sites
18 hours ago, Capt. Hunt said:

I haven't read anything that suggests he's not working on it.

On 3/15/2020 at 5:29 AM, alberro+ said:

Wait, so there'll be a 1.9.1 update? I thought that nothing would be put out due to the DX12 workaround.

On 3/14/2020 at 10:55 PM, Gabriel B said:

Hi @blackrack  :D ! Good evening, i would like to know if we have some prevision to the release of Scaterrer 1.9.1 

There will be a proper 1.9.X update guys, I haven't worked on it much yet though for now.

 

Link to post
Share on other sites
On 3/16/2020 at 5:31 AM, blackrack said:

There will be a proper 1.9.X update guys, I haven't worked on it much yet though for now.

 

Real life takes priority.  Just know we appreciate that you will be working on it when you get to it. :D

Link to post
Share on other sites

[SOLVED] sry :unsure:

Greetings fellow Kerbonauts!

I am new to KSP and just started to use Mods, and I also get the "frozen Kerbin" glitch, but I downgraded my version to 1.8.1 using the Steam Beta option. The game shows 1.8.1, but our home planet still looks frozen (like in the menu pictures shown here). As I understand this shouldn't be the case. I even tried the config patch and forcing DX12, but nothing changed. Don't get me wrong, I can live with it if neccessary and I gladly wait for an updated version of Scatterer, but I'm confused if an update would even help when downgrading to 1.8.1 did not. Any ideas, maybe I do something wrong (I already deleted and reinstalled Scatterer after downgrading)?

EDIT: Nevermind, after restarting the game again it solved itself. No idea why, loading took longer, way more pictures were showed, and a message above the load progress bar said something about updating (can't remember what exactly it said, it ended with "76").

Oh and ... great Mod btw, Kerbin looks fantastic. Can't wait to see the rest of Kerbol!

Edited by Sepone
Link to post
Share on other sites

Hello all.

Not wishing to step on anyone's toes again, I am formerly requesting Blackrack's permission to release a binary build of the following code, which enables Scatterer to work on the unified camera in KSP 1.9.1/1.9 and generally puts us in a better situation there. 

The work is not complete, nor will I be the one to complete it!  I don't understand half of what is going on in scatterer and I do not pretend to.  I just managed to cobble together something that works.  It is presently lacking the following:

1.) Caustics and the new ocean effects are completely gone.  I wasn't able to merge them without breaking some of the old unified camera prototype code I based this on. (the branch is here: https://github.com/LGhassen/Scatterer/tree/unified-camera)

2.)  It still depends on my config fix (I'll integrate that if he lets me release it).

PS:  I want to issue full credit to blackrack for the code on this one, I just glued it together from his work by merging a bunch of stuff he otherwise would have had to do by hand likely.

Here is the source.  The following bits are really just for the dev, blackrack:

@blackrack

This is simply your unified camera branch built with all the most recent features (sunflares included) up to here: https://github.com/LGhassen/Scatterer/commit/7cadb9ae3ec13597452c6718f285a64f93c11b62

I was not able to integrate your core refactoring or caustics because I really have no idea what's going on in there with regards to the camera and was not comfortable guessing at it.

The only commits after that integrated were:

https://github.com/LGhassen/Scatterer/commit/2399fed1fa8c15d0eee57299e6fca73daee1b748 (a crash fix for the destructor)

https://github.com/LGhassen/Scatterer/commit/ded126bd70f1aa0cfa3c53a706554a5a2830f074 (a sunflare thing)

 

Nothing more was done except some merging of the codebases.  Still, it is provided in the hope that it helps somehow.  It DOES seem to work.  And it took hours.  So I hope it saves you some trouble!  Here is the source, provided under your same license (GPL-3.0): 

Source here:

http://glacialsoftware.net/scatterer-ufc.zip

Let me know if binaries would be ok (I have them ready, and they'd log themselves as version "0.0542RTBDEV" for your knowledge.

Take care and get to it when you can, just seeing if I can't help out while we all wait.  This is all I can do though, my head hurts too much after this, you are a very skilled man to understand all that.

-RTB

EDIT:  having host issues, standby.

EDIT2:  Should be good now.  There does seem to be a bug where sunflares don't work right in actual flightmap...  I'll see if I can't fix that later.

Edited by R-T-B
Link to post
Share on other sites
2 hours ago, TheKurgan said:

Tested out R-T-B's build.

Looks good so far. Works without forcing DX12.

Thanks.  The only issue I've found is the mapview in flight lost sunflares.  I'm working on it.  it's a weird bug because I can make the sunflares reappear, but they seem to map to the inflight sun angle and not the map angle when in map view.  Confused.

 

I know, I should've made this a proper github pull request, but really...  I wasn't expecting it to work. lol.

Oh, and there weren't supposed to be binaries in there.  Sorry, but I gotta scrub those until blackrack says otherwise.  You can keep what you dl'd though I'm sure.

Edited by R-T-B
Link to post
Share on other sites

 

5 minutes ago, R-T-B said:

Oh, and there weren't supposed to be binaries in there.

I didn't even check to see if there were... I downloaded your source and compiled it.

Edited by TheKurgan
Link to post
Share on other sites
2 minutes ago, TheKurgan said:

 

I didn't even check to see if there were... I downloaded your source and compiled it.

Oh, well all good then.  I just figured I'd left the bin folder and checked and yep, I had.  lol.

This one sunflare glitch is driving me crazy, but it's still tiers more usable than dx12 mode IMO.  Hope blackrack can weigh in soon.

Edited by R-T-B
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...