blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

@Bucky9000On 1.2.2, using the 'alternate SQRT' option on scatterer's startup menu (option-F11, on the menu with 'start game' etc) may work.

If that doesn't work, you can try just disabling the entire outer rim fade out feature in the configs, with these steps:

It will still look a bit weird, but less weird than the halos.

Edited by Rodger

Share this post


Link to post
Share on other sites

By any chance, is there a way to make scatterer atmospheres 'extend' above a small radius above a planet? I'm making a relatively small moon with a large atmosphere, here:

Although the atmosphere extends to 315 KM above the surface, I planned to add EVE clouds to the planet (Kniedas), which may or may not present complications with its appearance.

Share this post


Link to post
Share on other sites

@Rodger Thanks, sir, I will check this out.  I know it's all about playing the game in the end, but I also like to tinker and this has me stumped. It looks so great until this stage in the gameplay, it's gotta be something OpenGL related?  I do media creation so I live in the Mac world but if I had a PC I'd love to compare.  Anyway, thanks again for the advice.

Share this post


Link to post
Share on other sites

hello to all.

first, my thanks to all that have anything to do with this mod.  it makes everything look so real, it's crazy.. great job!!!!!

I am having problems with the "ocean blocks in space" issue.  i have tried to edit the scatter config and set     useOceanShaders =  to False.  However, for some unknown reason, every-time i change it and then start ksp, it gets re-set to True...

I must be doing something really dumb, but as that happens so often i have not been able to isolate it... lol..

thanks again for a really great mod.

cheers.

Share this post


Link to post
Share on other sites
1 hour ago, drtedastro said:

I am having problems with the "ocean blocks in space" issue.  i have tried to edit the scatter config and set     useOceanShaders =  to False.  However, for some unknown reason, every-time i change it and then start ksp, it gets re-set to True...

I must be doing something really dumb, but as that happens so often i have not been able to isolate it... lol..

as dumb as using scaterrer build for 1.2.2 with KSP 1.3.0 maybe??? try to remove scatterer, download correct version of scatterer for your KSP again and then try. There should be no need for blackrack magic. :D

This question's been asked so many times on this thread - please read the last 10 pages (if possible :P)

Share this post


Link to post
Share on other sites

Well buddy, thanks, but even I make sure that the version is the correct one.  been there, done that.  now if anyone 'ELSE' has a helpful comment, that would be nice.

The problem is not so much the blocks, but why the config file is being reset.  other than the config file itself and the Alt-F10 to scatter, what else has opportunity to change the config.  that's the real question.

again, thanks.

Edited by drtedastro

Share this post


Link to post
Share on other sites
9 hours ago, Tynton said:

By any chance, is there a way to make scatterer atmospheres 'extend' above a small radius above a planet? I'm making a relatively small moon with a large atmosphere, here:

Although the atmosphere extends to 315 KM above the surface, I planned to add EVE clouds to the planet (Kniedas), which may or may not present complications with its appearance.

If you mean scaling up the Scatterer atmosphere in terms of height, then yes - in the scatterer tool, raise the value of 'HR'.

  • Like 1

Share this post


Link to post
Share on other sites
55 minutes ago, drtedastro said:

Well buddy, thanks, but even I make sure that the version is the correct one.  been there, done that.  now if anyone 'ELSE' has a helpful comment, that would be nice.

The problem is not so much the blocks, but why the config file is being reset.  other than the config file itself and the Alt-F10 to scatter, what else has opportunity to change the config.  that's the real question.

again, thanks.

You could try setting the file to read only for a few game restarts. See if that forces it to stick.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, drtedastro said:

hello to all.

first, my thanks to all that have anything to do with this mod.  it makes everything look so real, it's crazy.. great job!!!!!

I am having problems with the "ocean blocks in space" issue.  i have tried to edit the scatter config and set     useOceanShaders =  to False.  However, for some unknown reason, every-time i change it and then start ksp, it gets re-set to True...

I must be doing something really dumb, but as that happens so often i have not been able to isolate it... lol..

thanks again for a really great mod.

cheers.

If you are using the latest scatterer in 1.3, then the floating tiles are no longer an issue. Only the 1.2.2 version of scatterer causes that issue in 1.3. 

if you are using SVE, you are not using the latest version. SVE use to use an MM cfg to make changes that would overwrite the default scatterer settings like ocean shaders. It no longer does this in the latest version. If you are not using SVE, disregard this message, but if you are, please insure you have the latest version and the most up to date dependencies.

  • Like 2

Share this post


Link to post
Share on other sites

I am trying to use Sigma Eve Recolor, but I still get the purple halo, even with the recolored planet and clouds. Is the purple color hard-coded, or can it be changed so it matches the recolor?

Share this post


Link to post
Share on other sites
5 hours ago, strudo76 said:

You could try setting the file to read only for a few game restarts. See if that forces it to stick.

Nice idea.  will give that a go.  THANKS.....

11 minutes ago, Galileo said:

If you are using the latest scatterer in 1.3, then the floating tiles are no longer an issue. Only the 1.2.2 version of scatterer causes that issue in 1.3. 

if you are using SVE, you are not using the latest version. SVE use to use an MM cfg to make changes that would overwrite the default scatterer settings like ocean shaders. It no longer does this in the latest version. If you are not using SVE, disregard this message, but if you are, please insure you have the latest version and the most up to date dependencies.

I 'was' sure that i had the latest and greatest but as this is coming from you I will start from scratch and do again to make sure i have not screw'd the pooch somehow and have a corrupted mod install.  Many thanks for your / all of the great ideas and help.

Again, thanks.

Cheers to all.

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, DJ Reonic said:

I am trying to use Sigma Eve Recolor, but I still get the purple halo, even with the recolored planet and clouds. Is the purple color hard-coded, or can it be changed so it matches the recolor?

It can, but you will have to use the config tool located in the OP

Share this post


Link to post
Share on other sites

@The White Guardian

I don't think it worked, given this result (with my EVE clouds on the same planet):

The EVE clouds extend 80-90 KM above the planet's surface. The scatterer haze would otherwise be present, although not necessarily 'above' the clouds as I'd intend.

Also, by any chance should I change the planet template from Laythe to Eve? I'm not entirely certain whether that would work or not.

Edited by Tynton

Share this post


Link to post
Share on other sites
13 hours ago, Tynton said:

@The White Guardian

I don't think it worked, given this result (with my EVE clouds on the same planet):

The EVE clouds extend 80-90 KM above the planet's surface. The scatterer haze would otherwise be present, although not necessarily 'above' the clouds as I'd intend.

Also, by any chance should I change the planet template from Laythe to Eve? I'm not entirely certain whether that would work or not.

Try the "experimentalAtmoScale" option in the scatterer UI.

 

23 hours ago, drtedastro said:

Well buddy, thanks, but even I make sure that the version is the correct one.  been there, done that.  now if anyone 'ELSE' has a helpful comment, that would be nice.

The problem is not so much the blocks, but why the config file is being reset.  other than the config file itself and the Alt-F10 to scatter, what else has opportunity to change the config.  that's the real question.

again, thanks.

Make sure you don't have a ModuleManager patch that's overriding it or something.

 

On 29/07/2017 at 0:08 AM, Bucky9000 said:


Howdy,

I'm new to the mod scene so I apologize if I missed the answer to my problem.  I'm not exactly sure what to call it so here is a screen shot.  I turned off and on most of the setting for scatterer without any luck.  I'm using 1.2.2 on a Mac, recent OSX.  I've only installed this mod on a clean install of KSP.  Any guidance would be awesome.  Thanks.

This seems to be happening on macs atm and the "alternate SQRT" option doesn't fix it. No known fix for now.

3 hours ago, Vonnmillard said:

Link to the ship lowering the Sub?

Ask @V8jester

  • Like 1

Share this post


Link to post
Share on other sites

thanks.  I am rebuilding from scratch to see what is the root of the problem.  I tried a new installation, but still had the issues, so now deleted all from that area and will start from scratch and find the problem.

thanks again to all who have offered suggestions and ideas.

Cheers.

Share this post


Link to post
Share on other sites
8 hours ago, Vonnmillard said:

Link to the ship lowering the Sub?

It was built from Sm Marine as well as LBP.... Honestly there are way too many mods (and custom patches) in my install these days to really share most of my builds I'm over 120 or so at this point....

 

Share this post


Link to post
Share on other sites

So I messed with the values in the scatterer UI (I have EVE clouds over this planet which extend to ~90 KM above the surface, the result:

I'm not certain if the atmospheric effects/haze is fixed to extend roughly 30 (ish, upon appearance) KM for example above sea level. The planet in question is 248 KM in radius, though.

Edited by Tynton

Share this post


Link to post
Share on other sites

Hi @blackrack and @Galileo. I have update on the errors mentioned before. The OnPreCull exception disappears when I switch off ocean shaders. Other exceptions are logged only when switching to or from Tracking Station.

Just to be sure, that I don't have wrong versions. I have KSP 1.3, scatterer 0.0320b, SVE 1.2.5.0 and EVE 1.2.2-1 (just mod, not configs).

Share this post


Link to post
Share on other sites

Has anybody seen this before? Is it the "halo" I keep seeing mentioned here, or is it something else? Atmosphere is being drawn in front of terrain, and disappears at certain camera angles.

e30606318d.png

332b890a7a.png

EDIT: here's another shot, showing terrain transparency:

4868b2eb66.png

 

Edited by blorgon
  • Like 2

Share this post


Link to post
Share on other sites
On 31/07/2017 at 10:01 PM, blorgon said:

EDIT: here's another shot, showing terrain transparency

This has bugged me for a while. I hope it's fixed in the future - I imagine it's a known issue because it's very common :)

Share this post


Link to post
Share on other sites
7 minutes ago, Gameslinx said:

This has bugged me for a while. I hope it's fixed in the future - I imagine it's a known issue because it's very common :)

Very known, but not really an issue, more like a limitation. Scatterer can only render perfect sphere atmospheres, leaving bodies with greater distortion with bits and pieces popping through. Raising the atmo effect looks worse, leaving a gap between the atmo effect and the surface. Gotta love unity.

Edited by Galileo
  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Galileo said:

Very known, but not really an issue, more like a limitation. Scatterer can only render perfect sphere atmospheres, leaving bodies with greater distortion with bits and pieces popping through. Raising the atmo effect looks worse, leaving a gap between the atmo effect and the surface. 

Ah, that makes sense. Perhaps it's possible to render the atmosphere after the terrain? Then again if it was possible, there would be other visual concerns.

I guess the moral of the story is to make less bumpy planets! (Or in emergencies use the spherical mesh)

Share this post


Link to post
Share on other sites
8 hours ago, Galileo said:

Very known, but not really an issue, more like a limitation. Scatterer can only render perfect sphere atmospheres, leaving bodies with greater distortion with bits and pieces popping through. Raising the atmo effect looks worse, leaving a gap between the atmo effect and the surface. Gotta love unity.

Well but what about those two screenshots I posted? In the first one the atmosphere is behaving how you describe (and how I expected, too, since you can clearly see that the "ring" starts at what appears to be Duna's sea level), but the second one shows the atmosphere behaving a little closer to how it should just by making a very small change in camera angle. Is it still Unity that is preventing the behavior in the second screenshot from being consistent, or does it have to do with the way scatterer draws the atmosphere relative to the game camera?

Share this post


Link to post
Share on other sites

Anyone could explain me wich one options leads to terrible fps drop in scatterer??Because my monster rig(i7-6700 k,32 gigs ram and gtx 1070 8 gig) don't handle it well

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now