blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

Scatterer sure helps to make the system bodies look beautiful.

But unfortunately, it also makes the night side of them so realistically pitch dark it becomes difficult or impossible to perceive what's on the surface below, especially in the Tracking Centre and map view.  I've seen this with scatterer with both Sci-Fi Visual Enhancements and Stock Visual Enhancements and despite looking worse, I've had to remove scatterer just to be able to properly play.

Is there some simple adjustment to scatterer settings to make things a bit more visible on the dark sides?  I've tried the mods Ambience Light Adjustment and Minimum Ambient Lighting and they both have no affect in the Tracking Centre and map view.

Share this post


Link to post
Share on other sites
21 minutes ago, Jacke said:

Scatterer sure helps to make the system bodies look beautiful.

But unfortunately, it also makes the night side of them so realistically pitch dark it becomes difficult or impossible to perceive what's on the surface below, especially in the Tracking Centre and map view.  I've seen this with scatterer with both Sci-Fi Visual Enhancements and Stock Visual Enhancements and despite looking worse, I've had to remove scatterer just to be able to properly play.

Is there some simple adjustment to scatterer settings to make things a bit more visible on the dark sides?  I've tried the mods Ambience Light Adjustment and Minimum Ambient Lighting and they both have no affect in the Tracking Centre and map view.

Use the stock ambient light settings. You can control ambient in different scenes individually like flight and map. (I think Tracking Station map use the same slider setting as flight map)

Share this post


Link to post
Share on other sites
43 minutes ago, Starwaster said:

Use the stock ambient light settings. You can control ambient in different scenes individually like flight and map. (I think Tracking Station map use the same slider setting as flight map)

The 3 stock ambient lighting settings don't appear to affect the dark side of bodies in the Tracking Station or map view.

To be sure there wasn't any other interaction, I used CKAN to install scatterer in a clean KSP 1.6.1 (w/Making History) test bed, with the minimum packages involved.

Spoiler

Environmental Visual Enhancements
Module Manager
scatterer
scatterer - default config
scatterer - sunflare
Stock Visual Enhancements
Stock Visual Enhancements - Low Resolution Textures

 

Using Kerbin as a test body, I moved all 3 stock ambient sliders over their full extend of -100% to +100%.  With scatterer installed, changing the stock sliders had no effect on the dark side of Kerbin in either the Tracking Station or map view.  It's dark with the lights of cities.  At +100% all other views are noticeably bright and near washed out, but Tracking Station and map views not affected.  And unable to see any terrain features on the dark sides.

Share this post


Link to post
Share on other sites

@Jacke maybe Distant Object Enhancement can help you, it has settings for ambient light too IIRC.

Share this post


Link to post
Share on other sites
6 hours ago, Jacke said:

The 3 stock ambient lighting settings don't appear to affect the dark side of bodies in the Tracking Station or map view.

To be sure there wasn't any other interaction, I used CKAN to install scatterer in a clean KSP 1.6.1 (w/Making History) test bed, with the minimum packages involved.

  Hide contents

Environmental Visual Enhancements
Module Manager
scatterer
scatterer - default config
scatterer - sunflare
Stock Visual Enhancements
Stock Visual Enhancements - Low Resolution Textures

 

Using Kerbin as a test body, I moved all 3 stock ambient sliders over their full extend of -100% to +100%.  With scatterer installed, changing the stock sliders had no effect on the dark side of Kerbin in either the Tracking Station or map view.  It's dark with the lights of cities.  At +100% all other views are noticeably bright and near washed out, but Tracking Station and map views not affected.  And unable to see any terrain features on the dark sides.

Are you running in Open GL mode? If so try DX11 or default

Share this post


Link to post
Share on other sites

Thanks for helping out here.  Didn't think of the video mode.

 

5 hours ago, Starwaster said:

Are you running in Open GL mode? If so try DX11 or default

I'm on Windows 10 using default.  Stopped using Open GL a while back when KSP became okay in Windows 64-bit as I'd heard or seen both it and DX11 had visual artifacts in one way or another.

My command line:

Quote

KSP_x64.exe -single-instance -popupwindow -nyan-nyan

"-single-instance" is what CKAN provides, so I left it in. "-popupwindow" is for the borderless full-screen sized window that makes KSP play nice with other programs.  "-nyan-nyan" is for the Nyan Cat progress indicator from Module Manager.

Tried adding "-force-d3d11".  Didn't help with the ambient light issue.  Did turn all the part selector icons in the VAB to grey blobs.

Edited by Jacke

Share this post


Link to post
Share on other sites

@Jacke out of ideas then... it doesn’t act like this for me though it does something similar if I use OGL.  (The gray icons when using DX11 is a known issue that can be worked around with Textures Unlimited but if DX11 isn’t fixing your base problem then there’s no need to use it)

:(

Share this post


Link to post
Share on other sites

@Jacke Are you sure you aren't over water? If I understood it correctly, water doesn't respond to ambient lighting yet.

As for me: My KSC, as well as all land, in perfectly well-lit, even at night.

Share this post


Link to post
Share on other sites
16 hours ago, Dafni said:

@Jacke maybe Distant Object Enhancement can help you, it has settings for ambient light too IIRC.

In DOE, I see a setting for Skybox Dimming but not anything for ambient lighting.

 

30 minutes ago, Delay said:

@Jacke Are you sure you aren't over water? If I understood it correctly, water doesn't respond to ambient lighting yet.

As for me: My KSC, as well as all land, in perfectly well-lit, even at night.

I'm looking at the whole dark side hemisphere of Kerbin, either in the Tracking Station or the map view.  There should be both land and water visible, but it's all blacked out, with only the city night lights effects visible.

 

1 hour ago, Starwaster said:

@Jacke out of ideas then... it doesn’t act like this for me though it does something similar if I use OGL.  (The gray icons when using DX11 is a known issue that can be worked around with Textures Unlimited but if DX11 isn’t fixing your base problem then there’s no need to use it)

:(

When I go into the Tracking Station, for a moment I see the dark side semi-lit, with continents visible.  Then I assume scatterer catches up and the whole dark hemisphere goes pitch black except for the city night light effects.

There's got to be something different between my video setup and yours that leads to the difference with scatterer.  I've got an NVIDIA GeForce GTX 765M with the latest drivers (version 418.81) running on Windows 10 1809.  Then KSP v1.6.1 and only those mods I listed (now along with Distance Object Enhancement and its config).

I use the wireframe toggle in the scatterer window and I can see the wireframe on Kerbin on the darkside if I zoom right it.  So the globe is being blacked out by some interaction and setting.

Share this post


Link to post
Share on other sites
22 hours ago, Jacke said:

Scatterer sure helps to make the system bodies look beautiful.

But unfortunately, it also makes the night side of them so realistically pitch dark it becomes difficult or impossible to perceive what's on the surface below, especially in the Tracking Centre and map view.  I've seen this with scatterer with both Sci-Fi Visual Enhancements and Stock Visual Enhancements and despite looking worse, I've had to remove scatterer just to be able to properly play.

Is there some simple adjustment to scatterer settings to make things a bit more visible on the dark sides?  I've tried the mods Ambience Light Adjustment and Minimum Ambient Lighting and they both have no affect in the Tracking Centre and map view.

Disable "disable ambient light in scatterer"

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, Jacke said:

Is there some simple adjustment to scatterer settings to make things a bit more visible on the dark sides?

I've found turning off, "disable scaled space ambient light," in the Scatterer menu at the KSC scene, fixes that. Then the stock graphics sliders for ambient light boost will work. (urgh, ninja'd by Blackrack!)

I've also noticed that Scatterer eclipse shadows still darken the surface beyond whatever the stock ambient light setting is, at least in map view.

Beyond both of these though: If you're using Stock Visual Enhancements as well, EVE eclipse shadows are just stupid in that they kill all ambient light, even that coming from lights on your craft. I just turn off EVE shadows and use Scatterer shadows instead.

Edited by Gordon Fecyk
  • Like 2

Share this post


Link to post
Share on other sites
27 minutes ago, blackrack said:

Disable "disable ambient light in scatterer"

 

26 minutes ago, Gordon Fecyk said:

I've found turning off, "disable scaled space ambient light," in the Scatterer menu at the KSC scene, fixes that. Then the stock graphics sliders for ambient light boost will work. (urgh, ninja'd by Blackrack!)

Thanks, both!  That worked!  I swear I looked in the scatterer config window ingame and just didn't see that "Disable scaled space ambient light" option at the bottom. :)

 

26 minutes ago, Gordon Fecyk said:

I've also noticed that Scatterer eclipse shadows still darken the surface beyond whatever the stock ambient light setting is, at least in map view.

Beyond both of these though: If you're using Stock Visual Enhancements as well, EVE eclipse shadows are just stupid in that they kill all ambient light, even that coming from lights on your craft. I just turn off EVE shadows and use Scatterer shadows instead.

Thanks for that.  I looked and I think SVE now doesn't use EVE shadows itself.  In "GameData/StockVisualEnhancements/SVE_Configs/EVE_Eclipse.cfg",

Spoiler

EVE_SHADOWS
{
	//OBJECT
	//{
	//	body = Kerbin
	//	caster = Mun
	//}
	//OBJECT
	//{
	//	body = Mun
	//	caster = Kerbin
	//}
	//OBJECT
	//{
	//	body = Eve
	//	caster = Gilly
	//}
	//OBJECT
	//{
	//	body = Gilly
	//	caster = Eve
	//}
	//OBJECT
	//{
	//	body = Duna
	//	caster = Ike
	//}
	//OBJECT
	//{
	//	body = Ike
	//	caster = Duna
	//}
	//OBJECT
	//{
	//	body = Jool
	//	caster = Laythe
	//	caster = Bop
	//	caster = Tylo
	//	caster = Vall
	//}
	//OBJECT
	//{
	//	body = Pol
	//	caster = Jool
	//}
	//OBJECT
	//{
	//	body = Bop
	//	caster = Jool
	//}
	//OBJECT
	//{
	//	body = Tylo
	//	caster = Jool
	//	caster = Laythe
	//	caster = Vall
	//}
	//OBJECT
	//{
	//	body = Laythe
	//	caster = Jool
	//	caster = Tylo
	//	caster = Vall
	//}
	//OBJECT
	//{
	//	body = Vall
	//	caster = Jool
	//	caster = Laythe
	//	caster = Tylo
	//}
}

 

the entire coding for shadows is commented out.  If there's another config you suggest I adjust, can you tell me where to find it?  Thanks.

Share this post


Link to post
Share on other sites
9 hours ago, Gordon Fecyk said:

I've also noticed that Scatterer eclipse shadows still darken the surface beyond whatever the stock ambient light setting is, at least in map view.

Yep, because the eclipse is just a multiplicative filter which darkens what's behind it. It doesn't integrate with the lighting system which means it has no notion of ambient or directional light, it doesn't darken the light component, it darkens the surface after it has been rendered.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Jacke said:

The entire coding for shadows is commented out.  If there's another config you suggest I adjust, can you tell me where to find it?

Stock Visual Enhancements has another EVE_SHADOWS section in another file: Scatterer_EVEShadows.cfg, that is not commented out. This is the one that gets used when Scatterer is present, and at the start of a new game you can see Vall become a black ball in Jool's shadow. Also, if you try to land something on the Mun while in Kerbin's shadow you can't even see the surface, even with landing lights on the craft.

I deleted this file entirely in my installation of SVE.

  • Like 1

Share this post


Link to post
Share on other sites
On 2/16/2019 at 4:46 AM, blackrack said:

Yep, because the eclipse is just a multiplicative filter which darkens what's behind it. It doesn't integrate with the lighting system which means it has no notion of ambient or directional light, it doesn't darken the light component, it darkens the surface after it has been rendered.

Just want to say, as an end user rather than a modder I love getting these little bite sized glimpses into how things work. Helps me understand what I am looking at/if I am having bugs vs intended features.

  • Like 1

Share this post


Link to post
Share on other sites
On 2/16/2019 at 4:27 AM, Gordon Fecyk said:

Stock Visual Enhancements has another EVE_SHADOWS section in another file: Scatterer_EVEShadows.cfg, that is not commented out. This is the one that gets used when Scatterer is present, and at the start of a new game you can see Vall become a black ball in Jool's shadow. Also, if you try to land something on the Mun while in Kerbin's shadow you can't even see the surface, even with landing lights on the craft.

I deleted this file entirely in my installation of SVE.

Thanks, @Gordon Fecyk!  I've now done the same.

Share this post


Link to post
Share on other sites

Working AA (notice no black lines or aliasing around horizon and mountains)

8ko9Qxg.jpg

 

8ln7KqD.jpg

 

Compatibility with camera mods:

IIz4ON8.jpg

 

 

  • Like 24

Share this post


Link to post
Share on other sites
22 minutes ago, blackrack said:

Working AA (notice no black lines or aliasing around horizon and mountains)

Pure awesomeness! Thanks a ton! Definitely finally a real reason to move to 1.6.1 from 1.3.1 once you release it. Cheers man, I appreciate your work a lot.

 

On 2/16/2019 at 12:27 PM, Gordon Fecyk said:

Stock Visual Enhancements has another EVE_SHADOWS section in another file: Scatterer_EVEShadows.cfg, that is not commented out. This is the one that gets used when Scatterer is present, and at the start of a new game you can see Vall become a black ball in Jool's shadow. Also, if you try to land something on the Mun while in Kerbin's shadow you can't even see the surface, even with landing lights on the craft.

I deleted this file entirely in my installation of SVE.

Oh, thank you for this. I never knew that, but was bothered by this issue before. Cheers.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, blackrack said:

Working AA (notice no black lines or aliasing around horizon and mountains)

Hello @blackrack

Does it mean it also might be more "rescale friendly" ?

Share this post


Link to post
Share on other sites
7 minutes ago, evileye.x said:

Hello @blackrack

Does it mean it also might be more "rescale friendly" ?

Depends on which issue you have with rescale.

Share this post


Link to post
Share on other sites
On 4/12/2015 at 9:26 PM, blackrack said:

Just launch a craft

yes

Sorry to ask it this way, Are we close to have a 1.6 update release or do we need to go with 1.5.x and read the last pages for tweaks?

Share this post


Link to post
Share on other sites
On 2/19/2019 at 9:20 PM, blackrack said:

Depends on which issue you have with rescale.

I don't know how to describe it in words... White edges on mountains in transition to orbit?.. I'll make proper screenshots eventually.

 

Share this post


Link to post
Share on other sites
20 hours ago, Cratzz said:

Hi, it looks a little wierd for me here. Not sure if it's driver related or if it's got to do with this mod. As you can see on the outline of Kerbin there is something not right.

Does anyone have any ideas? Thank you!

https://www.dropbox.com/s/o3hv7vz12qicgsc/Untitled.png?RAW=1

That's just the atmosphere extinction, that's nomal for the latest version. In the next (unreleased version) I've toned it down and made it much less high.

7 hours ago, Jiraiyah said:

Sorry to ask it this way, Are we close to have a 1.6 update release or do we need to go with 1.5.x and read the last pages for tweaks?

Current version works fine in 1.6 no? What tweaks are you looking for?

1 hour ago, evileye.x said:

I don't know how to describe it in words... White edges on mountains in transition to orbit?.. I'll make proper screenshots eventually.

Hmm, so here is what causes this. The reason is in local space you have mountains and a lot of features, but in orbit the planet is spherical, perfectly so, and the tranistion between them is just fading out the moutains and revealing the flat sphere.

Either in the current version or the next, fading out the scatterer effect will not look right and will always reveal brighter and whiter mountains, believe me I tried. So I can't and will not fix it.

However a solution is to make a scaledSpace object (ie the orbit model) which matches the local space model (the one with mountains), and then everything will be perfect! Especially so in the next version of scatterer. If any modder maintaining a visual pack or a planet pack wants to fix it, this is the way to do it, and will look perfect in next release (due to new way of handling the effects on scaled Space objects, but will not look better in current). This is not scatterer's job to fix, since it essentially requires changing the model of the planet.

Edited by blackrack
  • Like 5

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

ither in the current version or the next, fading out the scatterer effect will not look right and will always reveal brighter and whiter mountains, believe me I tried. So I can't and will not fix it.

I have 1.3 install with quite old version of scatterer, and this particular problem looks way better.

I'll try to find time to make proper screenshot to show what exactly I mean for clarity. Until then, thank you for response and your amazing mod.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now