blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

7 minutes ago, blackrack said:

Does anybody else feel the stock re-entry/mach effects are big performance hogs?

They are - but can anything be really done?

Share this post


Link to post
Share on other sites
Just now, sashan said:

They are - but can anything be really done?

Well I'm not sure, I was just thinking about using the same method as the godrays method I'm using or the improved one rbray suggested with the projected grid. Only limitation I can imagine is that it might be tricky to make them visible from the inside, like is currently the case with terrain godrays. I was watching this https://youtu.be/mXTxQko-JH0?t=1496 and it seems the method they're using is a lot more complicated with a fur-like shader. They also tried a godrays method but they don't get in detail on why they dropped it, they only mention it drawing on top of the UI but they probably ran into the same limitation or something else.

Share this post


Link to post
Share on other sites
17 hours ago, V8jester said:

also @daniel l. the lens flare is fairly easy to modify. I ripped the textures from an asset file for AVP I2 and was able to modify it to work with scatterer. And modders can use a similar approache as texture replacer. Just make there own textures and you would over right existing scatterer textures. Then you would have a new flare with fewer mod folders to keep track of.

I understand that :) Great textures btw, But the reason why i want a standalone flare is so i can have beautiful space engine like flares for the stars in my upcoming pack Here is a screenshot of Space Engine showing what such a mod could do:space_engine_exploration_log_3__exotic_b

Share this post


Link to post
Share on other sites

Can the Mun be made to shine? I know you showed multiple light sources before, is it too taxing?

Share this post


Link to post
Share on other sites
3 minutes ago, selfish_meme said:

Can the Mun be made to shine? I know you showed multiple light sources before, is it too taxing?

Wait... Multiple light sources! YESSSSS This has been an issue with Kopernicus forever now! @blackrack Please i mean PLEASE give whatever source code you have to @Thomas P. So we can all finally have working binary systems.

 

Sorry to steal the show there @selfish_meme i just didnt know that was possible and im really excited

Edited by daniel l.

Share this post


Link to post
Share on other sites
1 hour ago, selfish_meme said:

Can the Mun be made to shine? I know you showed multiple light sources before, is it too taxing?

It's not, planetshine is still planned.

1 hour ago, daniel l. said:

Wait... Multiple light sources! YESSSSS This has been an issue with Kopernicus forever now! @blackrack Please i mean PLEASE give whatever source code you have to @Thomas P. So we can all finally have working binary systems.

Sorry to steal the show there @selfish_meme i just didnt know that was possible and im really excited

Really the "source code" was just copying the sun's Light component and changing it's intensity and moving it around, not exactly something @Thomas P. would have trouble with. Why doesn't multiple suns work in Kopernicus?

Edited by blackrack

Share this post


Link to post
Share on other sites

Anybody else having weird line/shadow things originating from vessels sometimes? I'm using an AMD GPU if that might have anything to do with it.

b8104lQ.png

HRtccCn.png

Share this post


Link to post
Share on other sites

Yeah, IIRC, that's a know issue with Godrays.  I think we have to live with them for a bit or turn that feature off.

Share this post


Link to post
Share on other sites

If only people would read the OP or the last few pages for this kind of thing...

Share this post


Link to post
Share on other sites
11 hours ago, blackrack said:

Really the "source code" was just copying the sun's Light component and changing it's intensity and moving it around, not exactly something @Thomas P. would have trouble with. Why doesn't multiple suns work in Kopernicus?

Its an issue with light sources and lens flares, See @Thomas P.'s post below. I really do believe that you have solved several problems, Your flare plugin with a slight modification could allow binary stars to shine at the same time, And if you can really make multiple light sources work then you deserve a medal because @Thomas P. Hasnt had time to implement that and you could really have just saved all us planet pack makers's skins.

On 1/27/2016 at 6:51 AM, Thomas P. said:

Multiple Lensflares and light sources are not easy to program at all. I haven't found the time for implementing it properly yet. Generally I have a lot of cool ideas for Kopernicus, and KSP in general, but I simply don't have the time to implement them all, because I'm the sole maintainer of Kopernicus. I haven't had any bigger contributions since Version 0.2, and never a regulary contributor.

I would love to share the developer role with someone else, but there are various reasons why I don't expect regular contributions. :( Which is sad..

Share this post


Link to post
Share on other sites

@blackrack So everything turning blue (I honestly have never seen it before now ) I even went as far as rebuilding my install. It looks like it appears in versions 232 and 233. It accurse before a normal crash due to the normal memory leak in the base game. So I don't really see this as a "Bug" for you to fix. Really hope 1.1 brings with it a more stable use of memory.

So again as I said previously. Amazing job man! I truly can't believe this is the same game after everything you've done. Thank you!

Share this post


Link to post
Share on other sites
11 hours ago, daniel l. said:

Its an issue with light sources and lens flares, See @Thomas P.'s post below. I really do believe that you have solved several problems, Your flare plugin with a slight modification could allow binary stars to shine at the same time, And if you can really make multiple light sources work then you deserve a medal because @Thomas P. Hasnt had time to implement that and you could really have just saved all us planet pack makers's skins.

Alright, I'll see what I can do. Btw @daniel l. keep in mind additional light sources will not work with the stock sky but will work with stock planets, terrain and water, it's one of the reasons I wanted to add this to the scatterer sky.

7 hours ago, V8jester said:

@blackrack So everything turning blue (I honestly have never seen it before now ) I even went as far as rebuilding my install. It looks like it appears in versions 232 and 233. It accurse before a normal crash due to the normal memory leak in the base game. So I don't really see this as a "Bug" for you to fix. Really hope 1.1 brings with it a more stable use of memory.

So again as I said previously. Amazing job man! I truly can't believe this is the same game after everything you've done. Thank you!

Hmm I'm not sure why it would still happen really, I'll try to send you a modified .dll you can test with.

Edited by blackrack

Share this post


Link to post
Share on other sites
On March 5, 2016 at 0:50 PM, V8jester said:

I was just too stoked about this, I have to share. So I put GEM FX on top of everything (Scatterer EVE AVP) and this was the end result :)

 

You sir, are a god.

Share this post


Link to post
Share on other sites
3 hours ago, blackrack said:

Hmm I'm not sure why it would still happen really, I'll try to send you a modified .dll you can test with.

Here is something I just thought about...

I've been working on rockets instead of planes the last few days. Would jumping in and out of map view and manipulating nodes (general rocket stuff) have anything to do with how Scatterer works? I did notice map view was experiencing similar "Blue" texture issues. Like a Blue Moon yes I said it :)  As well as dark blue trajectory lines. Also whatever was blue would change color as I zoomed in / out from it. And lastly planets would be covered by huge square Shadows that would render like something more inline with Minecraft. (Squares would move based on where you where looking. Really strange stuff, It honestly seems to have cropped up out of no where.

And before you waste too much time. DX11 wont corrupt anything if you are trying DX9, DX11 OpenGL right? I recall seeing someone mention that the -nosinglethread command would corrupt saves. But I have never seen anyone have issues switching between DX11 or DX9. This was also something I was playing with the last couple of days. I have been running DX9 almost religiously, but tried DX11 when 233 came out, to try an further optimize everything.

Hopefully I'm not just forming a rabbit trail here.

25 minutes ago, Cooboo said:

You sir, are a god.

Nah, there's only one of them. And I'm pretty sure he doesn't play KSP.

Share this post


Link to post
Share on other sites
11 hours ago, blackrack said:

Alright, I'll see what I can do. Btw @daniel l. keep in mind additional light sources will not work with the stock sky but will work with stock planets, terrain and water, it's one of the reasons I wanted to add this to the scatterer sky.

Hmm I'm not sure why it would still happen really, I'll try to send you a modified .dll you can test with.

Its ok, It should work fine if both stars are close enough in the sky to each other that one can cover the lighting for the other. :) 

Share this post


Link to post
Share on other sites
8 minutes ago, zilfondel said:

Umm, so how do I fix this?

 

Scatterer, no EVE, just stock settings:

 

MV8ohRsl.png

@blackrack these are the "Square shadows" I mentioned previously.

Share this post


Link to post
Share on other sites

I found an odd bug that only occurs at night time that highlights the edge of objects with strange, red dots. It only started happening when I updated to the newest version of Scatterer.

HBqrHbB.jpg

I checked the OP and didn't see anything relating to this.

Edited by Arditan427

Share this post


Link to post
Share on other sites

Hey, so I was working on a rocket, loaded it up to launch, noticed that there were no Scatterer effects (after it worked great just minutes before with a different vessel) and alt+f11 showed no configs, observed my performance going in the toilet, and checked the debug log to find a lot of "out of memory exception" and "added eclipse caster Mun for Kerbin" and "added eclipse caster Minmus for Kerbin" spam.

Here's the KSP.log: https://drive.google.com/file/d/0B6ZYgATQfNhBb1ZLQjZfRU91MXM/view?usp=sharing

The trouble appears to begin around [LOG 20:08:07.097].

Share this post


Link to post
Share on other sites
8 hours ago, theonegalen said:

Hey, so I was working on a rocket, loaded it up to launch, noticed that there were no Scatterer effects (after it worked great just minutes before with a different vessel) and alt+f11 showed no configs, observed my performance going in the toilet, and checked the debug log to find a lot of "out of memory exception" and "added eclipse caster Mun for Kerbin" and "added eclipse caster Minmus for Kerbin" spam.

Here's the KSP.log: https://drive.google.com/file/d/0B6ZYgATQfNhBb1ZLQjZfRU91MXM/view?usp=sharing

The trouble appears to begin around [LOG 20:08:07.097].

Have you checked your memory usage in the windows task manager when this happens?

8 hours ago, Arditan427 said:

I found an odd bug that only occurs at night time that highlights the edge of objects with strange, red dots. It only started happening when I updated to the newest version of Scatterer.

I checked the OP and didn't see anything relating to this.

You're the second person to report this and the guy before didn't give enough info to know what's going on. So yeah, poke around more, play with the settings, play with the features, play with your driver, check the debug log etc etc until you find something that affects it at all because at the moment I have no idea what this is. Also try forcing dx11 or opengl.

10 hours ago, zilfondel said:

Umm, so how do I fix this?

Scatterer, no EVE, just stock settings:

Same as above, try to find some sort of clue and do a more detailed report.

 

Edited: I found something interesting.

You know how the terminators look weird when using both scatterer and EVE? By making the atmosphere draw on top of the clouds instead of under, the terminator can be made really soft.

Before:

YmqbgEV.jpg

After:

hCZrCZr.jpg

The shadows don't disappear either, they're there, but subtler, can mostly be seen to the left, in the brightest area:

rlQGeON.jpg

TJdZwmd.jpg

 

mNZBhWl.jpg

GVP3mDc.jpg

In a way this is wrong as it treats the clouds as if they were at the ground level, but I find the end results looks pleasing and more homegeneous.

Thoughts on this? @Proot @Nhawks17 @pingopete

Also, if I go through with this, the transition from PQS to scaledSpace may be even more problematic, may have to work something out with @rbray89

Edited by blackrack

Share this post


Link to post
Share on other sites
On 2/19/2016 at 7:52 PM, blackrack said:

Very nice! I had been aware of this issue in EVE for a while, I guess if there's no fix, then covering it up with beautiful atmo shading works just as well X) Are the cloud shadows being made non-visble however? The issue I found with eve is that it simulated the darkening cloud terminator effect too soon on the terminator. Ideally we could get some way to manually position the terminator on the planet (EVE). Also does your atmo shader still work on a multiply effect?

Edited by pingopete

Share this post


Link to post
Share on other sites
Just now, pingopete said:

Very nice! I had been aware of this issue in EVE for a while, I guess if there's no fix covering it up with beautiful atmo shading works just as well X) Are the cloud shadows being made non-visble however? The issue I found with eve is that it simulated the darkening cloud terminator effect too soon on the terminator. Ideally we could get some way to manually position the terminator on the planet. Also does your atmo shader still work on a multiply effect?

They're still there, but subtler (perhaps way too subtle), if you look in the second set of screenshots you can see them on the left side, near the brightest area. In the first set of screenshots you can also see them near the sun's reflection. Well with scatterer you can't really control where the terminator starts or ends :(

The extinction part works with multiply blending (you can see it tinting the clouds yellow-brown in some of the screens, the atmo color works with additive blending.

Share this post


Link to post
Share on other sites
3 minutes ago, blackrack said:

They're still there, but subtler (perhaps way too subtle), if you look in the second set of screenshots you can see them on the left side, near the brightest area. In the first set of screenshots you can also see them near the sun's reflection. Well with scatterer you can't really control where the terminator starts or ends :(

The extinction part works with multiply blending (you can see it tinting the clouds yellow-brown in some of the screens, the atmo color works with additive blending.

Ok cool, nah I didn't mean that'd be something for scatterer, I was thinking it could be something for EVE which handles the clouds. Either way it's been too long since I tested with the latest Scatterer versions; so many new features I have yet to try out. Shame rbray has been out of business for a while though :(

Edited by pingopete

Share this post


Link to post
Share on other sites
12 minutes ago, pingopete said:

Ok cool, nah I didn't mean that'd be something for scatterer, I was thinking it could be something for EVE which handles the clouds. Either way it's been too long since I tested with the latest Scatterer versions; so many new features I have yet to try out. Shame rbray has been out of business for a while though :(

Alright, another advantage I have found to this is that eclipses will also work on clouds this way, at least from an orbital viewpoint:

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, blackrack said:

Alright, another advantage I have found to this is that eclipses will also work on clouds this way, at least from an orbital viewpoint:

 

 

Ah yes no this method works much better in this case!!

Edited by pingopete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.