blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

I like it! It really doesn't look like much of a big difference that it would effect anything (at least from your pictures). I really like that it fixes the eclipse shadow on clouds. When I was testing the Laythe-Jool interaction yesterday I noticed the eclipse looked really weird given it was making the planet dark but the bright white clouds were still there. I'm in favor of it!

Share this post


Link to post
Share on other sites
5 hours ago, blackrack said:

Alright, another advantage I have found to this is that eclipses will also work on clouds this way, at least from an orbital viewpoint:

 

Nuh uh! Nowai!!! Whut sorcery is this???

Ooooooo how does it interact with the god rays? Someone needs to get a shot of an eclipse on the horizon (as in during sunrise). That would look awesome

Edited by Starwaster

Share this post


Link to post
Share on other sites

Those strange terminators where allways the biggest flaw of scatterer for me. Great you managed to fix them, now it looks very good!

Share this post


Link to post
Share on other sites
7 hours ago, blackrack said:

In a way this is wrong as it treats the clouds as if they were at the ground level, but I find the end results looks pleasing and more homegeneous.

I think that you can actually assume clouds to be at the ground level - at least in RSS. They are quite low actually IRL - most of the atmo is above them.

Share this post


Link to post
Share on other sites
Just now, sashan said:

I think that you can actually assume clouds to be at the ground level - at least in RSS. They are quite low actually IRL - most of the atmo is above them.

While it's true that they are rather low altitude-wise, I would think the thickest part of the atmosphere is beneath them.

Share this post


Link to post
Share on other sites
7 hours ago, blackrack said:

Have you checked your memory usage in the windows task manager when this happens?

You're the second person to report this and the guy before didn't give enough info to know what's going on. So yeah, poke around more, play with the settings, play with the features, play with your driver, check the debug log etc etc until you find something that affects it at all because at the moment I have no idea what this is. Also try forcing dx11 or opengl.

Same as above, try to find some sort of clue and do a more detailed report.

 

The shadows don't disappear either, they're there, but subtler, can mostly be seen to the left, in the brightest area:

TJdZwmd.jpg

GVP3mDc.jpg

In a way this is wrong as it treats the clouds as if they were at the ground level, but I find the end results looks pleasing and more homegeneous.

Thoughts on this? @Proot @Nhawks17 @pingopete

Also, if I go through with this, the transition from PQS to scaledSpace may be even more problematic, may have to work something out with @rbray89

Looks lovely! One thing I could do is lower the intensity of cloud shadows near the terminator. Another thing we could talk about would be to write a value to alpha in the screen buffer to control how much the scatterer overlays blend.

Share this post


Link to post
Share on other sites
3 minutes ago, blackrack said:

While it's true that they are rather low altitude-wise, I would think the thickest part of the atmosphere is beneath them.

Okay, I'll make a quick check of that. At which altitude are RSS clouds at?

 

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

hile it's true that they are rather low altitude-wise, I would think the thickest part of the atmosphere is beneath them.

Well, I quickly did this graph. 
DVnVQTR.png
Half of the atmosphere mass-wise is below 5 km :P 

Edited by sashan

Share this post


Link to post
Share on other sites
29 minutes ago, sashan said:

Well, I quickly did this graph. 
Half of the atmosphere mass-wise is below 5 km :P 

It seems most of the clouds are below 5 km though, so you were right :P

1 hour ago, rbray89 said:

Looks lovely! One thing I could do is lower the intensity of cloud shadows near the terminator. Another thing we could talk about would be to write a value to alpha in the screen buffer to control how much the scatterer overlays blend.

Yeah, that would be cool. One quick question though, I noticed that your clouds are composed of the "texture" layer mapped onto a sphere that you see from orbit and the particle-like volumes that you see from the ground or when flying through the cloud layer. Is there a reason you switch the sphere layer between local space and scaled space and not keep it in scaled space all the time? I would've thought it's so craft can fly through it but you seem to "create a hole" in that layer when the craft get through it.

Edited by blackrack

Share this post


Link to post
Share on other sites
45 minutes ago, blackrack said:

Is there a reason you switch the sphere layer between local space and scaled space and not keep it in scaled space all the time? I would've thought it's so craft can fly through it but you seem to "create a hole" in that layer when the craft get through it.

Otherwise you'd get a situation where clouds are behind terrain all the time when looking down at the body. It'd be fine when looking from ground to sky though, aside from when the cloud layer should go through mountains.

Share this post


Link to post
Share on other sites
Just now, rbray89 said:

Otherwise you'd get a situation where clouds are behind terrain all the time when looking down at the body. It'd be fine when looking from ground to sky though, aside from when the cloud layer should go through mountains.

Yeah, that went right over my head, I've been thinking about this too much today :P . I'm going to have to move my orbital shader into local space and fade it in and then switch to scaledspace I guess.

Share this post


Link to post
Share on other sites
13 hours ago, blackrack said:

You're the second person to report this and the guy before didn't give enough info to know what's going on. So yeah, poke around more, play with the settings, play with the features, play with your driver, check the debug log etc etc until you find something that affects it at all because at the moment I have no idea what this is. Also try forcing dx11 or opengl.

 

 

I'm not really sure what I would be looking for though, should I post my output log or something like that?

Share this post


Link to post
Share on other sites
On 6 March 2016 at 9:05 PM, blackrack said:

Does anybody else feel the stock re-entry/mach effects are big performance hogs?

 

Yes, plus they come in ridiculously early, I actually adjusted them to come in much later, over Mach 4, so now if I have flames something is going to blow up soon

Share this post


Link to post
Share on other sites
15 hours ago, blackrack said:

Have you checked your memory usage in the windows task manager when this happens?

Yes, the KSP memory usage at the time was ~3,200,000b. I played again, and even though I got up to ~3,550,000b, I didn't have the same problem. Both times, I still had at least a GB of my RAM free.

Share this post


Link to post
Share on other sites
9 hours ago, selfish_meme said:

Yes, plus they come in ridiculously early, I actually adjusted them to come in much later, over Mach 4, so now if I have flames something is going to blow up soon

Oh I'd like to know how you did that.

 

No, forum editor. Don't just merge posts like that. At least put a divider in between!

 

Interesting loop ... loop ... loop ... loop.

Maybe because of the ~20 units having a party at the KSC. Interface still works though. Don't know what will happen when I switch to simulation yet.

Rl2Bita.png

Edited by Azimech

Share this post


Link to post
Share on other sites
5 minutes ago, Azimech said:

Oh I'd like to know how you did that.

aeroFXVelocityExponent = 3.5
aeroFXDensityExponent1 = 0.5

In physics.cfg, I think I chose 4.0 and 1.0 instead, I can't check ATM

Edited by selfish_meme

Share this post


Link to post
Share on other sites
Just now, selfish_meme said:

aeroFXVelocityExponent = 3.5
aeroFXDensityExponent1 = 0.5

In physics.cfg, I think I chose 4.0 and 1.0 instead

Thank you very much! I see a lot of possibilities here!

Share this post


Link to post
Share on other sites
1 hour ago, Azimech said:

Interesting loop ... loop ... loop ... loop.

Maybe because of the ~20 units having a party at the KSC. Interface still works though. Don't know what will happen when I switch to simulation yet.

Your game is behaving like it's switching between fullscreen and windowed mode permanently, try a different video mode or switch to windowed, perhaps try borderless fullscreen?

9 hours ago, theonegalen said:

Yes, the KSP memory usage at the time was ~3,200,000b. I played again, and even though I got up to ~3,550,000b, I didn't have the same problem. Both times, I still had at least a GB of my RAM free.

If you're not using the 64bit workaround you've reached the limit of how much memory 32-bit KSP can use. It doesn't matter how much RAM you have free.

10 hours ago, Arditan427 said:

I'm not really sure what I would be looking for though, should I post my output log or something like that?

Post the log but I doubt there will be anything in it. Really just play with the settings and see if anything affects it.

Share this post


Link to post
Share on other sites
2 hours ago, blackrack said:

Your game is behaving like it's switching between fullscreen and windowed mode permanently, try a different video mode or switch to windowed, perhaps try borderless fullscreen?

 

I went to the SPH, when I went back to KSC scene it was gone. Don't consider it a problem but thanks for the tip.

Share this post


Link to post
Share on other sites

Just a quick question:

eclipseCasters
		{
			Item = Moon
		}

For this is the item the CB name or the transform name?

Share this post


Link to post
Share on other sites
23 minutes ago, pingopete said:

Just a quick question:

For this is the item the CB name or the transform name?

It doesn't handle differing CB/transform names so it's CB name. I thought the differing names were only needed for Kerbin/Earth?

Share this post


Link to post
Share on other sites
1 minute ago, blackrack said:

It doesn't handle differing CB/transform names so it's CB name. I thought the differing names were only needed for Kerbin/Earth?

Ah right ok. Yeah just trying out the latest release, really nice to see even more frames back in opengl, among other fixes :) One big issue I noticed though is there's no ocean shader what so ever in RSS PQS? Fine in SS but nothing not even at higher levels in PQS?

Share this post


Link to post
Share on other sites
10 minutes ago, pingopete said:

Ah right ok. Yeah just trying out the latest release, really nice to see even more frames back in opengl, among other fixes :) One big issue I noticed though is there's no ocean shader what so ever in RSS PQS? Fine in SS but nothing not even at higher levels in PQS?

There's a new variable in the config points "_GlobalOceanAlpha" if you're using an older config it's value will be 0 at all config points

Share this post


Link to post
Share on other sites
20 minutes ago, blackrack said:

There's a new variable in the config points "_GlobalOceanAlpha" if you're using an older config it's value will be 0 at all config points

Ahh I see thank you! Man the fading extinction looks so sweet!

XxwXWjw.png

Share this post


Link to post
Share on other sites
1 minute ago, pingopete said:

Ahh I see thank you! Man the fading extinction looks so sweet!

Wait, what fading extinction?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.