blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

On 18/12/2016 at 7:01 PM, RufousTreepie said:

First of all, a big thanks @blackrack for the wonderful work. I had a bug report, didn't see it mentioned anywhere. Sorry if it is already known.

On a stock 1.2.2 install, on exiting from the space centre to the main menu, the "Mun or bust" screen appears. But with only scatterer 0.256 added to stock, the main menu is kerbin, not the mun or bust screen. Not much of an issue, but it would be interesting to know why. :)

http://imgur.com/l6OcuTK

http://imgur.com/T1FNKYV

As far as I understand this is random and I don't see how scatterer would affect it.

Share this post


Link to post
Share on other sites

Hello everyone, I'm having a strange issue with Scatterer.

I'm trying to create Scatterer configurations for the next update of a planet pack of mine, but for some weird reason the scattering effect is way bigger than the planets themselves - even bigger than their entire planetary system in some cases.

Here is an example:

wyx3lRv.png

And the code I used:

	Cyran
	{
		displayInterpolatedVariables = True
		experimentalAtmoScale = 3
		mapExtinctionMultiplier = 1
		mapExtinctionTint = 0.699999988
		mapSkyExtinctionRimFade = 1
		_mapExtinctionScatterIntensity = 1
		drawSkyOverClouds = True
		drawOverCloudsAltitude = 100000
		MapViewScale = 99.5999985
		mapExposure = 0.0700000003
		mapSkyRimExposure = 0.0700000003
		cloudColorMultiplier = 1
		cloudScatteringMultiplier = 1
		mapAlphaGlobal = 1
		Rg = 6000000
		Rt = 6084904
		RL = 6086321
		atmosphereGlobalScale = 1
		AVERAGE_GROUND_REFLECTANCE = 0.100000001
		HR = 10
		HM = 1.20000005
		BETA_MSca = 0.00400000019,0.00400000019,0.00400000019
		m_betaR = 0.07843,0.03686,0.01137
		m_mieG = 0.850000024
		rimBlend = -20
		rimpower = 100
		specR = 1
		specG = 1
		specB = 1
		shininess = 10
		assetPath = PlanetCyran/Textures/Atmosphere/Cyran
		configPoints
		{
			Item
			{
				altitude = 1000
				skyAlpha = 1
				skyExposure = 0.0700000003
				skyRimExposure = 0.0700000003
				postProcessAlpha = 0.779999971
				postProcessDepth = 0.0599999987
				postProcessExposure = 0.230000004
				skyExtinctionMultiplier = 0
				skyExtinctionTint = 1
				skyextinctionRimFade = 0
				skyextinctionGroundFade = 0
				openglThreshold = 0
				edgeThreshold = 0
				viewdirOffset = 0
				_Post_Extinction_Tint = 0
				postExtinctionMultiplier = 0
				_GlobalOceanAlpha = 0
				_extinctionScatterIntensity = 1
			}
			Item
			{
				altitude = 5000
				skyAlpha = 1
				skyExposure = 0.0700000003
				skyRimExposure = 0.0700000003
				postProcessAlpha = 0.779999971
				postProcessDepth = 0.100000001
				postProcessExposure = 0.230000004
				skyExtinctionMultiplier = 0
				skyExtinctionTint = 1
				skyextinctionRimFade = 0
				skyextinctionGroundFade = 0
				openglThreshold = 0
				edgeThreshold = 0
				viewdirOffset = 0
				_Post_Extinction_Tint = 0
				postExtinctionMultiplier = 0
				_GlobalOceanAlpha = 0
				_extinctionScatterIntensity = 1
			}
			Item
			{
				altitude = 55000
				skyAlpha = 1
				skyExposure = 0.0700000003
				skyRimExposure = 0.0700000003
				postProcessAlpha = 0.779999971
				postProcessDepth = 0.800000012
				postProcessExposure = 0.230000004
				skyExtinctionMultiplier = 0
				skyExtinctionTint = 1
				skyextinctionRimFade = 0
				skyextinctionGroundFade = 0
				openglThreshold = 0
				edgeThreshold = 0
				viewdirOffset = 0
				_Post_Extinction_Tint = 0
				postExtinctionMultiplier = 0
				_GlobalOceanAlpha = 0
				_extinctionScatterIntensity = 1
			}
			Item
			{
				altitude = 160000
				skyAlpha = 1
				skyExposure = 0.0700000003
				skyRimExposure = 0.0700000003
				postProcessAlpha = 0.779999971
				postProcessDepth = 2.4000001
				postProcessExposure = 0.230000004
				skyExtinctionMultiplier = 1
				skyExtinctionTint = 0.699999988
				skyextinctionRimFade = 0
				skyextinctionGroundFade = 0
				openglThreshold = 0
				edgeThreshold = 0
				viewdirOffset = 0
				_Post_Extinction_Tint = 0
				postExtinctionMultiplier = 0
				_GlobalOceanAlpha = 0
				_extinctionScatterIntensity = 1
			}
			Item
			{
				altitude = 500000
				skyAlpha = 1
				skyExposure = 0.0700000003
				skyRimExposure = 0.0799999982
				postProcessAlpha = 0.779999971
				postProcessDepth = 2.4000001
				postProcessExposure = 0.230000004
				skyExtinctionMultiplier = 1
				skyExtinctionTint = 0.699999988
				skyextinctionRimFade = 0
				skyextinctionGroundFade = 0
				openglThreshold = 0
				edgeThreshold = 0
				viewdirOffset = 0
				_Post_Extinction_Tint = 0
				postExtinctionMultiplier = 0
				_GlobalOceanAlpha = 0
				_extinctionScatterIntensity = 1
			}
		}
	}

Info about the planet:

Radius: 8 000 000m

Surface gravity: 1.7g

Atmosphere height: 500 000m

Atmosphere pressure: 20 atmospheres

Atmosphere color (RGBA): 0.7843,0.3686,0.1137,1

Does anyone know what could be the problem here? Since I know next to nothing about Scatterer any help would be much appreciated.

Share this post


Link to post
Share on other sites
2 hours ago, The White Guardian said:

MapViewScale = 99.5999985

 

Seems rather large for a float value.

Share this post


Link to post
Share on other sites
14 hours ago, Poodmund said:

Seems rather large for a float value.

Jool has the exact same value yet no such issue, strangely. How could this be anything different in Cyran's case? Or at least anything smaller?

Edited by The White Guardian

Share this post


Link to post
Share on other sites

@blackrack does Scatterer have some kind of in-game GUI like EVE or Kopernicus(KittopiaTech plugin)? That'd help me greatly with figuring out the cause of the issue I described above.

Share this post


Link to post
Share on other sites
35 minutes ago, The White Guardian said:

@blackrack does Scatterer have some kind of in-game GUI like EVE or Kopernicus(KittopiaTech plugin)? That'd help me greatly with figuring out the cause of the issue I described above.

MapViewScale should be 1 not 100, ie 0.99 not 99.99. @Poodmund is right, I use 1 for all my configs.

For the UI, alt+f10 or alt+f11 are the default binds

Share this post


Link to post
Share on other sites
Just now, blackrack said:

MapViewScale should be 1 not 100, ie 0.99 not 99.99. @Poodmund is right, I use 1 for all my configs.

For the UI, alt+f10 or alt+f11 are the default binds

What?! But I literally copied it from Jool's default config out of desperation because I couldn't find the problem!

How strange. Anyhow, thanks for the help, both of you. I'll adjust the numbers and see what pops up. Also, lots of thanks about the UI!

Share this post


Link to post
Share on other sites
4 minutes ago, The White Guardian said:

What?! But I literally copied it from Jool's default config out of desperation because I couldn't find the problem!

How strange. Anyhow, thanks for the help, both of you. I'll adjust the numbers and see what pops up. Also, lots of thanks about the UI!

Actually I forgot how I did this but there might be a weird bug where size in map view = mapViewScale * default radius in Kerbin. I will fix it soon, for now just open the UI and set it by eye. it makes sense because Jool is about 100 times bigger than Kerbin.

No idea if this issue went undetected for everyone or everyone worked around it (including me a year ago when I did the default configs)

Edited by blackrack

Share this post


Link to post
Share on other sites
33 minutes ago, blackrack said:

Actually I forgot how I did this but there might be a weird bug where size in map view = mapViewScale * default radius in Kerbin. I will fix it soon, for now just open the UI and set it by eye. it makes sense because Jool is about 100 times bigger than Kerbin.

No idea if this issue went undetected for everyone or everyone worked around it (including me a year ago when I did the default configs)

Off the top of my head the mapViewScale for me seemed to be dynamically scaled/calculated from the Proland Configuration tool...? Is that a possibility?

Share this post


Link to post
Share on other sites
58 minutes ago, Poodmund said:

Off the top of my head the mapViewScale for me seemed to be dynamically scaled/calculated from the Proland Configuration tool...? Is that a possibility?

<?xml version="1.0" encoding="utf-8"?>
<config>
    <string name="Planet">NAME</string>
    <string name="Rg">6000000</string>
    <string name="Rt">6056603</string>
    <string name="RL">6057547</string>
    <vector3 name="BETA_R">
        <x>0.0058</x>
        <y>0.0235</y>
        <z>0.0331</z>
    </vector3>
    <vector3 name="BETA_MSca">
        <x>0.004</x>
        <y>0.004</y>
        <z>0.004</z>
    </vector3>
    <string name="MIE_G">0.8</string>
    <string name="HR">8</string>
    <string name="HM">1.2</string>
    <string name="AVERAGE_GROUND_REFLECTANCE">0.1</string>
    <string name="atmosphereGlobalScale">1</string>
</config>

I don't see the value anywhere. Or did you mean calculated in-game? As in, in KSP?

Edited by The White Guardian

Share this post


Link to post
Share on other sites

MapViewScale = 0.998000026 in the default atmo.cfg for Kerbin. I don't know where you want to change it @The White Guardian though. 

 

When inside the GUI ingame, make sure to be in Map view.

Edited by Theysen

Share this post


Link to post
Share on other sites
Just now, Theysen said:

MapViewScale = 0.998000026 in the default atmo.cfg for Kerbin. I don't know where you want to change it @The White Guardian though. 

I use that value for the moons, but I used 99 for a gasplanet. Both cases, oversized effects. I'm loading up KSP right now, I'll start messing with the in-game GUI until I get a nice value.

Share this post


Link to post
Share on other sites

I found the problem. I used ModuleManager to patch Scatterer's files to add Cyran's scatterer configs. I didn't know that it'd permanently add them to another config, namely that of Planet Arkas, and when I moved the atmo textures to Scatterer's folder it, of course, could no longer find the textures and crashed the atmospheres.

Share this post


Link to post
Share on other sites

I'm testing latest experimental version of scatterer along with EVE in KSP 1.2.2. Everything is amazing, except one thing. All clouds in tracking station view are black, not only on Kerbin but on all planets with clouds. Eve is entirely black for that reason. However in both space centre and normal game view clouds are as they should be, mesmerizing that is.

I found these lines related to EVE in my KSP.log from when I opened tracking station:

[LOG 22:46:10.300] [EVE CloudsManager]: CloudsPQS: (Jool-clouds1) OnSphereInactive
[LOG 22:46:10.301] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.302] [EVE CloudsManager]: CloudsPQS: (Eve-clouds5) OnSphereInactive
[LOG 22:46:10.303] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.304] [EVE CloudsManager]: CloudsPQS: (Eve-clouds4) OnSphereInactive
[LOG 22:46:10.305] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.307] [EVE CloudsManager]: CloudsPQS: (Eve-clouds3) OnSphereInactive
[LOG 22:46:10.308] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.309] [EVE CloudsManager]: CloudsPQS: (Eve-clouds2) OnSphereInactive
[LOG 22:46:10.310] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.311] [EVE CloudsManager]: CloudsPQS: (Eve-clouds1) OnSphereInactive
[LOG 22:46:10.312] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.313] [EVE CloudsManager]: CloudsPQS: (Duna-clouds1) OnSphereInactive
[LOG 22:46:10.314] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.315] [EVE CloudsManager]: CloudsPQS: (Laythe-clouds1) OnSphereInactive
[LOG 22:46:10.316] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.317] [EVE CloudsManager]: CloudsPQS: (Kerbin-clouds1) OnSphereInactive
[LOG 22:46:10.319] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.320] [EVE] Applying _MainTex Cubemap
[LOG 22:46:10.321] [EVE] Applying _MainTex Cubemap

Have anyone encountered this bug before?

Share this post


Link to post
Share on other sites
2 hours ago, Sol Invictus said:

I'm testing latest experimental version of scatterer along with EVE in KSP 1.2.2. Everything is amazing, except one thing. All clouds in tracking station view are black, not only on Kerbin but on all planets with clouds. Eve is entirely black for that reason. However in both space centre and normal game view clouds are as they should be, mesmerizing that is.

I found these lines related to EVE in my KSP.log from when I opened tracking station:


[LOG 22:46:10.300] [EVE CloudsManager]: CloudsPQS: (Jool-clouds1) OnSphereInactive
[LOG 22:46:10.301] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.302] [EVE CloudsManager]: CloudsPQS: (Eve-clouds5) OnSphereInactive
[LOG 22:46:10.303] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.304] [EVE CloudsManager]: CloudsPQS: (Eve-clouds4) OnSphereInactive
[LOG 22:46:10.305] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.307] [EVE CloudsManager]: CloudsPQS: (Eve-clouds3) OnSphereInactive
[LOG 22:46:10.308] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.309] [EVE CloudsManager]: CloudsPQS: (Eve-clouds2) OnSphereInactive
[LOG 22:46:10.310] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.311] [EVE CloudsManager]: CloudsPQS: (Eve-clouds1) OnSphereInactive
[LOG 22:46:10.312] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.313] [EVE CloudsManager]: CloudsPQS: (Duna-clouds1) OnSphereInactive
[LOG 22:46:10.314] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.315] [EVE CloudsManager]: CloudsPQS: (Laythe-clouds1) OnSphereInactive
[LOG 22:46:10.316] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.317] [EVE CloudsManager]: CloudsPQS: (Kerbin-clouds1) OnSphereInactive
[LOG 22:46:10.319] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 22:46:10.320] [EVE] Applying _MainTex Cubemap
[LOG 22:46:10.321] [EVE] Applying _MainTex Cubemap

Have anyone encountered this bug before?

It's a known issue, I mentioned it when I posted the first experimental version, although I should have added it in the OP or somewhere.

Fix is easy, but I don't know when I will find some time for the mod, then I will do a proper release.

Share this post


Link to post
Share on other sites

@blackrack, I've found a bug/glitch with this mod. Some parts have large see-through areas when viewed from IVA. Here is a pic:

Spoiler

KQ9GgNb.jpg

I was using the version of Scatterer bundled with SVE, so I removed Scatterer, and the problem disappeared. I then installed Scatterer from spacedock to see if the SVE cfg files were the problem, and the issue was there again. I then installed Scatterer on a fresh, clean install of KSP 1.2.2 to see if it was a mod conflict, and it was there again. Here is a log from the clean install: https://drive.google.com/file/d/0B_LmNeaJxkIpX19ZNHc1TVJuTzA/view?usp=sharing

Edited by Micro753

Share this post


Link to post
Share on other sites

Eclipses and atmospheres are giving me issues on Scatterer experimental 0.0275

- Atmospheres don't show up. At all. I WAS able to get one of the atmospheres to load a grey haze, however this stopped working after a reload and never worked again.

- Eclipses only work on stock planets, such as Kerbin, Duna, Jool, Etc. Any modded planets suck as Urlum or Neidon from OPM do not work. (I did add them to the planetsList.cfg)

 

There were some instructions, like those included with Arkas that say to directly add the planetList config lines to the planetsList.cfg file, but that does nothing. So I made it into a ModuleManager file instead, but this doesn't work either. Did I screw it up?

 

Link to MM config - https://drive.google.com/file/d/0B24EOH5WdHk6ZzlIOTBibTdOczg/view?usp=sharing

Link to logs - https://drive.google.com/file/d/0B24EOH5WdHk6d3lFQ2haYl9HNzQ/view?usp=sharing 

 

I'll upload a few images later when I get the chance.

EDIT: Images are here - https://drive.google.com/open?id=0B24EOH5WdHk6N2tVUjRsUTY3N3M

Edited by Hammersamatom
Added Images

Share this post


Link to post
Share on other sites

k0aFoxH.pngEqlv1ah.png

 

How can I get rid of this double atmosphere edge bug? I have searched the thread for this bug and can't find anything on the subject. 

Share this post


Link to post
Share on other sites
1 hour ago, Westi29 said:

How can I get rid of this double atmosphere edge bug? I have searched the thread for this bug and can't find anything on the subject. 

If you search for "Halo" you might find some stuff about it :wink:.

There's a toggle in the main menu UI that'll fix the issue. You might have to turn it on *or* off depending on your graphics set up.

http://i.imgur.com/Mrhcnpp.png

 

Share this post


Link to post
Share on other sites
1 hour ago, darvo110 said:

If you search for "Halo" you might find some stuff about it :wink:.

There's a toggle in the main menu UI that'll fix the issue. You might have to turn it on *or* off depending on your graphics set up.

http://i.imgur.com/Mrhcnpp.png

 

Thank you! That fixed it. I should have realized what halo meant, d'oh! 

Share this post


Link to post
Share on other sites
On 12/13/2016 at 5:14 PM, Galileo said:

Those experimental dll's work great without clouds. amazing work

FtCgYRx.png
GTTvtIu.png

That... is the prettiest I think I've ever seen Jool. Assuming this is Jool? How on earth did you accomplish that?!

Share this post


Link to post
Share on other sites

So my computer is pretty low end in terms of graphical capabilities (it has an integrated GPU) but I still use scatterer just because it is too beautiful :D. I find that there is a very sizable amount of lag when on the surface of Earth (I'm using RSS) but in space, the lag is pretty much non-existent. Could I possibly delete the shaders that produce the atmospheric effects on the surface, but keep the shaders that produce the effects seen in space? If so, what shaders would I have to delete?

Share this post


Link to post
Share on other sites
15 hours ago, AndrewDrawsPrettyPictures said:

So my computer is pretty low end in terms of graphical capabilities (it has an integrated GPU) but I still use scatterer just because it is too beautiful :D. I find that there is a very sizable amount of lag when on the surface of Earth (I'm using RSS) but in space, the lag is pretty much non-existent. Could I possibly delete the shaders that produce the atmospheric effects on the surface, but keep the shaders that produce the effects seen in space? If so, what shaders would I have to delete?

I think the most impact on FPS while on the surface is from the ocean, try disable it in Scatterer 's menu (it should be showing on the top left corner of the screen when in main menu).

Share this post


Link to post
Share on other sites
On ‎12‎/‎27‎/‎2016 at 9:56 AM, Li0n said:

I think the most impact on FPS while on the surface is from the ocean, try disable it in Scatterer 's menu (it should be showing on the top left corner of the screen when in main menu).

Yeah I thought that was causing the FPS hit as well but I disabled the ocean, there is only a small change in FPS. It also has nothing to do with EVE's volumetric clouds, because I removed EVE and the improvement is minimal. It must have something to do with scatterer's sky shaders because when I point the camera towards the sky, the FPS gets unbelievably horrible.

I wonder if it would be possible for @blackrack to create a lite version of scatterer which is much less graphically intensive, but still improves the visuals of KSP, just to a lesser degree.

Share this post


Link to post
Share on other sites
15 hours ago, AndrewDrawsPrettyPictures said:

Yeah I thought that was causing the FPS hit as well but I disabled the ocean, there is only a small change in FPS. It also has nothing to do with EVE's volumetric clouds, because I removed EVE and the improvement is minimal. It must have something to do with scatterer's sky shaders because when I point the camera towards the sky, the FPS gets unbelievably horrible.

I wonder if it would be possible for @blackrack to create a lite version of scatterer which is much less graphically intensive, but still improves the visuals of KSP, just to a lesser degree.

Still seems a bit suss that it lags so much. I've got a 2014 intel integrated GPU which handles fine. Like has been said, volumetric clouds and the ocean shader will jank your fps pretty bad, but the scatterer shader itself is pretty low-intensity.

If your computer can't handle that alone, I suspect there isn't much you really could improve without hurting FPS 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.