blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

10 minutes ago, blackrack said:

Not yet, it isn't an SVE-exclusive issue though, it's the same with stock EVE and scatterer but a bit less pronounced mostly because of the lower cloud altitude and the less dense clouds.

Ok cool so I haven't missed anything.  I saw that you posted your kopernicus version on the kopernicus thread. I haven't tested it yet.  Is that part a finished product? 

Share this post


Link to post
Share on other sites
25 minutes ago, Galileo said:

Ok cool so I haven't missed anything.  I saw that you posted your kopernicus version on the kopernicus thread. I haven't tested it yet.  Is that part a finished product? 

I still have to add particles/noise when zooming on the ring, everything else should be finished.

Share this post


Link to post
Share on other sites

@blackrack

Would it be much work / possible to move the scatterer config to a subfolder called PluginData sooner or later?
If a cfg is in a subfolder with that name, Modulemanager ignores it for the cache invalidation check. So the cfg can change without invalidating the mm cache, which speeds up loading time in my installation by about 2-5 minutes.

Edited by Jebs_SY

Share this post


Link to post
Share on other sites
2 hours ago, Jebs_SY said:

@blackrack

Would it be much work / possible to move the scatterer config to a subfolder called PluginData sooner or later?
If a cfg is in a subfolder with that name, Modulemanager ignores it for the cache invalidation check. So the cfg can change without invalidating the mm cache, which speeds up loading time in my installation by about 2-5 minutes.

I think you can already move it there and it will work. Technically, it should.

Share this post


Link to post
Share on other sites

I'm trying to recreate the effect that I got after questioning you here...

...to recreate an atmosphere looking something like this.

zC1qzxF.png

I've tried doing what you previously suggested, adjusting the Extinction and Extinction Tint values, but they appear to be making absolutely no difference, even when set to absolute extremes. Does anyone have any suggestions?

Edited by MrMeeb

Share this post


Link to post
Share on other sites

I know it says 1.2, but it looks like people are playing on 1.2.2 and this is working? I put this on a fresh install and its not working. Do I have to activate it at all? My gamedata folder is squad and scatterer and thats it

Share this post


Link to post
Share on other sites
4 hours ago, MrMeeb said:

I've tried doing what you previously suggested, adjusting the Extinction and Extinction Tint values, but they appear to be making absolutely no difference, even when set to absolute extremes. Does anyone have any suggestions?

I've been messing with the Scatterer console lately and it took me a while to puzzle this out. There are various altitude layers you can modify. Look towards the top for arrow buttons around the field named something like "altitude layer" and make sure you select the one closest to but still below your current altitude, then modify those values to see a change

Edited by Drew Kerman

Share this post


Link to post
Share on other sites
8 hours ago, Drew Kerman said:

I've been messing with the Scatterer console lately and it took me a while to puzzle this out. There are various altitude layers you can modify. Look towards the top for arrow buttons around the field named something like "altitude layer" and make sure you select the one closest to but still below your current altitude, then modify those values to see a change

Don't worry, I'm doing that. I have past experience of modifying in the console, and have made other changes to the layer that do show. It's this extinction stuff that doesn't seem to

Share this post


Link to post
Share on other sites
18 hours ago, TonyMacaroni said:

I know it says 1.2, but it looks like people are playing on 1.2.2 and this is working? I put this on a fresh install and its not working. Do I have to activate it at all? My gamedata folder is squad and scatterer and thats it

Only because it was a ways back......you'll also need Module Manager I believe.

And just for good measure....

 

Edited by V8jester

Share this post


Link to post
Share on other sites

Hwy blackrack, is it possible to set the sunflares to fade based on how far you are from the sun? I know it fades when you get close, but would it be possible to fade it if you are extremely far away as well but still mute the stock corona and all that crap?

Share this post


Link to post
Share on other sites

@blackrackUmm, I'm new to scatterer as in I've never used it before, and I'm not exactly good with code or know anything for that matter, I'm seeing you post lots of mega downloads and I have no idea what they a for, I just want the newest version for 1.2.2. So, my question is what in the world do I need to download?

Edited by ashencloud

Share this post


Link to post
Share on other sites
5 hours ago, ashencloud said:

@blackrackUmm, I'm new to scatterer as in I've never used it before, and I'm not exactly good with code or know anything for that matter, I'm seeing you post lots of mega downloads and I have no idea what they a for, I just want the newest version for 1.2.2. So, my question is what in the world do I need to download?

Just get this one, should be fine: https://mega.nz/#!rcATSATC!WFhNe9UULsYRE-aWZtAfoG-IeDLeNCbWkVQc9hXc0ag

13 hours ago, Galileo said:

Hwy blackrack, is it possible to set the sunflares to fade based on how far you are from the sun? I know it fades when you get close, but would it be possible to fade it if you are extremely far away as well but still mute the stock corona and all that crap?

Yeah, I've been thinking about adding it but didn't get around to it. What do you mean mute the stock corona?

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

Just get this one, should be fine: https://mega.nz/#!rcATSATC!WFhNe9UULsYRE-aWZtAfoG-IeDLeNCbWkVQc9hXc0ag

Yeah, I've been thinking about adding it but didn't get around to it. What do you mean mute the stock corona?

When scatterer isn't installed,  the stock Corona is very large no matter how far away you put the star.  Scatterer fixes that,  but If you disable it when one gets too far away,  I wouldn't want the stock Corona to show is ugly face again. 

Share this post


Link to post
Share on other sites
2 hours ago, Galileo said:

When scatterer isn't installed,  the stock Corona is very large no matter how far away you put the star.  Scatterer fixes that,  but If you disable it when one gets too far away,  I wouldn't want the stock Corona to show is ugly face again. 

Hmm, I stopped messing with the corona since I made the lens flare shader because it looks cool in sunsets with extinction and looks cool during eclipses. Are you sure scatterer changes anything about the corona? Can you try a black sunflare just to be sure?

Share this post


Link to post
Share on other sites
37 minutes ago, blackrack said:

Hmm, I stopped messing with the corona since I made the lens flare shader because it looks cool in sunsets with extinction and looks cool during eclipses. Are you sure scatterer changes anything about the corona? Can you try a black sunflare just to be sure?

I will when I get time this evening and I'll take some screenies of what I'm talking about.  It's kinda hard to explain.  

EDIT:

@blackrack basically,  everything is perfect,  I just want the ghosts to disappear when I am at a greater distance.  I don't know why I didn't explain it like that to begin with..  My brain just likes to make things complicated. 

If you do get around to doing something about it,  could you also add the fix to the current release 0.0256? It's the version I'm packaging with GPP and It now has 2 stars in the pack and having two large set of ghosts is a bit of an distraction IMO.  Only if you have time of course

Edited by Galileo

Share this post


Link to post
Share on other sites
25 minutes ago, Galileo said:

I will when I get time this evening and I'll take some screenies of what I'm talking about.  It's kinda hard to explain.  

EDIT:

@blackrack basically,  everything is perfect,  I just want the ghosts to disappear when I am at a greater distance.  I don't know why I didn't explain it like that to begin with..  My brain just likes to make things complicated. 

If you do get around to doing something about it,  could you also add the fix to the current release 0.0256? It's the version I'm packaging with GPP. Only if you have time of course.  

I'm planning to make a full release soon, just fixing the last issues on the new cloud integration.

Btw if you have time, can you test if this fixes the auroras? https://mega.nz/#!HEB0QAIJ!uBy1GmpzC9F6FkCGyGXDR19uL5TvcAYfEfc0boVXFmU

Share this post


Link to post
Share on other sites
19 minutes ago, blackrack said:

I'm planning to make a full release soon, just fixing the last issues on the new cloud integration.

Btw if you have time, can you test if this fixes the auroras? https://mega.nz/#!HEB0QAIJ!uBy1GmpzC9F6FkCGyGXDR19uL5TvcAYfEfc0boVXFmU

I will this evening.  I may just have to hold of on an update until you get the next release out if you are close. :)

Share this post


Link to post
Share on other sites
3 minutes ago, Phineas Freak said:

@blackrack allow me to confirm that with the new shaders the auroras display correctly, both in the Tracking Station and in the Map/Flight scenes.

Thanks for the quick test.

Share this post


Link to post
Share on other sites

Hi @blackrack. First of all I would like to congratulate you on your amazing work, its one of mine favorite mods. I've been testing your latest experimental version and once again is awesome but i think i found a little thing, I think the overall brightness seems a little high. for example:
I took the Kerbal X ship to the dark side of Kerbin, with the version 0.0256, the ship is barely visible.
http://imgur.com/1BUyQJ0


But with the experimental version it's quite visible.
http://imgur.com/EfGq8iC

 

I tested this in a clean install of KSP with only Scatterer installed. I noticed another thing, in my career mode i use a mod called PlanetShine and while it works perfectly with version 0.0256 it doesn't work well with the experimental version, all but one function of PlanetShine aren't working, only the PlanetShine light intensity works. I know that PlanetShine is not your responsibility and I prefer to use Scatterer than PlanetShine. I don't have a log file at this moment but if you need one I'll post it here.

And I'm sorry but I don't know how to use Imgur correctly, I don't know what are the correct links to put a image here, I'm a noob in this things.

Share this post


Link to post
Share on other sites
On 04/01/2017 at 10:43 PM, MrMeeb said:

I'm trying to recreate the effect that I got after questioning you here...

...to recreate an atmosphere looking something like this.

I've tried doing what you previously suggested, adjusting the Extinction and Extinction Tint values, but they appear to be making absolutely no difference, even when set to absolute extremes. Does anyone have any suggestions?

I might have broken them without noticing, I will investigate. I don't really remember how we ever got that shading though.

 

16 hours ago, PmThay said:

Hi @blackrack. First of all I would like to congratulate you on your amazing work, its one of mine favorite mods. I've been testing your latest experimental version and once again is awesome but i think i found a little thing, I think the overall brightness seems a little high. for example:
I took the Kerbal X ship to the dark side of Kerbin, with the version 0.0256, the ship is barely visible.
http://imgur.com/1BUyQJ0


But with the experimental version it's quite visible.
http://imgur.com/EfGq8iC

 

I tested this in a clean install of KSP with only Scatterer installed. I noticed another thing, in my career mode i use a mod called PlanetShine and while it works perfectly with version 0.0256 it doesn't work well with the experimental version, all but one function of PlanetShine aren't working, only the PlanetShine light intensity works. I know that PlanetShine is not your responsibility and I prefer to use Scatterer than PlanetShine. I don't have a log file at this moment but if you need one I'll post it here.

And I'm sorry but I don't know how to use Imgur correctly, I don't know what are the correct links to put a image here, I'm a noob in this things.

I will check with planetshine, do I just grab the latest version? Also the lighting in the second image doesn't look right at all, for me ingmae it still looks like the first image. Which experimental version you use? The one from the OP?

Share this post


Link to post
Share on other sites
1 minute ago, blackrack said:

I will check with planetshine, do I just grab the latest version? Also the lighting in the second image doesn't look right at all, for me ingmae it still looks like the first image. Which experimental version you use? The one from the OP?

hi, thanks for the response. The Scatterer that i used to do the second image was the one that you shared in this page, the scattererTrackingStation.zip. In relation to the planetshine its the latest version witch is  v0.2.5.2. But the images that i show you were only with scatterer. maybe its better for me to test again and post here a log file.

Share this post


Link to post
Share on other sites
9 minutes ago, PmThay said:

hi, thanks for the response. The Scatterer that i used to do the second image was the one that you shared in this page, the scattererTrackingStation.zip. In relation to the planetshine its the latest version witch is  v0.2.5.2. But the images that i show you were only with scatterer. maybe its better for me to test again and post here a log file.

Yeah, do post a log file, that shouldn't happen with scatterer only. Does it happen at any and all altitudes? Can it happen at say, an orbit of 3000km?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.