blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

7 minutes ago, blackrack said:

Yeah, do post a log file, that shouldn't happen with scatterer only. Does it happen at any and all altitudes? Can it happen at say, an orbit of 3000km?

hmmmm I didn't tested in a such high orbit but i did test in very low altitude like in a night time flight, but in a couple of hours I'll do a test and take some pictures and I'll post the log. once again thanks for the support and amazing work. :wink:

Share this post


Link to post
Share on other sites

Hello again @blackrack. so has promised here are some more pictures.

With scatterer-0.0256:
RPxvMSo.jpg

With scattererTrackingStation:
dVeuXr7.jpg

with scatterer-0.0256:

CKM0aSB.jpg

With scattererTrackingStation:

5IBEBQO.jpg

With scatterer-0.0256:

7VED0Ni.jpg

With scattererTrackingStation:

4OTUtYn.jpg

And now my log: https://drive.google.com/open?id=0BwOktgRlclqKaE1YWWhaTzdTbTQ
I hope this helps in any way.
:)

Share this post


Link to post
Share on other sites

Now, one thing I don't like is that the water is absolutely pitch-black on the night side. It looks like I'm splashing down in a sea of ink. Perhaps you could bump up the ambient light a slight bit so that we can tell that we're not just sitting atop a black void?

Share this post


Link to post
Share on other sites
On 1/3/2017 at 4:21 PM, blackrack said:

Not yet, it isn't an SVE-exclusive issue though, it's the same with stock EVE and scatterer but a bit less pronounced mostly because of the lower cloud altitude and the less dense clouds.

ok i think i figured something out regarding SVE and Scatterer.

When i open the EVE gui and hit apply without making any changes, the hard terminators go away but the volumetric clouds turn black

Then, i hit "Map EVE clouds" in the scatterer gui and everything looks gorgeous!

unfortunately, its not persistent and has to be done each time you load the game. 

maybe this can lead you to another possible solution.

Edited by Galileo

Share this post


Link to post
Share on other sites
19 minutes ago, Galileo said:

ok i think i figured something out regarding SVE and Scatterer.

When i open the EVE gui and hit apply without making any changes, the hard terminators go away but the volumetric clouds turn black

Then, i hit "Map EVE clouds" in the scatterer gui and everything looks gorgeous!

unfortunately, its not persistent and has to be done each time you load the game. 

maybe this can lead you to another possible solution.

Can you post pics at sunrise/sunset? I would expect something else to be lost if you don't have the hard terminators anymore.

Share this post


Link to post
Share on other sites

@blackrack

im on it right now. as far as i can tell, everything works. i get the color change at sunset and sunrise, auroras work sun reflection on water looks good

that technique fixes every atmospheric body with clouds

EDIT: the only thing i see as broken is the terminator color in scaled space. It reverts to the old fade white to black. but the volumetric clouds seem to change perfectly

JvF4CeU.png

ToOinDE.png

szAtM4w.png

Edited by Galileo

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

ok i think i figured something out regarding SVE and Scatterer.

When i open the EVE gui and hit apply without making any changes, the hard terminators go away but the volumetric clouds turn black

Then, i hit "Map EVE clouds" in the scatterer gui and everything looks gorgeous!

unfortunately, its not persistent and has to be done each time you load the game. 

maybe this can lead you to another possible solution.

That is the process that I deduced when going through updating OPM-VO. Seemed a little laborious and hacky at the time so I didn't continue doing it... I thought this issue had been identified quite a while back though?

Wasn't it a part of the whole shader load-sequence problems?

Edited by Poodmund

Share this post


Link to post
Share on other sites
16 minutes ago, Poodmund said:

That is the process that I deduced when going through updating OPM-VO. Seemed a little laborious and hacky at the time so I didn't continue doing it... I thought this issue had been identified quite a while back though?

Wasn't it a part of the whole shader load-sequence problems?

It does seem a bit like the issue that was brought up before. Like When EVE was first ported over to 1.2 and we had to basically hack our way through editing. Pain in the butt. 

Edited by Galileo

Share this post


Link to post
Share on other sites
On ‎12‎/‎29‎/‎2016 at 0:33 PM, blackrack said:

I also think you might have some other issue if your game lags so much. Post your output.log file.

Anyway, I guess I will make the postprocessing and all the other features togglable from main menu.

Sorry it's taken me a while to post my output log. I kind of forgot.

Output log:

https://drive.google.com/open?id=0B4wjXOtt9_9XN252TGJJYmRoUXM

Share this post


Link to post
Share on other sites
6 hours ago, Galileo said:

@blackrack

im on it right now. as far as i can tell, everything works. i get the color change at sunset and sunrise, auroras work sun reflection on water looks good

that technique fixes every atmospheric body with clouds

EDIT: the only thing i see as broken is the terminator color in scaled space. It reverts to the old fade white to black. but the volumetric clouds seem to change perfectly

As far as I can see, you have the color change on the volumetrics but NOT on the 2d clouds, which is also why you do'nt have the color change in scaled space clouds.

So yeah, this technique breaks the 2d clouds which is IMO against the point, i wouldn't exactly call it a "fix", but if you want the want to have the color change on the volumetrics only I can always make it an option.

Edited by blackrack

Share this post


Link to post
Share on other sites
39 minutes ago, blackrack said:

As far as I can see, you have the color change on the volumetrics but NOT on the 2d clouds, which is also why you do'nt have the color change in scaled space clouds.

So yeah, this technique breaks the 2d clouds which is IMO against the point, i wouldn't exactly call it a "fix", but if you want the want to have the color change on the volumetrics only I can always make it an option.

Well yeah, it's a hacky fix.  I would love it if you made it an option.  that's better than nothing,   ya know?  And I'm sure one day, SVE and the scaled space color change will play nice

Edited by Galileo

Share this post


Link to post
Share on other sites

I have installed SVE, which comes with Scatterer. My pc has not a very strong GPU, and I was hoping to tweak a bit the configuration of scatterer to be more performance friendly. What do you recomend I change from te main menu or in game settings? (or maybe deleting a file or else.) Also, SVE is what gives could, or is it scatterer? I know hot to change the clouds configs, but I need to do something else because that isn't enough. My frame rate gives me 20 fps, sometimes 15...

Share this post


Link to post
Share on other sites
20 minutes ago, Agustin said:

I have installed SVE, which comes with Scatterer. My pc has not a very strong GPU, and I was hoping to tweak a bit the configuration of scatterer to be more performance friendly. What do you recomend I change from te main menu or in game settings? (or maybe deleting a file or else.) Also, SVE is what gives could, or is it scatterer? I know hot to change the clouds configs, but I need to do something else because that isn't enough. My frame rate gives me 20 fps, sometimes 15...

Scatterer is probably one of the most memory-consuming mods out there if everything is enabled. First thing you should try is reducing it to just the atmosphere shaders. If that doesn't do the job, reduce the texture resolution in KSP's settings.

Share this post


Link to post
Share on other sites

@Agustin I would highly recommend completely turning off the volumetric cloud particles for all cloud layers from the EVE menu. They are very performance expensive, and only add to your game experience for a short period of time on the way into space. Also, there is an old trick for getting performance from the game if you decided not to use scatterer's ocean shaders. It involves modifying values in the settings.cfg file for ksp (the one in the root folder, next to the .exe for the game), so make backups and proceed at your own risk. I appologize I cannot find astronomer's original posting of this, but it hails back from the .24 era. 

Simply replace all the Terrain nodes at the bottom of the .cfg with this:

 

TERRAIN
{
	preset = Default V2
	version = 1.2.2
	PRESET
	{
		name = Low V2
		PLANET
		{
			name = Kerbin
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = KerbinOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Mun
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Minmus
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 5
		}
		PLANET
		{
			name = Bop
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 5
		}
		PLANET
		{
			name = Duna
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Eve
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = EveOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Gilly
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 5
		}
		PLANET
		{
			name = Ike
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Laythe
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = LaytheOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Moho
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Tylo
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Vall
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Dres
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Pol
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Eeloo
			minDistance = 4
			minSubdivision = 1
			maxSubdivision = 6
		}
	}
	PRESET
	{
		name = Default V2
		PLANET
		{
			name = Kerbin
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = KerbinOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Mun
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Minmus
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Bop
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Duna
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Eve
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = EveOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Gilly
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Ike
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Laythe
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = LaytheOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Moho
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Tylo
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Vall
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Dres
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Pol
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
		PLANET
		{
			name = Eeloo
			minDistance = 6
			minSubdivision = 1
			maxSubdivision = 8
		}
	}
	PRESET
	{
		name = High V2
		PLANET
		{
			name = Kerbin
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 10
		}
		PLANET
		{
			name = KerbinOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Mun
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Minmus
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 7
		}
		PLANET
		{
			name = Bop
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Duna
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Eve
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 10
		}
		PLANET
		{
			name = EveOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Gilly
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 7
		}
		PLANET
		{
			name = Ike
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 7
		}
		PLANET
		{
			name = Laythe
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 10
		}
		PLANET
		{
			name = LaytheOcean
			minDistance = 3
			minSubdivision = 1
			maxSubdivision = 6
		}
		PLANET
		{
			name = Moho
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Tylo
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Vall
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Dres
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Pol
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
		PLANET
		{
			name = Eeloo
			minDistance = 8
			minSubdivision = 1
			maxSubdivision = 9
		}
	}
}

 

Edited by Errol

Share this post


Link to post
Share on other sites

Thank you but i love the water, and I don,t think that,s what,s killing my framerates. INdeed the clouds are the most expensive I think, but I,ve managed to lower the density by changing from 4 to 2 the second number next to size and area in yhe layerVolume tag. THat gives me like 10 more fps, and I still have pretty decent clouds. I also have no loss when adding mire visibleRange. Also, tetures in game settings don,t have an impact on fps, what really does though are terrain textures on main menu settings, but I have it at low already. I thought Maybe you guys could give me an idea of what scatterer does besides the oceanShaders which I love, and the atmospheric which I really don,t care to much but dont know how to disable. maybe that,s what I really need disabled.

Share this post


Link to post
Share on other sites
3 hours ago, The White Guardian said:

Scatterer is probably one of the most memory-consuming mods out there if everything is enabled. First thing you should try is reducing it to just the atmosphere shaders. If that doesn't do the job, reduce the texture resolution in KSP's settings.

Memory and framerate are mostly unrelated.

2 minutes ago, Agustin said:

Thank you but i love the water, and I don,t think that,s what,s killing my framerates. INdeed the clouds are the most expensive I think, but I,ve managed to lower the density by changing from 4 to 2 the second number next to size and area in yhe layerVolume tag. THat gives me like 10 more fps, and I still have pretty decent clouds. I also have no loss when adding mire visibleRange. Also, tetures in game settings don,t have an impact on fps, what really does though are terrain textures on main menu settings, but I have it at low already. I thought Maybe you guys could give me an idea of what scatterer does besides the oceanShaders which I love, and the atmospheric which I really don,t care to much but dont know how to disable. maybe that,s what I really need disabled.

Which GPU do you have? In any case your best bet is disabling the ocean shaders or the volumetric clouds, nothing else hits the performance as hard. Or maybe just use less volumetrics layers.

And turn the ocean fourierGridSize down to 64 if you haven't already, set m_resolution to 8 instead of 4

22 hours ago, AndrewDrawsPrettyPictures said:

Sorry it's taken me a while to post my output log. I kind of forgot.

Output log:

https://drive.google.com/open?id=0B4wjXOtt9_9XN252TGJJYmRoUXM

Everything looks fine in your log, can't see anything wrong. Wait a bit and try the next experimental version.

Share this post


Link to post
Share on other sites
28 minutes ago, Agustin said:

Thank you but i love the water, and I don,t think that,s what,s killing my framerates. 

The water is the most demanding part of scatterer. 

Share this post


Link to post
Share on other sites

 Ok thank you all for your help. I am tweaking and trying to optimize everything, considering what you said. Now, I dont know in what thread should this next question belong, but do you know how to disable / decrease the parameter that prevents the stars to be seen fronthe surface of the planet at night? I would love to be able to see them at any moment really, no matter what in reallity is supposed to work (I think if you are in the midle of nothing on real esrth, you see the stars quite good)

Share this post


Link to post
Share on other sites
3 minutes ago, Agustin said:

 Ok thank you all for your help. I am tweaking and trying to optimize everything, considering what you said. Now, I dont know in what thread should this next question belong, but do you know how to disable / decrease the parameter that prevents the stars to be seen fronthe surface of the planet at night? I would love to be able to see them at any moment really, no matter what in reallity is supposed to work (I think if you are in the midle of nothing on real esrth, you see the stars quite good)

Distant Object Enhanchement is your friend.

Share this post


Link to post
Share on other sites
On 13/01/2017 at 0:54 PM, Nansuchao said:

Distant Object Enhanchement is your friend.

I think that @Agustin is probably already using DOE, since they said that they are using SVE. I'm pretty sure DOE is included with SVE, isn't it? Perhaps you just need to mess with the DOE settings?

EDIT: I would like to add that I have been noticing inconsistencies with DOE's skybox dimming lately, and am also using SVE. I doesn't bother me much, so I haven't paid attention to the exact conditions for repro steps. My issue is sometimes the skybox doesn't dim when it should because the camera is facing the sun, so I can see Kerbol and the skybox at the same time. A bit different then your issue.

Edited by Errol

Share this post


Link to post
Share on other sites

THanks! INdeed it is the SKybox dimming setting.

Now I have also found that at night, i have like 8 fps more than at day-time

Edited by Agustin

Share this post


Link to post
Share on other sites

@blackrack  Just a small question.  Are you using Unity ocean shaders for your scatterer ? Bcs I think Naval Action another Unity based game has the same nice oceans like your mod :)

Share this post


Link to post
Share on other sites
22 hours ago, ZobrAA said:

Scatterer sun glare bug:

Does this happen at any distance from the ship?

6 hours ago, Jovzin said:

@blackrack  Just a small question.  Are you using Unity ocean shaders for your scatterer ? Bcs I think Naval Action another Unity based game has the same nice oceans like your mod :)

No and as far as I know unity doesn't have included ocean shaders. They probably coded their own system.

Edited by blackrack

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:
22 hours ago, ZobrAA said:

Scatterer sun glare bug:

Does this happen at any distance.

Hmmm, actually no. At some point, maybe 200-300m zoom out from the ship, sun glare covers fairing too...

Edited by ZobrAA

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.