blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

8 minutes ago, ouyin2000 said:

I need help, please. Total newbie here and I really have no clue what is going on.

 

I'm getting a pink kerbin in map view (and on the start screen) and I can't figure out what is wrong. I've tried uninstalling Scatterer via CKAN and then verifying the steam files. Nothing seems to be helping.

post your output log

Its located in your KSP_x64_Data folder in you KSP directory

Share this post


Link to post
Share on other sites

I got extremely low framerate with the 0.300 version of scatterer.
It has to do with a combination of KSP v1.2 running RSS/RO/RSSVE (which includes scatterer)
The culprit is that RO isn't optimized for v1.2 of ksp and has issues with scatterer.
However, a user on the RO thread stated that version 0.256 of scatterer does not have this performance issue.

Does anybody know where I can get version 0.256? I can't find it on the Github page. If it isn't available can somebody share it with me?

Edited by Razorforce7

Share this post


Link to post
Share on other sites
5 hours ago, Razorforce7 said:

I got extremely low framerate with the 0.300 version of scatterer.
It has to do with a combination of KSP v1.2 running RSS/RO/RSSVE (which includes scatterer)
The culprit is that RO isn't optimized for v1.2 of ksp and has issues with scatterer.
However, a user on the RO thread stated that version 0.256 of scatterer does not have this performance issue.

Does anybody know where I can get version 0.256? I can't find it on the Github page. If it isn't available can somebody share it with me?

It's on spacedock. Just go to the change log and scroll down

Share this post


Link to post
Share on other sites

Water transparency based on depth and contact foam, how does this look?

 

 

On 09/04/2017 at 7:35 PM, TampaPowers said:

Installed using CKAN and now Eve is pitch black on the surface Also have EVE and Kopernicus installed.

Looks like cloud shadows are too strong, configure them through EVE. Nothing to do with scatterer here.

On 13/04/2017 at 9:24 AM, Greatness101 said:

I tried to install Scatterer but every time I tried to start the game this happened:

  Reveal hidden contents

17948296_457952007881188_1615166980_o.pn

 
 
 

 

Can't see your image but in the log everything looks fine, are you on the latest EVE version? If so try disabling EVE integration from scatterer main menu and try running in forced dx11 or opengl.

On 14/04/2017 at 8:44 PM, ouyin2000 said:

Is there something that I should be looking for specifically in there?

https://drive.google.com/file/d/0BwVCoI2m-SIsdHNxeFA4al9IdDg/view?usp=sharing

I don't see anything relating to scatterer is it installed correctly?

Share this post


Link to post
Share on other sites
40 minutes ago, blackrack said:

Can't see your image but in the log everything looks fine, are you on the latest EVE version? If so try disabling EVE integration from scatterer main menu and try running in forced dx11 or opengl.

2

I wasn't using EVE when I encountered this issue. (I'm not sure why the image isn't showing up)

I'll try OpenGL but I doubt it would change anything. :P

Edited by Greatness101

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

Water transparency based on depth and contact foam, how does this look?

:o That is... absolutely fantastic.

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

Water transparency based on depth and contact foam, how does this look?

AANNND @blackrack shows up again with the thing you never knew you needed but now you can't live without! 

Seriously awesome

Share this post


Link to post
Share on other sites
2 hours ago, blackrack said:

Water transparency based on depth and contact foam, how does this look?

 

 

Looks like cloud shadows are too strong, configure them through EVE. Nothing to do with scatterer here.

Can't see your image but in the log everything looks fine, are you on the latest EVE version? If so try disabling EVE integration from scatterer main menu and try running in forced dx11 or opengl.

I don't see anything relating to scatterer is it installed correctly?

Oh my God that is amazing

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
28 minutes ago, Avera9eJoe said:

Oh my god that is amazing.

 

34 minutes ago, Galileo said:

AANNND @blackrack shows up again with the thing you never knew you needed but now you can't live without! 

Seriously awesome

 

1 hour ago, Poodmund said:

:o That is... absolutely fantastic.

Also,

wAoIxyN.jpg

d7elx11.jpg

Share this post


Link to post
Share on other sites
10 minutes ago, blackrack said:

 

 

Also,

wAoIxyN.jpg

d7elx11.jpg

2035_-_autoplay_gif_gif_vince_mcmahon_ww

I can't wait to use these in Spectra!!! Well done Blackrack... it's beautiful ;.;

Share this post


Link to post
Share on other sites
5 hours ago, blackrack said:

 

I don't see anything relating to scatterer is it installed correctly?

I can only assume so? I installed the scatterer, default config, and sunflare via CKAN. Then I tried using the SVE config and that didn't work either. So I uninstalled all of them and the problem has not gone away. That output file is after I uninstalled.

Share this post


Link to post
Share on other sites

Oh my, this is beautiful. 

Blackrack, are you secretly hired to work on KSP2 or what?

cant wait to install it, hope it will work with my current 1.2.2 career play

Share this post


Link to post
Share on other sites

My fear of the deep is tingling

 

Y3n3UA8.jpg

 

V23kFFM.jpg

 

 

 

Ah, feels better here, where I can see the coast

LS0zr6W.jpg

 

13 hours ago, Kurtvw said:

@blackrack those latest screens look great!   Does this mean you're nearing a new version?

I just started after a long absence, but maybe in like a week I'll have a preview version.

Share this post


Link to post
Share on other sites
3 hours ago, blackrack said:

I just started after a long absence, but maybe in like a week I'll have a preview version.

So glad you've found some time!  The new stuff looks great!  Can't wait.

Share this post


Link to post
Share on other sites

Hi!

Is your work rendered by GPU processes or is it CPU "bound" similarly to KSP? Trying to work out if installing a 280X I have lying around will be of any benefit in terms of FPS with this mod :)

I also have the uncharacteristically low frame rate issue (with particle number turned WAY down as suggested) I saw mentioned a few pages back, any fix for this yet?

Thanks for the great work!

Share this post


Link to post
Share on other sites
22 minutes ago, MR L A said:

Hi!

Is your work rendered by GPU processes or is it CPU "bound" similarly to KSP? Trying to work out if installing a 280X I have lying around will be of any benefit in terms of FPS with this mod :)

I also have the uncharacteristically low frame rate issue (with particle number turned WAY down as suggested) I saw mentioned a few pages back, any fix for this yet?

Thanks for the great work!

GPU bound. What issue is this? Maybe you have a config issue or something, do you have other mods installed?

And what's the rest of your specs?

Edited by blackrack

Share this post


Link to post
Share on other sites
4 minutes ago, blackrack said:

GPU bound. What issue is this? Maybe you have a config issue or something, do you have other mods installed?

huh, I'll whack it in and see what happens :)

I'll do a bit of digging but I vaguely remember a few people saying their performance was unexpectedly (much more of a hit than Scatterer should have).

I've used a fresh install of KSP when testing scatterer :( so conflicts don't appear to be the problem.

I'm not with my PC for about a week, so I can't currently show you my config.. it should be exactly as appears on download though

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.