blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

i having the issue parts are purple

http://i.imgur.com/Mh4K1hK.png

and this

http://i.imgur.com/pHuFypT.png

Fix is in the previous page:

For everyone getting the pink missing textures thing just download an old version of scatterer and stick the "replacement shaders" folder into the new version, that should fix it for now. This will get you back to the old low-res terrain, if you don't want low-res just don't replace any of the shaders that have PQS in the name.

Reported working by proot. I'll add it to the OP or make a fixed version later, please stop reporting bugs that have fixes or that have already been reported a lot.

Share this post


Link to post
Share on other sites

http://imgur.com/a/niokn

Wonderful, wondelful job Blackrack.

Some notes: dx9, win 8.1, core to quad

- This is a mix of the actual state of KSPRC (wip-EVE, DOE, PS & TR) + lattest scatterer. Without fine tunning yet.

- Pink textures solved with your tip

- Atmo is working in map view, clouds are visible but the surface of the planet not (sometimes this view show the wrong flare -the inside atmo one, instead the stock one-, sometimes the atmo appears behind the planet or a bit displaced from it).

- Clouds are visible now, yes, but the scattering still overlaps the clouds layers if you look them in the horizon. This same problem appeared in the first stages of development of wip-EVE, so probably Rbray89 knows a solution for that.

This and EVE should be brethren mods.

Share this post


Link to post
Share on other sites

yo man i just wanna say, [snip] if you would like share your files that you used to get the game looking that pretty, I swear i'll name my first born son after you.

Share this post


Link to post
Share on other sites

Ah, it's the old "name my first born after you" strategy...

Well I DL's the .014 (.14, whatever) and replaced the files in the folder mentioned (and only replaced files that diddn't have PQS in the filename. That fixed the pink issue. Turning off anisotropic filtering did the trick on the ground with the lines (grid lines?). But it made Kerbin from orbit look like an old CRT monitor display (alternating light & dark horizontal lines) as well as weird effects that look like irregularly shaped concentric rings centered around the focus of your POV.

Share this post


Link to post
Share on other sites

Where can Scatterer version .014 be downloaded?

Addendum: Found it! Great mod!

Edited by AstroRick

Share this post


Link to post
Share on other sites

Had to make another video with this mod :3

Keep up the amazing work man

Share this post


Link to post
Share on other sites
Ah, it's the old "name my first born after you" strategy...

Well I DL's the .014 (.14, whatever) and replaced the files in the folder mentioned (and only replaced files that diddn't have PQS in the filename. That fixed the pink issue. Turning off anisotropic filtering did the trick on the ground with the lines (grid lines?). But it made Kerbin from orbit look like an old CRT monitor display (alternating light & dark horizontal lines) as well as weird effects that look like irregularly shaped concentric rings centered around the focus of your POV.

Yeah, I have the same issue. Setting render quality to "fastest" didn't help either. Running on Linux, so I have no choice but using OpenGL...

Share this post


Link to post
Share on other sites

Hi, everyone, just reporting some pink issues.

I just tried the new version 0.015 and it seemed much better than the previous version. However, I found some part and building become pink like those ones above.

It seemed the Old cockpit Memorial become pink in my case.

screenshot306.png

(see the little pink dot in the left middle?)

And some stock parts, for example, the 2.5m ore tank.

screenshot334.png

Also the interior of the Hitchhiker Storage Container become pink.

screenshot335.png

I'm not sure which part will becomes pink, the storage bays and the fairings are fine for me. Both mod parts and stock parts have some pinky issue. The wheel of RoveMax Model XL3 is pink now.

The mod I'm using: EVE, AVP, TP, Distant Object, Stock Revamp and some other stuffs.

Share this post


Link to post
Share on other sites
Hi, everyone, just reporting some pink issues.

Already reported/answered previously;

For everyone getting the pink missing textures thing just download an old version of scatterer and stick the "replacement shaders" folder into the new version, that should fix it for now. This will get you back to the old low-res terrain, if you don't want low-res just don't replace any of the shaders that have PQS in the name.

Share this post


Link to post
Share on other sites
Where can Scatterer version .014 be downloaded?

Addendum: Found it! Great mod!

OK I'll ask again in the hope of a link posted or a link to the post with the link...

Where can 0.14 be downloaded from. I've checked the OP but that takes you to 0.15 on KerbalStuff.

Share this post


Link to post
Share on other sites

Thank you muchly. Have your first rep points.

(If that link wasn't working)

http://i57.tinypic.com/2vvkeno.jpg

(the answer you are looking for is of course black magic, voodoo and other forms of geometry not yet discovered; wrought from my kickstrater fuelled pixelstick)

EDIT: The reflection in the window is the easter egg that gives away that this was a practical effect and not a photoshop job.

Curse you, just ordered a pixelstick...

Share this post


Link to post
Share on other sites

Ummm... So, yeah. Map view is kinda bugged...

a527eb5763.jpg It also has that black circle around the sun in Map view.

Share this post


Link to post
Share on other sites

May I ask, without any malice, why people seem to not read anything in the forums lately?

Not just in this thread, seems to happen in any other hot topic...

In this way, at the end, any valuable information for the mod's creator is buried among tons of the same questions and complaints.

Share this post


Link to post
Share on other sites
May I ask, without any malice, why people seem to not read anything in the forums lately?

Not just in this thread, seems to happen in any other hot topic...

In this way, at the end, any valuable information for the mod's creator is buried among tons of the same questions and complaints.

this is work in progress is can occur bugs [WIP]

- - - Updated - - -

May I ask, without any malice, why people seem to not read anything in the forums lately?

Not just in this thread, seems to happen in any other hot topic...

In this way, at the end, any valuable information for the mod's creator is buried among tons of the same questions and complaints.

so don't worry proot purple parts bug will be fixed soon

Share this post


Link to post
Share on other sites
May I ask, without any malice, why people seem to not read anything in the forums lately?

Not just in this thread, seems to happen in any other hot topic...

In this way, at the end, any valuable information for the mod's creator is buried among tons of the same questions and complaints.

IMO it's related to the 1.0 release, there has been a ton of new member influx and many of them haven't gotten used to our common forum courtesies yet. It's a bit like The September That Never Ended on a smaller scale.

Share this post


Link to post
Share on other sites
May I ask, without any malice, why people seem to not read anything in the forums lately?

Not just in this thread, seems to happen in any other hot topic...

In this way, at the end, any valuable information for the mod's creator is buried among tons of the same questions and complaints.

I noticed this, and tbh it's been putting me off the forums a bit lately. Even in a huge thread people should at least try to read the 5 first and 5 last pages before posting.

Ummm... So, yeah. Map view is kinda bugged...

http://puu.sh/hPkQs/a527eb5763.jpg It also has that black circle around the sun in Map view.

Looks like I forgot to disable the effectin mapview (it's useless anyway, it's just the atmosphere you see at the edges of the planet).

Share this post


Link to post
Share on other sites

It's funny because now that I've been editing textures and getting involved with EVE/Scatterer/KSPRC, I've been more able to help out the new members with difficulties haha. I hope it's not annoying. :P

But anyhoo, next week will be pretty light on my schedule and so I should be able to continue helping and experimenting with mixing the three.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
I noticed this, and tbh it's been putting me off the forums a bit lately. Even in a huge thread people should at least try to read the 5 first and 5 last pages before posting.

Completely agree.

Looks like I forgot to disable the effectin mapview (it's useless anyway, it's just the atmosphere you see at the edges of the planet).

For me is a very nice thing. Almost essential to keep the coherence in-game.

You can get a great effect with little effort, with the following settings:

7Jg0MpK.jpg

Despite the "displacement" problems. If those settings could be separated and triggered just in map view... that would be a pretty easy and perfect solution until you put the final "map view" shader.

Share this post


Link to post
Share on other sites
Completely agree.

For me is a very nice thing. Almost essential to keep the coherence in-game.

You can get a great effect with little effort, with the following settings:

http://i.imgur.com/7Jg0MpK.jpg

Despite the "displacement" problems. If those settings could be separated and triggered just in map view... that would be a pretty easy and perfect solution until you put the final "map view" shader.

7Jg0MpK.jpg

as08-16-2593hr.jpg

Breathtaking.

Share this post


Link to post
Share on other sites
Completely agree.

For me is a very nice thing. Almost essential to keep the coherence in-game.

You can get a great effect with little effort, with the following settings:

http://i.imgur.com/7Jg0MpK.jpg

Despite the "displacement" problems. If those settings could be separated and triggered just in map view... that would be a pretty easy and perfect solution until you put the final "map view" shader.

That looks good indeed, mapview is just the scaledspace object though, which is flat. Postprocessing needs the detail of the PQS to work so it won't be as easy as enabling it for now. But I will add separate settings for orbit and ground if you want.

Breathtaking indeed, when the clouds are no longer getting drawn over by postprocessing it'll look 10 times better.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.