blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

I'm also using SVE and getting a black sky and water. What's recommended to be used with Scatterer now?

Share this post


Link to post
Share on other sites
1 hour ago, dlrk said:

I'm also using SVE and getting a black sky and water. What's recommended to be used with Scatterer now?

I'm taking the approach of just sticking with the last version of Scatterer until SVE is updated.

Share this post


Link to post
Share on other sites
6 hours ago, Tybot said:

Are you by chance using Stock Visual Enhancements? I'm getting the same thing on my end but it's likely if you're using a graphics enhancement mod that uses Scatterer it they need to update things on their end to incorporate the new version.

Yep !

Return to prévious version, everything is ok !

Share this post


Link to post
Share on other sites
7 hours ago, TaintedLion said:

 

I'm using Spectra, which I installed manually.

Spectra needs an update to run with new Scatterer

Share this post


Link to post
Share on other sites

I've not tried Dx11 just yet, but on the latest scatterer (054) I got the white sky bug again:

Using the DLL you sent earlier for 2 days of career playing, I had not received this bug since, but after installing the latest scatterer (054) I got it on my second launch.

kZzAIfl.png

SHYnUXg.png

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Gameslinx said:

I've not tried Dx11 just yet, but on the latest scatterer (054) I got the white sky bug again:

Using the DLL you sent earlier for 2 days of career playing, I had not received this bug since, but after installing the latest scatterer (054) I got it on my second launch.

Upon closer inspection of your log file, I see this error

[LOG 10:21:40.599] [Scatterer] Multiple config files detected, check your install

I see you have these config files

[LOG 10:21:48.346] Config(Scatterer_config) scatterer/config/config/Scatterer_config
[LOG 10:21:48.341] Config(Scatterer_config) BeyondHome/scatterer/config/config/Scatterer_config

Shouldn't you have only one or the other? Shouldn't you have a ModuleManager patch overriding the stock one if that's what you want for your mod? Try deleting one of them.

Although I'm not sure this is the cause, there were times before were people with duplicate installs had white sky, worth a try.

Can you retest with the previous .dll also, this would be weird as the fix is still there in the new version.

20 hours ago, Errol said:

Downloaded that and am using it now, it's great. Noticing that it doesn't seem to work with parts that have the new stock texture switching (many of the rocket fuel tanks)....any suggestions on how to fix that?

That's probably because it's from the days before the new parts.

Search for their *.mu files in the Squad folder and add their paths in the ModuleManager patch you are using.

Edited by blackrack

Share this post


Link to post
Share on other sites
Posted (edited)

@Gameslinx Were you playing with the new mk2 lander can doors when this happenned? It seems there is a big bug when activating them that kills most of the scatterer effects. I will investigate...

It seems that this DragCubeSystem starts removing my commandbuffers and scripts from the cameras when the door in mk2 lander can is activated.

Edited by blackrack

Share this post


Link to post
Share on other sites
12 minutes ago, blackrack said:

@Gameslinx Were you playing with the new mk2 lander can doors when this happenned? It seems there is a big bug when activating them that kills most of the scatterer effects. I will investigate...

It seems that this DragCubeSystem starts removing my commandbuffers and scripts from the cameras when the door in mk2 lander can is activated.

I wasn't using the doors, I didn't realise they existed until just now!

Share this post


Link to post
Share on other sites
29 minutes ago, Gameslinx said:

I wasn't using the doors, I didn't realise they existed until just now!

From your log It looks like you are loading something with them pre-activated, or something is activating them. Anyway, maybe try to test if you get the white sky while avoiding to use this part?

Share this post


Link to post
Share on other sites
Posted (edited)

What is the correct order to install EVE, Scatterer, and Stock Visual Enhancements, along with which mods' config files should I load? I like to use CKAN, but can do manual method if needed to get the mods to work correctly. I'm currently using all but Scatterer, since with Scatterer I get a black sky and ocean in the KSC scene and during the vehicle launch screen.

Edited by GJNelson

Share this post


Link to post
Share on other sites
3 minutes ago, GJNelson said:

What is the correct order to install EVE, Scatterer, and Stock Visual Enhancements, along with which mods' config files should I load? I like to use CKAN, but can do manual method if needed to get the mods to work correctly. I'm currently using all but Scatterer, since with Scatterer I get a black sky and ocean in the KSC scene and during the vehicle launch screen.

Go check the SVE thread- it hasn’t yet been updated to the new scatterer. 

Share this post


Link to post
Share on other sites

Cool, missed that post. Guess I'll have to decide to either play KSP without SVE, using only EVE and Scatterer, or play with EVE and SVE. Time to decide. Thanks for pointing that out!

Share this post


Link to post
Share on other sites
On 3/17/2019 at 4:26 AM, blackrack said:

In the screenshot, you have stock EVE, latest scatterer, and for the part shaders Textures Unlimited with some moduleManager patches for stock parts (can't remember where I grabbed it but probably this https://spacedock.info/mod/1841/Textures Unlimited Default Stock Config - Unofficial)
The screenshot is taken at around sunrise.

A quick FYI for anyone trying these TU configs, it may wind up blocking visibility out of the cockpit / IVA mode. Ooops. Looks really gorgeous on the outside, though. :)

@blackrack -- this scatterer release looks absolutely gorgeous. The prodigious amount of haze reminds me a lot of the skies in the late summer when the forest fires are going strong, but it makes for some beautiful screenshots. ;)

Share this post


Link to post
Share on other sites
4 hours ago, Beetlecat said:

A quick FYI for anyone trying these TU configs, it may wind up blocking visibility out of the cockpit / IVA mode. Ooops. Looks really gorgeous on the outside, though. :)

@blackrack -- this scatterer release looks absolutely gorgeous. The prodigious amount of haze reminds me a lot of the skies in the late summer when the forest fires are going strong, but it makes for some beautiful screenshots. ;)

If I remember correctly you can remove the internal spaces from the list.

Not sure what you mean about the haze, as it hasn't changed since previous releases.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, @blackrack

I had some time, to test latest release more carefully - I still get scatterer effects overlayed on ships, but now it lasts only for a while - on altitudes between 90 and 110 km. Same recreation steps (clean 1.6.1 install with sigma diemnsions set to 6.4 and scatterer). Anyway, now it disappears without scene reload, so I can live with it :)

Edited by Walker

Share this post


Link to post
Share on other sites
2 hours ago, Walker said:

Hi, @blackrack

I had some time, to test latest release more carefully - I still get scatterer effects overlayed on ships, but now it lasts only for a while - on altitudes between 90 and 110 km. Same recreation steps (clean 1.6.1 install with sigma diemnsions set to 6.4 and scatterer). Anyway, now it disappears without scene reload, so I can live with it :)

I will take a look.

Share this post


Link to post
Share on other sites
18 hours ago, blackrack said:

It seems that this DragCubeSystem starts removing my commandbuffers and scripts from the cameras when the door in mk2 lander can is activated.

LoL; stock code sometimes :confused: ....  One might wonder why toggling a bay door would do anything with or to cameras.  Unfortunately, I know the answer to this one all to well.

Share this post


Link to post
Share on other sites

Hey @blackrack It’s been a long while. Just spun up a new 1.6.1 game last night. And I just had to drop by and say.

- Fantastic work! Each time I think you’ve really gone and “finished” Scatterer. You just keep making it better! KSP wouldn’t be the same without ya man! Thanks.

Share this post


Link to post
Share on other sites

Hey, I hate to pile on but I think I might have a new variant of this bug everyone's having. The thrust reverser on the goliath engine triggers a rebuild of the ocean for me. My log specifically mentions its drag cube which sounds an awful lot like the mk2 lander can bug mentioned elsewhere in the thread.

Share this post


Link to post
Share on other sites
Posted (edited)

ok, I'm glad it wasn't something I did.  Looks like I'm having the same SVE incompatibility issue.

I also noticed that when I reloaded the cache, it fixed the sky, but I got a black bar on the bottom of the screen.

I'll rollback to a previous Scatterer build for now.  What is the last stable build for SVE?

Edited by Capt. Hunt

Share this post


Link to post
Share on other sites
On 3/19/2019 at 12:14 PM, Capt. Hunt said:

ok, I'm glad it wasn't something I did.  Looks like I'm having the same SVE incompatibility issue.

I also noticed that when I reloaded the cache, it fixed the sky, but I got a black bar on the bottom of the screen.

I'll rollback to a previous Scatterer build for now.  What is the last stable build for SVE?

Check the SVE thread. You'll be pleasantly surprised.

Share this post


Link to post
Share on other sites

@blackrack amazing work, once again. Many many thanks.

Mod works just as advertised for me here.

One quick question though: i was always using Galileos FlareReplacer alongside Scatterer with no issues. Now it overrides that flare. And when I disable Scatterers flare in the Scatterer menu, I get no flare at all. Even though FlareReplacer is still installed, and it worked fine before the Scatterer update too.

Any idea how to keep the flare from FlareReplacer and still run the beautiful Scatterer???

Here are the flares in question btw, works off of Kopernicus as far as I understand

 

thanks in advance!

 

Share this post


Link to post
Share on other sites
On 3/19/2019 at 4:35 PM, V8jester said:

Hey @blackrack It’s been a long while. Just spun up a new 1.6.1 game last night. And I just had to drop by and say.

- Fantastic work! Each time I think you’ve really gone and “finished” Scatterer. You just keep making it better! KSP wouldn’t be the same without ya man! Thanks.

Thank you.

3 hours ago, Dafni said:

@blackrack amazing work, once again. Many many thanks.

Mod works just as advertised for me here.

One quick question though: i was always using Galileos FlareReplacer alongside Scatterer with no issues. Now it overrides that flare. And when I disable Scatterers flare in the Scatterer menu, I get no flare at all. Even though FlareReplacer is still installed, and it worked fine before the Scatterer update too.

Any idea how to keep the flare from FlareReplacer and still run the beautiful Scatterer???

Here are the flares in question btw, works off of Kopernicus as far as I understand

 

thanks in advance!

 

Did you change scenes after disabling the flare? Does it override the stock sunflare as well? Try both then open an issue on github.

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, blackrack said:

Did you change scenes after disabling the flare? Does it override the stock sunflare as well? Try both then open an issue on github.

Affirmative on the scene change, but will double check tonight.

Affirmative on the stock flare too. Gives me only a small white dot.

Will have to sign up to github, but will gladly do it help you out in the future as well.

Cheers, and many thanks for your time. Appreciate the swift response.

 

Edit: @blackrack I never used github like that and will have to read into it and such. Might take me a while, dont think I can tackle this one tonight.

Edited by Dafni

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.