blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

On ‎6‎/‎8‎/‎2019 at 11:01 AM, Inacio said:

kgoQW5n.png

Is there a fix / way to prevent white skies?

I have the same issue, did you find a way to fix it?

Share this post


Link to post
Share on other sites
On 5/4/2019 at 4:29 PM, blackrack said:

To fix this, there are 2 solutions:

1) As proposed by @Phineas Freak here, we can increase the far clip plane. This is a good solution but also has a downside.. You see when we increase the gap between far and clip plane we "spread" the depth buffer precision even further resulting in potentially more z-fighting artifacts and blurrier shadows.

2) A second solution is to simply deactivate the PQS and switch to scaledSpace before reaching the altitude where we reach the far clip plane limitations. The issue with this is that we switch to scaledSpace sooner and so, we have less details to look at, at low altitude. Here is a MM Kopernicus patch I made (very quickly) to switch to scaledSpace earlier, I tested this on 6.4x rescale and it seems to be fine, although the transition could be worked on:

I'm using your second solution in a 6.4 scaled Kerbin, so no RSS or RSSVE. But the loss of ground detail when I switch to scaledSpace (I've set it to 100km altitude) is really sad. I'd like to try the other solution, and find a happy compromise between them.

I haven't seen any explanation for how to actually apply solution 1 anywhere in this thread in a way that makes sense on a rescaled stock system, rather than in RSS/RO/RSSVE. The linked MM patches have all been removed, and other references are made to RSSVE, which I don't use. How can I actually use solution 1 in practice on a 6.4x Kerbin, rather than just in theory?

Apologies in advance if I'm being dense or if I've missed something. And many thanks for your help and for your gorgeous mod.

Share this post


Link to post
Share on other sites
2 hours ago, SpaceFace545 said:

I keep getting white skys in ksp with scatterer

I was getting black skies in my KSP v1.7.3 + GPP/GEP installation and I had to revert to a previous version of Scatterer to solve the problem.  In my case, I eventually got to version 0.0336 before the problem disappeared.  However, this is more of a limitation of GPP than it is of Scatterer.

Read the post at the link in my signature block for guidelines on how to report problems.  The information you provide, such as KSP and Scatterer mod versions, may help others find a better solution for you.

Share this post


Link to post
Share on other sites
3 hours ago, Brigadier said:

I was getting black skies in my KSP v1.7.3 + GPP/GEP installation and I had to revert to a previous version of Scatterer to solve the problem.  In my case, I eventually got to version 0.0336 before the problem disappeared.  However, this is more of a limitation of GPP than it is of Scatterer.

Read the post at the link in my signature block for guidelines on how to report problems.  The information you provide, such as KSP and Scatterer mod versions, may help others find a better solution for you.

thank you I finally got it to work and now I am back to taking screenshots

Share this post


Link to post
Share on other sites

Hey @blackrack, I was reading your planned features and saw new terrain system, I was wondering what you might have planned for that? would it involve allowing for new terrain textures as EVE used to allow? Just wondering as this is one of the reasons I halted work on RVE, and as far as I can tell there's no available option for it currently around in KSP other than altering the global body textures

Share this post


Link to post
Share on other sites
On 5/4/2019 at 11:29 AM, blackrack said:

Alright everyone, so as @Phineas Freak said this is an issue with the camera's far clip plane.

Now, why do we still see the planet but not the scatterer effect after the limit distance you ask? It's simple, you are seeing the scaledSpace planet. Due to blending considerations, scatterer will apply the effect either in local or scaled but not the two at the same time, so when the clip plane of the local camera "eats" the local scenery, it eats the scatterer effect with it.

To fix this, there are 2 solutions:

1) As proposed by @Phineas Freak here, we can increase the far clip plane. This is a good solution but also has a downside.. You see when we increase the gap between far and clip plane we "spread" the depth buffer precision even further resulting in potentially more z-fighting artifacts and blurrier shadows.

2) A second solution is to simply deactivate the PQS and switch to scaledSpace before reaching the altitude where we reach the far clip plane limitations. The issue with this is that we switch to scaledSpace sooner and so, we have less details to look at, at low altitude. Here is a MM Kopernicus patch I made (very quickly) to switch to scaledSpace earlier, I tested this on 6.4x rescale and it seems to be fine, although the transition could be worked on:


@Kopernicus:FINAL:NEEDS[Kopernicus]
{
    @Body[Kerbin]
    {
		@PQS
		{
			fadeStart = 40000
			fadeEnd =   50000
			deactivateAltitude = 50000
		}
		@ScaledVersion
		{
			fadeStart = 40000
			fadeEnd   = 50000
		}
    }
}

On 3.2x rescale the values probably don't need to be as extreme. You could probably get away with switching around 110km

They are completely unrelated so scatterer doesn't take it into account. I could either implement a miminum value or try to use the existing brightnessCurve.

I'm sorry to ask such a silly question, but how do I apply this to my game? I tried adding this to my mm config file, but it did not work. If anybody could set me straight, that would be incredible. Thank you!

Share this post


Link to post
Share on other sites
On 8/16/2019 at 6:40 AM, roulbs said:

I'm sorry to ask such a silly question, but how do I apply this to my game? I tried adding this to my mm config file, but it did not work. If anybody could set me straight, that would be incredible. Thank you!

Took me a while to figure this out too. Make a new text file in your gamedata folder, call it something like camerafix.cfg, paste that stuff into it and save it. That works for me!

Share this post


Link to post
Share on other sites

Quick question here, how do I change the atmosphere config that a planet uses? Was trying to figure out why my Duna looks weird and it looks as though it's loading the config for Urlum instead of Duna. It doesn't seem as though I can change the loading path in the in-game scatterer options menu. 

Share this post


Link to post
Share on other sites
On 8/21/2019 at 1:11 PM, General Petrov said:

Quick question here, how do I change the atmosphere config that a planet uses? Was trying to figure out why my Duna looks weird and it looks as though it's loading the config for Urlum instead of Duna. It doesn't seem as though I can change the loading path in the in-game scatterer options menu. 

I have this bug also, but I dont have scatterer installed.. was looking to see if installing scatterer might fix it 

Share this post


Link to post
Share on other sites
Posted (edited)

I've encountered a bug that I'm 99 percent certain is related to the coastal foam effect,as it looks like this:

https://imgur.com/a/TLokHBe

Every few seconds, its cycling between an ocean that looks mostly normal from far away, but with artifacts near the coast, to completely white.

When you get closer, you can see the artifacts at the bottom of those images, and when you get really close you get lots of really tall spiky waves.

Edit: It also doesn't happen all the time, when i landed the plane, when back to space centre and then launched it again, it didn't appear again for the time i flew that flight.

Edited by Amodii

Share this post


Link to post
Share on other sites

Hi I'm having a problem with City Lights and Scatterer.

I have City lights on my planet with EVE and Scatterer seems to have dim the intensity of those light.

When I'm close the light are dim and when I get Further the intensity get back to normal.

Can I tweak the intensity of those Light ?

Spoiler

From Close

dTsWbwf.jpgFrom Far

NuihjgP.jpg

My EVE config File

Spoiler
EVE_CITY_LIGHTS
{
    OBJECT
    {
        body = Ecumenopolis
        cityLightsMaterial
        {
            _CityOverlayTex
            {
                value = Ecumenopolis/EVE/Textures/main
            }
            _CityDarkOverlayDetailTex
            {
                value = Ecumenopolis/EVE/Textures/detaildark
            }
            _CityLightOverlayDetailTex
            {
                value = Ecumenopolis/EVE/Textures/detaildark
            }
        }
    }
}

 

 

Share this post


Link to post
Share on other sites

Hello Everyone.

It seems that the black sky and no water issue is caused by Transfer Window Planner. Removing this fixed these problems for me. Also, in the TWP-Forum people complained about bugs with the mod and the Autor is fixing it as far as i know.

EDIT: The latest Update of Transfer Window Planner works, for me at least.

Edited by Smarti

Share this post


Link to post
Share on other sites

So I thought I'd clarify on my previous question about an issue I'm having with scatterer. Basically for some reason or another the surface terrain of Duna appears to be partially transparent from a distance. This is most noticeable as you descend through the atmosphere, and when you're on the surface looking at hills several kilometres away. Its not immediately clear from these screenshots, but you can just about see that at first the terrain almost appears as if its a part of the atmosphere, but as you descend it becomes less transparent. 

TDqaXyf_d.jpg?maxwidth=640&shape=thumb&f

jfpu7Ur_d.jpg?maxwidth=640&shape=thumb&f

eiqe1XE_d.jpg?maxwidth=640&shape=thumb&f

oehLhSi_d.jpg?maxwidth=640&shape=thumb&f

I tried to find out what was causing this, and the only thing I found was that in the game Scatterer options menu, it looks as though Scatterer is loading the config for Urlum instead of Duna judging by the file path. I couldn't figure out how to change this though. I've been looking for a solution for some time now but I can't find anything. Would greatly appreciate if anyone could help me stop my Duna from looking as though its being snapped out of existence as I enter orbit. 

 

Share this post


Link to post
Share on other sites

Been playing around with some new 128k downscaled to 64k earth textures, but having a hard time getting Scatterer to run properly, would be awesome to revamp this. I found if I enable eve integration with clouds and hit map clouds all terrain goes white, so for the time being I've been running without that, but on occasion it would work briefly over certain areas:

Just to clarify the mapping of eve clouds only seems to not work for cube mapped eve cloud texture but work fine for normal single texture cloud maps and detail 

Edited by pingopete

Share this post


Link to post
Share on other sites

Are the ring shadows/extinction not actually supported/integrated, or am I doing something wrong? I see the setting for it, but I can't get the shadows (on the planet) or sunlight extinction to happen with my planet's rings. I've already checked that it isn't simply the alignment with the sun.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.