blackrack

[WIP][1.8] Scatterer-atmospheric scattering (v0.0541 - 26/10/2019)

Recommended Posts

1 minute ago, blackrack said:

@Alshain could you maybe do this

and do comparisons?

 

Yes, I'll give it a shot.

Share this post


Link to post
Share on other sites
8 minutes ago, blackrack said:

Actually you can just grab the shaders folder from 0.0255 and drop it into 0.0256 and it will work and you'll have the old blending, then you can do comparison pics, if you have time of course.

Awesome. I'll do that once I get home - ETA around one hour? I'm always up for helping out :)

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
1 minute ago, Avera9eJoe said:

Awesome. I'll do that once I get home - should be up in around an hour?

4 minutes ago, Alshain said:

Yes, I'll give it a shot.

Ok, whichever one of you does it first :D

 

Share this post


Link to post
Share on other sites
3 minutes ago, blackrack said:

Ok, whichever one of you does it first :D

Racers start your engines! :P

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites

@blackrack Ok so after copying the shaders from the previous release (0.0255) it appears as if they aren't on.  It doesn't look any different than not having the mod installed anyway.  However, the sunset on the ground is working so I know the mod is active and running. In a way this is the best option so far (IMO) but it doesn't quite look like the screenshots @Avera9eJoe was posting earlier.

AySGnVO.png

Share this post


Link to post
Share on other sites
3 minutes ago, Alshain said:

@blackrack Ok so after copying the shaders from the previous release (0.0255) it appears as if they aren't on.  It doesn't look any different than not having the mod installed anyway.  However, the sunset on the ground is working so I know the mod is active and running. In a way this is the best option so far (IMO) but it doesn't quite look like the screenshots @Avera9eJoe was posting earlier.

Hmm alright, there is probably another issue here. I'll check this one when I can.

Share this post


Link to post
Share on other sites
3 minutes ago, Alshain said:

It doesn't quite look like the screenshots @Avera9eJoe was posting earlier.

Hm, I've posted a lot of screenshots today :P could you insert the ones you mean to be sure?

Share this post


Link to post
Share on other sites
1 minute ago, Avera9eJoe said:

Hm, I've posted a lot of screenshots today :P could you insert the ones you mean to be sure?

Yes sorry, I meant the one you posted here.  You said it was blackrack's screenie.

Share this post


Link to post
Share on other sites
4 minutes ago, blackrack said:

@Galileo What am I looking at here? Also, do the changes to the orbit shader in 0.0256 bother you?

I would say he wants to show how great Kerbin is looking now and that all is well - or?

Share this post


Link to post
Share on other sites

After unloading and then reloading a number of different mods (mostly Environmental Visual Enhancements and Stock Visual enhancements), I have finally determined that it's only when I load scatterer that the daytime sky appears black. Is there a setting I can change to fix this?

 

Edited by SSgt Baloo

Share this post


Link to post
Share on other sites

Meanwhile, back in 0.24:

e1qdO8w.jpg

We were happy with this back then

 

1 minute ago, SSgt Baloo said:

After unloading and then reloading a number of different mods (mostly Environmental Visial Enhancements and Stock Visual enhancements), I have finally determined that it's only when I load scatterer that the daytime sky appears black. Is there a setting I can change to fix this?

Check logs

Edited by blackrack

Share this post


Link to post
Share on other sites
1 minute ago, blackrack said:

Meanwhile, back in 0.24:

e1qdO8w.jpg

We were happy with this back then

 

Check logs

Not an expert, here. How do I check logs?

 

Share this post


Link to post
Share on other sites
1 minute ago, SSgt Baloo said:

Not an expert, here. How do I check logs?

Open KSP.log file and look for error spams

Share this post


Link to post
Share on other sites
13 minutes ago, blackrack said:

@Galileo What am I looking at here? Also, do the changes to the orbit shader in 0.0256 bother you?

what Alshain was disliking was the amount of post processing on Kerbin causing it to look like the atmosphere was very very thick. so i cut the post processing down to 0.0 in orbit and changed the sky orbit alpha from 1 to 0.6 and made changes all the way to the ground to blend well together. I hope that answers the question.  The new shaders don't bother me one bit. Here is a comparison pic:

 

Currently in SVE
YmGyNOw.png

 

The changes i just made
3KSSSu0.png

 

Both look good but one is just a little more real i guess i could say

 

Edited by Galileo

Share this post


Link to post
Share on other sites
5 minutes ago, blackrack said:

Meanwhile, back in 0.24:

e1qdO8w.jpg

We were happy with this back then

A long, long time ago... 
I can still remember 
How that planet used to make me smile. 
And I knew if I had my chance
That I could make those people dream
And, maybe, they’d be happy for a while.

...
(imagine the well known music to it)

Share this post


Link to post
Share on other sites
10 minutes ago, blackrack said:

Meanwhile, back in 0.24:

e1qdO8w.jpg

We were happy with this back then

lol :P

35 minutes ago, Galileo said:

Yku3YGE.png

@Galileo (can't ping people on my phone gur) That looks beautiful :) - exactly what I was trying to do with my edits

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
4 minutes ago, Avera9eJoe said:

lol :P

@Galileo (can't ping people on my phone gur) That looks beautiful :) - exactly what I was trying to do with my edits. How'd you get it that thin with it still looking nice on the surface?

I had to edit each altitude level so that it got thinner as you went up. Ill post some pics of my settings in a bit

Edited by Galileo

Share this post


Link to post
Share on other sites

Thanks for the instructions. I reinstalled scatterer, loaded the game, played a bit with a black sky, then exited.  I didn't notice before, but the ocean seems to be missing, or, at the very least, it's surface seems to be absent. Kind of neat, if I was seeing this on some other planet.

See?
AS-1_zpsbdz3zfpu.jpg



The log file itself is over 40 MB. How can I make its contents available for someone to view? I can't just cut-n-paste it here, and I don't know of any services that I could upload it to for others to view.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.