blackrack

[WIP][1.8] Scatterer-atmospheric scattering (v0.0541 - 26/10/2019)

Recommended Posts

1 minute ago, blackrack said:

For dx11, that's great news! It's my favourite video mode, so that means squad fixed the issue with frequent crashes in dx11 on scene changes?

I have not promlem with dx11 in anytime.

Share this post


Link to post
Share on other sites
4 hours ago, blackrack said:

Hmm, I ran opengl and glcore with no issues several times before uploading the last release...

For dx11, that's great news! It's my favourite video mode, so that means squad fixed the issue with frequent crashes in dx11 on scene changes?

I've not had a single CTD in dx11 mode.

I do not mean scatterer by itself. Reproduce:

  • Setup: Fresh + Kopernicus, EVE, Scatterer
  • Run with -force-glcore
  • Use the following code and look at something about the shader, such as its name:
    Shader[] oShaders = Resources.FindObjectsOfTypeAll<Shader>();

     

It only CTDs with Kopernicus, EVE, and Scatterer installed; other mods that add and use shaders have no issue. I didn't bother to figure out which of the 3 was actually blowing up, so it may not be scatterer; but running in dx11 mode has no problem and all 3 worked fine, so I just ignored it.

 

[Update]

Trying various things... I've come to a conclusion: this is unrelated to Kopernicus, EVE, and scatterer. Ever since the last Windows Update, -opengl and -glcore have both becomes extremely unstable. This is not exclusive to KSP either.

Edited by Electrocutor

Share this post


Link to post
Share on other sites

With Scatterer 0.0336 I'm only getting about 25-30 fps when looking at just loaded KSC. 30 fps is with every scatterer checkbox unchecked! Without scatterer loaded at all I get about 270 fps looking at KSC. I don't have fps numbers for the previous version of scatterer, but it wasn't noticeably bad like this. System is up-to-date Arch Linux with a Radeon RX580.

Share this post


Link to post
Share on other sites
5 hours ago, Electrocutor said:

dx11 is actually more stable than dx9, but the icons are broken unless you drop TU into your install.

How do you use dx11, and what is TU?

Share this post


Link to post
Share on other sites
55 minutes ago, strudo76 said:

How do you use dx11, and what is TU?

A quick Google search revealed the following:

1. You can force KSP to use dx11 with a command line switch.  Squad may or may not have added CL switches in subsequent versions.

2. TU is the mod Textures Unlimited.

 

Edited by Brigadier

Share this post


Link to post
Share on other sites
6 hours ago, Moofed said:

With Scatterer 0.0336 I'm only getting about 25-30 fps when looking at just loaded KSC. 30 fps is with every scatterer checkbox unchecked! Without scatterer loaded at all I get about 270 fps looking at KSC. I don't have fps numbers for the previous version of scatterer, but it wasn't noticeably bad like this. System is up-to-date Arch Linux with a Radeon RX580.

You probably have a nullref spam. Press alt+F12 and see what is going on, if it's the case make a proper bug report, check in the OP for a bug report example.

Share this post


Link to post
Share on other sites
8 hours ago, strudo76 said:

How do you use dx11, and what is TU?

It`s my mod with TU configs. Welcome!

Edited by alexus

Share this post


Link to post
Share on other sites
On 11/17/2018 at 7:14 AM, alexus said:

What did you mean? dx11 is stable. can you fix it?

Will you fix it?

 

On 11/16/2018 at 3:21 PM, alexus said:

Bug report.

1. ksp x64 1.5.1

2. installed mods: scatterer only last version

3. problem: it is transparent hills.

what will I do? Can you fix it?

 

  Reveal hidden contents

KSP-x64-2018-11-16-15-03-15-31.jpgKSP-x64-2018-11-16-15-17-34-77.jpgKSP-x64-2018-11-16-15-17-40-55.jpgKSP-x64-2018-11-16-15-18-08-64.jpg

 

 

Share this post


Link to post
Share on other sites

Getting some crazy light effects when ocean lighting is turned on. It also doesn't seem to reflect light on the water when this is happening. (the light show is eating up all the photons! :D )

Example and info below:

Spoiler

947D800B86B2E308DACECE8734D4F780CD952E47

Spoiler

KSP: 1.5.1 Windows 64bit

Problem: Ship lighting glitch when ocean lighting enabled

Mods installed:

Scatterer 0.0336 (via CKAN)

Reproduction steps:

With ocean lighting enabled, default scatterer settings: Launch a ship from KSP, turn on craft lights; depending on angle, the craft light source creates a visual glitch that floods the screen (depending on angle).

Log:

https://www.dropbox.com/s/3tc1brse90v686c/output_log.txt?dl=0

 

Share this post


Link to post
Share on other sites

minor issue: Kopernicus wrecks the main menu display of Scatterer. Not surprising really since it does its own main menu hijinks, like allowing you to assign a new planet to show up (I don't use that feature, but still gets in the way of Scatterer showing up). Tested on KSP 1.5.1 with just the latest versions of Scatterer and Kopernicus installed

Share this post


Link to post
Share on other sites
On 11/21/2018 at 9:01 AM, alexus said:

Will you fix it?

Will be fixed in next version.

On 11/22/2018 at 7:29 PM, Beetlecat said:

Getting some crazy light effects when ocean lighting is turned on. It also doesn't seem to reflect light on the water when this is happening. (the light show is eating up all the photons! :D )

Example and info below:

  Reveal hidden contents

947D800B86B2E308DACECE8734D4F780CD952E47

  Reveal hidden contents

KSP: 1.5.1 Windows 64bit

Problem: Ship lighting glitch when ocean lighting enabled

Mods installed:

Scatterer 0.0336 (via CKAN)

Reproduction steps:

With ocean lighting enabled, default scatterer settings: Launch a ship from KSP, turn on craft lights; depending on angle, the craft light source creates a visual glitch that floods the screen (depending on angle).

Log:

https://www.dropbox.com/s/3tc1brse90v686c/output_log.txt?dl=0

 

Will be fixed in next version.

40 minutes ago, Drew Kerman said:

minor issue: Kopernicus wrecks the main menu display of Scatterer. Not surprising really since it does its own main menu hijinks, like allowing you to assign a new planet to show up (I don't use that feature, but still gets in the way of Scatterer showing up). Tested on KSP 1.5.1 with just the latest versions of Scatterer and Kopernicus installed

I will check it out, I made it in a generic way so it should support any planet in the main menu but looks like it messed up.

Share this post


Link to post
Share on other sites

Help me please, I can't get scatterer to work without having graphic errors. With Dx9 game flickers like crazy when near ground (https://imgur.com/a/iLfuHcb). Dx11 forced I am able to fly planes and rockets without any flickering although this happens in the VAP and SPH (https://imgur.com/a/JAmc5AU).  

KSP 1.4.5

Mod List: https://imgur.com/a/IJr7Em7

Output log Dx11: https://ufile.io/8rc9f

Output Log Dx9: https://ufile.io/pdsbn

 

Share this post


Link to post
Share on other sites
9 minutes ago, HaydenTheKing said:

Help me please, I can't get scatterer to work without having graphic errors. With Dx9 game flickers like crazy when near ground (https://imgur.com/a/iLfuHcb). Dx11 forced I am able to fly planes and rockets without any flickering although this happens in the VAP and SPH (https://imgur.com/a/JAmc5AU).  

KSP 1.4.5

Mod List: https://imgur.com/a/IJr7Em7

Output log Dx11: https://ufile.io/8rc9f

Output Log Dx9: https://ufile.io/pdsbn

 

Not sure about what's going on with DX9, but the DX11 issue is stock and unrelated to Scatterer.  There are mods that fix it.  Installing Textures Unlimited (even with no configuration for it) will fix it, IIRC @Electrocutor also extracted the fix into a standalone package.

It may be worth using DX11 if you can.  It uses significantly less RAM.

Edited by blowfish

Share this post


Link to post
Share on other sites
7 minutes ago, blowfish said:

Not sure about what's going on with DX9, but the DX11 issue is stock and unrelated to Scatterer.  There are mods that fix it.  Installing Textures Unlimited (even with no configuration for it) will fix it, IIRC @Electrocutor also extracted the fix into a standalone package.

It may be worth using DX11 if you can.  It uses significantly less RAM.

That mod, (KSP 1.4 Fixes), solved the problem.  Now I have my textures back in the VAB and SPH.  Really weird why that happened on there with Dx9. 

 

It didn't do that with SVE, just with AVP and its mods.  I switched to AVP from SVE because I wasn't getting clouds on duna for what ever reason.  Happy that every thing is workign well with AVP.

Share this post


Link to post
Share on other sites

I don't understand the config tweak for RSS or something is not working properly. I only want the ocean shader activated really. Anyone can help me? I opened and closed the game too many times with allways seeing or not water or the "stock" shader.
Ksp 1.3.1

Edited by Agustin

Share this post


Link to post
Share on other sites

I'm playing on KSP 1.4.5, and I tried out scatterer.

It absolutely decimated the frame rate from the its original value.

Like In space -

Camera towards Space - extremely smooth camera and game time shows green

Camera towards Kerbin - Sudden lag and stuttering and game time shows yellow

What are the best settings to play on for maximum performance?

Share this post


Link to post
Share on other sites
2 minutes ago, Xurkitree said:

What are the best settings to play on for maximum performance?

Try disabling the water shaders. If I read things correctly they're mostly responsible for the lag.

Merely turning off water refraction also helps slightly.
God rays are also in early development; they don't look that good as of now and can be disabled.

Those are the settings I use, at least. I'm not sure if this is the best you can do while keeping the game as good as Scatterer makes it, though.

Share this post


Link to post
Share on other sites
17 minutes ago, Agustin said:

configs

Like, in the way I described? Or actually editing the files of Scatterer?

Share this post


Link to post
Share on other sites
1 minute ago, Delay said:

Like, in the way I described? Or actually editing the files of Scatterer?

Editing files.

I made the water look a lot uglier but still is a lot better than stock and disable lot of things.

Share this post


Link to post
Share on other sites
1 minute ago, Agustin said:

Editing files.

What did you do?

My fps are not as bad as those described by Xurkitree, but it would be nice to know.

Share this post


Link to post
Share on other sites
7 minutes ago, Delay said:

What did you do?

My fps are not as bad as those described by Xurkitree, but it would be nice to know.

I edited my last comment. I changed mainly 3 settings ofthe ocean. One was something about MAX_VERTS: I downgraded from 65000 to 20000

I also changed from 4 to 8 two settings: m_resolution and m_varianceSize

Also the resolution factor to 32. Again. Water looks way uglier. But gained a lot of performance on my mid_end-pc

Edited by Agustin

Share this post


Link to post
Share on other sites
46 minutes ago, Agustin said:

MAX_VERTS: I downgraded from 65000 to 20000

I tried that, but Scatterer always reset that value to 65000.

Share this post


Link to post
Share on other sites

Okay but what about the other tweaks? If you are running low fps u could try it. I reallydid gain a lot of fps doing that and not having eve

Edited by Agustin

Share this post


Link to post
Share on other sites

I didn't find any performance difference.

MAX_VERTS was a value that should be changeable. Going into wireframe shows how overkill 65000 vertices actually is, even if 65000 refers to the total number of water vertices the game can use.
It's very small detail for a very large area.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.