blackrack

[WIP][1.8] Scatterer-atmospheric scattering (v0.0541 - 26/10/2019)

Recommended Posts

Excuse me, I am playing on windows 10, I have kerbal space program, 1.6.1, but the scatter screen dose not open at all.

Is there a new one I need or do I need to play on a older version of Kerbal space program?

Share this post


Link to post
Share on other sites
13 hours ago, The_Arcitect said:

Excuse me, I am playing on windows 10, I have kerbal space program, 1.6.1, but the scatter screen dose not open at all.

Is there a new one I need or do I need to play on a older version of Kerbal space program?

@blackrack I have bigger issue, 1080 ti here have to use d3d11 for textures unlimited and when i put scatterer into the data folder, my vga crashed to black screen with it's fan going crazy, have to reset the pc manually. the driver is uptodate and i even uninstalled nvidia experience because i read in some forums that it can cause the problem. vga'a temp. is 53 degree so it's not over heat, used after burner to declock the vga by -25 and reduce power input by 15%. none of that helps. having your mod or ks3p in the folder causes the problem.

 

http://prntscr.com/moy88v

 

same deal is happening with ks3p and there is no output log in the folder to send at all !!!!

Edited by Jiraiyah

Share this post


Link to post
Share on other sites
15 hours ago, The_Arcitect said:

Excuse me, I am playing on windows 10, I have kerbal space program, 1.6.1, but the scatter screen dose not open at all.

Is there a new one I need or do I need to play on a older version of Kerbal space program?

In the space center scatterer now uses a stock toolbar icon to open the config settings.

Share this post


Link to post
Share on other sites

@blackrack

Sir, take a look at my post, it looks like there are minor issues here and there, but the crash was solved as i describe there

 

Share this post


Link to post
Share on other sites
On 2/19/2019 at 1:41 PM, blackrack said:

Working AA (notice no black lines or aliasing around horizon and mountains)

8ko9Qxg.jpg

 

8ln7KqD.jpg

 

Compatibility with camera mods:

IIz4ON8.jpg

 

 

If i got it right, the black horizon problem solution comes with the new update? because i still have them on current version.

 

Also

 

[Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEVolumetrics () [0x00000] in <filename unknown>:0 
d3d11: failed to create staging 2D texture w=6 h=6 d3dfmt=77 [80070057]
d3d11: failed to create staging 2D texture w=3 h=3 d3dfmt=77 [80070057]
Load(Texture): scatterer/config/Sunflares/Sun/Ghost1
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

d3d11: failed to create staging 2D texture w=6 h=6 d3dfmt=77 [80070057]
d3d11: failed to create staging 2D texture w=3 h=3 d3dfmt=77 [80070057]
Load(Texture): scatterer/config/Sunflares/Sun/Ghost2
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Load(Texture): scatterer/config/Sunflares/Sun/Ghost3

 

log file : https://www.dropbox.com/s/dfumid6idmn1f3w/output_log_dx11.txt?dl=0

ksp log : https://www.dropbox.com/s/i7garihegf3m89n/KSP.log?dl=0

 

By the way I am using dx11 for textures unlimited, you may want to look into that case too.

Edited by Jiraiyah

Share this post


Link to post
Share on other sites
1 hour ago, Jiraiyah said:

If i got it right, the black horizon problem solution comes with the new update? because i still have them on current version.

 

Also

 


[Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEVolumetrics () [0x00000] in <filename unknown>:0 
d3d11: failed to create staging 2D texture w=6 h=6 d3dfmt=77 [80070057]
d3d11: failed to create staging 2D texture w=3 h=3 d3dfmt=77 [80070057]
Load(Texture): scatterer/config/Sunflares/Sun/Ghost1
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

d3d11: failed to create staging 2D texture w=6 h=6 d3dfmt=77 [80070057]
d3d11: failed to create staging 2D texture w=3 h=3 d3dfmt=77 [80070057]
Load(Texture): scatterer/config/Sunflares/Sun/Ghost2
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Load(Texture): scatterer/config/Sunflares/Sun/Ghost3

 

log file : https://www.dropbox.com/s/dfumid6idmn1f3w/output_log_dx11.txt?dl=0

ksp log : https://www.dropbox.com/s/i7garihegf3m89n/KSP.log?dl=0

 

By the way I am using dx11 for textures unlimited, you may want to look into that case too.

For black horizon, on current version, yes, on next version no.

Is ks3p updated? From looking at the mod's thread it seems like it is still using unity 5.4.

The volumetric clouds error you can discard, just means you don't have EVE installed or a volumetric layer.

The other error with sunflares is more worrying, try starting scatterer with sunflare shader disabled.

Edited by blackrack

Share this post


Link to post
Share on other sites
33 minutes ago, blackrack said:

For black horizon, on current version, yes, on next version no.

Is ks3p updated? From looking at the mod's thread it seems like it is still using unity 5.4.

The volumetric clouds error you can discard, just means you don't have EVE installed or a volumetric layer.

The other error with sunflares is more worrying, try starting scatterer with sunflare shader disabled.

There was an unofficial build for ks3p using direct x 11, after putting it in the folder without your mod, ksp is totally stable, but adding your mod causes crash on random times but most likely entering ksc or flight the very first time.

Share this post


Link to post
Share on other sites
4 hours ago, Jiraiyah said:

There was an unofficial build for ks3p using direct x 11, after putting it in the folder without your mod, ksp is totally stable, but adding your mod causes crash on random times but most likely entering ksc or flight the very first time.

Link to the unofficial build?

Share this post


Link to post
Share on other sites
9 hours ago, nibelung165 said:

I hope this is going to be updated. Such a great mod is a must-have for everyone

I actually don't think it needs to be updated. Give it a try and see if it works :)

Share this post


Link to post
Share on other sites
On 2/26/2019 at 4:19 AM, Deddly said:

I actually don't think it needs to be updated. Give it a try and see if it works :)

Without an update this mod is a bit harder to install, because it is not present in CKAN

Share this post


Link to post
Share on other sites
15 minutes ago, nibelung165 said:

Without an update this mod is a bit harder to install, because it is not present in CKAN

scatterer is in CKAN.  Going to Settings > Compatible KSP Version and check KSP 1.6, 1.5, and 1.4 (everything since the major Unity change between 1.3 and 1.4) as all mods compiled for any 1.6.x and 1.5.x will work under 1.6.1 (as the 1.6.x releases haven't had major breaking changes) and virtually any mod made for 1.4.x works too.  Then you'll see the 3 parts scatterer is split into in CKAN.

Share this post


Link to post
Share on other sites
On 2/23/2019 at 8:06 PM, blackrack said:

Link to the unofficial build?

ok, tried to have a cleaner instance of the game and try your mod, again crash to black screen, here are the log files and a screenshot of my mods folder, all the visual mods are the latest Officials and "I'm forcing open gl" this time. so it's not even direct x11 related anymore !

ksp log : https://www.dropbox.com/s/iyurnwglj63xgc2/KSP.log?dl=0

ouputlog : https://www.dropbox.com/s/a19hye0xhlnbwz2/output_log.txt?dl=0

gamedata folder (removed scatterer already) : http://prntscr.com/mqzeuj

 

by the way the version of your mod i was trying was the latest from github itself 0.0336

Edited by Jiraiyah

Share this post


Link to post
Share on other sites
Posted (edited)
On 2/27/2019 at 1:20 PM, Jiraiyah said:

ok, tried to have a cleaner instance of the game and try your mod, again crash to black screen, here are the log files and a screenshot of my mods folder, all the visual mods are the latest Officials and "I'm forcing open gl" this time. so it's not even direct x11 related anymore !

ksp log : https://www.dropbox.com/s/iyurnwglj63xgc2/KSP.log?dl=0

ouputlog : https://www.dropbox.com/s/a19hye0xhlnbwz2/output_log.txt?dl=0

gamedata folder (removed scatterer already) : http://prntscr.com/mqzeuj

 

by the way the version of your mod i was trying was the latest from github itself 0.0336

That is not a clean install. Unzip a completely fresh copy of KSP from your download, and give it's folder a unique name, such as KSP_testbed(1.6.1). Then install JUST scatterer in the the testbed. You need to establish a baseline that scatterer either does or doesn't work at all on your system configuration, either due to video card, driver, OS or other issues. Testing with a bunch of other mods installed means that it could easily be in some sort of unpredictable mod conflict. Once you have a working copy of vanilla KSP with scatterer installed, you can start to add in mods, only a few at a time and testing over and over. One of two things will happen, either you eventually get all your mods installed, or you run into the crash bug again. The first one means that you must have borked your install somehow the first time you were adding mods, and the second means that you just found your mod conflict, now remove the last few mods you put in one at a time until you find the exact mod that is causing the issues. Then provide logs of that case, if you find it.

Edited by Errol

Share this post


Link to post
Share on other sites
7 hours ago, Errol said:

That is not a clean install. Unzip a completely fresh copy of KSP from your download, and give it's folder a unique name, such as KSP_testbed(1.6.1). Then install JUST scatterer in the the testbed. You need to establish a baseline that scatterer either does or doesn't work at all on your system configuration, either due to video card, driver, OS or other issues. Testing with a bunch of other mods installed means that it could easily be in some sort of unpredictable mod conflict. Once you have a working copy of vanilla KSP with scatterer installed, you can start to add in mods, only a few at a time and testing over and over. One of two things will happen, either you eventually get all your mods installed, or you run into the crash bug again. The first one means that you must have borked your install somehow the first time you were adding mods, and the second means that you just found your mod conflict, now remove the last few mods you put in one at a time until you find the exact mod that is causing the issues. Then provide logs of that case, if you find it.

it's not my first time modding ksp, also, i hope you know that crash to black screen with vga's fan going crazy, is most likely a shader crash on the mod itself. it's not a normal ksp game crash. the vga driver itself crashes and there is no other way but to restart the pc manually. these simptoms can be one of the very few things :

1- temperature (checked, it's not the reason)

2- over clock (checked even down clocked slightly, so it's not power nor hardware)

3- driver version (triple checked, it's not that)

4- shader crash on the vga, causing a null pointer error on the vga side of things that repeats itself constantly, causing overflow and vga crash (most likely)

 

knowing all this, do you still think having scatterer alone would be different? i tell you from experience, it did the same but a little bit later in the game, for example, opens to ksc, go to vab, come back to ksc ==> crash ! and that in on vanilla + scatterer.

 

The reason i gave the log file above, it that the mod developer himself will be the best to judge if there is a solo issue or if there is a conflict between two graphical mods. having this log may show something regarding a conflict that a solo install won't. Also knowing that solo install still had the issue, i would still think that there is some shader crash or something like that. things get worse if you force direct x. but even on open gl, it still crashes but not as soon as main menu wants to come up at least !

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Jiraiyah said:

it's not my first time modding ksp, also, i hope you know that crash to black screen with vga's fan going crazy, is most likely a shader crash on the mod itself. it's not a normal ksp game crash. the vga driver itself crashes and there is no other way but to restart the pc manually. these simptoms can be one of the very few things :

1- temperature (checked, it's not the reason)

2- over clock (checked even down clocked slightly, so it's not power nor hardware)

3- driver version (triple checked, it's not that)

4- shader crash on the vga, causing a null pointer error on the vga side of things that repeats itself constantly, causing overflow and vga crash (most likely)

 

knowing all this, do you still think having scatterer alone would be different? i tell you from experience, it did the same but a little bit later in the game, for example, opens to ksc, go to vab, come back to ksc ==> crash ! and that in on vanilla + scatterer.

 

The reason i gave the log file above, it that the mod developer himself will be the best to judge if there is a solo issue or if there is a conflict between two graphical mods. having this log may show something regarding a conflict that a solo install won't. Also knowing that solo install still had the issue, i would still think that there is some shader crash or something like that. things get worse if you force direct x. but even on open gl, it still crashes but not as soon as main menu wants to come up at least !

I find it very hard to follow what you have and haven't done, and I am obviously not the mod author, so I am not an authority. But in my experience, if you have not at least tried a particular mod in a vanilla install to verify it can work at all on your system, that a mod author wont be too motivated to help you.

You need to do this by process of elimination, not by intellectualizing some logic of what you think is going on. Don't try to force openGL or dx 11 or what ever, just install scatterer with default settings into a stock KSP, and check to see if you get the crash. It isn't a difficult, or time consuming test to do, and it will be very informative on the potential of mod conflicts. It is up to you to spend the time figuring out if your bug is do to a botched install, before you ask a mod author to spend their time hunting down an alleged bug.

I'm not trying to be rude, but look at it this way, you are the only one currently reporting this issue, what are the chances that there is a bug that only you are experiencing vs the chances you installed something incorrectly or have some sort of conflict? What is the harm in checking to see which case you are in?

Edited by Errol

Share this post


Link to post
Share on other sites
3 hours ago, Errol said:

I find it very hard to follow what you have and haven't done, and I am obviously not the mod author, so I am not an authority. But in my experience, if you have not at least tried a particular mod in a vanilla install to verify it can work at all on your system, that a mod author wont be too motivated to help you.

You need to do this by process of elimination, not by intellectualizing some logic of what you think is going on. Don't try to force openGL or dx 11 or what ever, just install scatterer with default settings into a stock KSP, and check to see if you get the crash. It isn't a difficult, or time consuming test to do, and it will be very informative on the potential of mod conflicts. It is up to you to spend the time figuring out if your bug is do to a botched install, before you ask a mod author to spend their time hunting down an alleged bug.

I'm not trying to be rude, but look at it this way, you are the only one currently reporting this issue, what are the chances that there is a bug that only you are experiencing vs the chances you installed something incorrectly or have some sort of conflict? What is the harm in checking to see which case you are in?

I know you are not rude. If I wrote words that sounded like that i apologize. the thing is, as i said, i tried vanilla + scatterer the very first time i got the crash. it would come few minutes later in game sometimes when you are on launch pad sometimes when you go into vab and back to ksc. but when i add more graphical mods, things get much worse.

Share this post


Link to post
Share on other sites
2 hours ago, Jiraiyah said:

I know you are not rude. If I wrote words that sounded like that i apologize. the thing is, as i said, i tried vanilla + scatterer the very first time i got the crash. it would come few minutes later in game sometimes when you are on launch pad sometimes when you go into vab and back to ksc. but when i add more graphical mods, things get much worse.

Ok, so if you are getting the crash with just ksp and scatterer, then you need to provide those logs. That is about all I can offer to help make this easy for blackrack or others to track down.

Share this post


Link to post
Share on other sites
Posted (edited)

Currently do not have much time to test this fully with a log, but it should be relatively simple to reproduce - 

EVE cloud integration enabled is a huge performance hit. After disabling it, I went from 41 FPS to 60+. This only really affects looking at the horizon, but it's a significant hit.

The only problem is that EVE clouds are black with this turned off... Huge bummer.

Edited by Gameslinx

Share this post


Link to post
Share on other sites

I love the mod, it makes the game look like it could've shipped with these grapical enhances to begin with. The only downside is that it makes my pc run at 20 fps when viewing Kerbin... lol

 

I feel like all the other planned features should be put off for a bit more optimization/polish to it, so that medium-end systems would be able to handle it better. Other than that, I don't have much else to say other than it's great!

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/7/2019 at 8:07 PM, SoldierX5 said:

I feel like all the other planned features should be put off for a bit more optimization/polish to it, so that medium-end systems would be able to handle it better. 

Hi, welcome to the forum.

As is the case with all internet forums, it is generally advisable to read some of the thread before posting questions. At least the last few pages. This specific question has been asked, and responded to by the mod author, numerous times in the past. The short answer is, scatterer is already well optimized for what it does, and there is no easy performance lever that blackrack can pull to magically make it run faster on low end machines. 

Edited by Errol

Share this post


Link to post
Share on other sites

Good day, my question is, who's using this in 1.6.1 and do you see any significant problems

Share this post


Link to post
Share on other sites
6 minutes ago, The-Doctor said:

Good day, my question is, who's using this in 1.6.1 and do you see any significant problems

I am, and no significant problems that I can see (KSP v1.6.1, Galileo's Planet Pack + Grannus Expansion Pack)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.