blackrack

[WIP][1.8] Scatterer-atmospheric scattering (v0.0541 - 26/10/2019)

Recommended Posts

On 2/27/2019 at 6:10 PM, Jacke said:

scatterer is in CKAN.  Going to Settings > Compatible KSP Version and check KSP 1.6, 1.5, and 1.4 (everything since the major Unity change between 1.3 and 1.4) as all mods compiled for any 1.6.x and 1.5.x will work under 1.6.1 (as the 1.6.x releases haven't had major breaking changes) and virtually any mod made for 1.4.x works too.  Then you'll see the 3 parts scatterer is split into in CKAN.

Even with the solution you're providing, I'm having trouble installing Scatterer through CKAN; I can't click the checkbox to install it

Share this post


Link to post
Share on other sites
6 hours ago, nibelung165 said:

Even with the solution you're providing, I'm having trouble installing Scatterer through CKAN; I can't click the checkbox to install it

It sounds as if there is a mod conflict that CKAN is recognizing.  Have you checked the Relationships tab for the Scatterer mod in CKAN?  Is anything listed there with the Conflicts icon?

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry if it is already posted, but I'm experiencing a weird visual glitch that I didn't see elsewhere.

jCawuPx.jpg

NqJI7i0.jpg

 

I'm messing around with Kopernicus and basically replaced kerbin with paradise from TheWorldBeyond mod, and north/south hemisphere's atmosphere have a color difference. It only appears on this planet, and regardless of scatterer version I'm using (0.0336/0.054) / atmoshpere file I'm using (the default kerbin one / Paradise's file comes from TWB mod). Changing between opengl / d3d11 don't help either. Is this a glitch only appears in 1.7.0 or I messed up the config file?

Weird, it's caused by the planet's rings. Shadow of the planet's rings when their inclination is exactly the same as the sun. Should I do a bug report on Github or something?

I'm new to this forum and if I've done something stupid, I'm sorry for that.:blush:

Edited by Miracle Magician
found the cause of the glitch

Share this post


Link to post
Share on other sites

Hello, I would like to make you guys aware of some exceptions scatterer is throwing, I can´t quite identify the problems in-game but I might as well share them. KSP 1.6.1

Here´s the log: KSP.log

I hope it's of some use.

Share this post


Link to post
Share on other sites

Sorry to bring this back up, @Phineas Freak, but will that fix for iGGnitE work for 1.3.1 as well? I'm running GPP at 10.625x scale and getting the same issue.

Share this post


Link to post
Share on other sites
8 hours ago, .50calBMG said:

Sorry to bring this back up, @Phineas Freak, but will that fix for iGGnitE work for 1.3.1 as well? I'm running GPP at 10.625x scale and getting the same issue.

For me, it only partially fixed the scatterer glitch on the horizon (which I assume you're talking about?)
You can always download the fix and try it out, you can just remove it if it doesn't work.

Share this post


Link to post
Share on other sites

After trying that fix on 1.3.1, it did fix the horizon glitch on ascent, but once my rocket left the atmosphere all the scatterer effects just disappeared. Do I need to change some configs or is it just not compatible?

Share this post


Link to post
Share on other sites

Yeah, I'm an idiot, you were right. Had .0324 running. Should have checked CKAN closer, but I just removed an RSS setup which also had scatterer through CKAN and it didn't have any problems so I assumed it had installed the right one. Thanks guys.

Share this post


Link to post
Share on other sites
Posted (edited)

in the latest version scatterer and latest mm that it still gives off white skies on Mac OS/OS X with the same mod config as the above-linked post.

not my computer so I cannot get player.log off

Spoiler

Screen_Shot_2019-04-28_at_11.39.44_AM.pn

 

Edited by ssd21345

Share this post


Link to post
Share on other sites

How does sunGlareFadeDistance work compared with Kopernicus brightnessCurve? Does it override its behaviour?

I'm asking because, with Scatterer, distant stars are not visible from Earth, whereas Kopernicus brightnessCurve allowed for a fully configurable curve - and, consequently, for a non-zero minimum "size" (in this case, flare) to be set. Is there any way to limit the sunglare fading to a specific value at extreme distances?

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/4/2019 at 11:24 AM, BadOaks said:

@blackrack I love the look of the new version, and really appreciate all the hard work you've put into this mod. 

There are two issues that I found, the first is the same kind of black patches on the horizon that @evileye.x and @Citizen247 reported with rescaled systems. This is a 3.2x rescale on a clean install with only scatterer and the mods needed for rescaling (Kopernicus/Sigma/Rescale etc.).

wNSQ70Y.jpg

Alright everyone, so as @Phineas Freak said this is an issue with the camera's far clip plane.

Now, why do we still see the planet but not the scatterer effect after the limit distance you ask? It's simple, you are seeing the scaledSpace planet. Due to blending considerations, scatterer will apply the effect either in local or scaled but not the two at the same time, so when the clip plane of the local camera "eats" the local scenery, it eats the scatterer effect with it.

To fix this, there are 2 solutions:

1) As proposed by @Phineas Freak here, we can increase the far clip plane. This is a good solution but also has a downside.. You see when we increase the gap between far and clip plane we "spread" the depth buffer precision even further resulting in potentially more z-fighting artifacts and blurrier shadows.

2) A second solution is to simply deactivate the PQS and switch to scaledSpace before reaching the altitude where we reach the far clip plane limitations. The issue with this is that we switch to scaledSpace sooner and so, we have less details to look at, at low altitude. Here is a MM Kopernicus patch I made (very quickly) to switch to scaledSpace earlier, I tested this on 6.4x rescale and it seems to be fine, although the transition could be worked on:

@Kopernicus:FINAL:NEEDS[Kopernicus]
{
    @Body[Kerbin]
    {
		@PQS
		{
			fadeStart = 40000
			fadeEnd =   50000
			deactivateAltitude = 50000
		}
		@ScaledVersion
		{
			fadeStart = 40000
			fadeEnd   = 50000
		}
    }
}

On 3.2x rescale the values probably don't need to be as extreme. You could probably get away with switching around 110km

On 5/3/2019 at 12:20 AM, Tonas1997 said:

How does sunGlareFadeDistance work compared with Kopernicus brightnessCurve? Does it override its behaviour?

I'm asking because, with Scatterer, distant stars are not visible from Earth, whereas Kopernicus brightnessCurve allowed for a fully configurable curve - and, consequently, for a non-zero minimum "size" (in this case, flare) to be set. Is there any way to limit the sunglare fading to a specific value at extreme distances?

They are completely unrelated so scatterer doesn't take it into account. I could either implement a miminum value or try to use the existing brightnessCurve.

Edited by blackrack

Share this post


Link to post
Share on other sites
23 minutes ago, A Random Kerbonaut said:

Does the latest version work for 1.7?

Yes

Share this post


Link to post
Share on other sites
8 hours ago, blackrack said:

Alright everyone, so as @Phineas Freak said this is an issue with the camera's far clip plane.

Now, why do we still see the planet but not the scatterer effect after the limit distance you ask? It's simple, you are seeing the scaledSpace planet. Due to blending considerations, scatterer will apply the effect either in local or scaled but not the two at the same time, so when the clip plane of the local camera "eats" the local scenery, it eats the scatterer effect with it.

To fix this, there are 2 solutions:

1) As proposed by @Phineas Freak here, we can increase the far clip plane. This is a good solution but also has a downside.. You see when we increase the gap between far and clip plane we "spread" the depth buffer precision even further resulting in potentially more z-fighting artifacts and blurrier shadows.

2) A second solution is to simply deactivate the PQS and switch to scaledSpace before reaching the altitude where we reach the far clip plane limitations. The issue with this is that we switch to scaledSpace sooner and so, we have less details to look at, at low altitude. Here is a MM Kopernicus patch I made (very quickly) to switch to scaledSpace earlier, I tested this on 6.4x rescale and it seems to be fine, although the transition could be worked on:


@Kopernicus:FINAL:NEEDS[Kopernicus]
{
    @Body[Kerbin]
    {
		@PQS
		{
			fadeStart = 40000
			fadeEnd =   50000
			deactivateAltitude = 50000
		}
		@ScaledVersion
		{
			fadeStart = 40000
			fadeEnd   = 50000
		}
    }
}

On 3.2x rescale the values probably don't need to be as extreme. You could probably get away with switching around 110km

They are completely unrelated so scatterer doesn't take it into account. I could either implement a miminum value or try to use the existing brightnessCurve.

Thanks! Also, is there an easy way to reduce the size of a sunflare? I tried using the one from RSS's Sun on Proxima Centauri but, needless to say, it looks huge.

Share this post


Link to post
Share on other sites
 
 
 
 
 
 
 
6
On 5/4/2019 at 4:29 PM, blackrack said:

To fix this, there are 2 solutions:

1) As proposed by @Phineas Freak here, we can increase the far clip plane. This is a good solution but also has a downside.. You see when we increase the gap between far and clip plane we "spread" the depth buffer precision even further resulting in potentially more z-fighting artifacts and blurrier shadows.

2) A second solution is to simply deactivate the PQS and switch to scaledSpace before reaching the altitude where we reach the far clip plane limitations. The issue with this is that we switch to scaledSpace sooner and so, we have less details to look at, at low altitude. Here is a MM Kopernicus patch I made (very quickly) to switch to scaledSpace earlier, I tested this on 6.4x rescale and it seems to be fine, although the transition could be worked on:

Perhaps, on large rescales, a mixture of the two would be the best compromise?

Share this post


Link to post
Share on other sites
Posted (edited)

*bad post, ignore*

Edited by DDE

Share this post


Link to post
Share on other sites

Anyway, @Galileo, take two...

Problem: should these trees be so visible? It seems to me they shine right through scaterrer's atmo haze.

Spoiler

73709523B269FA26EE3673733BB1AF6D78B9786B

2ECEBB8ABFB206BABB8D8B89BF2DFE256D2E7888

Modlist

Spoiler

KSP: 1.7 (Win64) - Unity: 2017.1.3p1 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.6.3
ClickThroughBlocker - 0.1.7.2
TexturesUnlimited - 1.4.7.21
ToolbarControl - 0.1.6.20
B9 Part Switch - 2.6
Chatterer Extended - 0.6.2
Chatterer - 0.9.96.2332
Community Category Kit - 4.0
Community Resource Pack - 1.0
CryoEngines - 0.6.6
CryoTanks - 1.1.2
DeployableEngines - 1.0.1
DMagic Orbital Science - 1.4.2
DynamicBatteryStorage - 1.4.2
Environmental Visual Enhancements - 1.4.2.2
FASA Launch Clamps - 1.1.4
Firespitter - 7.9
FuseBoxContinued - 0.1.16.8
KAS - 1.3.7050.3681
Kerbal Foundries - 2.3.7.17
HyperEdit - 1.5.8
InlineBallutes - 1.2.8
Kerbal Inventory System - 1.20.7062.41416
<b><color=#CA7B3C>Kopernicus</color></b> - 1.7.0.1
KSP-AVC Plugin - 1.3.0.3
KSPWheel - 0.15.13.32
ModularFlightIntegrator - 1.2.6
Docking Port Alignment Indicator - 6.8.3
NearFutureProps - 0.5.1
NearFutureSolar - 1.0
NearFutureSpacecraft - 1.2.3
OuterPlanetsMod - 2.2.2
PlanetShine - 0.2.6.1
PoodsOPMVO - 0.3.5
RCS Build Aid - 0.9.7.6
RealChute - 1.4.7.4
RealPlume - Stock - 1.3.1
ReentryParticleEffect - 1.4
RemoteTech - 1.9.2
ReStock - 0.1.4
ReStockPlus - 0.1.4
SCANsat - 1.1.8.10
SmartParts - 1.9.13.4
StageRecovery - 1.9.1
StationPartsExpansionRedux - 1.2
Stock Visual Enhancements - 1.4
Stock Visual Terrain - 2.2
TextureReplacer - 3.7
ThrottleControlledAvionics - 3.5.4
TAC Life Support - 0.13.12
Trajectories - 2.2.2
Kerbal Alarm Clock - 3.10
Universal Storage 2 - 1.7.0.10
VenStockRevamp - 1.12

Logshttps://1drv.ms/t/s!AmlSZuL0ax7C5EVvjLdFS_GtLsg4

Share this post


Link to post
Share on other sites
Posted (edited)

I'm not sure if this is Scatterer or EVE, but I have an issue whereby KSC z-fights with the ground below it really badly.

This started occurring when I updated to latest scatterer (0.0540) and EVE (1.4.2.2). I'm still running KSP 1.3.1 - the mods are built from source for KSP 1.3.1 and I re-exported the shaders from Unity 5.4.0p4.

I have RSS installed, so this is on a full-scale Earth, I'm using RSSVE 1.4.5.2 configs.

Is this something just broken in old versions of unity, or is there a config tweak that might affect it?

Edit: I have a screenshots, seems it's not KSC, it's just terrain when the camera is below a certain height.

y4ma_4I73d5SYHy-nbmShrCzBSRM37Baj6aGVg1N

Edited by Flibble

Share this post


Link to post
Share on other sites

Scatterer 0.54:

gEyjPEp.png

Scatterer 0.53:

1fE4AWh.png

I'm not sure what's changed, but scatterer 0.54 has completely broken the effects on this planet i've made and I am unable to fix them.

Something that was changed between these two versions has caused this and i can't recreate the preferred effect (bottom picture) in scatterer 0.54.

Share this post


Link to post
Share on other sites
On 4/5/2019 at 2:56 PM, Phineas Freak said:

Try and add the following two parameters to the RSSVE RSS patch and see if they fix it:


%cam00FarClip = 1251.0
%cam01NearClip = 1249.0

And yes, you guessed correctly about the far clip plane. 

Rd7ehLk.png

Sorry, it seems not working for me, I still get the weird blue tint when switching to ScaledVersion  :(

I'm playing 10X rescale with some code from RSS's watchdog.cs so the effect should be same as RSS

Share this post


Link to post
Share on other sites
23 hours ago, Miracle Magician said:

I still get the weird blue tint when switching to ScaledVersion

And you are assuming that this was an assured fix for that bug. Note how i said "try and see" instead of "add this and it will fix it".

On 5/20/2019 at 9:47 PM, Gameslinx said:

I'm not sure what's changed, but scatterer 0.54 has completely broken the effects on this planet

You are not alone. I had the exact same problem and i ended up just remaking every Scatterer config + texture from scratch, although some things are still incorrect (and i still do not know what the actual fix was). Stick with 0.053 for now.

Share this post


Link to post
Share on other sites
55 minutes ago, Phineas Freak said:

And you are assuming that this was an assured fix for that bug. Note how i said "try and see" instead of "add this and it will fix it".

IKR, my English is just not good and I think I didn't express what I meant precisely. I was just mentioning it doesn't work because nobody mentioned whether this works or not:P

Share this post


Link to post
Share on other sites
14 hours ago, Phineas Freak said:

You are not alone. I had the exact same problem and i ended up just remaking every Scatterer config + texture from scratch, although some things are still incorrect (and i still do not know what the actual fix was). Stick with 0.053 for now.

Not only that but the sunflares disappear on scene reload, tabbing out, vessel switch. Even looking at them sometimes makes them disappear! 

Share this post


Link to post
Share on other sites
Posted (edited)

I'm having a problem as well where I can't change my settings and they always changing back to the same every time I reload the game, even when changing them in the file the game resets them on launch, and I've tried this for 0.036 and latest.

Edit: found out it was Astronomers Visual Pack overriding the original config, so everything's working again 

Edited by JinxerH

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.