blackrack

[WIP][1.8] Scatterer-atmospheric scattering (v0.0541 - 26/10/2019)

Recommended Posts

@blackrack Can we go ahead and set Scatterer to support KSP 1.7 and up in CKAN? I'm running it with 1.7.3 and have no visible issues. I'm asking because in CKAN it's still marked as only supporting up to KSP 1.6.1, and the devs are hesitant to mark it such without the mod author's consent.

Share this post


Link to post
Share on other sites
On 4/17/2019 at 4:31 AM, Phineas Freak said:

I also noticed them but no matter what value i used (up to 7500000 meters) would fix it. Weirdly enough, less than 2000000 meters are required for RSS (a larger body that even 10.6x scaled Kerbin) so i assume that something else is causing that (see final note).

Saw the same thing with just the default Scatterer distribution and a 10.6x rescale (see final note).

I...guess so? Give me some time and I'll whip something up.

Note: I would guess that both of these are caused by the fact that the default Scatterer configs/textures are not meant to be used "as-is" for rescales.

Edit: new version is up, now allows the user to define a custom clip value (located under "FarCameraFix/Configs/FarCameraFix_Settings.cfg"). Pinging @evileye.x for further testing.

Hi guys,

I'm having this problem with the camera's far clipping plane and i'm trying to apply the solution in the quoted post, but the link does not work anymore. Does anybody still have this cfg?

Share this post


Link to post
Share on other sites
On 10/15/2019 at 10:22 AM, randall_going_to_space said:

it's still marked as only supporting up to KSP 1.6.1

You can set CKAN to show mods compatible with previous versions of KSP.

Share this post


Link to post
Share on other sites
59 minutes ago, SnacklessKerbal said:

Does scatterer  work with 1.8? i'm away from my pc so i just want to check if the new engine broke it

You asked 15 minutes after it dropped.

Share this post


Link to post
Share on other sites
2 hours ago, SnacklessKerbal said:

Does scatterer  work with 1.8? i'm away from my pc so i just want to check if the new engine broke it

As was expected, 1.8 is not compatible with quite a few mods, scatterer included (in my case with a clean install). 
Please be patient and just wait a while for the modders to catch up.

Share this post


Link to post
Share on other sites

 

20 hours ago, Leophos said:

As was expected, 1.8 is not compatible with quite a few mods, scatterer included (in my case with a clean install). 
Please be patient and just wait a while for the modders to catch up.

 

21 hours ago, Galileo said:

You asked 15 minutes after it dropped.

My bad, didn't intend to seem rude. I was only wondering if it was compatible with 1.8 or it would need an update. Take your time modders, do it good like you always do!  :D

Share this post


Link to post
Share on other sites
1 hour ago, alberro+ said:

the ocean

 

 

the ocean is gone 

If you love your ocean, set it free!

If it comes back to you, it's yours.

If it doesn't then it was never meant to be. :(

Share this post


Link to post
Share on other sites

Ocean, ocean everywhere!

Oh well, patience it is, Scatterer is just too beautiful to be left apart.

Share this post


Link to post
Share on other sites
6 hours ago, alberro+ said:

the ocean

the ocean is gone 

Please read the thread linked in my signature block on how to report a problem.  What you provided was unhelpful to anyone trying to assist you and the harder you make it, the less help you'll receive.

Share this post


Link to post
Share on other sites

Any chance this mod is also causing this (in 1.8 - up to date install alongside EVE)?

z0YGvLi.jpg

It only becomes visible when you're looking towards the sun, as you would expect the sunflare to do, but as you can see ... different.

Also ... 

m854uZl.jpg?1

Arghhh ... Scorched Kerbin.  Oh the Kerbinity!

I love this mod BTW ... thanks for all your effort.

 

Edited by Stryks
Forgot the thanks.

Share this post


Link to post
Share on other sites

@Stryks 1.8 had significant changes

Significant upgrade to Unity

The API reference files themselves are changed. (this time around, if a mod works ok in 1.8 count that as a minor miracle. Instead of 1 or 2 files to reference there could be up to ten... or maybe more. (Real Fuels has to reference ten files now)

We're up to .NET 4 now instead of 3.5 like we've been on for years.

This is going to have to be updated. A recompile at the very least so be patient.

Share this post


Link to post
Share on other sites

I myself like seeing these kind of bugs now and again as it reminds me of the work that goes into making KSP and its mods amazing.  The bug squashing take's the effort of a human, and I really appreciated that in a game I use to kind of step away from humanity for a bit.

Share this post


Link to post
Share on other sites

 

Updated 1.8 build of scatterer with a rename, essentially.  It was renamed so bugs don't go to the original author.  It will work with original scatterer mods, you just need to run a small script.  You will lose your settings options unless you drag/drop the cfgs manually.

Just thought some of you may appreciate it.

EDIT:  You didn't.  Removed.  Sorry.

Edited by R-T-B

Share this post


Link to post
Share on other sites
32 minutes ago, zit said:

This guy got it to work with 1.8???

 

Yes, there was an unofficial build I put out using the standard name.  It worked with a few glitches, mostly sun flares.  It was up around 3 hours and had maybe 30 downloads.

Don't ask for it.  It was a mistake as I do not have naming permissions.  Unfortunate, but that one I completely understand, I was just eager to help.  That was a mistake on my part and I am sorry.

Edited by R-T-B

Share this post


Link to post
Share on other sites

i sent the author (ghassen?) an email a few days ago but i'm not sure if he is still around..

i was really thankful for R-T-B to make an unofficial update but wanted to wait until it's bugfree and AVP would use it... which was obviously a terrible mistake...

I don't really understand what was going on there on R-T-B's thread but stuff like that makes me loose faith in humanity.

I bet a lot of people won't play KSP until at least those graphics mods will work again, even if it takes forever.

1.7.3 had performance issues so playing that is not an option to me either.

Guess i have to wait for KSP 2... :(

Share this post


Link to post
Share on other sites
33 minutes ago, pwn said:

i sent the author (ghassen?) an email a few days ago but i'm not sure if he is still around..

i was really thankful for R-T-B to make an unofficial update but wanted to wait until it's bugfree and AVP would use it... which was obviously a terrible mistake...

I don't really understand what was going on there on R-T-B's thread but stuff like that makes me loose faith in humanity.

I bet a lot of people won't play KSP until at least those graphics mods will work again, even if it takes forever.

1.7.3 had performance issues so playing that is not an option to me either.

Guess i have to wait for KSP 2... :(

Modders work on their mods as hobbies.   They do this in their own free time, for no pay, just because they want to.  Perhaps the author is currently dealing with a death in the family?   It would help everybody if we could all be more patient and wait more than 4 days after a major release drops for their favorite mods to be updated.  

This is a visual mod.   It has no direct effect on gameplay.   The stock game should do you fine until then. 

Share this post


Link to post
Share on other sites
4 hours ago, Gargamel said:

It would help everybody if we could all be more patient and wait more than 4 days after a major release drops for their favorite mods to be updated.  

If I could 'like' this more than once, I would.  Well said.

(And, who do you mean by 'we' :P)

Share this post


Link to post
Share on other sites
4 hours ago, Gargamel said:

It would help everybody if we could all be more patient and wait more than 4 days after a major release drops for their favorite mods to be updated.

Yeah ... So, you'd like us to see a problem after an update, and *not* tell anyone, and instead wait patiently for an update?

Has it occurred to you that we *are* waiting patiently (and with greatest respect) for an update?  That, in lieu of actually modding the thing ourselves, we're trying to be helpful in the only way we can; by making a polite note here about the issues we encounter?

Apparently this is not the case, given that every post from a non-modder gets the obligitory admonishment not to be so demanding.  I dropped a similar post on another thread, got admonished, apoligised for having the temerity to make a post, and then had the thread removed for being off topic.   

If this is a place for modders only, then simply name the thread as such and we'll know that user comments aren't needed / desired.  Otherwise, allow that people want to contribute in the most obvious way available; the public forum.  Obvious examples aside, the interaction is intended to show interest and support for your work.  

Share this post


Link to post
Share on other sites
1 hour ago, PyjackMeat said:

So, I guess Scatterer is a dead mod now.

It's more than likely not dead. It is very easy to just be patient and wait for an update should the creator choose to devote their free time to it. 

4 hours ago, Stryks said:

Has it occurred to you that we *are* waiting patiently (and with greatest respect) for an update?  That, in lieu of actually modding the thing ourselves, we're trying to be helpful in the only way we can; by making a polite note here about the issues we encounter?

...

If this is a place for modders only, then simply name the thread as such and we'll know that user comments aren't needed / desired.  Otherwise, allow that people want to contribute in the most obvious way available; the public forum.  Obvious examples aside, the interaction is intended to show interest and support for your work.  

It has literally been 4 days and it is cosmetic content. I'm certain that blackrack has heard that ksp has been updated; just let them get to it when they have the time if they want to. Neither they, nor the moderators, need everyone telling them that ksp has been updated and mods are broken. 

Edited by Chezburgar7300

Share this post


Link to post
Share on other sites
8 hours ago, Gargamel said:

This is a visual mod.   It has no direct effect on gameplay.   The stock game should do you fine until then. 

Visuals matter too, for some much more than others.

 

I would simply suggest doing a simple thing though if you have the steam edition:

Under game properties, use the "betas" opt-in tab to revert to 1.7.3.

Thank me later.

 

Edited by R-T-B

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.