blackrack

[WIP][1.8] Scatterer-atmospheric scattering (v0.0541 - 26/10/2019)

Recommended Posts

On 11/5/2019 at 1:35 PM, BezKartuza said:

Perhaps the problem is in another modification. Why did you decide that the problem is with this mod?

You're right the problem is not with scaterrer it's just you see it better with scatterer

Share this post


Link to post
Share on other sites
18 minutes ago, Vortinium said:

You're right the problem is not with scaterrer it's just you see it better with scatterer

The "problem" is your planet. 

Scatterer atmospheres render in a perfect sphere, so any parts of the body that have a greater altitude than that of the Scatterer sphere will not be scattered, and will cause the issue you are seeing. You will need to adjust your planets Scatterer settings and raise it until the issue is gone.

Edited by Galileo

Share this post


Link to post
Share on other sites
15 minutes ago, Galileo said:

The "problem" is your planet. 

Scatterer atmospheres render in a perfect sphere, so any parts of the body that have a greater altitude than that of the Scatterer sphere will not be scattered, and will cause the issue you are seeing. You will need to adjust your planets Scatterer settings and raise it until the issue is gone.

It's an issue not a "problem" (mothertongue messing with my english :)).

I've got these bump on the planet do you think it's the normalmap (it's supposed to be flat except the routes connecting each cities)  ?

Spoiler

PFE0JAi.jpg

 

Share this post


Link to post
Share on other sites
35 minutes ago, Vortinium said:

It's an issue not a "problem" (mothertongue messing with my english :)).

I've got these bump on the planet do you think it's the normalmap (it's supposed to be flat except the routes connecting each cities)  ?

  Hide contents

PFE0JAi.jpg

 

It's the height map and normal map more than likely

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

It's the height map and normal map more than likely

Yeah I found something weird on my normal map, woking on it, can't wait to publish the planet !

Share this post


Link to post
Share on other sites
5 hours ago, Galileo said:

It's the height map and normal map more than likely

I still can't resolve the issue. May I send you the planet file so you can check it it ? it will be very helpful.

Share this post


Link to post
Share on other sites

I got a weird bug while reverting a quicksave.

The clouds no longer cover Kerbin as if it were a layer wrapped around a sphere, but as if it were a filter when looking at Kerbin. And they completely broke in Map view.

odMrPN2.jpg

xs3J1Bx.jpg

RMkCWx1.jpg

These are the mods I have:

ARhvcm2.png

Still even if it's a software bug or not I gotta upgrade from my poor little FX-8320.

Share this post


Link to post
Share on other sites
2 hours ago, Vortinium said:

I still can't resolve the issue. May I send you the planet file so you can check it it ? it will be very helpful.

Just PM me the files. Textures and cfgs, and when I get some time I'll look it over.

59 minutes ago, zit said:

I got a weird bug while reverting a quicksave.

The clouds no longer cover Kerbin as if it were a layer wrapped around a sphere, but as if it were a filter when looking at Kerbin. And they completely broke in Map view.

odMrPN2.jpg

xs3J1Bx.jpg

RMkCWx1.jpg

These are the mods I have:

ARhvcm2.png

Still even if it's a software bug or not I gotta upgrade from my poor little FX-8320.

That is just something that happens with EVE, not Scatterer. To fix it, you can do a scene change or restart the game.

Share this post


Link to post
Share on other sites

I've got a problem with a planet where the back is lit up when there is no other light source:

A change between scatterer 0.053 and 0.0540 caused this, and the only fix is to rollback versions. Rewriting the scatterer config for this planet did not help, and neither did regenerating the textures.

My configs:

https://www.dropbox.com/s/4e3tnfrena4ewzl/Hydrus-Scatterer.zip?dl=0

ty79zJj.png

Share this post


Link to post
Share on other sites

Спасибо! Когда будет выпущен KSP 1.8.1?

[Translation]
Thanks! When will KSP 1.8.1 be released?

Edited by James Kerman
Added translation

Share this post


Link to post
Share on other sites

hello, i have a problem with scatterer in view KSC it works very well but in launchpad view the sky is black and the sea invisible. have you a solution? my ksp is in 1.8.1

 

Share this post


Link to post
Share on other sites

@blackrack when will this be fixed? (kopernicus rings getting ignored by scatterer)
56CJ8XD.png

would be cool if it worked normal like in 1.6.x
thx:)

also ring shadows aren't a thing anymore

Edited by RJVB09

Share this post


Link to post
Share on other sites
1 minute ago, Idleness said:

I thought kopernicus wasn't updated for 1.8 yet?

its still on 1.7

 

Share this post


Link to post
Share on other sites
3 minutes ago, RJVB09 said:

its still on 1.7

 

It affects rings and such - I don't think rings work without kopernicus, but maybe I read that incorrectly.  That means there's a version mismatch between this and that.

Share this post


Link to post
Share on other sites

i play on 1.7 with kop and scatterer so yeah

Just now, Idleness said:

It affects rings and such - I don't think rings work without kopernicus, but maybe I read that incorrectly.  That means there's a version mismatch between this and that.

 

Share this post


Link to post
Share on other sites

We're running a KSP programme at our library using KSP EDU, which is version 1.4.5.0 and I'd like to install Scatterer if possible.  Is there a link to an older version that will work with that build?  I noticed CKAN does not show any compatible version, and I have not located anything on GitHub or other places.  

Edited by Klapaucius

Share this post


Link to post
Share on other sites
34 minutes ago, Klapaucius said:

We're running a KSP programme at our library using KSP EDU, which is version 1.4.5.0 and I'd like to install Scatterer if possible.  Is there a link to an older version that will work with that build?  I noticed CKAN does not show any compatible version, and I have not located anything on GitHub or other places.  

ON Github, all the releases look to be there.  Look for this.

Share this post


Link to post
Share on other sites

Hi my KSC is now underwater.... how can i fix it please?

I even removed all others mods but it's still the same.

Edited by Carrot
adding detail

Share this post


Link to post
Share on other sites
10 hours ago, Carrot said:

Hi my KSC is now underwater.... how can i fix it please?

it's a completely harmless issue just use the buttons on the left if you can't click on the actual buildings. It will be fine when you launch a vessel. if you just don't like seeing it then update to the latest Scatterer which fixed this issue

Share this post


Link to post
Share on other sites
On 11/28/2019 at 4:14 AM, Carrot said:

Hi my KSC is now underwater.... how can i fix it please?

I even removed all others mods but it's still the same.

This issue has been fixed since v0.052, what version of the mod and KSP are you running?

Edited by blackrack

Share this post


Link to post
Share on other sites

Minor report:

 

There appears to be an issue with ice sheets on the poles of Kerbin.  If they are at sealevel, it seems they appear as water.  Turning off water shaders works as a temp workaround.

I'd try to fix myself and make a PR, but my job is killing me right now, so this is all I can do.

 

EDIT:  Nevermind, pretty sure another mod was to blame for this one.  Doh!

Edited by R-T-B

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.